Näytä kirjoitukset

Tässä osiossa voit tarkastella kaikkia tämän jäsenen viestejä. Huomaa, että näet viestit vain niiltä alueilta, joihin sinulla on pääsy.


Aiheet - tikola

Sivuja: [1]
1
Yleistä keskustelua / Ubuntua vessassa
« : 25.05.18 - klo:15.47 »
Oslon lentokentän miestenvessan info/mainostaulu  :)

http://www.kolumbus.fi/ikola/images/ubuntu.jpg

Kuinkahan tyypillistä on että tällaisessa käytössä ajetaan Ubuntun päällä. Eikös niillä palvelinmiehillä ole vielä jotain suositumpiakin distroja?


2
Laitealue / Vanhat NVIDIA näytönohjaimet kuumenevat
« : 23.03.18 - klo:21.49 »
Olen kamppaillut kevyessä kotipalvelinkäytössä NVIDIAn näytönohjainten kanssa ja parilla yksilöllä on tullut vastaan ylikuumenemisongelmia. En ole oikein päässyt selville onko se yksilön vika vai yleisemmin käyttämieni NVIDIAn ajureiden vika, mutta ongelma on toistunut jo kolmella eri kortilla. Olen ratkaissut ongelman käyttämällä vastaavia Radeoneja ja ne ovat pysyneet pystyssä vaikka liki yhtä kuumilta tuntuvatkin.

Eli mitenkäs tämä NVIDIAn ajurihomma Ubuntussa menee? Miten sinne voi valita käytetäänkö oletusajurin sijasta jotain toista ja olisiko joku toinen virransäästön/kuumenemisen kannalta parempi? Kortit ovat käytännössä vanhoja passiivijäähdytteisiä kortteja ja ajurina se minkä Ubuntu (17.10) sinne oletuksena laittaa.

3
Kaverilta peritty HP Color Laserjet 1600 ja Ubuntu 12.04 64 bit. Homma alkaa toimia heti kättelyssä, eli piuhat kiinni ja tulostus päälle, mutta tulos ei ole toivottu. Käytännössä osaväreissä on aika roima siirtymä ja ne eivät kohdistu kohdakkain. Kaikki sopivanväriset kohteet esiityvät kahtena erivärisenä kappaleena vajaan puolen sentin päässä toisistaan. Ja kun täsmälleen sama printteri jaetaan verkon muille windows koneille samban avulla ja tulostetataan sieltä windowsista niin homma pelaa aivan virheettömästi.

Laitteessa on ollut vastaavia oireita välillä ihan laitetasollakin, eli laitteen oma demokuva on mennyt samaan tapaan pieleen. Noissa tapauksissa syy on oletettavasti ollut itse täytetyissä tai muuten vaan ihan tappiin vedetyissä kaseteissa. Nyt siinä on uudet kiinalaiset kopiokasetit ja demokuvat ja windows/samba reitillä homma toimii hienosti, mutta suoraan ubuntusta tulostettaessa väreissä on siirtymää.

Minun arvaus on se, että kokeilemalla niitä erilaisia linux tulostinajureita homma voisi korjautua löytämällä sopiva kombinaatio. Tai sitten linux puolella pitää ajaa joku värikasettien kohdistusjuttu. Hyviä ajatuksia otetaan vastaan, vaikka ei tuo nyt niin suuri ongelma ole sen toimivan windows/samba reitin takia.

timo

4
Päivitin Ubuntun 12.04 versioon ja kaikki meni läpi ongelmitta. Tv kortit lakkasivat yllättäen toimimasta ja kun aloin tutkia asiaa huomasin, että kernel on edelleen 3.0.0_17 vaikka synapticin mukaan minulla kyllä pitäisi olla viimeisin 3.2.x sarjan kernelikin asennettuna. Kun buuttaan koneen ja menen kernelin valinta menuun siellä kerrottaan, että käytettävissä on 2.6.x - 3.0.x version kerneleitä Ubuntu 11.10:lle

Toisin sanoen Ubuntu itse päivittyi hienosti versiosta 11.10 versioon 12.04, mutta kernelit jumahtivat 11.10 eivätkä päivittyneet. Olen kokeillut erilaisia googlattuja kikkoja grub-update jne. mutta viisastenkiveä ei ole vielä löytynyt.

Varsinainen ongelma ovat siis toimimattomat TV kortit, mutta yksi tie niiden heräämisen tiellä voisi hyvinkin olla tuo Kernel asian saaminen kuntoon ja se on nyt tämän topicin aihe.

Aiheesta alkuperäinen keskustelu osoitteessa:http://www.linuxtv.fi/viewtopic.php?f=12&t=4668

Käytännössä seuraavat konstit kokeiltu

- Manuaalinen kernelin valinta buutissa - uusia ei tarjolla
- /etc/default/grub tiedoston editointi ja sen jälkeen  sudo update-grub - tuo tiedosto on täysin tyhjä
- Uusimpien kernel paketeiden uudelleenasennus synapticissa

Näistä mikään ei siis vielä ole avuttanut

timo

5
Olen käyttänyt Ubuntua jo muutaman vuoden VDR ja kotiserverialustana. Kaikki on tähän saakka ollut aika loogista ja toimivaa, mutta nyt tekemäni 11.04 päivitys hämmensi käyttäjän. Mielestäni uusittu käyttöliittymä on kaikkea muuta kuin helppo, mutta onneksi kun olen sitä jo käytellyt pystyn löytämään työkalut joita kaipaan. Kaveri, joka nyt aloittelee on toki hieman pulassa. Tämä ei ole kuitenkaan varsinainen ongelma vaan pikemminkin ikävä ominaisuus, jonka kanssa pärjäilen.

Varsinainen ongelma on se, että minusta tuntuu, että käyttöliittymässäni on jotain oikeasti vialla. Käytän sitä pääosin ilman näyttöä VNC:n läpi. 11.04 version myötä VNC:n käyttö muuttui erinomaisen takkuisaksi. Jokainen klikkaus ja hiiren liike tulee ruudulle pienellä viiveellä, valikot eivät ilmesty ennen kuin hiiren raahaa kyseisen rivin päälle ja sitä rataa.

Toinen hämmentävä ominaisuus on, että ohelmien menut tuntuvat luiskahtavan ohjelmaikkunan ulkopuolelle ruudun ylälaitaan vaikka itse ohelma olisikin vain pienempi ruutu keskellä näyttöä.

Kaikki haiskahtaa minusta näytönohjaimen tai muuten vaan graafisen ympäristön sekoilulta. Yksi arvaus on, että päivityksen mukana tuova NVIDIA Vdpau ajuri on sotkenut näyttöpuolta.

Onko kukaan törmännyt moiseen vai onko tässä nyt jokin minun ikioma ongelma?

timo

6
Ubuntu tietokoneissa / Suurempi kuin 700mb CD polttaminen
« : 26.06.11 - klo:23.52 »
Ostin joskus innokkaana 900mb CD aihioita ajatuksena, että auton MP3 CD:lle saisi tungettua enemmän musiikkia kuin normaalille. Lopputulos on se, että kerran olen onnistunut tunkemaan yli 700mb noille CD:lle käyttäen Neroa Windows puolella ja silloinkin viimeiset kappaleet alkoivat takkuilla soittimessa.

Ubuntu taipuu lähtökohtaisesti mihin vain, mutta sillä en ole koskaan pystynyt tekemään yli 700mb CD:tä vaan homma kaatuu aina erilaisin virheilmoituksiin, jossa kerrotaan ettei data mahdu levylle. Levyssä lukee siis 900mb, mutta löytyykö maailmasta sellaista ihmelaitetta jolla sen kaiken tilan saisi oikeasti käyttöön. Vai onko myyntimies vetänyt minua höplästä?

Käytännössä olen siis yrittänyt muutamalla ensiksi löytämälläni Ubuntun poltto-ohjelmalla vailla menestystä.

timo

7
Tarina menee näin. Minulla on vuosia palvellut RAID-1 pakka (10.04 64bit Ubuntu), jota käytän kodin tiedostopalvelimena verkon yli. Viikolla huomasin, että jostain syystä en pysty antamaan Itunesissa tiedostoille mp3 tageja, siis esittäjän nimeä ja sitä rataa. Syy paljastui kun aloin käytellä Ubuntua suorana ja yritin kopioda tiedostoja raid levyjaolle. Ilmoitus oli jotain busy tai denied, eli pystyin lukemaan mutten kirjoittamaan.

Sen jälkeen kokeilin normaalikonstit md laitteen uudelleenkäynnistyksen ja koneen buuttauksen ja nyt olen päässyt siihen tilaan että md laite käynnistyy, mutta sen mounttaus ei onnistu. Virheilmoitus kertoo:

sudo mount /dev/md0 /home/tikola/data
mount: wrong fs type, bad option, bad superblock on /dev/md0,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so


Kun sitten aloin kokeilla kaikkea vähää mitä mdadm komennosta ymmärrän sain ulos seuraavia tietoja:

cat /proc/mdstat
Personalities : [linear] [multipath] [raid0] [raid1] [raid6] [raid5] [raid4] [raid10]
md_d0 : active raid1 sdc1[0] sdd1[1]
      976759936 blocks [2/2] [UU]
      unused devices: <none>


sudo mdadm --detail /dev/md0
/dev/md0:
        Version : 00.90
  Creation Time : Sun Jul 19 16:29:53 2009
     Raid Level : raid1
     Array Size : 976759936 (931.51 GiB 1000.20 GB)
  Used Dev Size : 976759936 (931.51 GiB 1000.20 GB)
   Raid Devices : 2
  Total Devices : 2
Preferred Minor : 0
    Persistence : Superblock is persistent

    Update Time : Fri Jun 17 01:39:38 2011
          State : clean
 Active Devices : 2
Working Devices : 2
 Failed Devices : 0
  Spare Devices : 0

           UUID : 925e226b:c1661175:5c658924:daf7db08 (local to host serveri)
         Events : 0.91684

    Number   Major   Minor   RaidDevice State
       0       8       33        0      active sync   /dev/sdc1
       1       8       49        1      active sync   /dev/sdd1


tikola@serveri:~$ dmesg | tail
[ 2917.458271] md: md0 stopped.
[ 2917.461336] md: bind<sdd1>
[ 2917.462588] md: bind<sdc1>
[ 2917.496878] raid1: raid set md0 active with 2 out of 2 mirrors
[ 2917.496907] md0: detected capacity change from 0 to 1000202174464
[ 2917.497357]  md0: unknown partition table
[ 2929.570056] journal_bmap: journal block not found at offset 3323 on md0
[ 2929.570059] JBD: bad block at offset 3323
[ 2929.570065] JBD: recovery failed
[ 2929.570066] EXT3-fs: error loading journal.


Kaikesta tuosta sain pääteltyä että levyt todennäköisesti ovat kunnossa, mutta jokain on nyt mennyt vikaan ja partition table tai joku muu kriittinen käynnistymisen kannalta olennainen komponentti on hukassa. Koska olen mdadm ja muiden levytyökalujen kanssa hieman noviisi olen hyvin varovainen ennen kuin jakelen mitään kokoa pakka uudelleen komentoja.

Mitä minun pitäisi tehdä jotta arvokkaat kotitiedostot saisin taas normaalisti käyttöön. Backuppi on kyllä muutaman viikon takaa, eli mitään korvaamatonta ei ole tapahtunut, mutta toisaalta en usko vielä minkään pahemmin rikkoutuneenkaan oikeasti.


timo


8
Tilanne on seuraava. Minulla on Topfield ja VDR pohjaisia TV tallenteita, jotka on tarkoitus siirtää DVD:lle (Ruotsin prinsessahäitä mummolle)

VDR pohjaiset käyttäytyvät siististi ja saan avidemuxilla (ja projectX:llä) tehtyä kaikki kaipaamani temput. Topfieldin digiboksilta tuomani tallenteet kaatavat avidemuxin (avaaminen ja indeksointi ei onnistu). Erona tiedostojen välillä on, että Linux peräisissä tiedostoissa tiedoston tyypin kohdalla lukee "MPEG-2 transpport stream" ja Topfield pohjaisissa lukee "Message catalogue" Tiedoston pääte on molemmissa sama ja mencoder skriptini muuntaa molemmat aviksi mukisematta. Ongelma on lähinnä se, että minun pitäisi askarrella tekstit kiinni kuvaan, koska mummon kielitaito on rajoittunut. Siihen tuo avidemux tarvittaisiin. Oletus on siis se, että pelkkä topfieldin .rec tiedostopääteen muuttaminen .ts:ksi ei muuttanut tuuota tiedostotyyppiä ja siihen avidemux kyykähtää.

Miten vaihtaa siis tiedostotyyppi vai onko se jotain jonka kone päättää puolestani päätteen perusteella.

timo

9
Tällä aloittelevan linux harrastajan tiellä on monta mutkaa. Versiopäivitys kannattaa ehdottomasti ja se tuo joka kerta korjauksia ongelmiin. Toisaalta lähes joka versiopäivityksessä jokin aiemmin hyvin toiminut asia rupeaa reistaamaan. Nyt 9.04 -> 9.10 päivtyksessä vaivaa rupesi tuottamaan yksi levy. Kyseessä on ihan perus SATA levy, jota olen käyttänyt TV tallennuspaikkana. Levy on normaali ext3 ja se on mountattu omaksi hakemistoksi kotihakemistooni. 9.04 maailmassa kaikki toimi kuin junan vessa ja buutin jälkeen kyseinen hakemisto näkyi datoineen. Nyt 9.10 versiossa Disk Utility kertoo levyllä olevan vähäinen määrä bad sectoreita. Tämä ilmeisestikkin poikii aina buutissa levyn tarkistuksen. Tuo tarkistus ei mene koskaan läpi ja kone vilauttaa ruudulla, jotan aiheeseen liittyvää. Lopputulost prosessista on että mountausta ei buutissa tapahdu ja jos yritän tehdä sen käsin saan vastauksen: device already mounted or mount point busy. Mountattu se ei varmasti ole koska hakemisto on täydellisen tyhjä.

Jos buutin aikana kun tarkastus alkaa painan esciä (esc to skip test) lopputulos on täydellisesti mounttautunut levy ja hakemisto jota pystyn käyttämään kuten ennenkin.

Siis jotain siinä levyssä nyt on jota Ubuntu ryhtyy skannaamaan ja riippuen annanko skannauksen mennä läpi (kaatunee omia aikojaan, kun prosentti on aina nolla) vai katkaisenko sen tulos on hakemiston mounttauksen kannalta erilainen.

Logeista en ole vielä osannut kaivaa mitään järjellistä aiheeseen liittyvää.

timo

ps. Tämän versiopäivityksen positiivista antia oli se, että ääkköset kulkevat nyt läpi näppäimistöltä VNC:n kautta Ubuntulle.

10
Kasasin eilen RAID-1 pakan ja kopion sinne datoja. Kaikki meni hienosti ja homma toimi. Aamulla buuttasin koneen ja katso raid pakkaa ei näkynytkään missään. No sitten googlella hakemaan neuvoja ja tähän on päästy.

1) Molemmat levyt ovat kunnossa ja mdadm -E antaa molemmista lupaavaa järkevää tietoa - correct lukee kaikkialla, joten oletan asioiden olevan kunnossa.

tikola@serveri:~$ sudo mdadm -E /dev/sdc1
/dev/sdc1:
          Magic : a92b4efc
        Version : 00.90.00
           UUID : 925e226b:c1661175:5c658924:daf7db08 (local to host serveri)
  Creation Time : Sun Jul 19 16:29:53 2009
     Raid Level : raid1
  Used Dev Size : 976759936 (931.51 GiB 1000.20 GB)
     Array Size : 976759936 (931.51 GiB 1000.20 GB)
   Raid Devices : 2
  Total Devices : 2
Preferred Minor : 0

    Update Time : Mon Jul 20 09:44:54 2009
          State : clean
 Active Devices : 2
Working Devices : 2
 Failed Devices : 0
  Spare Devices : 0
       Checksum : 34c46d6 - correct
         Events : 8


      Number   Major   Minor   RaidDevice State
this     0       8       33        0      active sync   /dev/sdc1

   0     0       8       33        0      active sync   /dev/sdc1
   1     1       8       49        1      active sync   /dev/sdd1



2) md0 laitetta ei ole, eli pakka ei ole käynnistynyt

tikola@serveri:~$ sudo mdadm --query --detail /dev/md0
mdadm: md device /dev/md0 does not appear to be active.


3) Syylliseksi epäilen "superblokin" puuttumista toisesta pakan levystä.

tikola@serveri:~$ sudo mdadm -A /dev/md0 /dev/sdc1
mdadm: cannot open device /dev/sdc1: Device or resource busy
mdadm: /dev/sdc1 has no superblock - assembly aborted


Kaikki hyvät ajatukset otetaan vastaan - vaikka ei se levyjen formatointi ja pakan uudelleenkasaus ole mikään mahdottomuus sekään, mutta jos tuon saisi heräteltyä niin hyvä - ja samalla kun saisi idean miten pitää se toimivana seuraavan buutin yli niin kaikki olisi taas hienosti.


timo

11
Samba ja ääkkösongelma nyt seuraavasta näkökulmasta (olen koettanut hakea mutten ole tähän omaan tilanteeseeni löytänyt ratkaisua):

Ubuntu koneeni 9.04 hoitelee mediaserverin virkaa kotona. Siitä on tehty ulos jako samballa, josta sitten eri koneet soittelevat muusiikkia videoita tms.

smb.conf tiedostossa ääkköset on hoidettu seuraavalla tavalla:
dos charset = CP350
unix charset = ISO8859-1
display charset = ISO8859-1

Käytännössä tämän myötä verkon muut koneet (windows) näkevät ääkköset ongelmitta ja osaavat tuoda sinne ääkkösiä sisältäviä tiedostoja.

Nyt kun haluaisin ottaa backupin ubuntusta suoraan irtokovalevylle törmään neliö-kysymysmerkki yhdistelmiin. Käytännössä siis windows koneet näkevät ääkköset samban läpi hyvin, mutta ubuntu itsessään ei niitä näe. Tästä seuraa se, että backup ei onnistu koska merkistö sekoaa jne.

Olen tähän mennessä yrittänyt hakea ratkaisua muuttamalla esim. terminaalin merkkikoodausta ylävalikosta samaksi kuin tuossa smb.confissa käytetyt jne. mutta toistaiseksi vailla menestystä.

Mitenkäs tämä pitäisi hoitaa siten että samban kautta tulevat windows koneet ja omia hakemistojaan kurkkiva Ubuntu näkisivät ääkköset samoin ja oikein.


timo

ps. Ja ääkköset pois tiedostonnimistä ei ole ratkaisu minullekkaan vaikka sitä toki mahdollisuuksien mukaan toteutan. Haluan Itunesilla kuunneella Yö yhteyeen kappaletta Särkynyt Enkeli ja antaa Itunesin järjestellä hakemistot sen mukaan. En siis halua kuunnella Yo yhtyettä - ainakaan olettaen Olli Lindholmin laulavan.





12
Arvoisa foorumi

Olen aloitteleva Ubuntu käyttäjä ja olen törmännyt seuraavaan kysymykseen. Jos olen ihan omin kätösin onnistunut kääntämään jotain (xine-lib tässä tapauksessa) ja nyt haivaitsen että pitää tehdä jotain toisin ja haluan poistaa käännökseni kokonaan - mitä teen?

Siis kysymys on lähinä se näyttäytyykö se xine-lib pakettienhallinnalle kuin mikä tahansa muukin paketti ja normaalit apt-get remove jutut purevat siihen vai aiheuttaako itse kääntäminen jotain sellaista ettei apt-get pure ja pitäisi osata tehdä jotain muuta.

Suurena kuviona tässä kummittelee vdr ja sen virittely henkiin. Virheilmoitusten ja foorumeiden perusteella on xine-libissä, jonka olen itse käännellyt ja lopputuloksena minulla taitaa olla useampi xine-lib koneessa. Haluaisin siis poistaa kaiken vähänkin xine-libiin viitaavan totaalisesti pois ja korvata ne hanno.de:n tarjoamilla valmiilla paketeilla, joilla vdr pitäisi hyrähtää lähes heittämällä käyntiin. Tai itse asiassa vdr hyrähtääkin jo ihan hyvin, mutta kuvaa ei tule koska xine puoli kaatuu.

timo

13
Hei

Minulla on kiusallinen digiTV ongelma. Minulla on uusin Ubuntu ja siinä Kaffeine pohjainen PVR hässäkkä. Toisin sanoen kone nauhoittelee Kaffeinella mitä olen määrännyt, jonka jälkeen mencoder pyöräyttää niistä helposti katsottavia .avi tiedostoja windows koneille.

Nyt Kaffeinen kanssa on alkanut tulla sellaista että aika ajoin tallennus epäonnistuu ja tuloksena on tyhjä tiedosto. Itse Kaffeine ei tuon ongelman aikana sano mitään sen kummempaa vaan näyttää tallettavan tyytyväisenä jotakin. Ongelma näyttäisi liittyvän osaan kanavanipuista. Toisin sanoen aiemmin ylen kanavat tekivät järjestelmällisestä tätä. Nyt hain kanavat uusiksi ja tuntuisi että nyt subtv tekee samaa (ja teema myös).

Onko joku törmännyt vastaavaan ja mistä lähteä haarukoimaan probleemaa eteenpäin?

Sen lisäksi tarjolla on muutakin probleemaa, eli Kaffeine ei näytä kuvaa lainkaan ja ylen kanavilta tehdyt tallennukset hajottavat mencoderin, mutta aloitetaanpas tuolla tyhjällä .m2t tiedostolla, koska se on ongelmista se fataalein.



timo


Sivuja: [1]