Kirjoittaja Aihe: Ubuntu 12.04 ja sampopankki java  (Luettu 9691 kertaa)

####¤¤¤¤####

  • Käyttäjä
  • Viestejä: 53
    • Profiili
Ubuntu 12.04 ja sampopankki java
« : 13.03.12 - klo:19.58 »
  Tuollaisen kopioin netistä ja sain sampopankin pelittämään javalla laakista ubuntu 12.04 kanssa.


http://www.webupd8.org/2012/01/install-oracle-java-jdk-7-in-ubuntu-via.html

To add our PPA and install the latest Oracle Java 7 in Ubuntu (supports Ubuntu 13.04, 12.10, 12.04, 11.10, 11.04 and 10.04), use the commands below:

sudo add-apt-repository ppa:webupd8team/java
sudo apt-get update
sudo apt-get install oracle-java7-installer




1. Avaa pääte: Sovellukset->Apuohjelmat->Pääte
    Kopio ja liitä päätteelle komento:
    sudo add-apt-repository "deb http://www.duinsoft.nl/pkg debs all"
    (paina entter, syötä salasanas, entteriä)
    
    2. Kopio ja liitä päätteelle komento:
    sudo apt-key adv --keyserver keys.gnupg.net --recv-keys 5CB26B26
    
    3. Kopio ja liitä päätteelle komento:
    sudo apt-get update && sudo apt-get install update-sun-jre
    
    Nyt kokeilet toimiiko. Jos ei niin selaimen tai tietokoneen reboot ja uudelleen.
    http://java.com/en/download/installed.jsp
« Viimeksi muokattu: 23.04.13 - klo:15.34 kirjoittanut ####¤¤¤¤#### »
Ubuntu 16.04 intel core2 Q6600 2.40GHz  GeForce GTS 450-1Gt,
Ubuntu 16.04 intel Centrino2 Elitebook 6930p

Daneli

  • Käyttäjä
  • Viestejä: 1036
  • Red Hat Chili Peppers
    • Profiili
    • www.daneli.org
Vs: Ubuntu 12.04 ja sampopankki java
« Vastaus #1 : 13.03.12 - klo:20.11 »
Mikä versio javasta pitäisi olla  ???

mrl586

  • Käyttäjä
  • Viestejä: 4526
    • Profiili
Vs: Ubuntu 12.04 ja sampopankki java
« Vastaus #2 : 13.03.12 - klo:20.21 »
Mikä versio javasta pitäisi olla  ???
Täällä Sampo Pankki toimii Oraclen Javalla
Koodia: [Valitse]
tux@S205:~$ java -version
java version "1.7.0_03"
Java(TM) SE Runtime Environment (build 1.7.0_03-b04)
Java HotSpot(TM) 64-Bit Server VM (build 22.1-b02, mixed mode)

Jakke77

  • Käyttäjä
  • Viestejä: 3644
  • Oulu (Oinaansuo)
    • Profiili
Vs: Ubuntu 12.04 ja sampopankki java
« Vastaus #3 : 13.03.12 - klo:20.36 »
kannattaa muistaa poistaa kaikki openjdk ja icedtea härpäkkeet, itselläni alko sampo toimimaan oikein vasta niiden poistamisen jälkeen
U_G_H

Aspire E5-575G V1.27 CPU: Intel i3-6100U (4) @ 2.300GHz GPU: Intel® HD Graphics 520 GPU: NVIDIA GeForce 940MX

uhappo

  • Käyttäjä
  • Viestejä: 1029
  • Sissos
    • Profiili
    • Urkin sivut
Vs: Ubuntu 12.04 ja sampopankki java
« Vastaus #4 : 13.03.12 - klo:21.47 »
Mikä versio javasta pitäisi olla  ???
Täällä Sampo Pankki toimii Oraclen Javalla
Koodia: [Valitse]
tux@S205:~$ java -version
java version "1.7.0_03"
Java(TM) SE Runtime Environment (build 1.7.0_03-b04)
Java HotSpot(TM) 64-Bit Server VM (build 22.1-b02, mixed mode)

Joo, samoin täällä Oracle
Koodia: [Valitse]
java -version
java version "1.7.0_03"
Java(TM) SE Runtime Environment (build 1.7.0_03-b04)
Java HotSpot(TM) 64-Bit Server VM (build 22.1-b02, mixed mode)
urkki@urkkimylly:~$

HP i7-pohjainen desktop ja itsekasattu i7-pohjainen desktop, uusin ubuntu 64bit
Ubuntu since 2008 Feb

Daneli

  • Käyttäjä
  • Viestejä: 1036
  • Red Hat Chili Peppers
    • Profiili
    • www.daneli.org
Vs: Ubuntu 12.04 ja sampopankki java
« Vastaus #5 : 13.03.12 - klo:23.30 »
Meitsi sai noilla ohjeilla: Java(TM) SE Runtime Environment (build 1.6.0_31-b04) Java HotSpot(TM) 64-Bit Server VM (build 20.6-b01, mixed mode)



I Svärd

  • Käyttäjä
  • Viestejä: 296
    • Profiili
Vs: Ubuntu 12.04 ja sampopankki java
« Vastaus #6 : 14.03.12 - klo:02.41 »
Oraclen java 7 pelittää sampopankissa myös, tai siis ainakin 11.10 ja 12.04 64bit Ubuntuun asennus onnistuu seuraavilla loruilla.

sudo add-apt-repository ppa:webupd8team/java
sudo apt-get update
sudo apt-get install oracle-jdk7-installer

Daneli

  • Käyttäjä
  • Viestejä: 1036
  • Red Hat Chili Peppers
    • Profiili
    • www.daneli.org
Vs: Ubuntu 12.04 ja sampopankki java
« Vastaus #7 : 14.03.12 - klo:17.12 »
Kyl nuo Porilaiset on viisaita  ;)

immoT

  • Käyttäjä
  • Viestejä: 435
    • Profiili
Vs: Ubuntu 12.04 ja sampopankki java
« Vastaus #8 : 19.05.12 - klo:11.41 »
Chromium selaimessa toimii, duinsoftin ohjeilla (http://www.duinsoft.nl/packages.php) :D
Firefox kaatuu aina turvakoodin kyselyyn, ei tule tekstinsyöttökenttää :(.

xynyt

  • Käyttäjä
  • Viestejä: 9
    • Profiili
Vs: Ubuntu 12.04 ja sampopankki java
« Vastaus #9 : 06.08.12 - klo:11.49 »
Tuon asensin ohjeiden mukaan 12.04 koneeseen

Koodia: [Valitse]
$ java -version
java version "1.7.0_05"
Java(TM) SE Runtime Environment (build 1.7.0_05-b05)
Java HotSpot(TM) Client VM (build 23.1-b03, mixed mode)

ja sisäänkirjautuminen pankkiin onnistui kyllä, mutta maksun suorittaminen ei vaan suju. Firefox käytössä, ja java näkyy liitännäisissä olevan käytössä, myös java.comin testissä näkyy olevan käytössä, mutta selain jumiutuu, kun pankin maksusivulla painaa "Hyväksy maksut". Pitääkö palata 1.6 javaan, mikä vielä Lucidissa toimi, vai mitä kikkoja on jäljellä? Nimesin uudelleen vanhan .java -hakemiston, ettei se siellä sotkisi kuvioita, mutta eipä auttanut sekään.

EDIT. Tämä asia ei oikeastaan kuulu kehitysversioon vaan peruskäyttöön, mutta onkohan tämä viesti siirrettävissä vai pitääkö antaa olla? Sillä vaan, ettei tämä nyt jää lukematta, kun kyseessä on kuitenkin kohtuullisen akuutti ongelma, eikä omat kyvyt riittäneet pidemmälle.
« Viimeksi muokattu: 06.08.12 - klo:11.56 kirjoittanut xynyt »

I Svärd

  • Käyttäjä
  • Viestejä: 296
    • Profiili
Vs: Ubuntu 12.04 ja sampopankki java
« Vastaus #10 : 06.08.12 - klo:19.04 »
java version "1.7.0_05"
Java(TM) SE Runtime Environment (build 1.7.0_05-b05)
Java HotSpot(TM) 64-Bit Server VM (build 23.1-b03, mixed mode)

Firefox 14.0.1 ja ubuntu 12.04 64bit just äsken maksoin sampopankissa laskuja ja hyväksyntäkin toimi normaalisti.
Läppärissäni on javana OpenJDK ja muuten sampopankki toimii mutta hyväksyntä ei.

Kun lisää ubuntun restricted extras paketin niin noita avoimia javoja tuppaa tulemaan koneelle eikä niitä aina huomaa. Näyttäis kuitenkin siltä että firefox ne kyllä honaa ja yrittää käyttää.

Olen asentanut Oraclen javan lisäämällä webupd8team pakettivaraston heti puhtaan asennuksen jälkeen eikä Sammon kanssa ole ollut ongelmia.

welmar

  • Käyttäjä
  • Viestejä: 1582
    • Profiili
Vs: Ubuntu 12.04 ja sampopankki java
« Vastaus #11 : 06.08.12 - klo:19.29 »
Pitääkö palata 1.6 javaan, mikä vielä Lucidissa toimi, vai mitä kikkoja on jäljellä?
Ei. Sampopankki ei toimi vanhalla javalla.

xynyt

  • Käyttäjä
  • Viestejä: 9
    • Profiili
Vs: Ubuntu 12.04 ja sampopankki java
« Vastaus #12 : 07.08.12 - klo:11.35 »
Pitääkö palata 1.6 javaan, mikä vielä Lucidissa toimi, vai mitä kikkoja on jäljellä?
Ei. Sampopankki ei toimi vanhalla javalla.

Hmm.

tässä ketjussa http://forum.ubuntu-fi.org/index.php?topic=42621.0 kyllä kerrotaan, että 1.6 javalla myös laskun hyväksyminen onnistuu, mikä uusimmalla ei suju. Lukuisia kertoja on kokeiltu, mutta painettua "hyväksy maksut" ei tapahdu mitään, ja jos sitä painaa uudestaan, Firefox jumiutuu.

anttimr

  • Käyttäjä
  • Viestejä: 1625
    • Profiili
Vs: Ubuntu 12.04 ja sampopankki java
« Vastaus #13 : 07.08.12 - klo:13.10 »
Pitääkö palata 1.6 javaan, mikä vielä Lucidissa toimi, vai mitä kikkoja on jäljellä?
Ei. Sampopankki ei toimi vanhalla javalla.
Nimenomaan kuutosjavalla toimii varmemmin kuin versiolla 7.
Ubuntu 12.10 Quantal Quetzal

welmar

  • Käyttäjä
  • Viestejä: 1582
    • Profiili
Vs: Ubuntu 12.04 ja sampopankki java
« Vastaus #14 : 08.08.12 - klo:16.44 »
Pitääkö palata 1.6 javaan, mikä vielä Lucidissa toimi, vai mitä kikkoja on jäljellä?
Ei. Sampopankki ei toimi vanhalla javalla.
Nimenomaan kuutosjavalla toimii varmemmin kuin versiolla 7.
Itse vaihdoin 7 javaan silloin kun en enään päässyt kirjautumaan pankkiin. Tosin 6 sarjan päitityskin olisi ehkä ollut olemassa mutta hain suoraan 7 ja sampo toimii. Itselleni ei sampopankin mobiiliversio riitä, joten pidän javan aina ajantasalla. Javan 7 versiota olen käyttänyt jo pitkään ja mielestäni ei ole ollut mitään ongelmaa. Toisin kun jos päivittää seuraavaan 6.xx niin päivitys pitää tehdäpaljon useimmin kuin jos 7 on asennutna. Onko toi varmaa tietoa että sampo toimii edelleen 6 sarjan javalla?
« Viimeksi muokattu: 08.08.12 - klo:16.46 kirjoittanut welmar »