Kirjoittaja Aihe: Myös Ubuntuun tupsahti Linux 5.8.0-36-generic ja näyttö jäi pimeäksi  (Luettu 988 kertaa)

elohope

  • Käyttäjä
  • Viestejä: 102
    • Profiili
Viime päivinä on keskusteltu Kubuntun päivitysongelmasta:
https://forum.ubuntu-fi.org/index.php?topic=55998.0

Tänään tuli tavalliseen Ubuntuuni iso määrä (354 MT) päivityksiä, ja kone ilmoitti päivitysten aikana järjestelmäongelmista, jotka sivuutin.

Koneen näyttö jäi pimeäksi, mutta otin koneeseen yhteyden toisella, ja minua tervehti seuraava:

Welcome to Ubuntu 20.04.1 LTS (GNU/Linux 5.8.0-36-generic x86_64)

En minäkään ole siirtynyt ytimeen 5.8 tietoisesti. Ongelma on siis ehkä sama kuin edellä mainitussa Kubuntu-keskustelussa.

Koneen Nvidia ja muut osat ovat vanhoja, ja Ubuntu on asennettu Legacy ja ei-Uefi-asetuksilla muistaakseni.

Tämä tiedoksi niille, jotka harkitsevat tuoreiden päivitysten asentamista vanhaan koneeseen.
« Viimeksi muokattu: 09.01.21 - klo:19.01 kirjoittanut elohope »

elohope

  • Käyttäjä
  • Viestejä: 102
    • Profiili
Palautin Timeshiftillä vanhan version (elokuulta 2020) ja siirryin tuohon jo haikeita muistoja herättävään aikaan:

5.4.0-42-generic #46-Ubuntu SMP Fri Jul 10 00:24:02 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

Ja nyt sitten jonkin aikaa varon päivityksiä.

nm

  • Käyttäjä
  • Viestejä: 14379
    • Profiili
Edellisen toimivan kernelin voi kyllä valita Grub-käynnistysvalikosta. Jos koneessa on vain yksi Ubuntu, eikä muita käyttöjärjestelmiä, valikko on piilossa, mutta sen saa esiin painamalla shiftiä (tai joissain koneissa Esc-näppäintä) koneen käynnistyessä, ennen kuin Ubuntu latautuu.

AimoE

  • Käyttäjä
  • Viestejä: 2099
    • Profiili
Edellisen toimivan kernelin voi kyllä valita Grub-käynnistysvalikosta. Jos koneessa on vain yksi Ubuntu, eikä muita käyttöjärjestelmiä, valikko on piilossa, mutta sen saa esiin painamalla shiftiä (tai joissain koneissa Esc-näppäintä) koneen käynnistyessä, ennen kuin Ubuntu latautuu.

Olkaa tarkkkana: 5.8-versioita on tullut kaksi (-34 ja -36), ja jos toisenkin perään ajaa autoremove:n niin silloin viimeisin 5.4 ei ole enää jäljellä.

elohope

  • Käyttäjä
  • Viestejä: 102
    • Profiili
Tein tähän korjauksen - ymmärsin nm:n neuvon väärin, eli pääsen kyllä Shift-painikkeella valitsemaan vanhemman ytimen kuten nm sanoi.

Edelleen minulle tarjotaan päivitystä ytimeen 5.8 ainakin osittain:

Koodia: [Valitse]
apt list --upgradable | grep linux
Tulos:

Koodia: [Valitse]
linux-firmware/focal-updates,focal-updates 1.187.7 all [päivitettävissä versiosta: 1.187.2]
linux-generic-hwe-20.04/focal-updates,focal-security 5.8.0.36.40~20.04.21 amd64 [päivitettävissä versiosta: 5.4.0.42.46]
linux-generic/focal-updates,focal-security 5.4.0.60.63 amd64 [päivitettävissä versiosta: 5.4.0.42.46]
linux-headers-generic-hwe-20.04/focal-updates,focal-security 5.8.0.36.40~20.04.21 amd64 [päivitettävissä versiosta: 5.4.0.42.46]
linux-headers-generic/focal-updates,focal-security 5.4.0.60.63 amd64 [päivitettävissä versiosta: 5.4.0.42.46]
linux-image-generic-hwe-20.04/focal-updates,focal-security 5.8.0.36.40~20.04.21 amd64 [päivitettävissä versiosta: 5.4.0.42.46]
linux-image-generic/focal-updates,focal-security 5.4.0.60.63 amd64 [päivitettävissä versiosta: 5.4.0.42.46]
linux-libc-dev/focal-updates,focal-security 5.4.0-60.67 amd64 [päivitettävissä versiosta: 5.4.0-42.46]
util-linux/focal-updates 2.34-0.1ubuntu9.1 amd64 [päivitettävissä versiosta: 2.34-0.1ubuntu9]
« Viimeksi muokattu: 10.01.21 - klo:14.05 kirjoittanut elohope »

mpiso

  • Käyttäjä
  • Viestejä: 535
    • Profiili
Oletko kokeilut noita ja mikä on vastaus?

Lainaukset ketjusta: https://forum.ubuntu-fi.org/index.php?topic=55998.20

(K)Ubuntu 20.04:ssä kernelin versio 5.8 liittyy HWE-päivityksiin. Jos paketti linux-generic-hwe-20.04 on asennettuna, kerneli päivittyy automaattisesti 5.8-sarjaan. Nähtävästi 20.04.1:ssä tuo paketti on joissain tapauksissa oletuksena asennettuna. Tämä saattaa johtua muutoksesta Ubuntun käytännöissä (aiemmin HWE on ollut vakiona päällä vain LTS:n .2-versiosta lähtien), tai voi olla, että HWE-paketti asentuu jonkin käyttäjän tekemään valinnan seurauksena. En vielä löytänyt tarkempaa tietoa, mutta syy selvinnee lähipäivinä.

Tulevien 5.8-kernelin päivitysten asentumisen voi estää poistamalla tuon hwe-paketin:

Koodia: [Valitse]
sudo apt purge linux-generic-hwe-20.04

Varmista myös, ettei järjestelmässä ole pakettia linux-generic-hwe-20.04-edge:

Koodia: [Valitse]
sudo apt purge linux-generic-hwe-20.04-edge
Jos sitäkään ei ole, en osaa sanoa, mistä kernelin versio 5.8 on ilmaantunut järjestelmääsi.

elohope

  • Käyttäjä
  • Viestejä: 102
    • Profiili

Tämä poisto onnistui, poistettiin yksi paketti:

Koodia: [Valitse]
sudo apt purge linux-generic-hwe-20.04
Sen sijaan pakettia

Koodia: [Valitse]
sudo apt purge linux-generic-hwe-20.04-edge
ei löytynyt eikä siis poistettu.

Vanhaa Nvidia-ajuriani tuetaan ytimessä 5.4 mutta ei enää ytimessä 5.8, joten siitä syystä näyttö pimeni minulla.

Koetan palauttaa uudestaan elokuun 2020 version (ainoa joka minulle on Timeshiftissä), sillä automaattiset turvapäivitykset taas toivat 5.8-ytimen Ubuntuuni.

Jos kaikki menee hyvin, kerron ja kehuskelen. Jos ei, voin mököttää päivän tai pari.


elohope

  • Käyttäjä
  • Viestejä: 102
    • Profiili
Aiemmin kuvatun Timeshift-järjestelmänpalautuksen ja hwe-paketin poiston jälkeen tilanne jatkuu ennallaan:

Edelleen minulle tarjotaan päivitystä ytimeen 5.8 samaalla tavoin kuin aiemmassa viestissäni.

Alan siis epäillä, että päivitys 5.8 johtuu jostain Ubuntun tuottajien (harvinaisesta) virheestä. Joka varmaan korjaantuu aikanaan. Jätän koneeni lepäämään.

JaniAlander

  • Käyttäjä / moderaattori+
  • Viestejä: 2992
    • Profiili
Mikäs Nvidia kortti sulla on? Jos tää koskee lähinnä tiettyä ikää vanhempia Nvidian kortteja? Käsittääkseni niissä käytetään myös vanhempaa ajuria?
Core i5-9400F 2.9ghz 32GB Ram, Nvidia RTX2060 Kubuntu 20.04.01-64bit, Windows 10 Pro 64-bit Samsung Series 5, AMD A-6 2.1 GHz 4 Gt Ram, Ubuntu 18.04 64-bit.
Lenovo T60 Core2Duo 2GB Ram Ati Mobility Radeon 128 MB Ubuntu Mate 16.04-64bit
Commodore Amiga 500 1MB Ram.

qwertyy

  • Käyttäjä
  • Viestejä: 5073
    • Profiili
Aiemmin kuvatun Timeshift-järjestelmänpalautuksen ja hwe-paketin poiston jälkeen tilanne jatkuu ennallaan:

Edelleen minulle tarjotaan päivitystä ytimeen 5.8 samaalla tavoin kuin aiemmassa viestissäni.

Alan siis epäillä, että päivitys 5.8 johtuu jostain Ubuntun tuottajien (harvinaisesta) virheestä. Joka varmaan korjaantuu aikanaan. Jätän koneeni lepäämään.
Taidat olla oikeassa. Asensin eilen HTPC koneeseeni mielenkiinnosta Ubuntu Budgien 20.10 ja näyttö meni pimeäksi heti asennuksen jälkeen. Käynnistin koneen recovery kernelillä ja tein päivitykset (full-upgrade) ja sen jälkeen näyttö palautui normaaliksi. Asensin recoveryssä myös Nvidian paketit. Kyseisessä koneessa Nvidian 1030 näytönohjain.

kaulahuivi

  • Käyttäjä
  • Viestejä: 246
    • Profiili
Ubuntu teki Manjarot, poisti Nvidia tukea. Siksi koneet pimenee.

elohope

  • Käyttäjä
  • Viestejä: 102
    • Profiili
Ongelman perussyy oli minulla ilmeisesti se, että Ubuntun lts-versioon 20.04 pääsi latautumaan
ydin 5.8, vaikka kyseisen version eliniän ajan Ubuntun tulisi pitäytyä päivittämässään
ytimessä 5.4.

Vanhan Geforce 210 näytönohjaimeni ajuri ei enää ole tuettu ytimessä 5.8, joten näyttöni sammui.

Joudun ilmeisesti odottelemaan, että Ubuntun päivityksistä poistetaan HWE-palikat

Koodia: [Valitse]
linux-generic-hwe-20.04
linux-image-generic-hwe-20.04

poistuvat tai systeemiä korjataan. Tämä hwe-ongelma toistuu erään kyynisen kommentaattorin mukaan jokaisen parittoman vuoden alussa johtuen Ubuntun päivitysaikataulutuksista. Siis varoitus
puhelimen kalenteriin vuoden 2022 joulukuun loppuun: vuoden 2023 alussa Ubuntu tökkii
HWE-päivityksen takia ...

Päivitin koneen, ja uudelleenkäynnistyksen aikana painoin Vaihto-näppäintä seuraten nm:n ohjetta. Niin pääsin valitsemaan avatuneesta Grub-valikosta tutun ytimen 5.4. Sen käynnistyttyä poistin Synapticilla kaikki sellaiset linux-alkuiset paketit, joissa oli versiomerkintä "5.8".

Komennolla uname -r varmistin käytössä olevan ytimen versionumeron ja päivitin sillä perusteella initramfs-tiedoston:

Koodia: [Valitse]
sudo update-initramfs -c -k 5.4.0-60-generic

No nyt sain ainakin ajanmukaisemman järjestelmän talteen Timeshiftille, ja
pääsen tekemään lumitöitä.
« Viimeksi muokattu: 12.01.21 - klo:12.22 kirjoittanut elohope »

shelby

  • Käyttäjä
  • Viestejä: 1864
    • Profiili
Tuli 5.8-xxx-37 ja nvidia on 460xx, ei onkkelmia.
Ubu Gnome 20.04.1 LTS
Win 8.1 laptop I
Win 10 laptop II
Ubu Mate 20.04.1 LTS
Kubu 20.04.1 LTS

Eesaurus

  • Käyttäjä
  • Viestejä: 3183
    • Profiili
Juu, vanhempienkin 2012 HP pöytäkoneen (Nvidia GT-520 suljetulla ajurilla) resoluutio oli mennyt ilmeisesti 5.8 kernelillä keturalleen, kaikki oli jättikokoista. Ajoin sitten kaikki päivitykset, se toi tuoreemman 5.8 -version, joka sitten hävitti verkkoyhteydenkin. :P

No, 5.4 Grub-Customizerilla käyttöön ja kaikki toimi taas. Harmillisia juttuja, olisin kuvitellut, että ko. koneella olisi päässyt vähän pitemmälle ilman ongelmia.