Kirjoittaja Aihe: Luotettava Lubuntu ...  (Luettu 1692 kertaa)

fossiili

  • Käyttäjä
  • Viestejä: 771
    • Profiili
Luotettava Lubuntu ...
« : 01.04.18 - klo:13.05 »
Ystävälläni on hänen nuoremman tyttärensä exmiehen silloiselle anopilleen lahjoittama pc, jossa oli peräti WindowsXP Professional.  Kuten tiedämme windowssit ikääntyvät nopeasti.  Minusta ko. mikro oli jo lähes käyttökelvoton.  Vaikka jonkinverran muutosvastarintaa esiintyi,  päivitin järjestelmäksi Linuxin.  Halusin kaiken tarpeettoman tauhkan pois konevanhuksen suonistosta ja siksi poistin täydellisesti Windowssin. Nykyään joudunkin toisinaan kuulemaan huokailua:
Lainaus
Silloin kun oli Windows, kaikki toimi hyvin ja helposti!
:'(

Kokemukseni mukaan Linux-jakeluilla ennemmin tai myöhemmin päivitykset sekoilee.  Valitettavasti en ole tullut opiskelleeksi riittävästi osatakseni korjata ongelmat.  Koska uuden  jakelun asentaminen on helppoa olen kopioinut tarvitsemani tiedostot usb-porttiin kytketylle kovalevylle ja sitten laittanut distron uusiksi.  Mutta nyt en pysty näin tekemään vaan tämä viimeksi marraskuussa päivitetty Lubuntu pitäisi saada toimimaan. Olen hyvin kiitollinen avusta  :-*
Koodia: [Valitse]
leena@leenanpc:~$ uname -a
Linux leenanpc 4.10.0-40-generic #44-Ubuntu SMP Thu Nov 9 14:48:37 UTC 2017 i686 athlon i686 GNU/Linux
Päivitysyritys:
Koodia: [Valitse]
leena@leenanpc:~$ sudo apt-get update
[sudo] password for leena:
Siv:1 http://fi.archive.ubuntu.com/ubuntu zesty InRelease
Siv:2 http://fi.archive.ubuntu.com/ubuntu zesty-updates InRelease
Siv:3 http://security.ubuntu.com/ubuntu zesty-security InRelease
Siv:4 http://fi.archive.ubuntu.com/ubuntu zesty-backports InRelease
Vrhe:5 http://fi.archive.ubuntu.com/ubuntu zesty Release
  404  Not Found [IP: 91.189.88.162 80]
Vrhe:6 http://security.ubuntu.com/ubuntu zesty-security Release
  404  Not Found [IP: 91.189.91.26 80]
Vrhe:7 http://fi.archive.ubuntu.com/ubuntu zesty-updates Release
  404  Not Found [IP: 91.189.88.162 80]
Vrhe:8 http://fi.archive.ubuntu.com/ubuntu zesty-backports Release
  404  Not Found [IP: 91.189.88.162 80]
Luetaan pakettiluetteloita... Valmis
E: The repository 'http://fi.archive.ubuntu.com/ubuntu zesty Release' does no longer have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: The repository 'http://security.ubuntu.com/ubuntu zesty-security Release' does no longer have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: The repository 'http://fi.archive.ubuntu.com/ubuntu zesty-updates Release' does no longer have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: The repository 'http://fi.archive.ubuntu.com/ubuntu zesty-backports Release' does no longer have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
leena@leenanpc:~$ sudo apt-get update
[sudo] password for leena:
Siv:1 http://fi.archive.ubuntu.com/ubuntu zesty InRelease
Siv:2 http://fi.archive.ubuntu.com/ubuntu zesty-updates InRelease
Siv:3 http://security.ubuntu.com/ubuntu zesty-security InRelease
Siv:4 http://fi.archive.ubuntu.com/ubuntu zesty-backports InRelease
Vrhe:5 http://fi.archive.ubuntu.com/ubuntu zesty Release
  404  Not Found [IP: 91.189.88.162 80]
Vrhe:6 http://security.ubuntu.com/ubuntu zesty-security Release
  404  Not Found [IP: 91.189.91.26 80]
Vrhe:7 http://fi.archive.ubuntu.com/ubuntu zesty-updates Release
  404  Not Found [IP: 91.189.88.162 80]
Vrhe:8 http://fi.archive.ubuntu.com/ubuntu zesty-backports Release
  404  Not Found [IP: 91.189.88.162 80]
Luetaan pakettiluetteloita... Valmis
E: The repository 'http://fi.archive.ubuntu.com/ubuntu zesty Release' does no longer have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: The repository 'http://security.ubuntu.com/ubuntu zesty-security Release' does no longer have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: The repository 'http://fi.archive.ubuntu.com/ubuntu zesty-updates Release' does no longer have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: The repository 'http://fi.archive.ubuntu.com/ubuntu zesty-backports Release' does no longer have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
Jos Zesty-jakelu on jo epärelevantti niin mikä pitäisi olla?Entä jos yritän:
Koodia: [Valitse]
leena@leenanpc:~$ sudo apt-get dist-upgrade
[sudo] password for leena:
Luetaan pakettiluetteloita... Valmis
Muodostetaan riippuvuussuhteiden puu       
Luetaan tilatiedot... Valmis       
Käsitellään päivitystä... Valmis
The following packages were automatically installed and are no longer required:
  linux-headers-4.10.0-19 linux-headers-4.10.0-19-generic linux-headers-4.10.0-22
  linux-headers-4.10.0-22-generic linux-headers-4.10.0-24 linux-headers-4.10.0-24-generic
  linux-headers-4.10.0-28 linux-headers-4.10.0-28-generic linux-image-4.10.0-19-generic
  linux-image-4.10.0-22-generic linux-image-4.10.0-24-generic linux-image-4.10.0-28-generic
  linux-image-extra-4.10.0-19-generic linux-image-extra-4.10.0-22-generic
  linux-image-extra-4.10.0-24-generic linux-image-extra-4.10.0-28-generic
Use 'sudo apt autoremove' to remove them.
Seuraavat UUDET paketit asennetaan:
  linux-headers-4.10.0-42 linux-headers-4.10.0-42-generic linux-image-4.10.0-42-generic
  linux-image-extra-4.10.0-42-generic
Nämä paketit päivitetään:
  apport apport-gtk distro-info-data firefox firefox-locale-en firefox-locale-fi flashplugin-downloader
  flashplugin-installer gir1.2-javascriptcoregtk-4.0 gir1.2-webkit2-4.0 gnome-software
  gnome-software-common gnome-software-plugin-snap libjavascriptcoregtk-4.0-18 libpoppler-glib8
  libpoppler64 libwebkit2gtk-4.0-37 linux-generic linux-headers-generic linux-image-generic nplan
  poppler-utils python3-apport python3-problem-report resolvconf snapd squashfs-tools
27 päivitetty, 4 uutta asennusta, 0 poistettavaa ja 0 päivittämätöntä.
Noudettavaa arkistoa 134 Mt.
Toiminnon jälkeen käytetään 244 M t lisää levytilaa.
Haluatko jatkaa? [K/e] k
Vrhe:1 http://fi.archive.ubuntu.com/ubuntu zesty-updates/main i386 distro-info-data all 0.33ubuntu0.4
  404  Not Found [IP: 91.189.88.152 80]
Vrhe:2 http://fi.archive.ubuntu.com/ubuntu zesty-updates/main i386 resolvconf all 1.79ubuntu4.1
  404  Not Found [IP: 91.189.88.152 80]
Vrhe:3 http://fi.archive.ubuntu.com/ubuntu zesty-updates/main i386 nplan i386 0.32~17.04.1
  404  Not Found [IP: 91.189.88.152 80]
Vrhe:4 http://fi.archive.ubuntu.com/ubuntu zesty-updates/main i386 python3-problem-report all 2.20.4-0ubuntu4.10
..............................................................
............................................................
ei onnistunut  404  Not Found [IP: 91.189.88.152 80]
E: Tiedoston http://security.ubuntu.com/ubuntu/pool/main/l/linux-meta/linux-image-generic_4.10.0.42.42_i386.deb nouto ei onnistunut  404  Not Found [IP: 91.189.88.152 80]
E: Tiedoston http://security.ubuntu.com/ubuntu/pool/main/l/linux/linux-headers-4.10.0-42_4.10.0-42.46_all.deb nouto ei onnistunut  404  Not Found [IP: 91.189.88.152 80]
E: Tiedoston http://security.ubuntu.com/ubuntu/pool/main/l/linux/linux-headers-4.10.0-42-generic_4.10.0-42.46_i386.deb nouto ei onnistunut  404  Not Found [IP: 91.189.88.152 80]
E: Tiedoston http://security.ubuntu.com/ubuntu/pool/main/l/linux-meta/linux-headers-generic_4.10.0.42.42_i386.deb nouto ei onnistunut  404  Not Found [IP: 91.189.88.152 80]
E: Tiedoston http://fi.archive.ubuntu.com/ubuntu/pool/main/s/squashfs-tools/squashfs-tools_4.3-3ubuntu2.17.04.1_i386.deb nouto ei onnistunut  404  Not Found [IP: 91.189.88.152 80]
E: Tiedoston http://fi.archive.ubuntu.com/ubuntu/pool/main/s/snapd/snapd_2.29.4.2+17.04_i386.deb nouto ei onnistunut  404  Not Found [IP: 91.189.88.152 80]
E: Joidenkin arkistojen nouto ei onnistunut, ehkä "apt-get update" auttaa tai kokeile --fix-missing?
leena@leenanpc:~$ sudo apt --fix-missing
apt 1.4.6 (i386)
Usage: apt [options] command

apt is a commandline package manager and provides commands for
searching and managing as well as querying information about packages.
It provides the same functionality as the specialized APT tools,
like apt-get and apt-cache, but enables options more suitable for
interactive use by default.

Most used commands:
  list - list packages based on package names
  search - search in package descriptions
  show - show package details
  install - install packages
  remove - remove packages
  autoremove - Poista kaikki käyttämättömät paketit
  update - update list of available packages
  upgrade - upgrade the system by installing/upgrading packages
  full-upgrade - upgrade the system by removing/installing/upgrading packages
  edit-sources - edit the source information file

See apt(8) for more information about the available commands.
Configuration options and syntax is detailed in apt.conf(5).
Information about how to configure sources can be found in sources.list(5).
Package and version choices can be expressed via apt_preferences(5).
Security details are available in apt-secure(8).
                                        This APT has Super Cow Powers.
leena@leenanpc:~$
  :o
Uskoin ja latasin jakelun lubuntu-17.10.1-desktop-i386.iso
PC-romiskossa on DVD-asema ja xfburn. Löytyi tyhjä DVD+RW. Jostakin syystä xfburn ja PCManFM 1.2.5 eivät tunnista DVD-asemaa.
Muistitikkuja löytyy, joten ei muuta kuin Lubuntun asentaminen tikulle. Miten se menikään: dd if=lubuntu-17.10.1-desktop-i386.iso  OF=
?
dd if=lubuntu-17.10.1-desktop-i386.iso  of=/dev/sdb1 -- tähänkö tapaan?


jekku

  • Käyttäjä
  • Viestejä: 1722
    • Profiili
Vs: Luotettava Lubuntu ...
« Vastaus #1 : 01.04.18 - klo:15.34 »
"dd if=lubuntu-17.10.1-desktop-i386.iso  of=/dev/sdb1 -- tähänkö tapaan?"

Noin muistinvaraisesti: sudolla ja koko levy kohteeksi, ei osio.
Koodia: [Valitse]
sudo dd if=lubuntu-17.10.1-desktop-i386.iso  of=/dev/sdb # -- tähänkö tapaan?

Tomin

  • Palvelimen ylläpitäjä
  • Käyttäjä / moderaattori+
  • Viestejä: 10304
    • Profiili
    • Tomin kotisivut
Vs: Luotettava Lubuntu ...
« Vastaus #2 : 01.04.18 - klo:15.37 »
Kannattaa asentaa LTS-versio (nyt uusin 16.04, pian 18.04), niin se ei vanhene noin nopeasti. Zesty eli 17.04 on julkaistu noin vuosi sitten, mutta tavallisen tuen versiona sen tuki loppui jo kolme kuukautta 17.10-version julkaisun jälkeen eli niitä olisi päivitettävä tiheään. Pitkän tuen version (siis LTS) tuki on viisi vuotta.

dd-komentoa kyllä käytetään tuohon tapaan, mutta of on asetettava muistitikun laitteeseen eikä sen ensimmäisen osion laitteeseen eli ilman osion numeroa. Tikun voi kirjoittaa vähemmällä muistamisella käyttämällä Levyt-ohjelmaa ja sen Levykuvan palautusta.
Automaattinen allekirjoitus:
Lisäisitkö [RATKAISTU] ketjun ensimmäisen viestin aiheeseen ongelman ratkettua, kiitos.

fossiili

  • Käyttäjä
  • Viestejä: 771
    • Profiili
Vs: Luotettava Lubuntu ...
« Vastaus #3 : 01.04.18 - klo:19.16 »
Levyt-ohjelmaa ei ole valmiina eikä sitä saa asennettua. Muistan, että oli jokin terminaalikomento, jolla of-nimen sai selville.  Kai mun kannattaa alkaa kirjoittaa hyviä komentoja ja lausekkeita huopakynällä tapettiin. Eipähän katoa. Jäävät perinnöksi  ;)

jekku

  • Käyttäjä
  • Viestejä: 1722
    • Profiili
Vs: Luotettava Lubuntu ...
« Vastaus #4 : 01.04.18 - klo:19.27 »
Onko tuloksessa eroa kun annat komennon

Koodia: [Valitse]

df -h


tikku irrotettuna ja kiinnitettynä.

Postimies

  • Käyttäjä
  • Viestejä: 2127
    • Profiili
Vs: Luotettava Lubuntu ...
« Vastaus #5 : 02.04.18 - klo:12.22 »
Levyistä saa infoa vaikka  sudo blkid tai  sudo fdisk -l

Tikku ei saa olla liitetty. Esim sudo umount /dev/sdb1 poistaa levyliitoksen.
Sen voi tehdä myös tiedostonhallinnalla.

Itsellä vielä LUbuntu 14 käytössä... tosin mediakoneessa.
Nettiselaimeksi voi harkita firefox esr versiota.
Itsellä toimii toistaiseksi oikoluku.

Ihan varma en ole tuen pituudesta LUbuntulle vaikka olisi
lts versio.

Meniskö kirjoitus ihan cat levy.iso > /dev/sdb ? Itse olen käyttänyt aina dd komentoa.
Olisi vähemmän kirjoittamista tapettiin. Komennot jäävät myös komentotulkin historiaan.
Tapetin sijaan niitä voi etsiä sieltäkin.

Päivittäminen voi olla tuskallista.... Päivittelin toista viikkoa hidasta konetta jossa
pitkään päivittämätön Gentoo (yli vuosi). Kummasti siinä kaikki uudistui - asennettu
2012 ja periaatteessa ei asenneta uudestaan.

JaniAlander

  • Käyttäjä / moderaattori
  • Viestejä: 2303
    • Profiili
Vs: Luotettava Lubuntu ...
« Vastaus #6 : 07.04.18 - klo:04.20 »
Lyhkäinen mutta yksinkertainen neuvo jos jollekin ystävälle tai tutulle asennat ja oletus on että he ei paljon halua opetella systeemin ylläpitoa:
Ubuntussa versiointi on muotoa xx.xx, joista jälkimmäinen numero on joko 04 tai 10. Ja sitten se iso numero vuosiluku. Noniin sitten se sääntö jokainen parillinen iso numero jota seuraa 04 on pitkän tuen versio, kaikki muut on väliversioita. Eli esim omalla Ubuntu historialla 8.04, 10.04, 12.04, 14.04, 16.04 ja tuleva 18.04 on pitkän tuen versioita. Lubuntussa tais olla rajatumpi tuki ainakin yhdessä vaiheessa, mutta Ubuntu ja Kubuntu on tuettuja 5v julkaisun jälkeen noissa versioissa.
Sitten taas lyhyen tuen versioita on esim 12.10, 13.04, 13.10, 14.10, 15.04, 15.10, 16.10, 17.04, 17.10. Ne on tuettu vaan siihen pisteeseen kun uudempi versio ilmaantuu. Niitä ei kannata asentaa sille kamulle. Kun tuki loppuu niin loppuu myös pakettien saanti.
Core i5-4460 3.2ghz 8GB Ram, Nvidia GTX950 Kubuntu 16.04-64bit FreeBSD 11.0-Release Windows 10 Pro 64-bit
Lenovo T60 Core2Duo 2GB Ram Ati Mobility Radeon 128 MB Ubuntu Mate 16.04-64bit
Commodore Amiga 500 1MB Ram.

Eesaurus

  • Käyttäjä
  • Viestejä: 2673
    • Profiili
Vs: Luotettava Lubuntu ...
« Vastaus #7 : 07.04.18 - klo:07.44 »
Sitten taas lyhyen tuen versioita on esim 12.10, 13.04, 13.10, 14.10, 15.04, 15.10, 16.10, 17.04, 17.10. Ne on tuettu vaan siihen pisteeseen kun uudempi versio ilmaantuu. Niitä ei kannata asentaa sille kamulle.

Täysin samaa mieltä. Ja minusta Linuxia ei pitäisi lainkaan asentaa vastahakoiselle käyttäjälle. Siitä ei välttämättä seuraa mitään hyvää, ja ainakin siinä hirttää itsensä atk -tueksi pitkälle tulevaisuuteen.
« Viimeksi muokattu: 07.04.18 - klo:07.46 kirjoittanut Eesaurus »

Postimies

  • Käyttäjä
  • Viestejä: 2127
    • Profiili
Vs: Luotettava Lubuntu ...
« Vastaus #8 : 07.04.18 - klo:12.31 »

Täysin samaa mieltä. Ja minusta Linuxia ei pitäisi lainkaan asentaa vastahakoiselle käyttäjälle. Siitä ei välttämättä seuraa mitään hyvää, ja ainakin siinä hirttää itsensä atk -tueksi pitkälle tulevaisuuteen.

Itse olen onneksi selvinnyt  melko vähällä.

jekku

  • Käyttäjä
  • Viestejä: 1722
    • Profiili
Vs: Luotettava Lubuntu ...
« Vastaus #9 : 07.04.18 - klo:13.16 »
Sitten taas lyhyen tuen versioita on esim 12.10, 13.04, 13.10, 14.10, 15.04, 15.10, 16.10, 17.04, 17.10. Ne on tuettu vaan siihen pisteeseen kun uudempi versio ilmaantuu. Niitä ei kannata asentaa sille kamulle.

Täysin samaa mieltä. Ja minusta Linuxia ei pitäisi lainkaan asentaa vastahakoiselle käyttäjälle. Siitä ei välttämättä seuraa mitään hyvää, ja ainakin siinä hirttää itsensä atk -tueksi pitkälle tulevaisuuteen.

Tosiaan, siinä mielessä redmondin systeemit helpompia, kunhan kertoo loppukäyttäjälle että on sitten omillaan :)

Muutamalle käyttäjälle olen sanonut että asennan Linuksin tai etsiköön jonkun toisen.

Eesaurus

  • Käyttäjä
  • Viestejä: 2673
    • Profiili
Vs: Luotettava Lubuntu ...
« Vastaus #10 : 07.04.18 - klo:17.14 »
Muutamalle käyttäjälle olen sanonut että asennan Linuksin tai etsiköön jonkun toisen.

Jep, toimii se noinkin. Minä saatan tarjota ensisijaisesti Windowsin uudelleenasennusta, jos kone on solmussa. Jos se ei jostain syystä ole mahdollista, niin sitten toki tilanteen voi pelata halutessaan niin, että esittää Linuxin ainoana vaihtoehtona pelastaa kone vielä käyttöön. ;) Mutta laiskuuttani välttelen hieman tuotakin, koska en halua joutua atk -tueksi. Nykyiset tuettavat riittää hyvin. :P


JaniAlander

  • Käyttäjä / moderaattori
  • Viestejä: 2303
    • Profiili
Vs: Luotettava Lubuntu ...
« Vastaus #11 : 09.04.18 - klo:05.35 »
Hyvälle ystävälle joka sai aina Windows koneensa solmuun asensin lts Ubuntun ja hän on tosi tyytyväinen systeemiin. Päivittyy automaattisesti ja ajaa hänen tarpeensa. Eikä enää tule haitakkeita koneelle.
Core i5-4460 3.2ghz 8GB Ram, Nvidia GTX950 Kubuntu 16.04-64bit FreeBSD 11.0-Release Windows 10 Pro 64-bit
Lenovo T60 Core2Duo 2GB Ram Ati Mobility Radeon 128 MB Ubuntu Mate 16.04-64bit
Commodore Amiga 500 1MB Ram.