Kirjoittaja Aihe: 12.04.3 ei käynnisty päivityksen jälkeen  (Luettu 1619 kertaa)

uggeli

  • Käyttäjä
  • Viestejä: 351
    • Profiili
12.04.3 ei käynnisty päivityksen jälkeen
« : 08.01.14 - klo:04.14 »
Kernel Update - Stopping System Runlevel V Compatibility

Laitan tästä uuden aiheen, kun en muista (enkä edes kunnolla nähnyt nopeasti menevää virheilmoitusta). Olin siis tänään (eilen :D) porukoilla ja päivitin ubuntun asennuksen, edellisestä päivityksestä oli varmaan liki kuukausi. Nyt päivityksiä tuli n. 150 kpl. Muuten kaikki vaikutti menneen ok (en tosin ollut vahtimassa koneen luona), mutta kun koneen käynnisti uudestaan ei x enää käynnistynyt, ei edes komennolla startx.

Nyt kun tätä kirjoittaessa googletin, niin ubuntulogon alle (siinä missä ne pallot muuttuvat punaiseksi logon alla, vuorollaan vasemmmmalta oikealle), taisi tulla teksti Stopping System V Runlevel. Tämän jälkeen käynnistys etenee mustaan tekstiruutuun, jossa voi kirjautua sisään terminal tilassa.

Kokeilin käynistystä pykälää vanhemmalla kernelillä => toimi. Epäilin että ongelma olisi nvidia ajureissa ja kokeilin vaihtaa käytössä olevaa ajuriversiota jonka seuraksena myös tällä kernelillä (ja myös tästä pykälää vanhmmalla) lakkasi graafinen tila toimimasta.


Tähän mennessä olen kokeillut asentaa nvidia-current ajurit uudestaan komentokehotteeseen käynnistetyäni ja käynnistää uudestaan => ei vaikutusta. Poistin nvidia-current ajurit, asensin nvidia-319 ajurit uudestaan => ei vaikutusta.


Mikähän tuossa meni mönkään? Tilanetta vaikeuttaa myös se, että ko kone on noin 13km päässä, joten en voi joka asiaa käydä tarkistamassa mitä ilmoittaa, enkä juuri tämän tarkemmin muista.. Ajattelin silti kysellä täältä jotain pohjatiedoksi, ennenkuin ajelen tuon välin uudestaan konetta katsomaan... Joten olen kaikista tilannetta selvittävistä neuvoista todella kiitollinen.


Edit: Täällä taitaa olla sama ongelma:

http://askubuntu.com/questions/399186/12-04-kernel-update-stopping-system-runlevel-v-compatibility/400906#400906 (lisätty linkkinä ylös)


Ainut ongelma, että tuolla neuvotaan palaamaan vanhaan kernel versioon, mutta itselläni nyt vika sielläkin..
« Viimeksi muokattu: 08.01.14 - klo:04.25 kirjoittanut uggeli »
Linux: Be root
Windows: Reboot

nm

  • Käyttäjä
  • Viestejä: 12903
    • Profiili
Vs: 12.04.3 ei käynnisty päivityksen jälkeen
« Vastaus #1 : 09.01.14 - klo:18.12 »
"Stopping System V Runlevel" taitaa olla ihan normaali vaihe käynnistyksessä. Ongelmana on vain se, että X.org ei lähde käyntiin. Katso siis X.org:n lokitiedostosta, mikä ongelma estää työpöydän käynnistymisen:

Koodia: [Valitse]
cat /var/log/Xorg.0.log

Veikkaan, että ongelma johtuu Nvidian ajurista. Varmista, että kaikki Nvidian suljetun ajurin versiot on poistettu järjestelmästä ja asenna sitten sopiva versio takaisin:

Koodia: [Valitse]
sudo apt-get purge "nvidia*"
sudo apt-get install nvidia-319

Jos tämä ei auta, tarkista taas X.org:n loki sekä dkms-moduulien tilanne:

Koodia: [Valitse]
dkms status

juyli

  • Vieras
Vs: 12.04.3 ei käynnisty päivityksen jälkeen
« Vastaus #2 : 09.01.14 - klo:21.55 »
Kokeilin käynistystä pykälää vanhemmalla kernelillä => toimi. Epäilin että ongelma olisi nvidia ajureissa ja kokeilin vaihtaa käytössä olevaa ajuriversiota jonka seuraksena myös tällä kernelillä ...

Nuo Nvidian suljetut ajurit ovat riippuvaisia käytettävästä kernel-versiosta. Ja sopivasti kernel-versioita ja Nvidia-ajureita vaihdettaessa saa X-järjestelmänsä kyllä vaivattomasti sekaisin.
Jos ylläpitämäsi järjestelmä ei välttämättä tarvitse suljettuja ajureita, käyttäisin Nouveau-ajureita, jotka jo oletuksena päivittyvät ihan normaaleina päivityksinä. Suljetut ajurit on asennettava aina erikseen. (Ja kuten nm kertoi, voi vanhempien ajureiden poistaminen olla vähintäänkin hyödyllistä.).
Jos nyt välttämättä ylläpidät toisten järjestelmiä, on aina vaihtoehtona SSH- ja muu etäkäyttö, joten 13Km ei olisi edes hidaste.

PS. Jos todellakin ylläpidät muiden järjestelmiä, olisi mielestäni hyödyllistä ihan aika-ajoin huolehtia, että ylläpidettävä järjestelmä on ajantasalla. n. 150-paketin päivitys viittaa Ubuntu-jakelussa aika pitkää aikaväliä päivitysten välillä. Päivitykset on kaikissa jakeluissa myös ajastettavissa, joten monia vaihtoehtoja on tarjolla.
« Viimeksi muokattu: 09.01.14 - klo:22.00 kirjoittanut juyli »

uggeli

  • Käyttäjä
  • Viestejä: 351
    • Profiili
Vs: 12.04.3 ei käynnisty päivityksen jälkeen
« Vastaus #3 : 09.01.14 - klo:22.59 »
Kiitos neuvoista, huomenna menen katsomaan josko tuon saisi kuntoon. Ylläpidettäviä (muiden) koneita ei ole tosiaan kuin tuo ja välillä aika menee muissa merkeissä kuin koneen parissa, niin saattaa tuo päivitysväli venähtää (etenkin nyt, kun oli joulu, uusivuosi jne). Etäyhteyttä olen toki harkinnutkin ja jossain määrin toteuttanutkin, mutta toistaiseksi vasta teamviewerillä (koneessa kun windowskin). Täytyy silti hakea hieman kestävämpi ratkaisu näiden päivitysten ajamiseksi, mikä se nyt tulee olemaankaan..

Ilmoittelen myöhemmin miten kävi & mitä selvisi. Kiitos tähän astisista.

Edit:

logia ei ollut (liejö poistunut ajurien poiston myötä? Noh noita ajureita oli siilti melko määrä muitakin kuin nuo 2, joten tuo

Koodia: [Valitse]
sudo apt-get purge "nvidia*"
sudo apt-get install nvidia-319-updates

korjasi ongelman. Päädyin tosiaan asentamaan nuo updates version ajurit ja hyvin pelittää. Ajuriongelmaksi itsekin aiemmin jo epäilin, mutta jäi tuo eri versioiden poisto vaillinaiseksi silloin..

Kiitos neuvoista!
« Viimeksi muokattu: 10.01.14 - klo:14.53 kirjoittanut uggeli »
Linux: Be root
Windows: Reboot