Kirjoittaja Aihe: Wlan-yhteysongelma  (Luettu 5033 kertaa)

tetrafuran

  • Käyttäjä
  • Viestejä: 405
    • Profiili
Wlan-yhteysongelma
« : 12.11.10 - klo:23.41 »
Aluksi wlan yhteys toimi, kuin junan vessa, muutta pari päivää sitten yhteyttä ei muodostunutkaan, vaan pitkän odotuksen jälkeen näyttöön ilmaantui verkon salasanaa kysyvä ikkuna. Salasana oli oikein, joten painoin vain ok, mutta jälleen pitkän odotuksen jälkeen sama ikkuna tuli uudelleen vastaan. Tietokoneen buuttaus ratkaisi tämän useita kertoja, mutta nyt tämäkin QAD-menetelmä on menettänyt tehonsa. Toissa päivänä sain kuitenkin jostain selittämättömästä syystä yhteyden muodostumaan. Se vain ei kestänyt pitkään ja hyvin kiusallisesti kesken huutokaupan jouduin vaihtamaan läppäriin. Yhteys on siis toiminut jokseenkin satunnaisesti... paitsi että nyt se on täysin ennustettavasti ja takuuvarmasti aina rikki.

Ongelma ei ole reitittimessä, koska se jakaa yhteyden täysin ongelmitta neljälle laitteelle päivittäin. Toisella kiintolevyllä (jossa on xp) sain kortin toimimaan pienen näpertelyn jälkeen, joten nähtävästi kaikki hardware virhelähteet on jo poissuljettu.

Luettuja sivuja:
https://help.ubuntu.com/community/WifiDocs/WirelessTroubleShootingGuide
https://help.ubuntu.com/community/WifiDocs/WirelessTroubleShootingGuide/Commands#iwconfig
https://help.ubuntu.com/community/WifiDocs/WirelessTroubleShootingGuide/Commands#lshw
https://help.ubuntu.com/community/WifiDocs/WirelessTroubleShootingGuide/Connections
https://help.ubuntu.com/community/WifiDocs/WirelessTroubleShootingGuide/Drivers
https://help.ubuntu.com/community/NetworkManager

http://linux.fi/index.php/WLAN
http://linux.fi/wiki/WLAN_UKK

Kokeiltuja komentoja:
sudo nm-tool
wlan0 on olemassa ja sen ajuri on rtl8180. HW-address on olemassa ja erilaiset enkryptauksen näyttävät yessiä. Wireless access point näyttää reitittimen nimen oikein - varmaan ne muutkin numerot on oikein.

sudo iwconfig
wlan0 näkyy ja siinä on paljon kaikenlaisia tietoja, joista en ymmärrä.

lshw -C network
Täällä ainakin näkyy wlan0 ja sillä on taas paljon kaikenlaisia kummia tietoja. Varmaan nekin on ihan ok. Kaiken tämän perusteella väitänkin, että hardware on tunnistettu oikein, ajurit toimivat. Toisaalta ilman nettiyteyttä ei mitään uusia ajureita saada mistään, joten unohdetaan se pivittäminen jo tässä vaiheessa.

sudo iwconfig wlan0 ap 00:22:B0:B7:6A:D9 jne ... pitkä komento
Ei toiminut kun en tiennyt mitä kaikkea sinne piti laittaa.

Syntaksi menisi teoriassa näin:
sudo iwconfig <ath0> essid <essid> ap <xx:xx:xx:xx:xx:> key <XXX> mode <> commit
ath0 tilalle pitäisi varmaankin tulla wlan0
essid: olisi sitten verkon nimi. Laitoin sen lainausmerkkeihin, koska kaksiosainen nimi taitaa sekoittaa komennon.
ap: on kait access point. Sen sain jo selvillä näillä muilla komennoilla.
Key: manista luin että siihen tulee s:minunverkkonisalasana

Lopputulos olis siis:
error for wireless requies "set encode" (8b2a):
set failed on device wlan0 invalid argument

Tässä vaiheessa uskallan sanoa yrittäneeni riittävästi, joten lienee jo korkea aika kysyä muilta ideoita.

OS:kubuntu
And so at last the beast fell and the unbelievers rejoiced. But all was not lost, for from the ash rose a great bird. The bird gazed down upon the unbelievers and cast fire and thunder upon them. For the beast had been reborn with its strength renewed, and the followers of Mammon cowered in horror.

Thinkit

  • Käyttäjä
  • Viestejä: 912
  • Kysyvä ei tieltä eksy, eikä eksyvä tietä kysy.
    • Profiili
Vs: Wlan-yhteysongelma
« Vastaus #1 : 13.11.10 - klo:08.35 »
Toimisiko tämä ohje:

Lainaus
To connect to a Wireless network, first type

Koodia: [Valitse]
sudo iwlist wlan0 scan
This scans and lists all wireless networks which broadcast their ESSID. Assuming the ESSID is "Rox", then connect to the network

Koodia: [Valitse]
sudo iwconfig wlan0 essid "Rox"
If the network requires a Key then, associate the key

Koodia: [Valitse]
sudo iwconfig wlan0 key ABCD-1234-5678-EFG2
Finally, request for an IP

Koodia: [Valitse]
sudo dhclient wlan0
You should be able to connect.

t: Antti  ;)
Lenovo Thinkpad e520
Kde Neon 5.22.3
Intel(R) Core(TM) i5-2410M CPU @ 2.30GHz
Amd Radeon HD 6630m
Intel HD 3000 integroitu
Samsung Evo 120G kovo ja 8G muistia
Sony Xperia 5 mk2 ja android 11

tetrafuran

  • Käyttäjä
  • Viestejä: 405
    • Profiili
Vs: Wlan-yhteysongelma
« Vastaus #2 : 13.11.10 - klo:12.43 »
sudo iwconfig wlan0 essid "Rox"
Tämä komento ei anna mitään vastausta riippumatta siitä minkä nimisen verkon sinne antaa. Ei siis ole harmainta aavistusta kirjoitinko verkon nimen oikein tai väärin. Noh. kopioin sen sellaisenaan, joten kyllä se on oikein, mutta komennon non-verbose käyttäytyminen hämmentää hieman.

sudo iwconfig wlan0 key ABCD-1234-5678-EFG2
Kuten aikaisemminkin: en käytä heksamuotoisia salausavaimia, vaan ihan tavallista salasanaa, kuten esim Abc123. Tällöin siis komento olisi:
sudo iwconfig wlan0 key s:Abc123
Luin manuaalista, että tuo s: pitää tulla salasanan eteen, mikäli salasana on tarkoitettu ihmisiä varten. Komennon vastauksena sain saman errorin, kuin viimeksikin:
error for wireless request set encode 8b2a
set failed on device wlan0; invalid argument
And so at last the beast fell and the unbelievers rejoiced. But all was not lost, for from the ash rose a great bird. The bird gazed down upon the unbelievers and cast fire and thunder upon them. For the beast had been reborn with its strength renewed, and the followers of Mammon cowered in horror.

timbba

  • Käyttäjä
  • Viestejä: 1413
    • Profiili
Vs: Wlan-yhteysongelma
« Vastaus #3 : 13.11.10 - klo:13.08 »
Mikä salaus kyseessä? Eikö sulla ole network-manageria? Tuleeko dmesgiin jotain ihmeellistä error tyyppistä tulostetta? Entä löytyykö logista jotain mielenkiintoista (file taitaa olla /var/log/syslog)?

tetrao

  • Käyttäjä
  • Viestejä: 177
    • Profiili
Vs: Wlan-yhteysongelma
« Vastaus #4 : 13.11.10 - klo:15.08 »
Lainaus
sudo iwconfig wlan0 key s:Abc123
Luin manuaalista, että tuo s: pitää tulla salasanan eteen, mikäli salasana on tarkoitettu ihmisiä varten. Komennon vastauksena sain saman errorin, kuin viimeksikin:
error for wireless request set encode 8b2a
set failed on device wlan0; invalid argument

Testailin huvikseni. Tuota ylläolevaa komentoa suorittaessa pitää olla tarkkana, että antaa salasanan oikean mittaisena. Väärä pituutta käyttäessä saa mainitsemasi virheen.

Esim.
64-bittinen salaus=40bitin avain (5-merkkiä) + 24bitin IV-data
128-bittinen salaus=104bitin avain (13-merkkiä) + 24bitin IV-data
256-bittinen salaus =232bitin avain (29-merkkiä) + 24bitin IV-data

Vastaavat pituudet heksalukuja käytettäessä:
64-bittinen salaus= 10-merkkiä
128-bittinen salaus= 26-merkkiä
256-bittinen salaus= 58-merkkiä

Jos saat salasanan syötettyä, eikä vieläkään toimi, niin kannattaa kokeilla lisätä channel auto iwconfig rimpsun loppuun. Tällä varmistetaan että oikea kanava löytyy liikennöintiä varten. Jos tiedät kanavan voit antaa sen myös itse parametrina channel <kanavanumeo>  

Edit: Nuo lukemat siis WEP-salaukselle, jota en tietenkään suositte, kun on käytössä jämerämpiä menetelmiä kuten WPA.
« Viimeksi muokattu: 13.11.10 - klo:15.23 kirjoittanut tetrao »
Arch Linux - A simple, lightweight distribution

tetrafuran

  • Käyttäjä
  • Viestejä: 405
    • Profiili
Vs: Wlan-yhteysongelma
« Vastaus #5 : 13.11.10 - klo:15.59 »
Tarkempi kuvaus ongelmasta:
KDE-alapalkissa on se verkkonappula. Ohjelmien nimiähän ei missään vaiheessa näy, mutta jos minulta kysytään niin tuon nimi voisi hyvin olla vaikka se network manager. Joka tapauksessa sieltä sitten vihdoin valitsen oikean verkon ja normaalisti tämä riittäisi. Tällä kertaa (ja edellisellä parillakymmenellä kerralla) tovin odottelun jälkeen näyttöön ilmaantuu ikkuna, jossa kysytään verkon salasanaa. Olen jo antanut salasanan jo kauan aikaa sitten ja silloin tuolla salasanalla päästiin sisään oikein mukavasti. En myöskään ole vaihtanut verkon salasanaa, joten se on taatusti juuri se, jonka tuohon olen kirjoittanut. Tässä ikkunassa lukee, että security: wpa/wpa2  personal. Ok napin painalluksen jälkeen ikkuna häviää ja alapalkin nimetön-ehkän-etwork-manager näyttää tekstin "configuring interface". Tämän jälkeen samainen salasanakysely ilmaantuu jälleen näyttöön aivan kuin salasana olisi väärä.

Niin ja mitä mielenkiintoista sieltä logista sitten pitäisi löytää?
Nojoo siellä logissa tosin NetworkManager sanoo että lyhennettynä seuraavaaa:

authentification with 00:00:00:00: timed out
wlan0 link timed out dvice state change 6->9 reason 7
activation wlan0 failed for access point (Kala Verkko)

marking connection 'Kala Verkko' invalid,
activation wlan0 failed, device stage change 9 ->3 reason 0
deactivating device, reason 0
jne jne
Mitä tästä logista siis pitäisi havainnoida?
And so at last the beast fell and the unbelievers rejoiced. But all was not lost, for from the ash rose a great bird. The bird gazed down upon the unbelievers and cast fire and thunder upon them. For the beast had been reborn with its strength renewed, and the followers of Mammon cowered in horror.

timbba

  • Käyttäjä
  • Viestejä: 1413
    • Profiili
Vs: Wlan-yhteysongelma
« Vastaus #6 : 13.11.10 - klo:18.07 »
Tarkempi kuvaus ongelmasta:
KDE-alapalkissa on se verkkonappula. Ohjelmien nimiähän ei missään vaiheessa näy, mutta jos minulta kysytään niin tuon nimi voisi hyvin olla vaikka se network manager. Joka tapauksessa sieltä sitten vihdoin valitsen oikean verkon ja normaalisti tämä riittäisi. Tällä kertaa (ja edellisellä parillakymmenellä kerralla) tovin odottelun jälkeen näyttöön ilmaantuu ikkuna, jossa kysytään verkon salasanaa. Olen jo antanut salasanan jo kauan aikaa sitten ja silloin tuolla salasanalla päästiin sisään oikein mukavasti. En myöskään ole vaihtanut verkon salasanaa, joten se on taatusti juuri se, jonka tuohon olen kirjoittanut. Tässä ikkunassa lukee, että security: wpa/wpa2  personal. Ok napin painalluksen jälkeen ikkuna häviää ja alapalkin nimetön-ehkän-etwork-manager näyttää tekstin "configuring interface". Tämän jälkeen samainen salasanakysely ilmaantuu jälleen näyttöön aivan kuin salasana olisi väärä.

Auttaako jos poistaa kde:n network-managerista asetukset langattomalle verkolle ja luo ne uudestaan?


Niin ja mitä mielenkiintoista sieltä logista sitten pitäisi löytää?
Nojoo siellä logissa tosin NetworkManager sanoo että lyhennettynä seuraavaaa:

authentification with 00:00:00:00: timed out
wlan0 link timed out dvice state change 6->9 reason 7
activation wlan0 failed for access point (Kala Verkko)

marking connection 'Kala Verkko' invalid,
activation wlan0 failed, device stage change 9 ->3 reason 0
deactivating device, reason 0
jne jne
Mitä tästä logista siis pitäisi havainnoida?

Tuohon liittyen löysin tälläisen:
https://bugs.launchpad.net/ubuntu/+bug/572777

Jossa jotkut oli ratkoneet asian asentamalla Debian Sidin wpasupplicant paketin ja jotkut asentamalla uuden kernelin ppa:kernel-ppa :sta. Noitahan voi kokeilla.

mrl586

  • Käyttäjä
  • Viestejä: 4638
    • Profiili
Vs: Wlan-yhteysongelma
« Vastaus #7 : 14.11.10 - klo:02.06 »
Minkä valmistajan wlan-piiri tetrafuranilla on? Piirin tarkka malli?
« Viimeksi muokattu: 14.11.10 - klo:03.44 kirjoittanut mrl586 »

tetrafuran

  • Käyttäjä
  • Viestejä: 405
    • Profiili
Vs: Wlan-yhteysongelma
« Vastaus #8 : 19.11.10 - klo:20.53 »
Pakkauksessa lukee seuraavaa:
zyxel 802.11g wireless PCI adapter g-302 v3

Pitäiskö koneesta irrottaa toi kortti että sais selville ton sirun nimen, vai saisko sen näppärästi jollain komennollakin.
And so at last the beast fell and the unbelievers rejoiced. But all was not lost, for from the ash rose a great bird. The bird gazed down upon the unbelievers and cast fire and thunder upon them. For the beast had been reborn with its strength renewed, and the followers of Mammon cowered in horror.

mrl586

  • Käyttäjä
  • Viestejä: 4638
    • Profiili
Vs: Wlan-yhteysongelma
« Vastaus #9 : 19.11.10 - klo:20.56 »
lspci

CoreX

  • Käyttäjä
  • Viestejä: 2
    • Profiili
Vs: Wlan-yhteysongelma
« Vastaus #10 : 19.11.10 - klo:23.07 »
Mulla oli ongelmia buffalon usb Wlan-tikun kanssa, mut löysin siihen netistä ratkaisun.
Verkon pätkimiset alkoivat, kun päivitin Ubuntu 10.04 -> 10.10 versioon. Ilmeisesti ubuntu 10.10 versiossa jotku Wlan-ajurit häiritsevät toisiaan. En ole varma onko tästä apua tuohon pci-väyläiseen Wlan:iin, mut tässä on lista komennoista joilla oma Wlan alkoi pelittään...

sudo modprobe -rf rt2800usb
sudo modprobe -rf rt2870sta
sudo modprobe rt2870sta
sudo depmod
echo 'backlist rt200usb' | sudo tee -a /etc/modprobe.d/blacklist.conf
sudo service network-manager restart

tetrafuran

  • Käyttäjä
  • Viestejä: 405
    • Profiili
Vs: Wlan-yhteysongelma
« Vastaus #11 : 21.11.10 - klo:20.14 »

lspci
00:00.0 RAM memory: nVidia Corporation C51 Host Bridge (rev a2)
00:00.1 RAM memory: nVidia Corporation C51 Memory Controller 0 (rev a2)
00:00.2 RAM memory: nVidia Corporation C51 Memory Controller 1 (rev a2)
00:00.3 RAM memory: nVidia Corporation C51 Memory Controller 5 (rev a2)
00:00.4 RAM memory: nVidia Corporation C51 Memory Controller 4 (rev a2)
00:00.5 RAM memory: nVidia Corporation C51 Host Bridge (rev a2)
00:00.6 RAM memory: nVidia Corporation C51 Memory Controller 3 (rev a2)
00:00.7 RAM memory: nVidia Corporation C51 Memory Controller 2 (rev a2)
00:02.0 PCI bridge: nVidia Corporation C51 PCI Express Bridge (rev a1)
00:03.0 PCI bridge: nVidia Corporation C51 PCI Express Bridge (rev a1)
00:04.0 PCI bridge: nVidia Corporation C51 PCI Express Bridge (rev a1)
00:09.0 RAM memory: nVidia Corporation MCP51 Host Bridge (rev a2)
00:0a.0 ISA bridge: nVidia Corporation MCP51 LPC Bridge (rev a3)
00:0a.1 SMBus: nVidia Corporation MCP51 SMBus (rev a3)
00:0b.0 USB Controller: nVidia Corporation MCP51 USB Controller (rev a3)
00:0b.1 USB Controller: nVidia Corporation MCP51 USB Controller (rev a3)
00:0d.0 IDE interface: nVidia Corporation MCP51 IDE (rev a1)
00:0e.0 RAID bus controller: nVidia Corporation MCP51 Serial ATA Controller (rev a1)
00:0f.0 RAID bus controller: nVidia Corporation MCP51 Serial ATA Controller (rev a1)
00:10.0 PCI bridge: nVidia Corporation MCP51 PCI Bridge (rev a2)
00:10.1 Audio device: nVidia Corporation MCP51 High Definition Audio (rev a2)
00:14.0 Bridge: nVidia Corporation MCP51 Ethernet Controller (rev a3)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
03:00.0 VGA compatible controller: nVidia Corporation G92 [GeForce 8800 GT] (rev a2)
04:07.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8185 IEEE 802.11a/b/g Wireless LAN Controller (rev 20)

Nyt taas jostain maagisesta syystä wlaniyhteydet muodostuvat aivan kuten ennenkin. Tämä ongelma siis käyttäytyy äärimmäisen satunnaisesti. Itseasiassa viime päivinä se on vain kerran tuottanut hankaluuksia.
And so at last the beast fell and the unbelievers rejoiced. But all was not lost, for from the ash rose a great bird. The bird gazed down upon the unbelievers and cast fire and thunder upon them. For the beast had been reborn with its strength renewed, and the followers of Mammon cowered in horror.

RistoR

  • Käyttäjä
  • Viestejä: 410
    • Profiili
Vs: Wlan-yhteysongelma
« Vastaus #12 : 05.01.11 - klo:23.13 »
Mulla oli ongelmia buffalon usb Wlan-tikun kanssa, mut löysin siihen netistä ratkaisun.
Verkon pätkimiset alkoivat, kun päivitin Ubuntu 10.04 -> 10.10 versioon. Ilmeisesti ubuntu 10.10 versiossa jotku Wlan-ajurit häiritsevät toisiaan.

Minulla Wlan-yhteys alkoi pätkimään kun ja hidastelee ikävästi kun päivitin Ubuntun 10.10:een. Voisiko asia olla kuten arvelu tuossa yllä?
Voisiko kyse olla Firefoxin hidastelusta tai vain Elisa kaapeliyhteyden hidasteluista.
Mistä voisi lähteä tutkimaan noita Wlan-ajureita?