Kirjoittaja Aihe: Compaq, Ubuntu 10.4 ja näyttöongelmat...  (Luettu 3464 kertaa)

IceQueen

  • Käyttäjä
  • Viestejä: 36
    • Profiili
Compaq, Ubuntu 10.4 ja näyttöongelmat...
« : 05.10.10 - klo:14.35 »
Eli ongelmana seuraavanlainen kuvio.

Kone lähtee päälle ihan komeesti, toimii hetken, joskus pidempäänkin ihan ok ja yhtäkkiä näyttöön ilmestyy tosi suttuisella tekstiää Ubuntu (ihan samanlainen kuva, kuin aloitus ja lopetus kuva) ja sit alkaa vilkkumaan mustia ja valkoisia pystysuuntaisia palkkeja ylhäältä päin n. puoleen ruutuun asti.

Tämä vika ilmeni 10.4 päivittäessa, aiemmin ongelmana oli se, että näyttö yksinkertaisesti jämähti, eli hiiri oli ainut, mikä liikkui, eikä mitään voinut tehdä...

Koneena Compaq Evo, oiskohan tyyppi joku D51C??, näytönohjain integroitu emolevyyn, näyttönä Fujitsu Siemens.

Itseltäni loppuu ymmärrys tähän...
« Viimeksi muokattu: 05.10.10 - klo:16.58 kirjoittanut nm »

nm

  • Käyttäjä
  • Viestejä: 16293
    • Profiili
Vs: Compaq, Ubuntu 10.4 ja näyttöongelmat...
« Vastaus #1 : 05.10.10 - klo:16.36 »
Ongelman lähde on todennäköisesti sama, mutta vika vain ilmenee hieman eri tavalla uudemmassa Ubuntussa. Veikkaan että näytönohjain tai prosessori kuumenee liikaa, koska jäähdytyselementteihin on kertynyt pölyä tai joku tuuletin on rikki. Toinen yleinen ongelma tämän ikäluokan tietokoneissa on emolevyn virransyötön temppuilu huonojen elektrolyyttikondensaattorien vuoksi.

Ota virtajohto irti sammutetusta koneesta, avaa kotelo, puhdista pölyt imurin ja maalipensselin tai vastaavan avulla. Puhdista myös virtalähteen tuuletusaukot. Tarkista ettei emolevyllä näy päistään pullistuneita tai vuotaneita elkoja.

Laita sitten virtajohto takaisin ja käynnistä kone niin että kotelo on auki. Katso että kaikki tuulettimet pyörivät, mutta älä koske sisuskaluihin silloin kun virtajohto on kytkettynä. Jos kaikki näyttää olevan kunnossa, sammuta kone, ota virtajohto irti ja kasaa kotelo.

IceQueen

  • Käyttäjä
  • Viestejä: 36
    • Profiili
Vs: Compaq, Ubuntu 10.4 ja näyttöongelmat...
« Vastaus #2 : 06.10.10 - klo:21.05 »
Ongelman lähde on todennäköisesti sama, mutta vika vain ilmenee hieman eri tavalla uudemmassa Ubuntussa. Veikkaan että näytönohjain tai prosessori kuumenee liikaa, koska jäähdytyselementteihin on kertynyt pölyä tai joku tuuletin on rikki. Toinen yleinen ongelma tämän ikäluokan tietokoneissa on emolevyn virransyötön temppuilu huonojen elektrolyyttikondensaattorien vuoksi.
Jep, eli vahvistit epäilykseni näytönohjaimen ylikuumenemisesta...

Tarviipa putsailla konetta ja katsoa, jos apua siitä vaikka olisi.


IceQueen

  • Käyttäjä
  • Viestejä: 36
    • Profiili
Vs: Compaq, Ubuntu 10.4 ja näyttöongelmat...
« Vastaus #3 : 17.10.10 - klo:17.41 »
Putsailin koneen mutta apua ei tästä ollut vaan sama vika jatkuu yhä... :-\

Mitäs seuraavaksi kannattais kokeilla? Vai viittaako nyt vaan siihen, että näytönohjain olisi rikki? Mietin myös, mistä saisin tietää mikä näytönohjain on kyseessä, et voiko olla esim. ajuriongelmaa?

nm

  • Käyttäjä
  • Viestejä: 16293
    • Profiili
Vs: Compaq, Ubuntu 10.4 ja näyttöongelmat...
« Vastaus #4 : 17.10.10 - klo:20.40 »
Mitäs seuraavaksi kannattais kokeilla? Vai viittaako nyt vaan siihen, että näytönohjain olisi rikki?

Integroidun näytönohjaimen tapauksessa on todennäköisempää, että emolevyllä on jotain muuta vikaa, joka häiritsee prosessorin, piirisarjan tai muistien toimintaa. Tarkistitko ne kondensaattorit?

Lainaus
Mietin myös, mistä saisin tietää mikä näytönohjain on kyseessä, et voiko olla esim. ajuriongelmaa?

Luultavasti Intelin piiri, mutta tarkista vaikka lspci:llä:

Koodia: [Valitse]
lspci -nn
X.org:n loki (/var/log/Xorg.0.log) voi kertoa tarkan mallin.

nomalab

  • Käyttäjä
  • Viestejä: 15
    • Profiili
Vs: Compaq, Ubuntu 10.4 ja näyttöongelmat...
« Vastaus #5 : 18.10.10 - klo:14.29 »
Mulla oli sama vika sekä tässä läppärillä (Toshiba Satellite Pro L100, näytönohjain ATI Xpress 200M) että tuossa vanhassa Pentium II myllyssä, jossa muistaakseni myös joku ATI:n näyttis (en nyt jaksa käynnistää tarkistaakseni). Eli se näytön korruptoituminen muutaman minuutin käytön jälkeen.

Pääsin viasta eroon lisättyäni Grubin käynnistyslitaniaan "nomodeset". Kokeilin sitä ensin LiveCDn kanssa "lennossa", ja kun se toimi, lisäsin asennettuani /etc/default/grub tiedostoon, jossa siis:

Koodia: [Valitse]
GRUB_CMDLINE_LINUX_DEFAULT="quiet nosplash nomodeset"
Lisäksi läppärissä oli ongelmana se, että USB portit tipahtivat pelistä muutaman minuutin kuluttua (lukuunottamatta sitä, jossa nettitikku oli kiinni) ja USB hiiri jämähti ruudulle. Toisinaan hyytyi kone kokonaan, eli ei toiminut myöskään touchpad eikä näppis.

Näihin auttoi Ubuntufoorumilta löytämäni niksi:

Grubin käynnistyskomentoon lisätään "acpi=force irqpoll"

Läppärin käynnistysstanza onkin nyt kokonaisuudessaan:

Koodia: [Valitse]
GRUB_CMDLINE_LINUX_DEFAULT="quiet nosplash nomodeset acpi=force irqpoll"
Pelittää. Käytössä Ubuntu 10.10, mutta samat oli ongelmat tuossa 10.04 versiossakin, jota kokeilin LiveCD:ltä.
Toshiba Satellite Pro L100 | ATI Xpress 200M | Huawei E1552 | Saunalahti prepaid mobiililaajakaista | Arch

IceQueen

  • Käyttäjä
  • Viestejä: 36
    • Profiili
Vs: Compaq, Ubuntu 10.4 ja näyttöongelmat...
« Vastaus #6 : 27.10.10 - klo:00.38 »
Mitäs seuraavaksi kannattais kokeilla? Vai viittaako nyt vaan siihen, että näytönohjain olisi rikki?

Integroidun näytönohjaimen tapauksessa on todennäköisempää, että emolevyllä on jotain muuta vikaa, joka häiritsee prosessorin, piirisarjan tai muistien toimintaa. Tarkistitko ne kondensaattorit?

Lainaus
Mietin myös, mistä saisin tietää mikä näytönohjain on kyseessä, et voiko olla esim. ajuriongelmaa?

Luultavasti Intelin piiri, mutta tarkista vaikka lspci:llä:

Koodia: [Valitse]
lspci -nn
X.org:n loki (/var/log/Xorg.0.log) voi kertoa tarkan mallin.

Konkat näytti olevan kunnossa.

Tarvii testata nomalabin vinkkiä...

nomalab

  • Käyttäjä
  • Viestejä: 15
    • Profiili
Vs: Compaq, Ubuntu 10.4 ja näyttöongelmat...
« Vastaus #7 : 27.10.10 - klo:10.03 »
Testasin tossa Crunchbang Linuxia buuttaamalla LiveCD ISOn suoraan kovelevyltä (tai no, squashfsin). Siinä ei sitten tuo nomodeset pelkästään riittänytkään, vaan tuo "kuvan palamisefekti" iski minuutti X:n käynnistymisen jälkeen.

Näytön korruptoituminen poistui buuttaamalla Crunchbangin viansietovaihtoehdolla, jossa Grubin asetustiedoston mukaan oli seuraava litania:

Koodia: [Valitse]
noapic noapm nodma nomce nosmp vga=normal
Kun ehdin suorittaa buuttaussulkeiset, testailen mikä/mitkä noista tarvitaan jotta näyttö toimii. Yhden testasin: vga=normal yksinään ei riitä. Lokitiedostoja en ole ehtinyt tutkimaan, otin kyllä dmesg etc. talteen muistitikulle.

Viisaammat vahvistakoon (tai kumotkoon): eikös tuo /etc/default/grub tiedostossa oleva GRUB_CMDLINE_LINUX_DEFAULT ole universaali, eli on käytössä kaikissa Grubin Linux entryissä? Eli Crunchbangin (Debian + Openbox) toimintaa testatakseni pitäisi siirtää "nomodeset acpi=force irqpoll" Ubuntun linux riville ja säätää Crunchbangin parametrit sitten erikseen, samoin kyseisen entryn omalla linux rivillä? Jotta siis selviää, mitä Crunchbang todella tarvitsee.
Toshiba Satellite Pro L100 | ATI Xpress 200M | Huawei E1552 | Saunalahti prepaid mobiililaajakaista | Arch

Agakonna

  • Käyttäjä
  • Viestejä: 9
    • Profiili
Vs: Compaq, Ubuntu 10.4 ja näyttöongelmat...
« Vastaus #8 : 06.01.11 - klo:18.12 »
Minulla oli sama ongelma Linux Mintin kanssa Scaleo L koneessa, jossa on Intelin integroitu piiri. Enää en siinä Minttiä käytä ja missään muissa jakeluissa en vastaavaa ole huomannut.