Kirjoittaja Aihe: 64-bittinen juhannus  (Luettu 7241 kertaa)

janne

  • Käyttäjä
  • Viestejä: 5150
    • Profiili
64-bittinen juhannus
« : 21.06.08 - klo:18.39 »
minä vietin sitten hitusen perinteistä poikkeavan juhannuksen...

päätin perjantaina päivittää koneeni, joten kävin hakemassa kaupasta tarvittavat osat. uusi emolevy, prosessori, muistit, näytönohjain, iso kiintolevy ja suunnitelmien ulkopuolelta yhteensopiva virtalähde. kasaaminen oli nopeaa, nykyiset emolevyt ovat kyllä jotain ihan muuta kuin vaikka kymmenen vuotta sitten.

en keksinyt yhtään syytä olla asentamatta 64-bittistä ubuntua joten käsillä ollut 64-bittinen live-cd sisään ja konetta käynnistämään. kone käynnistyy nopeasti ja ff3 tuntuu vanhaa konetta vikkelämmältä jopa live-levyltä ajettuna, päivitys alkaa vaikuttaa hyvältä siirrolta, mutta... ubuntu ei näytä tunnistavan sata2-väylässä olevia kiintolevyjä :(

puoli päivää sitä säädettiin ja lopulta löytyi (hyvin triviaalit, mutta epätodennäköisen tuntnuiset) bios-asetukset joilla levyt tunnistuivat. loistavaa. nyt /homen kopiointi uudelle suurelle levylle ja asennus voi alkaa. loppupäivä meneekinsitten tuossa kopioidessa, koska live-cd näyttää hidastelevan kopioinnin kanssa, varsinkin jos koneella ei tee mitään.

kun kaikki oli kopioitu, aloitettiin asennus. prässätty live-cd kiukutteli, ja valitti useista virheellisistä tiedostoista. painoin aina 'retry' ja homma tuntui etenevän. lopputuloksena järjestelmä joka ei toiminut ja josta puuttui mm. firefox, vaikka paketti koneesta löytyikin. uusi asennus ja firefox löytyy, mutta päivityksen ja nvidian ajurin lataamisen jälkeen hiiri tahmaa, näppiksen repeat ei toimi ja ikkunoiden otsikkopalkkien sisältö näyttää siirtyneen sen verran oikealle, että nappulat ovat kadoksissa. aika mennä nukkumaan.

kolmas asennus, en asenna päivityksiä enkä nvidian ajuria ja silti otsikkoplakit ovat sekaisin. poltatan 'alternative install'-cd:n toisella koneella ja kokeilen sillä. asennukset sujuvat tältä levyltä hyvin, mutta silti tuota otsikkopalkki/hiiri/näppis-ongelmaa esiintyy kolmella ensimmäisellä kerralla joko ennen päivityksiä tai niiden jälkeen. google ei löydä aiheesta keskustelua, enkä saa itse pääteltyä mistä vika johtuu. asennan vielä kerran ja homma toimii, päivitän ja homma toimii edelleen. nvidian ajuria en ole vielä asentanut, koska pelkään kaiken taas rikkoutuvan. olen verraten tyytyväinen näin, mutta olen keksinyt syyn olla asentamatta 64-bittistä. en ole vakuuttunut, mutta tällä mennään ainakin vielä hetki.

sitten onkin aika tilittää foorumilla...
Janne

shelby

  • Käyttäjä
  • Viestejä: 1865
    • Profiili
Vs: 64-bittinen juhannus
« Vastaus #1 : 21.06.08 - klo:22.37 »
Samat täällä. Kubuntu ja konkka, :D
« Viimeksi muokattu: 21.06.08 - klo:22.39 kirjoittanut shelby »
Ubu Gnome 20.04.3 LTS
Win 8.1 laptop I
Win 10 laptop II
Ubu Mate 20.04.3 LTS
Kubu 20.04.3 LTS

SuperOscar

  • Käyttäjä
  • Viestejä: 4007
  • Ocatarinetabellatsumtsum!
    • Profiili
    • Legisign.org
Vs: 64-bittinen juhannus
« Vastaus #2 : 21.06.08 - klo:23.53 »
Täytyy sanoa että oma kokemukseni 64-bittisen Ubuntun asennuksen kanssa oli pelkästään myönteinen: ei ongelman ongelmaa kummassakaan käyttökoneessani (palvelimeen en tässä välissä kajoa).
pöytäkone 1, kannettavat 1–3: Debian GNU/Linux 12; pöytäkone 2: openSUSE Tumbleweed; NUC: openSUSE Leap 15.5; RPi 1: FreeBSD 14-RELEASE; RPi 2: LibreELEC 11

chiku

  • Käyttäjä
  • Viestejä: 72
    • Profiili
Vs: 64-bittinen juhannus
« Vastaus #3 : 22.06.08 - klo:00.31 »
Samat sanat. Kaikki on täälläkin toiminut juuri niinkuin pitääkin.

Storck

  • Vieras
Vs: 64-bittinen juhannus
« Vastaus #4 : 22.06.08 - klo:03.03 »
Sama täällä, ei mitään ongelmia 64 bit kanssa.

Tomin

  • Palvelimen ylläpitäjä
  • Käyttäjä / moderaattori+
  • Viestejä: 11449
    • Profiili
    • Tomin kotisivut
Vs: 64-bittinen juhannus
« Vastaus #5 : 22.06.08 - klo:10.28 »
Ja minulla myös tässä läppärissä (muualla 32-bittinen) ilman ongelmia.
Automaattinen allekirjoitus:
Lisäisitkö [RATKAISTU] ketjun ensimmäisen viestin aiheeseen ongelman ratkettua, kiitos.

janne

  • Käyttäjä
  • Viestejä: 5150
    • Profiili
Vs: 64-bittinen juhannus
« Vastaus #6 : 22.06.08 - klo:10.32 »
taisin sitten valita vaivoikseni varsin erikoisen yhdistelmän komponentteja... no, nyt on kyllä toiminut ihan kivasti, joskaan nvidian binääriajureita en ole vielä pistänyt, enkä mitään 32-bit yhteensopivuuskirjastoja. saas nähdä josko niitäkin yrittelisi jossain vaiheessa, nyt vaan huvitti välillä käyttääkin konetta :)
Janne

janne

  • Käyttäjä
  • Viestejä: 5150
    • Profiili
Vs: 64-bittinen juhannus
« Vastaus #7 : 22.06.08 - klo:22.42 »
Ihan mielenkiinnosta, mitä komponentteja sitten ostit?

emoksi asuksen p5q-e intelin p45-piirisarjalla. harkitsin hetken myös gigabyteä, mutta minun hintaluokassani kaikissa oli integroitu realtekin verkkokortit ja minä otin mieluummin marvellin piiriin perustuvan. myös intelin emo oli harkinnassa, ehkä jopa integroigulla näytönohjaimella, mutta niiden saatavuus oli tosi huono ja integroituna ohjaimia oli vain mAtx-emoissa.

prossuksi tuli intelin core 2 due e8400, koska se kävi kuuleman mukaan aika viileänä ja siinä oli kohtalainen hinta/nopeussuhde.

näytönohjaimeksi otin halvimman sillä hetkellä (perjantaina juuri ennen sulkemista) liikkeestä löytyvän, pasivijäähdytteisen, ei atin valmistaman kortin, joka sattui sillä hetkellä olemaan asuksen en7300gt silent.

kiintolevyksi (uusi /home) tuli seagate barracuda 7200.11 1TB, kapasiteetin/hinnan, takuuajan pituuden ja hitusen merkinkin perusteella. western digital kilpaili hetken, mutta lyhempi takuu tai merkittävästi kalliimpi hinta (mallista riippuen) käänsi vaakaa seagaten puoleen.

muistit olivat joku ocz:n 4GB:n kitti. valinta oli taas perusteella "ainoa 4GB kitti kaupassa sillä hetkellä". hyvin tuntuu toimivan. [edit] näköjään "4096MB REAPER, CL4 800MHz DDR2"

virtalähde puolestaan oli liikkeen halvin hiljaiseksi lupailtu antec earthwatts 500W. hiljainen on ja käy viileänä.

Täällä on käytetty 64bit ubuntua Edgystä lähtien, aina päivittäen uudempaan. Rauta on muutaman vuoden ikäistä jo kaupoista poistunutta, mutta hyvin tuettua. Näyttis nvidian, aina binääriajureita käytetty.

minulla on ollut nyt tänään jokunen ongelma esim. hal/udev:n kanssa ja mm. thunderbird segfaulttasi suoraan käynnistyksessä, kunnes asensin sen uudelleen. kummallista käytöstä.
« Viimeksi muokattu: 22.06.08 - klo:22.45 kirjoittanut janne »
Janne

Timo Jyrinki

  • Sr. Member
  • ****
  • Viestejä: 1256
    • Profiili
    • kotisivu
Vs: 64-bittinen juhannus
« Vastaus #8 : 22.06.08 - klo:23.15 »
minulla on ollut nyt tänään jokunen ongelma esim. hal/udev:n kanssa ja mm. thunderbird segfaulttasi suoraan käynnistyksessä, kunnes asensin sen uudelleen. kummallista käytöstä.

Melko outoa kyllä, ja jotenkin hw-kokoonpanoon liittyvää varmaankin. NVIDIAn binääriajuri on tietty oman arpapelinsä mukaan tuova, mutta ilman sitä jos on ongelmia niin luultavasti ongelmiin on jokin syy... Memtestiä kannattanee pari tuntia ajaa.

Itselläni 64-bit on ollut jotain pari vuotta pöytäkoneella (nyttemmin myös kannettavalla), ongelmia ei ole ollut. Sittemmin jossain vaiheessa proprietary-Flash alkoi asentua nspluginwrapperin avulla 64-bittisessäkin Ubuntussa, niin 64-bittistä versiota on voinut melko lailla suositella tavallisillekin käyttäjille. ia32-libs:tkin ovat kehittyneet sen verran että myös Google Earth & vähän kaikki muutkin mahdollisesti tarvittavat toimivat. Wine-paketit löytyvät ja toimivat suoraan vaikka kyse on toki 32-bittisten WIN32-APIen toteuttamisesta. Java-liitännäisenkin asiankin hoitaa nykyään icedtea-gcjwebplugin yhdessä openjdk:n kanssa, mutta siinä kuitenkin vielä yksi asia joka ei ole aivan täydellinen tavallisten käyttäjien kannalta - proprietary-Javasta ei ole 64-bittisille alustoille selainliitännäistä, ja openjdk:sta puuttuu vielä LiveConnect-ominaisuudet. Varmaan 8.10:een mennessä korjaantuu.

64-bittisyys lisää toki nopeuttakin (kun on kyseessä x86-arkkitehtuuri), mutta useimmille käyttäjille perusohjelmissa sillä ei ole niin väliä. Kuitenkin nykyään alkaa tuota 4 gigatavua muistiakin olemaan, niin olisi se vähän hölmöä olla sitä käyttämättä.

janne

  • Käyttäjä
  • Viestejä: 5150
    • Profiili
Vs: 64-bittinen juhannus
« Vastaus #9 : 23.06.08 - klo:01.53 »
Periaatteessa hyvää rautaa oot ostanu. Ainoa ehkä on tuo Asus, sen maine piireissä ei ole ollut viime vuosina oikein hyvä. Mutta en mene mitään väittämään onko emolla merkitystä ongelmiisi.

juu, näin minä olen myös ymmärtänyt, mutta tuo emo nyt sattui olemaan spekseiltään paras minun kuviteltuihin tarpeisiini. eiköhän tuolla seuraavat viisi vuotta mennä helposti. tavallaan ärsytti, kun hehkuttivat tuon emon sivuilla kuin hyvä se on ylikellotettaessa. en minä haluaa ylikellottaa, vaan mahdollisimman vakaan ja toimivan alustan.

Tuli vaan mieleen että toivottavasti et laittanut mitään laitetta näihin Silicon Imagen levyohjaimen sata-liittimiin, vaan kaikki niihin punaisiin Intelin levyohjaimen liittimiin.

juu, punaisiin hyvinkin.

Onko optinen asema pata-mallinen(olisi kiinni marvellin levyohjaimessa)? Nämä voisi selittää tuon alkuperäisen kenkkuilun ja tiedostokorruptiot.

optinen on tosiaan pata, mutta miten se selittää alkuperäisen kenkkuilun ja poltetun toimimisen? tosin minulla oli kyllä ongelmia joskus aikaisemminkin ubuntun prässättyjen levyjen kanssa.

pitänee pistää muistit vielä testiin. nvidian binääriajurit eivät ole käytössä, vaikka tuskinpa ne olivat syypää kokemiini ongelmiin, koska niitä esiintyi ilman ajureitakin. myös graafisen puolen ongelmia.
Janne

MoB

  • Käyttäjä
  • Viestejä: 314
  • Debian Jessie, Ubuntu 12.04 LTS, Android-x86 2.3
    • Profiili
Vs: 64-bittinen juhannus
« Vastaus #10 : 23.06.08 - klo:10.41 »
5.10 versiosta lähtien menty 64-bittisellä täällä. En näe mitään syytä, miksi pitäisi retroilla 32-bittisenä :)
Registered Linux user #186837

Ux64

  • Käyttäjä
  • Viestejä: 586
    • Profiili
Vs: 64-bittinen juhannus
« Vastaus #11 : 23.06.08 - klo:19.05 »
5.10 versiosta lähtien menty 64-bittisellä täällä. En näe mitään syytä, miksi pitäisi retroilla 32-bittisenä :)

64 bit oli täällä myös "alusta" asti, eli nyt noin 9 kk.

Vielä on jotain ongelmia, jotka ei sinänsä liity suoraan 64 bittisyyteen. Mutta voivat ehkä (?) olla paremmin 32 bit puolella.

Eli ongelmia on mm. audio toistossa, ilmeisesti äänikortin puskureiden täyttö irkkujen tms kautta ei toimi aina ajallaan. Aiheuttaa äänen napsahtelua ja pätkimistä. Ei isoa, mutta just sen verran että huomaa ettei toimi niin kuin pitäisi.

Tähän tietysti vaikuttaa emolevy, äänikortti jne. Mutta kuitenkin, ajoitusongelmia.

Toinen raivostuttava juttu on näppiksen ja hiiren jumittelu. Pitäisi kai kokeilla live cd:ltä onko sama ongelma myös 32 bit puolella.

qwertyy

  • Käyttäjä
  • Viestejä: 5682
    • Profiili
Vs: 64-bittinen juhannus
« Vastaus #12 : 23.06.08 - klo:20.00 »
Itsellä ongelmia tuotti vain Javan toiminta aluksi 64bit asennuksen jälkeen, vaan Heron kyllä sekoitti sen näemmä 32bit asennuksessakin. Mitään muuta eroa ole äkkiseltään huomannut 32 vs. 64bit versioissa. Samoin openSUSE toimii todella hienosti 64bit asennuksena, eikä kyllä edes tullut mieleen kokeilla 32bit asennusta.

Lankku tosiaan on Asukselta ja tuntuu toimivan hemmetin hienosti, mikä tuntuu kummalta kun monilla foorumeilla haukutaan Asuksen rautaa linux käytössä, mutta siguista niitä ei löydy sitten lainkaan  :) ::)

Ux64

  • Käyttäjä
  • Viestejä: 586
    • Profiili
Vs: 64-bittinen juhannus
« Vastaus #13 : 23.06.08 - klo:20.03 »
Itsellä ongelmia tuotti vain Javan toiminta aluksi 64bit asennuksen jälkeen, vaan Heron kyllä sekoitti sen näemmä 32bit asennuksessakin. Mitään muuta eroa ole äkkiseltään huomannut 32 vs. 64bit versioissa.

Mikäs Java sulla on? Mä jouduin laittamaan IcedTean ja se ei selvästi toimi kyllä läheskään jokaisen siten kanss. Monin paikoin "initializin applet" kohtaan jää jumittamaan ja appletin ala jää harmaaksi. OpenJDKta olisin halunnut käyttää. Pitänee varmaan asentaa toi kääntäjäkin jossain vaiheessa jos taas innostuu koodaamaan. Pythonista luovuin kun huomasin että multicore suorituskyky on todella olematon (ei hyödynnä lainkaan). Ellei sitten käytä stackless pythonia.
« Viimeksi muokattu: 23.06.08 - klo:20.05 kirjoittanut Ux64 »

qwertyy

  • Käyttäjä
  • Viestejä: 5682
    • Profiili
Vs: 64-bittinen juhannus
« Vastaus #14 : 24.06.08 - klo:02.19 »
Mikäs Java sulla on? Mä jouduin laittamaan IcedTean ja se ei selvästi toimi kyllä läheskään jokaisen siten kanss. Monin paikoin "initializin applet" kohtaan jää jumittamaan ja appletin ala jää harmaaksi.
Muistaakseni jotenkin sain sen juuri IcedTea ohjeilla toimimaan muistaakseni vielä tämän foorumin ohjeilla. Tosin oikeastaan ainut Java ohjelma mitä olen käyttänyt on "onneksi" rajoittunut lähinnä ProjectX:n käyttöön. Ppc ps3 ja Java tuntuu vieläkin mahdottomalta yhdistelmältä. Vaikka kuinka etsin ohjeita ja yritin lukea niitä päivän ja soveltaa en saanut mitään toimivaa aikaiseksi.

janne

  • Käyttäjä
  • Viestejä: 5150
    • Profiili
Vs: 64-bittinen juhannus
« Vastaus #15 : 26.06.08 - klo:12.20 »
tässä kävi nyt sitten niin, että rauta osoittautui sittenkin vialliseksi ja muistikammat vaihdettuani, uusi asennus sujui ongelmitta ja kaikki on toiminut moitteetta. kauan se kesti, mutta nyt olen tyytyväinen.
Janne

Ux64

  • Käyttäjä
  • Viestejä: 586
    • Profiili
Vs: 64-bittinen juhannus
« Vastaus #16 : 26.06.08 - klo:14.36 »
Vialliseksi, yhteensopimattomaksi, vai väärillä asetuksilla käytetyksi?! ;)

Nuo kun joku voi tulkita vialliseksi, vaikka näinhän asian laita ei ole.

Huolellisen analyysin tekeminen siitä, mikä on oikeasti vialla on joskus tolkuttoman vaikeaa. Vaikka osan X vaihtaminen auttaisi, se ei todellakaan tarkoita sitä että vika olisi osassa X.

janne

  • Käyttäjä
  • Viestejä: 5150
    • Profiili
Vs: 64-bittinen juhannus
« Vastaus #17 : 26.06.08 - klo:16.22 »
Vialliseksi, yhteensopimattomaksi, vai väärillä asetuksilla käytetyksi?! ;)

Nuo kun joku voi tulkita vialliseksi, vaikka näinhän asian laita ei ole.

Huolellisen analyysin tekeminen siitä, mikä on oikeasti vialla on joskus tolkuttoman vaikeaa. Vaikka osan X vaihtaminen auttaisi, se ei todellakaan tarkoita sitä että vika olisi osassa X.

kyllä se tällä kertaa oli viallinen. tai ainakin uskoisin niin, koska myöhemmin ajettuna muistitesteri antoi virheitä ja koska virheitä tuli vain toisella muistikammalla ajaessani testeriä erikseen kummallekin kammalle, eikä lainkaan uudella kampaparilla, niin olen taipuvainen uskomaan toisen alkuperäisistä muistikammoista olleet viallinen.

ikävästi vika oli muistialueen yläpäässä jolloin siihen törmäsi harmillisen harvoin ja siitä syystä ongelmat ja tiedostojen korruptoituminen vaikuttivat satunnaisilta.

joka tapauksessa saman valmistajan, samanlaiset ja samoilla asetuksilla ajetut muistit toimivat nyt moitteetta. liekö tuo nyt sitten kyllin huolellinen analyysi, mutta ainakin riittävän vakuuttava minulle.
Janne

Ux64

  • Käyttäjä
  • Viestejä: 586
    • Profiili
Vs: 64-bittinen juhannus
« Vastaus #18 : 26.06.08 - klo:17.12 »
joka tapauksessa saman valmistajan, samanlaiset ja samoilla asetuksilla ajetut muistit toimivat nyt moitteetta. liekö tuo nyt sitten kyllin huolellinen analyysi, mutta ainakin riittävän vakuuttava minulle.

Noin mäkin luulin joskus. Ennen kuin todistin itse asian olevan eritavalla. Saman valmistajan, "samalaiset", samoilla asetuksilla ajetut muistit. Kyllä, ne olivat samanlaisia, mutta eri valmistuserästä (sarjanumeron kautta kaivetulla tiedolla). Joka johti siihen, että ne olivat erilaisia. Vaikka niitä ajettiin oikeilla ohjearvolla ne eivät toimineet. Mutta vain tietyn valmistajan tietyssä emolevymallissa. Muistipiirit siis eivät olleet viallisia, ne eivät vain toimineet tietyllä emolevyllä ja "oikeilla" asetuksilla. Jos vaihdoin yhtälöön, muistipiirit, toisen valmistajan emolevyn tai muistiasetuksissa alitin annetun speksin arvot samalla emolevyllä ne toimivat. Noiden muistin vaihtaminen ristiin toisen erän kanssa poisti kyllä ongelman. Joten muistit ja emolevy olivat ainakin molemmat osatekijöitä tuossa sopassa. Näitä samanlaisia tarinoita riittää varmaan vaikka kuinka paljon sellasilla tyypeillä jotka kasaa vähintään koneen päivässä ja mieluiten erilaisilla kokoonpanoilla. Kuten joku Jimm's tuned pc valmiiksi kokoonpantuna. Otetaan satunnainen lajitelma osia ja isketään yhteen, pitäisi speksien puolesta toimia, mutta toimiiko oikeasti?

Herää siis kysymys, oliko missään vikaa ja jos oli niin missä? ;)

Eikä tämä ole suinkaan ainoa kerta. On totta että jos koneita on vähän tai yksi, tuollaisen analyysin tekeminen on vaikeaa. Mutta jos esim 100 koneen erästä, 30 koneessa on ongelmia ja koneet ovat "samanlaisia", niin silloin alkaa heräämään epäilys mikä mättää. Vielä hauskemmaksi nuo ongelmat muuttu silloin kun ne ilmenevät vain tietynlaisissa käyttötilanteissa tai ympäristö-olosuhteissa. ;)

Yksi ongelma jäi muuten resurssien takia ratkaisematta, vaikka olisin halunnut kovasti tutkia. Meidän softa kaatuili epämääräisesti tietokoneilla joissa oli AMD:n prosessori. Intelin koneilla kaatuilua ei ilmennyt. Huom! Tämä oli siis nyt hyvin karkea rajaus, ikinä ei tehty tarpeellista haarukointia ongelman selvittämiseksi. Olisi ollut todella kiva tutkia johtuuko ongelma, prosessorista, emolevystä, jostain ajurista joka liittyy em. yhdistelmään. Ja miksi kaatuilu ilmeni VAIN meidän softan kanssa. Tein paljon testejä noille AMD koneille, enkä koskaan löytänyt mitään vikaa. Mutta meidän softan kanssa se homma vaan ei toiminut. Harmittaa ettei tuon ongelman tutkimiseen mönnetty tarvittavia resursseja, ongelman paikantaminen olisi ollut todella mielenkiintoista. Imho. Ärsyttää kun ongelmiin keksitään kiertoteitä, eikä selvitetä mistä ongelma oikeasti johtuu.

Noissa muisteissa ja emolevyissäkin olisi voinut tehdä vielä tarkemman tutkimuksen, että kumpi niistä on oikeasti rikki. Siihen tosin olisi tarvittu melkoiset tesitlaitteet ja mittarit, että saisi aukottoman todistuksen aikaiseksi. Oliko vika emolevyssä vai muistissa.

Yhdessä koneessa oli kaksi eri valmistajan mutta saman speksin mukaista muistikampaa, jos ne olivat "väärässä järjestyksessä" näytönohjain sekoili. ;) Tuonkin hiffaaminen kesti kyllä hetken. Ongelman ratkaisua ei yhtään helpottanut se, että olin vaihtanut koneeseen emolevyn, toisen muistipiirin ja näytönohjaimen samalla kerralla. Eikä tuo muisti yhdistelmä failannut muistitesteillä kummallakaan configuraatiolla. Se oli vain silloin kun näytönohjain lainasi keskusmuistia, kun sekoilu alkoi. Jos oli kumpi tahansa piiri yksinään ongelmaa ei ollut. Mutta parina ne piti olla oikeassa järjestyksessä.

Välillä lopputulos on se, että missään ei ole mitään vikaa. Ei vaan toimi yhdessä. Joka kertoo siitä, että tutkimista ei tehty riittävän yksityiskohtaisella tasolla.
« Viimeksi muokattu: 26.06.08 - klo:17.33 kirjoittanut Ux64 »