Kirjoittaja Aihe: Anysee usb-digi  (Luettu 244215 kertaa)

crope

  • Käyttäjä
  • Viestejä: 817
  • Fedora 12
    • Profiili
    • http://palosaari.fi/
Vs: Anysee usb-digi
« Vastaus #80 : 11.02.08 - klo:15.46 »
anyseen ihan se perus t versio löytyy

tälläistä löysyin tuolta messages hommasta

1. Sinulla on vanha versio ajurista
2. Logista puuttunee jotain koska frontendin rekisteröinnistä ei ole mainintaa (registering frontend 0...) se on varmasti ZL10353 tai MT352.
3. DigiTV:ssä suurin käytetty kanava on UHF69. Menee osa virityksistä sellaisille kanaville joita ei ole olemassakaan.

Asenna uusin ajuri ja raportoi uudelleen.

/antti

Topelius

  • Käyttäjä
  • Viestejä: 355
  • Opettelee LTSP:n käyttöä
    • Profiili
Vs: Anysee usb-digi
« Vastaus #81 : 11.02.08 - klo:15.52 »
eli jos saa pyytää niin miten asennan se uuden ajurin? Teenkö sen koko rimpsun alusta joka edellisellä sivulla neuvoittiin?


crope

  • Käyttäjä
  • Viestejä: 817
  • Fedora 12
    • Profiili
    • http://palosaari.fi/
Vs: Anysee usb-digi
« Vastaus #82 : 11.02.08 - klo:17.03 »
eli jos saa pyytää niin miten asennan se uuden ajurin? Teenkö sen koko rimpsun alusta joka edellisellä sivulla neuvoittiin?

EDIT: uudet ja toivottavasti tarkemmat ohjeet :) Nyt poistetaan vanhat moduulit ajosta (ei tarvitse välttämättä bootata). Sekä nollataan käännösasetukset "defaulttiin".

Koodia: [Valitse]
sudo apt-get install mercurial linux-headers-$(uname -r) build-essential
rm -rf anysee
hg clone http://linuxtv.org/hg/~anttip/anysee/
cd anysee
make distclean
make
sudo make install
sudo rmmod dvb_usb_anysee dvb_usb dvb_core tda10023 dvb_pll zl10353 mt352

/antti
« Viimeksi muokattu: 11.02.08 - klo:17.12 kirjoittanut crope »

Topelius

  • Käyttäjä
  • Viestejä: 355
  • Opettelee LTSP:n käyttöä
    • Profiili
Vs: Anysee usb-digi
« Vastaus #83 : 11.02.08 - klo:17.52 »
ERROR: Module dvb_usb_anysee does not exist in /proc/modules
ERROR: Module dvb_usb does not exist in /proc/modules
ERROR: Module dvb_core does not exist in /proc/modules
ERROR: Module tda10023 does not exist in /proc/modules
ERROR: Module dvb_pll does not exist in /proc/modules
ERROR: Module zl10353 does not exist in /proc/modules
ERROR: Module mt352 does not exist in /proc/modules


Mitä toi tarkoittaa tuossa viimeisessä vaiheessa?

crope

  • Käyttäjä
  • Viestejä: 817
  • Fedora 12
    • Profiili
    • http://palosaari.fi/
Vs: Anysee usb-digi
« Vastaus #84 : 11.02.08 - klo:18.05 »
ERROR: Module dvb_usb_anysee does not exist in /proc/modules
ERROR: Module dvb_usb does not exist in /proc/modules
ERROR: Module dvb_core does not exist in /proc/modules
ERROR: Module tda10023 does not exist in /proc/modules
ERROR: Module dvb_pll does not exist in /proc/modules
ERROR: Module zl10353 does not exist in /proc/modules
ERROR: Module mt352 does not exist in /proc/modules

Mitä toi tarkoittaa tuossa viimeisessä vaiheessa?

Niitä ajureira ei ole ladattuna muistiin. Eli kaikki on OK.
Nyt taitaa pelata Anysee?
/antti

Topelius

  • Käyttäjä
  • Viestejä: 355
  • Opettelee LTSP:n käyttöä
    • Profiili
Vs: Anysee usb-digi
« Vastaus #85 : 11.02.08 - klo:18.19 »
Joo kiitoksia vinkeistä nyt toimii:-)

m-o-r-g-a-n

  • Käyttäjä
  • Viestejä: 1
    • Profiili
Vs: Anysee usb-digi
« Vastaus #86 : 11.02.08 - klo:21.16 »
Tervehdys,

Itselläni on tuo kyseinen E30+. Ja testailin uusimpien ajureiden kansa. En havainnut mitään ongelmia jotka johtuisivat ajurista. Itselläni on tosin distrona Gentoo, mutta toimii hyvin siis silläkin. Kaukosäätimen toimintaa en testannut, mutta ainakin se näytti tunnistuvan ihan kivasti.

Suur kiitos ajurista, nyt voin vihdoinkin luopua tuosta windows käyttiksestä media pc:ssäni, vielä kun Joostin vääntäisivät linukalle.

Ihan siltä varalta, että törmäätte vastaavaan ongelmaan:
Boksi vastaa vähän hitaasti ehci_hcd read/all kutsuun, joka aiheuttaa sen tippumisen aika usein ohci_hcd:lle jolloin se ei toimi. En testaillut, mutta interputia pitäisi voida säätää kernelistä. Ja tätä ongelmaa ei ilmene jos laite on jo kytketty koneeseen kun sen käynnistää. What is the case usualy.


crope

  • Käyttäjä
  • Viestejä: 817
  • Fedora 12
    • Profiili
    • http://palosaari.fi/
Vs: Anysee usb-digi
« Vastaus #87 : 11.02.08 - klo:21.50 »
Itselläni on tuo kyseinen E30+. Ja testailin uusimpien ajureiden kansa. En havainnut mitään ongelmia jotka johtuisivat ajurista. Itselläni on tosin distrona Gentoo, mutta toimii hyvin siis silläkin. Kaukosäätimen toimintaa en testannut, mutta ainakin se näytti tunnistuvan ihan kivasti.

Upeeta, mahtavaa, upeeta, I am happy now. Vihdoinkin tainnut löytyä sellainen järjestys millä demodulaattorin "kiinnittäminen" onnistuu jokaisessa hardware versiossa. :)

Suur kiitos ajurista, nyt voin vihdoinkin luopua tuosta windows käyttiksestä media pc:ssäni, vielä kun Joostin vääntäisivät linukalle.

Ihan siltä varalta, että törmäätte vastaavaan ongelmaan:
Boksi vastaa vähän hitaasti ehci_hcd read/all kutsuun, joka aiheuttaa sen tippumisen aika usein ohci_hcd:lle jolloin se ei toimi. En testaillut, mutta interputia pitäisi voida säätää kernelistä. Ja tätä ongelmaa ei ilmene jos laite on jo kytketty koneeseen kun sen käynnistää. What is the case usualy.

Tarkoitat varmaan tätä:
Koodia: [Valitse]
Feb 11 17:26:10 localhost kernel: usb 1-5: new high speed USB device using ehci_hcd and address 23
Feb 11 17:26:11 localhost kernel: usb 1-5: device descriptor read/all, error -71
Feb 11 17:26:11 localhost kernel: usb 1-5: new high speed USB device using ehci_hcd and address 25
Feb 11 17:26:13 localhost kernel: usb 1-5: configuration #1 chosen from 1 choice
Feb 11 17:26:13 localhost kernel: dvb-usb: found a 'Anysee DVB USB2.0' in warm state.

En tiedä varmasti mistä tuo johtuu, mutta olen pyöritellyt mielessäni seuraavaa teoriaa; Anysee katkaisee kytkettäessä USB-väylän, eli tiputtaa itsensä väylältä. Käytännössä tämä johtuisi siitä että laite lataa firmwaren sisällä olevalta eeprommilta USB-sillalle (Cypress CY7C68013A). Firmwaren latauksen jälkeen USB-silta boottaa itsensä (tulee tuo katkaisu) ja alkaisi ajamaan lataamaansa firmwaren koodia. Tuossa USB-sillassa on speksien mukaan 8051-pohjainen prosessori ja siten se tarvii sen firmwaren. Ajuri ei lataa firmwarea, joten se ladataan eeprommilta.
No enivei, oli miten tahansa niin siitä ei kannata välittää.

Voitko vielä lähettää vaikkapa maililla ne tulosteet mitä message-logiin tulee?

/antti

Joniteus

  • Käyttäjä
  • Viestejä: 3
    • Profiili
Vs: Anysee usb-digi
« Vastaus #88 : 11.02.08 - klo:23.19 »
Ratkaisu omaan ongelmaani:

ennen makea tiedostosta linux/sound/pci/bt87x.c
tämä siis on anysee hakemistossa.

etsi rivi

#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,24)

ja muokkaa siitä 24 -> 25, eli

#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,25)

jonka jälkeen takaisin anysee kansioon jossa make nyt toimiikin


AION

  • Käyttäjä
  • Viestejä: 150
    • Profiili
Vs: Anysee usb-digi
« Vastaus #89 : 23.02.08 - klo:11.28 »
Kiitoksia ajurista, tämä toimii loistavasti!

Itseasiassa alkoi pelottaa aivan vi***i. Wintöösän puolella jökitti MTV3, Nelonen ja SubTV mutta ne toimivat täydellisesti Linuxissa. + Kuvan laatu parani huomattavasti. Onko tähän mitään selitystä?

peran

  • Vieras
Vs: Anysee usb-digi
« Vastaus #90 : 23.02.08 - klo:13.20 »
Kiitoksia ajurista, tämä toimii loistavasti!

Itseasiassa alkoi pelottaa aivan vi***i. Wintöösän puolella jökitti MTV3, Nelonen ja SubTV mutta ne toimivat täydellisesti Linuxissa. + Kuvan laatu parani huomattavasti. Onko tähän mitään selitystä?

Totaalisesti eri softa. Tosin saattaa olla ilmastakin kiinni, mikäli on DVB-T-mallia, jolla siis sattuu olemaan heikko signaali.

vehkis91

  • Käyttäjä
  • Viestejä: 19
    • Profiili
Vs: Anysee usb-digi
« Vastaus #91 : 23.02.08 - klo:16.26 »
Olen tehnyt kaikkien noiden ohjeiden mukaan ja silti se tökkää samat virhe ilmoitukset... Missä vika?

ighea

  • Käyttäjä
  • Viestejä: 158
  • Linux Power since 2001
    • Profiili
    • blogi&ks
Vs: Anysee usb-digi
« Vastaus #92 : 23.02.08 - klo:16.27 »
Olen tehnyt kaikkien noiden ohjeiden mukaan ja silti se tökkää samat virhe ilmoitukset... Missä vika?

Voisitko mahdollisesti kertoa sen virheilmoituksen?
Real Unix/Linux men, do not use Emacs, neither vi, neither ed
They use cat, and get it right the first time

Pikaruokaa.fi - Vatsantäytettä vaikka kotiovelle kuljetettuna

jebla

  • Käyttäjä
  • Viestejä: 1
    • Profiili
Vs: Anysee usb-digi
« Vastaus #93 : 24.02.08 - klo:16.42 »
Asensin Mythbuntun ja ajurit Anysee E30 C plus kortille. Kaffeine toimii mainiosti, mutta onko kukaan saanut toimimaan korttia mythtv:ssa?

vehkis91

  • Käyttäjä
  • Viestejä: 19
    • Profiili
Vs: Anysee usb-digi
« Vastaus #94 : 26.02.08 - klo:17.39 »
se vika oliki jossain Xscreensaverissa eikä anyseessä, nyt kaikki toimii, kun laitoin -gl2 lipun mplayeriin...

nikohal

  • Käyttäjä
  • Viestejä: 22
    • Profiili
Vs: Anysee usb-digi
« Vastaus #95 : 28.02.08 - klo:07.34 »
Ostin eilen Anysee E30 C Plus:n. Toimii ajurilla mainiosti kubuntussa. Kaukosäätimessäkin toimii kanavan valinta numeroilla ja volyymin säätö/ mute. Muita nappeja olen kokeillut ja ne eivät toimi. Onko tähän olemassa joku jippo? Ja milloinka tulee kortinlukija tuki ajurissa?

PS. Toimii helpommin kyseinen Anysee tällä ajurilla kuin omalla ajurilla XP:ssä

Risto H. Kurppa

  • Käyttäjä
  • Viestejä: 3024
  • Useita Kubuntuja ajossa.
    • Profiili
    • http://risto.kurppa.fi
Vs: Anysee usb-digi
« Vastaus #96 : 28.02.08 - klo:09.47 »
Onko tähän olemassa joku jippo? Ja milloinka tulee kortinlukija tuki ajurissa?

PS. Toimii helpommin kyseinen Anysee tällä ajurilla kuin omalla ajurilla XP:ssä

Näin alkuun kannattaa olla tyytyväinen siihen, että se ylipäätään toimii, crope on tehnyt mahtavan työn kirjoitellessaan ajurit.
Arvaisin että lisänappuloille ei vielä ole jippoa (voin olla väärässä) ja kortinlukijalle tuen tuleminen tulee kestämään melkoisesti. Perinteisesti tällaisiin kysymyksiin on vastattu että tuki tulee ajuriin sitten kun se on valmis.. Eli aika-arvioita on huono mennä antamaan kun vapaaehtoispohjalla mennään eikä kukaan saa puuhasta rahaa.

r
UUSI UBUNTUN KÄYTTÄJÄ: SÄÄSTÄ AIKAASI LUKEMALLA  -> TÄMÄ <-

uhappo

  • Käyttäjä
  • Viestejä: 1029
  • Sissos
    • Profiili
    • Urkin sivut
Vs: Anysee usb-digi
« Vastaus #97 : 29.02.08 - klo:11.05 »
Ootte te Linux-heebot aika uskomattomia!!!

Oon ottamassa ensiaskeleita tän uuden käyttis-maailman kanssa. Aattelin tänä aamuna että pitääpäs kokeilla saanko ton Anysee 30-perus antenniboxini toimimaan. Luin tätä keskustelua, tein cropen mallin mukaan

sudo apt-get install mercurial linux-headers-$(uname -r) build-essential
rm -rf anysee
hg clone http://linuxtv.org/hg/~anttip/anysee/
cd anysee
make distclean
make
sudo make install
sudo rmmod dvb_usb_anysee dvb_usb dvb_core tda10023 dvb_pll zl10353 mt352

Sit Kaffeine paikalleen

Herjas siitä Xine-hommasta ts.-hommien suhteen

Otin synapticista noita xine-mallin plugareita ja lisukkeita

RUPES TOIMIMAAN!!! WUHUU!!!

Pitää ihan hattua nostaa ajuri-herroille

Tekstityksiä en vielä saanu näkymään, ainakaan ylen puolelle, muita en kerenny kokeilemaan.

Keep up the good work


EDIT: Tekstitkin toimii, vaikka ne näytti NONE-tilaa valikossa.
« Viimeksi muokattu: 29.02.08 - klo:11.09 kirjoittanut uhappo »
HP i7-pohjainen desktop ja itsekasattu i7-pohjainen desktop, uusin ubuntu 64bit
Ubuntu since 2008 Feb

crope

  • Käyttäjä
  • Viestejä: 817
  • Fedora 12
    • Profiili
    • http://palosaari.fi/
Vs: Anysee usb-digi
« Vastaus #98 : 29.02.08 - klo:15.05 »
pikkasen väliaikatietoja...

Ajuri tunnistaa seuraavat mallit / versiot. Kannattaa huomata että uusin DVB-C, eli E30C Plus ei toimi. Riski saada kaupasta sellainen on tällähetkellä aika suuri. Siinä on rauta pikkasen muuttunut ja minulla ei tätä värkkiä ole niin en ole pystynyt tukea lisäämään. Ei varmaankaan olisi iso homma.

Koodia: [Valitse]
   model     demod    hw firmware
1. E30       MT352    02 0.2.1
2. E30       ZL10353  02 0.2.1
3. E30 Plus  ZL10353  06 0.1.0
4. E30C Plus TDA10023 0a 0.1.0
5. E30C Plus TDA10023 0f 0.1.2  (ei toimi)

Kortinlukija ei ole tuettuna ja sen lisääminen vaatisi aika paljon työtä. Ja mielelleen speksejä myös. Uusimmassa E30C Plus-mallisssa on kortinlukijan piirikin vaihtunut toiseen, joskaan se tuskin isoa ongelmaa aiheuttaa, eiköhän tuon laitteen firmware moiset muutokset piilottele sisälleen ja ajurin kannalta asia olisi merkityksetön.

Tämä ajuri on ollut aika vaikea implementoida, johtuen suuresta laitteiden määrästä (viisi laitetta) ja testilaitteita minulla ei ole ollut kun vanhempi E30C Plus. Iso kiitos Timo Jyringille laitteen lainaamisesta, sekä Tenho Tuhkalalle laitteen myymisestä varsin edulliseen kaveri-hintaan :) Kiitoksia myös kaikille testaajille palautteesta. Niitä saa pistää vieläkin tulemaan, erityisesti jos sattuu kohdalle laite joka ei ole tuolla listalla mainittuna.

Ja sitten suunnitelmat ajurin suhteen. Tämähän on nyt päässyt venymään pitkään, testilaitteiden puutteen vuoksi, joten aikaa menee vielä ennenkuin sen kerneliin matkaan saan. Tuo uusin Anysee E30C Plus on tietenkin se suurin ongelma. Sen suhteen on mietintämyssy päässä. Vaihtoehtoja on pari 1.) "Poistan" laitteen ajurista siten että se kirjoittaa logiin huomautuksen epäsopivasta raudasta. 2.) Yritetään saada laite toimimaan.

Niin, ja ajuria kannattaa katsella tuolta http://linuxtv.org/hg/ . Siellä näkyy useampi versio ja päiväyksestä voi arvuutella version uutuutta.

terveisin
Antti

jerem

  • Käyttäjä
  • Viestejä: 40
    • Profiili
Vs: Anysee usb-digi
« Vastaus #99 : 01.03.08 - klo:10.02 »
eli jos saa pyytää niin miten asennan se uuden ajurin? Teenkö sen koko rimpsun alusta joka edellisellä sivulla neuvoittiin?

EDIT: uudet ja toivottavasti tarkemmat ohjeet :) Nyt poistetaan vanhat moduulit ajosta (ei tarvitse välttämättä bootata). Sekä nollataan käännösasetukset "defaulttiin".

Koodia: [Valitse]
sudo apt-get install mercurial linux-headers-$(uname -r) build-essential
rm -rf anysee
hg clone http://linuxtv.org/hg/~anttip/anysee/
cd anysee
make distclean
make
sudo make install
sudo rmmod dvb_usb_anysee dvb_usb dvb_core tda10023 dvb_pll zl10353 mt352

/antti

Hei!

Yritin ohjeiden mukaan asentaa ajureita. Jo ensimmäinen rivi päättyy virheeseen.
 
sudo apt-get install mercurial linux-headers-$(uname -r) build-essential
E: Couldn't find package linux-headers-2.6.24-5-server

Sen jälkeen muutin komentoa seuraavaksi:
sudo apt-get install mercurial linux-headers build-essential

Nyt se meni ilman virheitä mutta seuraava virhe tulee
make distclean -komennon kohdalla.

Ilmeisesti tuo ensimmäinen komento ei sitten toimikkaan Ubuntu 8.04 server versiossa?
Vai mitä pitäisi tehdä?

-Jere