Kirjoittaja Aihe: Anysee usb-digi  (Luettu 243416 kertaa)

Kent

  • Käyttäjä
  • Viestejä: 124
    • Profiili
Anysee usb-digi
« : 03.02.06 - klo:16.39 »
Huom. lue ohje Anysee-tuen asentamiseksi Ubuntuun (8.04) tästä ensimmäisestä viestistä

Ubuntu 8.10

Ubuntu 8.10 sisältää tuen kaikille nykyisille Anysee-laitteille, kiitos Antti Palosaaren tekemän tuen joka on nyt sisällytetty Linux-ytimen versioon 2.6.27. Jos sinulla on anysee compo malli joudut asentamaan ajurin suoraan linux-DVB versiohallinnasta (ohje alhaalla). Linux-ydin 2.6.28 tukee compo mallia suoraan.

Combon käyttö jos tuki asennettu
Combossa on sekä DVB-C (kaapeli) sekä DVB-T (antenni) vastaanottimet. Combo käyttää vakiona DVB-C:tä. DVB-T:n käyttäminen onnistuu seuraavasti: Irroita anysee compo usb-portista, laita seuraavat komennot komentoriville

Koodia: [Valitse]
rmmod dvb-usb-anysee
modprobe dvb-usb-anysee delsys=1
laita laite takaisin ja nyt laitteesi on DVB-T.

Ubuntu 8.04 / uusi ohje
Tämä ohje on helppo tapa saada Ubuntu 8.04:een tuki Anysee-laitteille, mutta valitettavasti ohje kattaa vain hieman vanhemmat Anysee-laitteet, ei esim. combolaitteita.

Lainaus

1) Asenna paketti dkms
2) Mene sivulle https://launchpad.net/~pitti/+archive, napsauta tekstin "v4l-dvb-dkms" vasemmalla puolella olevaa nuolta
3) Avaa sitten alempaa linkki "v4l-dvb-dkms_0.20080610_all.deb", ja asenna kyseinen paketti selaimen tarjoamalla Ubuntun paketinasennusohjelmalla.

Tämä uusi tapa ei ylikirjoita Linux-ytimen olemassa olevaa Video4Linux-osiota (muutoin esim. jotkin web-kamerat voivat lakata toimimasta), ja ajureiden asentaminen tapahtuu täysin automaattisesti. Ajurit myös päivittyvät jatkossa automaattisesti niin kauan, kunnes tämä ''v4l-dvb-dkms''-paketti poistetaan esim. Synaptic-pakettienhallinnalla.
(eli: todella loistava systeemi, tuo DKMS)

Huomautuksena tosiaan, että koska kyseistä pakettia ei ole kesäkuun jälkeen päivitetty, uusimpien Anysee-laitteiden tuki ei ole sisällytettynä. Katso siis ongelmtapauksissa ohjeet alta.


Vanha ohje

Anyseen ajureiden asennusohjeet suoraan Linux-DVB:n versionhallinnasta. Pitäisi edelleen toimia jos ylläoleva ei toimi, mutta on hankalampi ja epävarmempi tapa (jonain tiettynä päivänä kääntäminen eli "make"-komennon suorittaminen ei välttämättä onnistu!)

Ohjetta päivitetty sen jälkeen kun Anysee-tuki sulautettiin osaksi pääasiallista Linux-DVB-versionhallintaa

EDIT: uudet ja toivottavasti tarkemmat ohjeet :) Nyt poistetaan vanhat moduulit ajosta (ei tarvitse välttämättä bootata). Sekä nollataan käännösasetukset "defaulttiin".

Koodia: [Valitse]
sudo apt-get install mercurial linux-headers-$(uname -r) build-essential
rm -rf v4l-dvb
hg clone http://linuxtv.org/hg/v4l-dvb/
cd v4l-dvb
make distclean
make
sudo make install
sudo rmmod dvb_usb_anysee dvb_usb dvb_core tda10023 dvb_pll zl10353 mt352

/antti
« Viimeksi muokattu: 06.11.08 - klo:15.30 kirjoittanut Kari Argillander »

JPK1990

  • Vieras
onko se joku uusi malli?

Kent

  • Käyttäjä
  • Viestejä: 124
    • Profiili
Minun oli pakko poistaa äskeinen linkki, se sulkee kaikki avoimet ikkunat. Kyllä se jo jonkin aikaa on ollut myynnissä mutta ilmeisesti sen verran uusi ettei siihen löydy edes keskustelua Linuxin puolelta kovinkaan paljon.

JPK1990

  • Vieras
www.netholic.com HTPC foorumi.

Kent

  • Käyttäjä
  • Viestejä: 124
    • Profiili
Ei valitettavasti satu minun silmään Anyseestä mitään :-( Voisiko mikään ohjelma lukea tuota USB porttia ja jos se on mahdollista mitenköhän tuo toteutettaisiin ?

JPK1990

  • Vieras
linux-ajuria ei vielä olla vielä ilmeisesti tehty

Kupuntu

  • Käyttäjä
  • Viestejä: 804
  • Kubuntu 8.10 @ Amilo A1645
    • Profiili
konstilla. Googlella en löytänyt, enkä myöskään haku komennolla, joku sitä oli kysynyt mutta ei kukaan osannut vastata. Voisiko se toimia jollain muulla tapaa, jonkin muun asetuksilla, vaikka hauppagen ?
Löyty netistä Googlella tollasta: http://www.pvrguide.no-ip.com/bbs-old/viewtopic.php?t=27310
EDIT: Listusb:
Koodia: [Valitse]
Bus 001 Device 006: ID 04b4:861f Cypress Semiconductor Corp.
Device Descriptor:
bLength 18
bDescriptorType 1
bcdUSB 2.00
bDeviceClass 0 (Defined at Interface level)
bDeviceSubClass 0
bDeviceProtocol 0
bMaxPacketSize0 64
idVendor 0x04b4 Cypress Semiconductor Corp.
idProduct 0x861f
Lainaus
Additionally I found out, that it uses an mt352-demod (driver exists) and
the pll is connected to i2c-port of the mt352 on 0x60.
« Viimeksi muokattu: 16.02.06 - klo:18.15 kirjoittanut Kupuntu »
Amilo A1645: AMD 3300+ 2.0 Ghz, 512 mb RAM, 80 gb kiintolevy.
Last.fm

Kent

  • Käyttäjä
  • Viestejä: 124
    • Profiili
Näköjään eivät tuossakaan saaneet sitä vielä toimimaan joten jatkan etsiskelyä, kiitti vinkistä kuitenkin. Joudun hyppäämään välillä Windowsiin kun haluan katsoa TV:tä kannettavalta, toistaiseksi.

koloppi

  • Käyttäjä
  • Viestejä: 14
    • Profiili
Onkos kukaan saanu anysee korttia toimiin Ubuntussa?

Deeveri

  • Käyttäjä
  • Viestejä: 20
    • Profiili
Anysee usb-digi
« Vastaus #9 : 15.12.06 - klo:12.06 »
Onkos mahdollista saada anysee usb-digi tv sovitin (E30) toimimaan 6.06 ja millä ohjelmalla se näkyis? Näin äkkiseltään en netistä löytynyt mitään vastausta vai pitääkös xp:ssä kattoa tv? T:päivän vanha ubuntu käyttäjä  ;)

Timo Jyrinki

  • Sr. Member
  • ****
  • Viestejä: 1208
    • Profiili
    • kotisivu
Re: Anysee usb-digi
« Vastaus #10 : 16.12.06 - klo:18.39 »
Hei. Nopealla vilkaisulla tuolle nimenomaiselle TV-kortille ei ole Linux-tukea. Tämä on tätä Linux-käyttäjän arkea, eli (tulevat) laitehankinnat pitää tutkia normaalia tarkemmin.

Valmistajaan on oltu yhteydessä, mutta he eivät halua tukea avoimen lähdekoodin käyttöjärjestelmiä kertomalla laitteistaan sellaisia tietoja, joilla Linuxin DVB-tuen tekijät voisivat lisätä tuen laitteelle. On silti mahdollista, että joku sinnikäs ja taitava koodaaja pystyy "sokkona" selvittämään kortin salat, mutta se kestää pidempään kuin laitteilla joista on paremmat tiedot/"speksit".

Joudut siis tuota digitv-korttia käyttämään toistaiseksi Windowsissa.

Stupido

  • Käyttäjä
  • Viestejä: 176
  • Gutsy Gibbon
    • Profiili
Re: Anysee usb-digi
« Vastaus #11 : 16.12.06 - klo:18.41 »
Perskuta, harkitsin itsekin tuota tv-korttia >:(

Ubuntun käyttäjä jo vuodesta 2006.

JoniR

  • Käyttäjä
  • Viestejä: 112
    • Profiili
    • Peugeot 206
Re: Anysee usb-digi
« Vastaus #12 : 16.12.06 - klo:19.01 »
Vaikka ei ihan suoraan tähän kuulukkaan.
EI toimi muuten Twinhan Alpha USB2 dtv usb tikkukaan Linuxissa.
Vaikka LinuxTV wiki niin lupaakin.
Tikusta on nimittäin tullut uus versio eikä edes toiminu mukana tulleilla windows ajureilla  ;D  ;D

Regel

  • Käyttäjä
  • Viestejä: 1090
  • Lucid
    • Profiili
Re: Anysee usb-digi
« Vastaus #13 : 16.12.06 - klo:21.31 »
Perskuta, harkitsin itsekin tuota tv-korttia >:(
Harkitsepa vaikka Nebulan PCI-korttia. Se toimii.

Deeveri

  • Käyttäjä
  • Viestejä: 20
    • Profiili
Re: Anysee usb-digi
« Vastaus #14 : 16.12.06 - klo:22.52 »
Jaaha kiitos vastauksista. No mikä usb-digi sovitin sitten toimis täs 6.06 ja mikä softa siihen tarttis?

Timo Jyrinki

  • Sr. Member
  • ****
  • Viestejä: 1208
    • Profiili
    • kotisivu
Re: Anysee usb-digi
« Vastaus #15 : 17.12.06 - klo:13.18 »
Jaaha kiitos vastauksista. No mikä usb-digi sovitin sitten toimis täs 6.06 ja mikä softa siihen tarttis?

Digi-tv:tä voi katsoa esim. asentamalla gxine-ohjelman. LinuxComp:lla näyttäisi olevan ainakin Nebulaa ja Twinhania myynnissä, ja kaupan pitäjältä voi esim. vielä tarkistaa että toimivat Ubuntu 6.06:ssa varmasti. Käytännössä kaikki Linuxtv.org:ssa listatut (toimivaksi merkityt) pitäisi toimia, tai jos ei toimi suoraan niin ainakin saa jollain tavalla toimimaan (esim. jos tuki on tullut vasta Ubuntu 6.06:n jälkeen).

Kaverilla on Hauppaugen Nova-T Stick USB (nimenomaan tuo "Stick", ei tavallinen Nova-T), joka on varsin näppärä kooltaan (kuin isohko USB-muistitikku) mutta jolle tuki on tullut vasta nyt tässä syksyllä eli ei toimi ihan suoraan. Kuitenkin ajurin asentamalla toimii kuulemma moitteetta.
« Viimeksi muokattu: 17.12.06 - klo:13.20 kirjoittanut Timo Jyrinki »

isvard

  • Vieras
Re: Anysee usb-digi
« Vastaus #16 : 17.12.06 - klo:13.58 »
Jaaha kiitos vastauksista. No mikä usb-digi sovitin sitten toimis täs 6.06 ja mikä softa siihen tarttis?

Digi-tv:tä voi katsoa esim. asentamalla gxine-ohjelman. LinuxComp:lla näyttäisi olevan ainakin Nebulaa ja Twinhania myynnissä, ja kaupan pitäjältä voi esim. vielä tarkistaa että toimivat Ubuntu 6.06:ssa varmasti. Käytännössä kaikki Linuxtv.org:ssa listatut (toimivaksi merkityt) pitäisi toimia, tai jos ei toimi suoraan niin ainakin saa jollain tavalla toimimaan (esim. jos tuki on tullut vasta Ubuntu 6.06:n jälkeen).

Kaverilla on Hauppaugen Nova-T Stick USB (nimenomaan tuo "Stick", ei tavallinen Nova-T), joka on varsin näppärä kooltaan (kuin isohko USB-muistitikku) mutta jolle tuki on tullut vasta nyt tässä syksyllä eli ei toimi ihan suoraan. Kuitenkin ajurin asentamalla toimii kuulemma moitteetta.
Kovast pripeästi tuli minulle sähköpostissa vastaus kun kyselin kaapeliverkkoon digikorttia, eip taida olla kaapelikorttien toimivuudesta varmuutta kellään, maanpäälliseen verkkoon näytäs olevan tarjontaa aikas hyvin

JocceKoo

  • Käyttäjä
  • Viestejä: 44
    • Profiili
Re: Anysee usb-digi
« Vastaus #17 : 17.12.06 - klo:22.36 »
Eikös digisovittimen saa mahdollisesti toimimaan, jos ajaisi windowssia virtuaalisena?  Itsellä olisi tarkoitus hommata Digital Everywhere FireDTV-C sovitin, kun sitä on kovin kehuttu.
Tää tuki laitteille on kyllä ehdottomasti linuxin suurin kompastuskivi. Täytyisi oikeastaan poikotoida tuollaisia laitevalmistajia, mutta minkäs teet kun tarve laitteelle on kova, ja vastaavaa ei oikein tahdo löytyä.
Olisi kyllä jees jos toi toimisi virtuaalisena ajattevan xp:n kautta, ei viitsisi alkaa xp.tä tähän muuten asentelemaan.

ceoran

  • Käyttäjä
  • Viestejä: 50
    • Profiili
Re: Anysee usb-digi
« Vastaus #18 : 18.12.06 - klo:00.57 »
Mulla on Terratec Cinergy T2, joka toimii Linuxissa suoraan. Ainoa ongelma on se, että asun liian digimastojen ulottumattomissa ja asunto on kaapeliverkossa, joten ei tosta sitten iloa ollut.

JocceKoo

  • Käyttäjä
  • Viestejä: 44
    • Profiili
Re: Anysee usb-digi
« Vastaus #19 : 18.12.06 - klo:17.31 »
Noh, tilasinpa joka tapauksessa tuollaisen FireDTV:n kaapeliin. Toimii toivottavasti sitten virtuaali xp:n puolella. Tiedä vaikka joskus linux-ajuritkin tulis :)