Kirjoittaja Aihe: Widowsin kello sekoilee. [RATKAISTU]  (Luettu 1120 kertaa)

raimo

  • Käyttäjä
  • Viestejä: 4107
  • openSUSE Tumbleweed
    • Profiili
Widowsin kello sekoilee. [RATKAISTU]
« : 20.11.23 - klo:06.03 »
Huomenta! :)

Windows (11 pro) kello näyttää aikaa joka on 2h tulevaisuudessa käynnistyksen jälkeen.
Pitää käydä hiiren oikealla kelloa ja "Muokkaa päivämäärää ja aikaa" ->
käyttää "Määritä aika automaattisesti -slaideri" off-asennossa ja takaisin päälle.
Kello menee sitten heti oikeaan aikaan ja pysyy seuraavaan käynnistykseen.
Olisiko jotain mukavaa reksiteriavainta avuksi?

Taisi alkaa kiukkuamaan kesäajan loppuessa. Aikavyöhyke on UTC +2 Helsinki ja kumppanit.
« Viimeksi muokattu: 20.11.23 - klo:19.10 kirjoittanut raimo »
So long and thanks for all the fish!

epiphone

  • Käyttäjä
  • Viestejä: 1014
    • Profiili
Vs: Widowsin kello sekoilee.
« Vastaus #1 : 20.11.23 - klo:06.26 »
Miten olet määrittänyt kellon Bios:ssa? Sekin vaikuttaa. Jospa Bios:n kello on muljahtanut väärin?
Kahvi on väkevin juomani

raimo

  • Käyttäjä
  • Viestejä: 4107
  • openSUSE Tumbleweed
    • Profiili
Vs: Widowsin kello sekoilee.
« Vastaus #2 : 20.11.23 - klo:06.37 »
Miten olet määrittänyt kellon Bios:ssa? Sekin vaikuttaa. Jospa Bios:n kello on muljahtanut väärin?

Itseasiassa se vaatii Fedorassa: käyntiä seotakseen, eli vanha kunnon multiboottivika, joka korjautui
@nm rekisteriavaimella. Biossin menen katsomaan heti, kiitti vinkistä. ;D
Fedoran kello pysyy ajassa vaikka boottailis kuinka ja usesasti.

Edit: ei auttanut BIOS-ajansäätö mitään, se vaatii sitä rekisteriavainta Windowsiin.
Josko se läytyisi haulla?
« Viimeksi muokattu: 20.11.23 - klo:06.53 kirjoittanut raimo »
So long and thanks for all the fish!

raimo

  • Käyttäjä
  • Viestejä: 4107
  • openSUSE Tumbleweed
    • Profiili
Vs: Widowsin kello sekoilee.
« Vastaus #3 : 20.11.23 - klo:07.15 »
En saa tuota rekisteritiedostoa asennettua Windows lataa sen tekstitiedostona eikä tuplaklikkaus siis onnistu asentamaan avainta.
https://forum.ubuntu-fi.org/index.php?topic=51829.msg408011#msg408011

Linuxiin tehty muutos (hieman ylempänä tuossa keskustelussa) ei auta mitään.
https://forum.ubuntu-fi.org/index.php?topic=51829.msg396997#msg396997
So long and thanks for all the fish!

epiphone

  • Käyttäjä
  • Viestejä: 1014
    • Profiili
Vs: Widowsin kello sekoilee.
« Vastaus #4 : 20.11.23 - klo:07.45 »
https://pureinfotech.com/fix-clock-out-sync-windows-11/
Tuollainen tuli Googlella vastaan, toivottavasti siitä olisi hyötyä.
Kahvi on väkevin juomani

raimo

  • Käyttäjä
  • Viestejä: 4107
  • openSUSE Tumbleweed
    • Profiili
Vs: Widowsin kello sekoilee.
« Vastaus #5 : 20.11.23 - klo:08.01 »
https://pureinfotech.com/fix-clock-out-sync-windows-11/
Tuollainen tuli Googlella vastaan, toivottavasti siitä olisi hyötyä.

Kiitos, kovin on monimutkainen, saman hoitaa toi rekisteriavain kun sen vaan saisi menemään reksiteriin,
nyt se aukeaa tekstieditoriin eikä mitkään säädöt anna sitä muuttaa.

edit: tuon ohjeen mukaiset asetukset olen käynyt läpi ja asetus "Määritä aika automaattisesti" slaideria klikkaamalla kello menee aikaan, mutta se ei jää pysyvästi vaan seuraava Fedora-reissu sekoittaa kellon taas.
« Viimeksi muokattu: 20.11.23 - klo:08.16 kirjoittanut raimo »
So long and thanks for all the fish!

nm

  • Käyttäjä
  • Viestejä: 16111
    • Profiili
Vs: Widowsin kello sekoilee.
« Vastaus #6 : 20.11.23 - klo:10.29 »
Voit tehdä tarvittavan rekisterinmuutoksen manuaalisesti regedit-ohjelmalla. Asetuksen polku on siis

Koodia: [Valitse]
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation
Aseta siellä "RealTimeIsUniversal" = 1
« Viimeksi muokattu: 20.11.23 - klo:10.31 kirjoittanut nm »

maksim

  • Käyttäjä
  • Viestejä: 235
  • Mikähän tässä nyt mättää?????
    • Profiili
Vs: Widowsin kello sekoilee.
« Vastaus #7 : 20.11.23 - klo:12.49 »
Vai onko kyseessä tämä sama ongelma?
https://forum.ubuntu-fi.org/index.php?topic=58266.0

nm

  • Käyttäjä
  • Viestejä: 16111
    • Profiili
Vs: Widowsin kello sekoilee.
« Vastaus #8 : 20.11.23 - klo:13.08 »
Vai onko kyseessä tämä sama ongelma?
https://forum.ubuntu-fi.org/index.php?topic=58266.0

Niin tosiaan Fedoran aikavyöhykeasetukset on myös syytä tarkistaa. Mitä sanoo:

Koodia: [Valitse]
timedatectl

raimo

  • Käyttäjä
  • Viestejä: 4107
  • openSUSE Tumbleweed
    • Profiili
Vs: Widowsin kello sekoilee.
« Vastaus #9 : 20.11.23 - klo:18.53 »
Niin tosiaan Fedoran aikavyöhykeasetukset on myös syytä tarkistaa. Mitä sanoo:

Koodia: [Valitse]
timedatectl

Koodia: [Valitse]
raimo@kone-2:~$ timedatectl
               Local time: Mon 2023-11-20 18:51:46 EET
           Universal time: Mon 2023-11-20 16:51:46 UTC
                 RTC time: Mon 2023-11-20 18:51:46
                Time zone: Europe/Helsinki (EET, +0200)
System clock synchronized: yes
              NTP service: active
          RTC in local TZ: yes

Warning: The system is configured to read the RTC time in the local time zone.
         This mode cannot be fully supported. It will create various problems
         with time zone changes and daylight saving time adjustments. The RTC
         time is never updated, it relies on external facilities to maintain it.
         If at all possible, use RTC in UTC by calling
         'timedatectl set-local-rtc 0'.
 
So long and thanks for all the fish!

raimo

  • Käyttäjä
  • Viestejä: 4107
  • openSUSE Tumbleweed
    • Profiili
Vs: Widowsin kello sekoilee. [RATKAISU]
« Vastaus #10 : 20.11.23 - klo:19.08 »
Vai onko kyseessä tämä sama ongelma?
https://forum.ubuntu-fi.org/index.php?topic=58266.0

No sehän se, eli tämä auttoi (taas): 
Koodia: [Valitse]
sudo timedatectl set-local-rtc 0  #  Bios UTC -aikaan
Kiitos paljon, ajoin joitakin noita muitakin komentoja kylläkin, mutta nyt kellot on yksimielisiä
niin en ala selvittelemään mitään. Pääasia että toimii OK.
Niin lyhyt se on ihmisen muisti. :)
« Viimeksi muokattu: 20.11.23 - klo:19.11 kirjoittanut raimo »
So long and thanks for all the fish!

raimo

  • Käyttäjä
  • Viestejä: 4107
  • openSUSE Tumbleweed
    • Profiili
Vs: Widowsin kello sekoilee.
« Vastaus #11 : 21.11.23 - klo:00.35 »
Voit tehdä tarvittavan rekisterinmuutoksen manuaalisesti regedit-ohjelmalla. Asetuksen polku on siis

Koodia: [Valitse]
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation
Aseta siellä "RealTimeIsUniversal" = 1

Se oli jo 1, outoa minustakin.
Mutta nyt siis kellot raksuttaa samaan tahtiin. :)
So long and thanks for all the fish!

maksim

  • Käyttäjä
  • Viestejä: 235
  • Mikähän tässä nyt mättää?????
    • Profiili
Vs: Widowsin kello sekoilee. [RATKAISTU]
« Vastaus #12 : 21.11.23 - klo:12.09 »
Olen omalla kohdalla huomannut ettei Fedoran asennus dual-boottiin Windowsin kanssa osaa laittaa Fedoraa UTC-aikaan.
Kokemusta on kolmesta eri asennuksesta. Kaikissa olen joutunut erikseen aikakomentoja antamaan.
Samaa ongelmaa ei ole ollut Kubuntun, Susen tai Manjaron kanssa, vaikka kaikki ovat vastaavissa dual-bootti asennuksissa.
 
Ps. Eihän Raimollakaan Windowsin kello sekoillut, tällä kertaa, vaan Fedoran.  8)
« Viimeksi muokattu: 21.11.23 - klo:12.13 kirjoittanut maksim »

raimo

  • Käyttäjä
  • Viestejä: 4107
  • openSUSE Tumbleweed
    • Profiili
Vs: Widowsin kello sekoilee. [RATKAISTU]
« Vastaus #13 : 21.11.23 - klo:13.51 »
Olen omalla kohdalla huomannut ettei Fedoran asennus dual-boottiin Windowsin kanssa osaa laittaa Fedoraa UTC-aikaan.
Kokemusta on kolmesta eri asennuksesta. Kaikissa olen joutunut erikseen aikakomentoja antamaan.
Samaa ongelmaa ei ole ollut Kubuntun, Susen tai Manjaron kanssa, vaikka kaikki ovat vastaavissa dual-bootti asennuksissa.
 
Ps. Eihän Raimollakaan Windowsin kello sekoillut, tällä kertaa, vaan Fedoran.  8)

Öööh, voisin vaikka väittää että Windowsin kello oli se joka näytti ajan väärin ja Fedora koko ajan oikein.
Enomiäs putosi veneestä. ;D
No korjauskomento kuitenkin ajettiin Fedoorassa, en ihan aina pysy näiden perässä.
No niin tai näin, kellot on samiksii jälleen. Yritän painaa tuon komennon mieleeni.
Lienee syytä laittaa tämä keskustelu kirjanmerkkeihin.
So long and thanks for all the fish!

nm

  • Käyttäjä
  • Viestejä: 16111
    • Profiili
Vs: Widowsin kello sekoilee. [RATKAISTU]
« Vastaus #14 : 21.11.23 - klo:16.53 »
Öööh, voisin vaikka väittää että Windowsin kello oli se joka näytti ajan väärin ja Fedora koko ajan oikein.

Sinulla oli ennestään Windows asetettu niin, että koneen kello (RTC) on UTC-ajassa. Oletuksena Windows käyttää paikallista aikaa RTC:ssä, mutta olet joskus aiemmin muuttanut sen ratkoessasi samaa ongelmaa.

Nähtävästi Fedoran asennusohjelma tekee Windowsin oletuskäytäntöä vastaavan konfiguraation, jos se havaitsee koneessa Windows-asennuksen. Muiden Linux-jakelujen asennuksessa ei tietääkseni ole tällaista toimintoa, vaan ne asettavat koneen kellon aina UTC-aikaan ellei käyttäjä itse muuta asetuksia.

raimo

  • Käyttäjä
  • Viestejä: 4107
  • openSUSE Tumbleweed
    • Profiili
Vs: Widowsin kello sekoilee. [RATKAISTU]
« Vastaus #15 : 21.11.23 - klo:18.38 »
Öööh, voisin vaikka väittää että Windowsin kello oli se joka näytti ajan väärin ja Fedora koko ajan oikein.

Sinulla oli ennestään Windows asetettu niin, että koneen kello (RTC) on UTC-ajassa. Oletuksena Windows käyttää paikallista aikaa RTC:ssä, mutta olet joskus aiemmin muuttanut sen ratkoessasi samaa ongelmaa.

Nähtävästi Fedoran asennusohjelma tekee Windowsin oletuskäytäntöä vastaavan konfiguraation, jos se havaitsee koneessa Windows-asennuksen. Muiden Linux-jakelujen asennuksessa ei tietääkseni ole tällaista toimintoa, vaan ne asettavat koneen kellon aina UTC-aikaan ellei käyttäjä itse muuta asetuksia.

Kiitos selvennykksestä. Miksiköhän Fedora haluaa kellot väärään aikaan, melko ilkeää minusta. :(
So long and thanks for all the fish!

nm

  • Käyttäjä
  • Viestejä: 16111
    • Profiili
Vs: Widowsin kello sekoilee. [RATKAISTU]
« Vastaus #16 : 21.11.23 - klo:19.40 »
Kiitos selvennykksestä. Miksiköhän Fedora haluaa kellot väärään aikaan, melko ilkeää minusta. :(

Se yrittää auttaa dual-boot-koneen käyttäjää, jotta Windowsin asetuksia ei tarvitsisi erikseen muuttaa. Ongelmasi johtui siitä, että olet itse muuttanut Windowsin kelloasetusta, eikä Fedora osaa havaita sitä, vaan olettaa, että koneen kello on lokaalissa ajassa, kuten yleensä Windows-koneissa.
« Viimeksi muokattu: 22.11.23 - klo:18.03 kirjoittanut nm »

raimo

  • Käyttäjä
  • Viestejä: 4107
  • openSUSE Tumbleweed
    • Profiili
Vs: Widowsin kello sekoilee. [RATKAISTU]
« Vastaus #17 : 22.11.23 - klo:14.26 »
Kiitos selvennykksestä. Miksiköhän Fedora haluaa kellot väärään aikaan, melko ilkeää minusta. :(

Se yrittää auttaa dual-boot-koneen käyttäjää, jotta Windowsin asetuksia ei tarvitsisi erikseen muuttaa. Ongelmasi johtui siitä, että olet itse muuttanut Windowsin kelloasetusta, eikä Fedora osaa havaita sitä, vaan olettaa, että koneen kello on lokaalissa ajassa,
kuten yleensä Windows-koneissa.

OK, kiitos selvennyksestä. :)
So long and thanks for all the fish!

raimo

  • Käyttäjä
  • Viestejä: 4107
  • openSUSE Tumbleweed
    • Profiili
Vs: Widowsin kello sekoilee. [RATKAISTU]
« Vastaus #18 : 29.11.23 - klo:05.25 »
openSUJSE Tumbleweed asennus sotkee välillä samalla tavalla kun valitsee UTC ajaksi ja sitten joutuu kämään Extra Settings tms laittamassa  kellon aikaan, se tosin onnistuu yhdellä klikkauksella, eli turhaa se Fedora yrittää auttaa kohdassa jossa apua ei tarvita.

Tuo välillä on melko mielenkiintoista, kokeilin asennusta useita kertoja ja joskus kello menee aikaan itsestään, yleensä kuitenkaan ei mene. Foliohattu päähän.  :D
So long and thanks for all the fish!

tapion

  • Käyttäjä
  • Viestejä: 213
    • Profiili
Vs: Widowsin kello sekoilee. [RATKAISTU]
« Vastaus #19 : 29.11.23 - klo:07.26 »
Sekoilee se kello Windowsissa myös Mintin kanssa. En siitä paljoa välitä kun Windowsin käyttöä on melko vähän.
Kaksi tuntia aina jäljessä.
En ole puolesta enkä vastaan, pikemminkin päinvastoin.