Kirjoittaja Aihe: Uusin Vivaldi ei toimi suomeksi [Uusin versio kunnossa]  (Luettu 1607 kertaa)

SuperOscar

  • Käyttäjä
  • Viestejä: 3991
  • Ocatarinetabellatsumtsum!
    • Profiili
    • Legisign.org
Harmillinen bugi: Vivaldi-selaimen uusin versio tuntuu hylkivän suomenkielistä käyttöliittymää! Tai siis se ei toimi, vaikka asetuksista kuinka valitsee suomen kielen.

Olen itsekin mukana Vivaldin kääntämisessä ja tiedän, että jonot on sataprosenttisesti käännetty. Kummallisinta on, että kaikki muut kokeilemani käyttöliittymäkielet tuntuvat toimivan – kokeilin ainakin viroa, ruotsia, saksaa, espanjaa ja jotakin kieltä josta en osaa tämän tuota.

Bugista ilmoitin saman tien.
« Viimeksi muokattu: 02.11.23 - klo:16.59 kirjoittanut SuperOscar »
pöytäkone 1, kannettavat 2 & 3: Debian GNU/Linux 12; pöytäkone 2, kannettava 1: openSUSE Tumbleweed; NUC: openSUSE Leap 15.5; RPi 1: FreeBSD 13.2-RELEASE; RPi 2: LibreELEC 11

epiphone

  • Käyttäjä
  • Viestejä: 1051
    • Profiili
Vs: Uusin Vivaldi ei toimi suomeksi
« Vastaus #1 : 29.10.23 - klo:21.06 »
Minulla oli vähän samantapainen ongelma Vivaldin kanssa. Jostakin asetuksista piti vaihtaa FI+ kotoistus -  suomalaiseksi niin minulla auttoi se.
Kahvi on väkevin juomani

maksim

  • Käyttäjä
  • Viestejä: 249
  • Mikähän tässä nyt mättää?????
    • Profiili
Vs: Uusin Vivaldi ei toimi suomeksi
« Vastaus #2 : 30.10.23 - klo:12.36 »
Eipä käänny Suomen kielelle minullakaan, muille kylläkin.
Tämä ongelma taitaa koskea vain uusia asennuksia, minullakin tämänpäiväinen asennus.
Puuttuisiko kenties koko kielipaketti?
 

SuperOscar

  • Käyttäjä
  • Viestejä: 3991
  • Ocatarinetabellatsumtsum!
    • Profiili
    • Legisign.org
Vs: Uusin Vivaldi ei toimi suomeksi
« Vastaus #3 : 30.10.23 - klo:14.50 »
Tämä ongelma taitaa koskea vain uusia asennuksia, minullakin tämänpäiväinen asennus.
Puuttuisiko kenties koko kielipaketti?

Ei, kyllä päivityksistäkin tulee virheellinen versio. Kielipaketti ei puutu: sekä /opt/vivaldi/locales/fi.pak että /opt/vivaldi/resources/vivaldi/_locales/fi/messages.json löytyvät. Kokeilin itse asiassa myös sitä, että kopioin suomen kielipaketin ruotsin paketin nimelle ja valitsin asetuksista kieleksi ruotsin, mutta sama tulos: käyttöliittymä jää englanninkieliseksi. Vika lienee siis jommassakummassa tai kummassakin tiedostossa.

Muoks: Lisättäköön kotihakkereille tiedoksi, että tuo messages.json ei ole kelvollinen JSON-tiedosto yhdelläkään kielellä. Ei siis kannata häkeltyä, vaikka jollakin jq:lla kokeiltaessa tulee virheilmoitus.
« Viimeksi muokattu: 30.10.23 - klo:14.52 kirjoittanut SuperOscar »
pöytäkone 1, kannettavat 2 & 3: Debian GNU/Linux 12; pöytäkone 2, kannettava 1: openSUSE Tumbleweed; NUC: openSUSE Leap 15.5; RPi 1: FreeBSD 13.2-RELEASE; RPi 2: LibreELEC 11

SuperOscar

  • Käyttäjä
  • Viestejä: 3991
  • Ocatarinetabellatsumtsum!
    • Profiili
    • Legisign.org
Vs: Uusin Vivaldi ei toimi suomeksi
« Vastaus #4 : 30.10.23 - klo:16.56 »
Ongelma on ilmeisesti nyt hyvin tiedossa, ja korjausta voitaneen odotella kohtuuajassa.

Harmi kyllä, Vivaldin bugi-ilmoitusjärjestelmästä en löytänyt mahdollisuutta käydä todentamassa jonkun tekemä raportti; muuten olisin pyytänyt paria ihmistä täältä käymään huutamassa perään.
pöytäkone 1, kannettavat 2 & 3: Debian GNU/Linux 12; pöytäkone 2, kannettava 1: openSUSE Tumbleweed; NUC: openSUSE Leap 15.5; RPi 1: FreeBSD 13.2-RELEASE; RPi 2: LibreELEC 11

SuperOscar

  • Käyttäjä
  • Viestejä: 3991
  • Ocatarinetabellatsumtsum!
    • Profiili
    • Legisign.org
Vs: Uusin Vivaldi ei toimi suomeksi [Uusin versio kunnossa]
« Vastaus #5 : 02.11.23 - klo:16.59 »
Tänään saapunut versiopäivitys korjasi tilanteen: suomen kieli toimii taas.
pöytäkone 1, kannettavat 2 & 3: Debian GNU/Linux 12; pöytäkone 2, kannettava 1: openSUSE Tumbleweed; NUC: openSUSE Leap 15.5; RPi 1: FreeBSD 13.2-RELEASE; RPi 2: LibreELEC 11