Kirjoittaja Aihe: Debian 10 päivitys (RATKAISTU)  (Luettu 893 kertaa)

Pendeli

  • Käyttäjä
  • Viestejä: 646
    • Profiili
Debian 10 päivitys (RATKAISTU)
« : 06.10.21 - klo:10.56 »
Yritän päivittää jonkun aikaa päivittämättömänä ollutta debian 10-konetta
ja tulee seuraavia kommentteja:

~$ apt-get update && apt-get upgrade
Luetaan pakettiluetteloita... Valmis
E: Lukkotiedostoa /var/lib/apt/lists/lock ei voitu avata - open (13: Lupa evätty)
E: Unable to lock directory /var/lib/apt/lists/
W: Problem unlinking the file /var/cache/apt/pkgcache.bin - RemoveCaches (13: Lupa evätty)
W: Problem unlinking the file /var/cache/apt/srcpkgcache.bin - RemoveCaches (13: Lupa evätty)

Mitähän tuolle pitäisi tehdä?
« Viimeksi muokattu: 06.10.21 - klo:14.32 kirjoittanut Pendeli »

kamara

  • Käyttäjä
  • Viestejä: 2598
    • Profiili
Vs: Debian 10 päivitys
« Vastaus #1 : 06.10.21 - klo:11.08 »
Ajaa roottina ?

Pendeli

  • Käyttäjä
  • Viestejä: 646
    • Profiili
Vs: Debian 10 päivitys
« Vastaus #2 : 06.10.21 - klo:11.30 »
Roottina antaa seuraavaa. Konetta ei ole päivitetty yli vuoteen joten omituiselta tuntuisi että kaikki on up to date. Viimeisellä rivillä maininnat 0 päivityksistä.
 Skypekin pitäisi olla poistettu mutta jotain kai jäänyt roikkumaan?

sudo apt update && sudo apt upgrade
Löytyi:1 http://security.debian.org/debian-security buster/updates InRelease
Löytyi:2 http://deb.debian.org/debian buster InRelease
Löytyi:3 http://deb.debian.org/debian buster-updates InRelease
Nouda:4 https://repo.skype.com/deb stable InRelease [4 502 B]
Vrhe:4 https://repo.skype.com/deb stable InRelease
  Seuraavat allekirjoitukset eivät olleet kelvollisia: EXPKEYSIG 1F3045A5DF7587C3 Skype Linux Client Repository <se-um@microsoft.com>
Noudettiin 4 502 t ajassa 1s (4 686 t/s)
Luetaan pakettiluetteloita... Valmis
Muodostetaan riippuvuussuhteiden puu       
Luetaan tilatiedot... Valmis       
All packages are up to date.
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://repo.skype.com/deb stable InRelease: Seuraavat allekirjoitukset eivät olleet kelvollisia: EXPKEYSIG 1F3045A5DF7587C3 Skype Linux Client Repository <se-um@microsoft.com>
W: Tiedoston https://repo.skype.com/deb/dists/stable/InRelease nouto ei onnistunut  Seuraavat allekirjoitukset eivät olleet kelvollisia: EXPKEYSIG 1F3045A5DF7587C3 Skype Linux Client Repository <se-um@microsoft.com>
W: Some index files failed to download. They have been ignored, or old ones used instead.
Luetaan pakettiluetteloita... Valmis
Muodostetaan riippuvuussuhteiden puu       
Luetaan tilatiedot... Valmis       
Käsitellään päivitystä... Valmis
0 päivitetty, 0 uutta asennusta, 0 poistettavaa ja 0 päivittämätöntä.

qwertyy

  • Käyttäjä
  • Viestejä: 5191
    • Profiili
Vs: Debian 10 päivitys
« Vastaus #3 : 06.10.21 - klo:13.04 »
Mikäs tuo InRelease tuolla on? Vapaasti käännettynä "julkaisussa". Onko /etc/apt/sources.list ihan "vakio"?

https://computingforgeeks.com/add-debian-10-buster-official-repositories-to-sources-list/

Eesaurus

  • Käyttäjä
  • Viestejä: 3239
    • Profiili
Vs: Debian 10 päivitys
« Vastaus #4 : 06.10.21 - klo:13.13 »
Roottina antaa seuraavaa. Konetta ei ole päivitetty yli vuoteen joten omituiselta tuntuisi että kaikki on up to date. Viimeisellä rivillä maininnat 0 päivityksistä.
 Skypekin pitäisi olla poistettu mutta jotain kai jäänyt roikkumaan?

sudo apt update && sudo apt upgrade
Löytyi:1 http://security.debian.org/debian-security buster/updates InRelease
Löytyi:2 http://deb.debian.org/debian buster InRelease
Löytyi:3 http://deb.debian.org/debian buster-updates InRelease
Nouda:4 https://repo.skype.com/deb stable InRelease [4 502 B]
Vrhe:4 https://repo.skype.com/deb stable InRelease
  Seuraavat allekirjoitukset eivät olleet kelvollisia: EXPKEYSIG 1F3045A5DF7587C3 Skype Linux Client Repository <se-um@microsoft.com>
Noudettiin 4 502 t ajassa 1s (4 686 t/s)
Luetaan pakettiluetteloita... Valmis
Muodostetaan riippuvuussuhteiden puu       
Luetaan tilatiedot... Valmis       
All packages are up to date.
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://repo.skype.com/deb stable InRelease: Seuraavat allekirjoitukset eivät olleet kelvollisia: EXPKEYSIG 1F3045A5DF7587C3 Skype Linux Client Repository <se-um@microsoft.com>
W: Tiedoston https://repo.skype.com/deb/dists/stable/InRelease nouto ei onnistunut  Seuraavat allekirjoitukset eivät olleet kelvollisia: EXPKEYSIG 1F3045A5DF7587C3 Skype Linux Client Repository <se-um@microsoft.com>
W: Some index files failed to download. They have been ignored, or old ones used instead.
Luetaan pakettiluetteloita... Valmis
Muodostetaan riippuvuussuhteiden puu       
Luetaan tilatiedot... Valmis       
Käsitellään päivitystä... Valmis
0 päivitetty, 0 uutta asennusta, 0 poistettavaa ja 0 päivittämätöntä.

Errorit koskevat Skypeä, joten jos ohjelmakin on poistettu, niin kannattaa poistaa myös Skypen repo siellä Ohjelmistot ja ohjelmalähteet -ohjelmassa. Sen jälkeen ei ainakaan tule ko. virheilmoituksia.

Vuoden seisoneeseen Debianiin pitäisi toki tulla päivityksiä, joten muutakin voi olla rikki.

Pendeli

  • Käyttäjä
  • Viestejä: 646
    • Profiili
Vs: Debian 10 päivitys
« Vastaus #5 : 06.10.21 - klo:14.06 »
Poistin synapticista  skypen rivit ja päivitys siistiytyi seuraavaan muotoon:

~$ sudo apt update && sudo apt upgrade

Löytyi:1 http://security.debian.org/debian-security buster/updates InRelease
Löytyi:2 http://deb.debian.org/debian buster InRelease
Löytyi:3 http://deb.debian.org/debian buster-updates InRelease
Luetaan pakettiluetteloita... Valmis
Muodostetaan riippuvuussuhteiden puu       
Luetaan tilatiedot... Valmis       
All packages are up to date.
Luetaan pakettiluetteloita... Valmis
Muodostetaan riippuvuussuhteiden puu       
Luetaan tilatiedot... Valmis       
Käsitellään päivitystä... Valmis
0 päivitetty, 0 uutta asennusta, 0 poistettavaa ja 0 päivittämätöntä.

Edelleenkään ei mitään ladattavaa!

Sources listassa vain kolme aitaamatonta lähdettä, onko tarpeeksi?

Onko lista ajantasainen vai puuttuuko jotain ja pitäisikö joltain riviltä poistaa rajoitus?



# deb cdrom:[Debian GNU/Linux 10.0.0 _Buster_ - Official amd64 NETINST 20190706-10:23]/ buster main

# deb cdrom:[Debian GNU/Linux 10.0.0 _Buster_ - Official amd64 NETINST 20190706-10:23]/ buster main
# -scr rivit kommentoitu pois, contrib ja non-free lisätty

deb http://deb.debian.org/debian/ buster main contrib non-free
# deb-src http://deb.debian.org/debian/ buster main

deb http://security.debian.org/debian-security/ buster/updates main
# deb-src http://security.debian.org/debian-security/ buster/updates main

# buster-updates, previously known as 'volatile'
deb http://deb.debian.org/debian/ buster-updates main contrib non-free
# deb-src http://deb.debian.org/debian/ buster-updates main

# This system was installed using small removable media
# (e.g. netinst, live or single CD). The matching "deb cdrom"
# entries were disabled at the end of the installation process.
# For information about how to configure apt package sources,
# see the sources.list(5) manual.

jekku

  • Käyttäjä
  • Viestejä: 2624
    • Profiili
Vs: Debian 10 päivitys
« Vastaus #6 : 06.10.21 - klo:14.12 »
Eiköös buster liene ns. 'oldstable' - ei hajuakaan kauanko on päivityksiä tarjolla ...

Pendeli

  • Käyttäjä
  • Viestejä: 646
    • Profiili
Vs: Debian 10 päivitys
« Vastaus #7 : 06.10.21 - klo:14.30 »
Näkyikin olevan var/log/apt/historiassa mainittu viimeinen päivitys 1.10.21. Joten ei ihme että ei uudempia päivityksiä vielä heti näy.  Joku oli käynyt paivittämässä ja kone tuli minulle vasta sen jälkeen alkuviikosta.
Päivityksiä muistaakseni  tarjolla vielä jonnekin vuoteen 2022/23 tms.
Sources lista ja kaikki muukin lienee kunnossa joten tästäkin hässäkästä selvittiin sujuvasti.

juyli

  • Käyttäjä / moderaattori
  • Viestejä: 663
    • Profiili
Vs: Debian 10 päivitys
« Vastaus #8 : 07.10.21 - klo:00.33 »
Päivityksiä muistaakseni  tarjolla vielä jonnekin vuoteen 2022/23 tms.
Toki Debian-jakelun tuki jatkuu.
Mutta Debian on päivittynyt versiosta Buster 10 versioon Bullseye 11. Buster toki on yhä tuettu pitkään, mutta lähinnä tietoturvaan perustuvin päivityksin.
Koodia: [Valitse]
apt update && sudo apt upgrade on toki kätevä komentosarja, mutta ... mielestäni on selkeämpää käynnistää komennot erikseen, jotta voi halutessaan tarkistaa, mitä koneelle/järjestelmään on päivitettävissä.
sudo apt update --- ja erikseen sudo apt full-upgrade. (Myös parametri dist-upgrade riittänee.) Tarvittaessa sudo apt clean on ihan hyödyllinen komento.

Kuten Canonical Ubuntu-jakeluissaan, luotan Debian-jakelun testiversion toimivuuteen, joten käytän Debianin Bookworm-versiota (sid/12?).