Kirjoittaja Aihe: update 18.4 >> 20.4 ARGH :( Chromium snap ) [Ratkaistu]  (Luettu 678 kertaa)

LeHiX

  • Käyttäjä
  • Viestejä: 470
    • Profiili
Päivitin 18.4 >> 20.4 mutta kaikki ei mennyt putkeen, päivitys keskeytyi ja siinä ilmoitettu komento "dpkg --configure -a" ei tee mitään, terminaalit katosi :O vain cairon terminaali ja rootin terminaali toimi mutta komento ei tehnyt mitään, näkeekö jostain logista versiopäivityksen tapahtumat, kerkesi ehdottaa ja päivittää jo jotain mutta esim cairo ilmoittaa "python-v* jotain puuttuu, miten päivitys taas korjattiinkaan, 3h istuu ensin ja katsoo kun tekstiä valuu ja sitten "päivitys keskeytyi"
Kumma kyllä firefox muistaa kirjanmerkit ja salasanat mutta
esim chromium ei, sen verran ehdin nähdä että se asentui snap:stä ja tuli heti mieleen että miten kirjan merkin? No ne oli tirtysti kadonneet avatessani chromiumin, olisikop ne vielä tallessa jos (ja miten) poistan snap chromiumin ja asennan sen uudestaan ilman snap:ä (mahdollista?)
« Viimeksi muokattu: 17.10.20 - klo:22.21 kirjoittanut LeHiX »
| Pros. AMD Phemon(tm) 9950 :) (4cores) | Emo: ASUS M3A78 | Mem 8GT
| x86_64, gnome, ubuntu 18.04  | GeForce GTX 750 Ti/PC

LeHiX

  • Käyttäjä
  • Viestejä: 470
    • Profiili
Vs: update 18.4 >> 20.4 ARGH :( Chromium snap, python?
« Vastaus #1 : 30.09.20 - klo:02.48 »
Ai niin, myös käynnistys tökkäili grup ei löytänyt joku... *file-filter tiedostoa onneksi muistin aikaisemmin olleen ongelmia ja kävin biossissa vaihtamassa ensimmäiseksi levyksi ubuntulevyn ja johan löytyi.
Minulla ei ole ollut reiluun vuoteen biossin batterissa virtaa joten aina käynnistyksen yhteydessä on sormet ristissä
| Pros. AMD Phemon(tm) 9950 :) (4cores) | Emo: ASUS M3A78 | Mem 8GT
| x86_64, gnome, ubuntu 18.04  | GeForce GTX 750 Ti/PC

nm

  • Käyttäjä
  • Viestejä: 13695
    • Profiili
Vs: update 18.4 >> 20.4 ARGH :( Chromium snap, python?
« Vastaus #2 : 30.09.20 - klo:14.37 »
Päivitin 18.4 >> 20.4 mutta kaikki ei mennyt putkeen, päivitys keskeytyi ja siinä ilmoitettu komento "dpkg --configure -a" ei tee mitään, terminaalit katosi :O

Mitä terminaaleja olet käyttänyt? Mitä tapahtuu, jos yrität asentaa ne takaisin?

Entä mitä sanoo:

Koodia: [Valitse]
sudo apt update
sudo apt full-upgrade


esim chromium ei, sen verran ehdin nähdä että se asentui snap:stä ja tuli heti mieleen että miten kirjan merkin? No ne oli tirtysti kadonneet avatessani chromiumin, olisikop ne vielä tallessa jos (ja miten) poistan snap chromiumin ja asennan sen uudestaan ilman snap:ä (mahdollista?)

Canonicalin puolesta Chromium on saatavilla Ubuntu 20.04:ään vain Snap-pakettina. Omalla vastuulla voit kuitenkin käyttää esimerkiksi tätä PPA:ta: https://launchpad.net/~saiarcot895/+archive/ubuntu/chromium-beta


Snap-versio kopioi vanhan profiilikansion (~/.config/chromium) ensimmäisen käynnistyksen yhteydessä, eli profiilin ja kirjanmerkkien pitäisi siirtyä automaattisesti. Jostain syystä tämä ei nyt ole onnistunut, joten kokeile sammuttaa Chromium, poista kansio ~/snap/chromium ja käynnistä selain uudelleen. Toimiiko sitten?

Voit myös kokeilla kopioida profiilin tiedostot manuaalisesti ~/.config/chromium -kansiosta ~/snap/chromium/current -kansioon, mutta tässä täytyy olla tarkkana, että tiedostot päätyvät oikeaan paikkaan hakemistorakenteessa.
« Viimeksi muokattu: 30.09.20 - klo:14.40 kirjoittanut nm »

LeHiX

  • Käyttäjä
  • Viestejä: 470
    • Profiili
Vs: update 18.4 >> 20.4 ARGH :( Chromium snap, python?
« Vastaus #3 : 30.09.20 - klo:15.29 »
Päivitin 18.4 >> 20.4 mutta kaikki ei mennyt putkeen, päivitys keskeytyi ja siinä ilmoitettu komento "dpkg --configure -a" ei tee mitään, terminaalit katosi :O

Mitä terminaaleja olet käyttänyt? Mitä tapahtuu, jos yrität asentaa ne takaisin?
gnome-terminal mutta kun en sitä saanut käynnistettyä kokeilin root-terminal mutta sekään ai ajanut komentoani nyt käynnissä cairo-dockin terminal-plugin, on niin pieni ikkunainen :O

Entä mitä sanoo:

Koodia: [Valitse]
sudo apt update
sudo apt full-upgrade

Muistelen että päivityksen yhteydessä vilahti ikkuna jossa oli jotain tyyliin python*jotain ei voitu päivittää/löytynyt
ja päivitys keskeytyi jossain vaiheessa eikä tullut vaatimusta käynnistää kone uudelleen, perään tuli jotain ohjelmistopäivityksiä ja vanhojen ytimien poistoa ja siinä yhteydessä piti käynnistää uudelleen.

Koodia: [Valitse]
eero@eero:~$ sudo apt full-upgrade
Luetaan pakettiluetteloita... Valmis
Muodostetaan riippuvuussuhteiden puu       
Luetaan tilatiedot... Valmis       
Käsitellään päivitystä... Valmis
Seuraavat paketit on alun perin asennettu automaattisesti, eikä niitä enää tarvita:
  app-install-data appmenu-gtk-module-common argyll argyll-ref blender-data
  cdparanoia cdrdao cdrskin command-not-found-data diffstat dvd+rw-tools
  fonts-dejavu fonts-hack-ttf g++-7 gcc-8-base:i386 geoclue geoclue-hostip
  geoclue-ubuntu-geoip geoip-database gir1.2-mutter-2
  gir1.2-networkmanager-1.0 gir1.2-nmgtk-1.0 glib-networking:i386 growisofs
  gstreamer1.0-plugins-base:i386 gstreamer1.0-plugins-good:i386
  gstreamer1.0-x:i386 guile-2.0-libs i965-va-driver:i386 icoutils
  indicator-applet-complete intel-media-va-driver:i386 iputils-arping ipython
  k3b k3b-data kde-l10n-fi kde-runtime-data kdelibs5-data kio-ldap kio-sieve
  libaa1:i386 libampache-browser libaom0:i386 libappmenu-gtk3-parser0
  libapt-pkg-perl libargon2-0 libarmadillo8 libasn1-8-heimdal:i386
  libasound2:i386 libasound2-plugins:i386 libasync-mergepoint-perl
  libasyncns0:i386 libaudqt2 libavahi-client3:i386 libavahi-common-data:i386
  libavahi-common3:i386 libavc1394-0:i386 libavdevice57 libavfilter6
  libavformat-ffmpeg56 libavresample3 libavutil56:i386
  libb-hooks-endofscope-perl libbind9-160 libblosc1 libbluray1
  libboost-locale1.71.0 libboost-regex1.65.1 libbrlapi0.6 libbrotli1:i386
  libburn4 libcaca0:i386 libcaf-openmpi-3 libcairo-gobject2:i386
  libcairo2:i386 libcamel-1.2-61 libcap2:i386 libcapi20-3:i386
  libcapture-tiny-perl libcdio-cdda1 libcdio13 libcdio17 libcdparanoia0:i386
  libcgi-fast-perl libcgi-pm-perl libcharls1 libclass-accessor-perl
  libclass-data-inheritable-perl libclass-xsaccessor-perl libcln6
  libclone-perl libcoarrays-openmpi-dev libcodec2-0.9:i386 libcoin80c
  libcollada-dom2.4-dp0 libcomerr2:i386 libcrypt-openssl-bignum-perl
  libcrypt-openssl-random-perl libcrypt-openssl-rsa-perl libcue1
  libcups2:i386 libdata-random-perl libdatrie1:i386 libdbus-1-3:i386
  libdcmtk14 libdevel-size-perl libdevmapper1.02.1:i386
  libdigest-bubblebabble-perl libdlrestrictions1 libdns-export1100 libdns1100
  libdouble-conversion1 libdv4:i386 libebook-contacts-1.2-2 libecal-1.2-19
  libedataserver-1.2-23 libemail-valid-perl libevent-2.1-6
  libevent-core-2.1-7 libevent-dev libevent-extra-2.1-7
  libevent-openssl-2.1-7 libevent-pthreads-2.1-7 libexif12:i386 libexiv2-14
  libexporter-tiny-perl libfabric1 libfcgi-perl libffi6:i386
  libfile-copy-recursive-perl libfile-find-rule-perl libfile-which-perl
  libflac8:i386 libflann1.9 libflickcurl0 libfluidsynth1 libfont-ttf-perl
  libfontconfig1:i386 libfreehand-0.1-1 libfreetype6:i386 libfribidi0:i386
  libfuse2:i386 libgd-perl libgd3:i386 libgdbm-compat4:i386 libgdbm5
  libgdbm6:i386 libgdcm2.8 libgdk-pixbuf2.0-0:i386 libgeoclue0 libgeoip1
  libgeos-3.6.2 libgeotiff2 libgfortran4 libgit2-26 libgl1-mesa-glx:i386
  libgl2ps1.4 libglew2.0 libglib2.0-0:i386 libglu1-mesa:i386 libgmime-3.0-0
  libgmp10:i386 libgnome-desktop-3-17 libgnutls30:i386 libgomp1:i386
  libgpaste9 libgpgme++2v5 libgphoto2-6:i386 libgphoto2-port12:i386 libgps20
  libgps23 libgraphite2-3:i386 libgsm1:i386 libgsoap-2.8.60 libgspell-1-1
  libgssapi-krb5-2:i386 libgssapi3-heimdal:i386 libgssdp-1.0-3
  libgstreamer-opencv1.0-0 libgstreamer-plugins-base1.0-0:i386
  libgstreamer-plugins-good1.0-0:i386 libgstreamer1.0-0:i386 libgtkimageview0
  libgudev-1.0-0:i386 libguess1 libgupnp-1.0-4 libgutenprint2
  libgutenprintui2-1 libgweather-3-15 libharfbuzz0b:i386
  libhcrypto4-heimdal:i386 libhdf5-openmpi-103 libheimbase1-heimdal:i386
  libheimntlm0-heimdal:i386 libhogweed4 libhogweed4:i386 libhogweed5:i386
  libhttp-parser2.7.1 libhttp-server-simple-perl libhwloc-dev
  libhwloc-plugins libhwloc15 libhwloc5 libhx509-5-heimdal:i386
  libibverbs-dev libical2 libicu60:i386 libicu66:i386 libiec61883-0:i386
  libieee1284-3:i386 libigdgmm11:i386 libimport-into-perl libindicator7
  libio-async-loop-epoll-perl libio-async-perl libio-pty-perl
  libio-string-perl libip4tc0 libip6tc0 libipc-run-perl libiptc0 libirs160
  libisc-export169 libisc169 libisccc160 libisccfg160 libisl19 libiso9660-10
  libiso9660-11 libjack-jackd2-0:i386 libjbig0:i386 libjemalloc2
  libjpeg-turbo8:i386 libjpeg8:i386 libjson-c3 libjson-maybexs-perl
  libjson-perl libk3b7 libk3b7-extracodecs libk5crypto3:i386
  libkdecorations2private5v5 libkeyutils1:i386 libkf5akonadiagentbase5
  libkf5akonadicalendar-data libkf5akonadicalendar5abi2
  libkf5akonadicore5abi1 libkf5akonadinotes-data libkf5akonadinotes5
  libkf5akonadiprivate5 libkf5akonadiwidgets5 libkf5alarmcalendar-data
  libkf5alarmcalendar5abi2 libkf5calendarcore5abi1 libkf5calendarutils-bin
  libkf5calendarutils-data libkf5calendarutils5abi1 libkf5cddb-data
  libkf5cddb5 libkf5contacteditor-data libkf5imap-data libkf5imap5
  libkf5jsembed-data libkf5jsembed5 libkf5xmlrpcclient-data
  libkf5xmlrpcclient5 libkolabxml1v5 libkonq5-templates libkpimgapicalendar5
  libkpimgapicontacts5 libkpimgapitasks5 libkpimkdav-data libkpimkdav5abi2
  libkrb5-26-heimdal:i386 libkrb5-3:i386 libkrb5support0:i386 liblcms2-2:i386
  liblept5 liblinear3 liblinux-epoll-perl liblircclient0 liblist-compare-perl
  liblist-moreutils-perl liblivemedia62 liblog4cplus-1.1-9 liblouis14
  liblouisutdml8 libltdl7:i386 liblwres160 libmagick++-6.q16-7
  libmagickcore-6.q16-3 libmagickcore-6.q16-3-extra libmagickwand-6.q16-3
  libmicrodns0 libminiupnpc10 libmodule-implementation-perl libmoo-perl
  libmoox-aliases-perl libmouse-perl libmowgli-2-0 libmp3lame0:i386
  libmpg123-0:i386 libmspub-0.1-1 libmutter-2-0 libmypaint-1.3-0 libmysofa0
  libmysqlclient20 libmysqlclient21:i386 libnamespace-clean-perl
  libncurses5:i386 libnet-dns-perl libnet-dns-sec-perl libnet-domain-tld-perl
  libnet-dropbox-api-perl libnet-ip-perl libnet-oauth-perl libnetcdf-c++4
  libnettle6 libnettle6:i386 libnettle7:i386 libnfs11 libnghttp2-14:i386
  libnl-3-dev libnl-route-3-dev libnm-glib4 libnm-gtk0 libnm-util2
  libntfs-3g88 libntrack0 libnuma-dev libnuma1:i386 libnumber-compare-perl
  liboauth0 libodbc1:i386 libogg0:i386 libopenal1:i386 libopencolorio1v5
  libopencv-core3.2 libopencv-dnn4.2 libopencv-flann3.2 libopencv-imgproc3.2
  libopencv-ml3.2 libopencv-photo3.2 libopencv-photo4.2 libopencv-shape3.2
  libopencv-video3.2 libopencv-viz3.2 libopencv-viz4.2 libopengl0
  libopenjp2-7:i386 libopenmpi-dev libopenmpi2 libopenmpi3 libopenshot14
  libopenthreads21 libopenvdb5.0 libopenvdb6.2 libopus0:i386
  liborc-0.4-0:i386 libosdcpu3.4.0 libosdgpu3.4.0 libosinfo-1.0-0
  libosmesa6:i386 libp11-kit0:i386 libpackage-stash-perl
  libpackage-stash-xs-perl libpagemaker-0.0-0 libpanel-applet3
  libpango-1.0-0:i386 libpangocairo-1.0-0:i386 libpangoft2-1.0-0:i386
  libparse-debianchangelog-perl libpath-class-perl libpath-tiny-perl
  libpcap0.8:i386 libpci3:i386 libperl4-corelibs-perl libperl5.26
  libperl5.30:i386 libperlio-gzip-perl libpixman-1-0:i386 libplacebo4
  libplymouth4 libpmix2 libpng16-16:i386 libpodofo0.9.5 libpodofo0.9.6
  libpostproc54 libproc-processtable-perl libproc-simple-perl libprocps6
  libproj12 libprotobuf-lite10 libprotobuf10 libproxy1v5:i386 libpsl5:i386
  libpsm-infinipath1 libpsm2-2 libpulse0:i386 libpython3.6-dev libqpdf21
  libqrencode3 libqt5networkauth5 libqxp-0.0-0 libraw1394-11:i386 libre2-4
  libreadonly-perl libref-util-perl libref-util-xs-perl
  libreoffice-style-tango libroken18-heimdal:i386 librsvg2-2:i386
  librsvg2-common:i386 librtmp1:i386 libruby2.5 libsamplerate0:i386 libsane1
  libsdl2-2.0-0:i386 libsereal-decoder-perl libsereal-encoder-perl
  libsereal-perl libshine3:i386 libshout3:i386 libslang2:i386
  libsnappy1v5:i386 libsndfile1:i386 libsndio6.1:i386 libsndio7.0:i386
  libsnmp35:i386 libsort-naturally-perl libsoup2.4-1:i386 libsoxr0:i386
  libspeex1:i386 libspeexdsp1:i386 libspiro0 libspnav0 libsqlite3-0:i386
  libsquish0 libssh-4:i386 libssl1.1:i386 libstb0:i386 libstdc++-7-dev
  libstreamanalyzer0v5 libstreams0v5 libstrictures-perl libstruct-dumb-perl
  libsub-exporter-progressive-perl libsub-identify-perl libsub-quote-perl
  libswresample3:i386 libtag1v5:i386 libtag1v5-vanilla:i386 libtagc0
  libtasn1-6:i386 libtesseract4 libtest-fatal-perl libtest-refcount-perl
  libtext-glob-perl libtext-levenshtein-perl libthai0:i386 libtheora0:i386
  libtiff5:i386 libtinfo5:i386 libtwolame0:i386 libtype-tiny-perl
  libtype-tiny-xs-perl libunicode-utf8-perl libunique-1.0-0 libupnp6
  libusb-1.0-0:i386 libusbmuxd4 libv4l-0:i386 libv4lconvert0:i386
  libva-drm2:i386 libva-x11-2:i386 libva2:i386 libvariable-magic-perl
  libvcdinfo0 libvdpau1:i386 libvisual-0.4-0:i386 libvkd3d1:i386
  libvorbis0a:i386 libvorbisenc2:i386 libvpx6:i386 libvtk6.3 libwavpack1:i386
  libwayland-cursor0:i386 libwayland-egl1:i386 libwayland-egl1-mesa
  libwayland-server0:i386 libwebp6:i386 libwebpmux3:i386
  libwind0-heimdal:i386 libwrap0:i386 libwww-mechanize-perl libwxgtk3.0-0v5
  libx11-protocol-other-perl libx264-155:i386 libx265-179:i386 libx86emu1
  libxcb-render0:i386 libxcb-shm0:i386 libxcb-xfixes0:i386
  libxcomposite1:i386 libxcursor1:i386 libxi6:i386 libxinerama1:i386
  libxkbcommon0:i386 libxml-simple-perl libxml-writer-perl libxml2:i386
  libxpm4:i386 libxrandr2:i386 libxrender1:i386 libxslt1.1:i386 libxss1:i386
  libxv1:i386 libxvidcore4:i386 libyaml-cpp0.5v5 libyaml-cpp0.6
  libyaml-libyaml-perl libzeitgeist-1.0-1 libzip4 libzmf-0.0-0 libzvbi0:i386
  lintian marble-data mda-lv2 mesa-va-drivers:i386 mesa-vdpau-drivers:i386
  nepomuk-core-data nplan ntrack-module-libnl-0 ocl-icd-libopencl1:i386
  openmpi-bin openmpi-common osinfo-db patchutils
  phonon-backend-gstreamer-common php7.2-bcmath php7.2-cli php7.2-common
  php7.2-curl php7.2-json php7.2-opcache php7.2-readline php7.2-xml
  printer-driver-gutenprint python-asn1crypto
  python-backports-shutil-get-terminal-size python-configobj python-decorator
  python-dnspython python-dulwich python-fastimport python-gtkspell
  python-ipython python-ipython-genutils python-pathlib2 python-pexpect
  python-pickleshare python-prompt-toolkit python-psutil python-ptyprocess
  python-pygments python-qrencode python-scandir python-simplegeneric
  python-simplejson python-svn python-talloc python-traitlets python-wcwidth
  python-zeitgeist python3-asn1crypto python3-feedparser python3-libvoikko
  python3-oauth python3-zope.interface python3.6 python3.6-dev
  python3.6-minimal qml-module-org-kde-extensionplugin
  qml-module-qtquick-controls-styles-breeze qpdf qtcore4-l10n
  ruby-did-you-mean ruby2.5 scribus-data sox t1utils transcode transcode-doc
  twolame unity-lens-applications unity-lens-files unity-lens-music
  unity-lens-video unity-scope-calculator unity-scope-chromiumbookmarks
  unity-scope-colourlovers unity-scope-devhelp unity-scope-firefoxbookmarks
  unity-scope-manpages unity-scope-openclipart unity-scope-texdoc
  unity-scope-tomboy unity-scope-video-remote unity-scope-virtualbox
  unity-scope-yelp unity-scope-zotero unity-scopes-runner va-driver-all:i386
  vcdimager vdpau-driver-all:i386
Suorita 'sudo apt autoremove' poistaaksesi ne.
Nämä paketit on jätetty odottamaan:
  cjs
Nämä paketit päivitetään:
  skypeforlinux
1 päivitetty, 0 uutta asennusta, 0 poistettavaa ja 1 päivittämätöntä.
Noudettavaa arkistoa 84,3 Mt.
Toiminnon jälkeen käytetään 963 k t lisää levytilaa.
Haluatko jatkaa? [K/e]
Nouda:1 https://repo.skype.com/deb stable/main amd64 skypeforlinux amd64 8.65.0.76 [84,3 MB]
Noudettiin 84,3 Mt ajassa 6s (14,8 Mt/s) 
(Luetaan tietokantaa... 429053 tiedostoa ja hakemistoa asennettu tällä hetkellä
.)
Valmistaudutaan purkamaan .../skypeforlinux_8.65.0.76_amd64.deb ...
Puretaan skypeforlinux (8.65.0.76) version (8.64.0.81) päälle...
Tehdään asetuksia: skypeforlinux (8.65.0.76) ...
Käsitellään paketin desktop-file-utils (0.24-1ubuntu3) liipaisimia...
Käsitellään paketin mime-support (3.64ubuntu1) liipaisimia...
Käsitellään paketin hicolor-icon-theme (0.17-2) liipaisimia...
Käsitellään paketin gnome-menus (3.36.0-1ubuntu1) liipaisimia...
Käsitellään paketin bamfdaemon (0.5.3+18.04.20180207.2-0ubuntu2) liipaisimia...
Rebuilding /usr/share/applications/bamf-2.index...
eero@eero:~$

Huh, pitkälista :O
Uskaltaako tuota autoremovea käyttää?

esim chromium ei, sen verran ehdin nähdä että se asentui snap:stä ja tuli heti mieleen että miten kirjan merkin? No ne oli tirtysti kadonneet avatessani chromiumin, olisikop ne vielä tallessa jos (ja miten) poistan snap chromiumin ja asennan sen uudestaan ilman snap:ä (mahdollista?)

Canonicalin puolesta Chromium on saatavilla Ubuntu 20.04:ään vain Snap-pakettina. Omalla vastuulla voit kuitenkin käyttää esimerkiksi tätä PPA:ta: https://launchpad.net/~saiarcot895/+archive/ubuntu/chromium-beta


Snap-versio kopioi vanhan profiilikansion (~/.config/chromium) ensimmäisen käynnistyksen yhteydessä, eli profiilin ja kirjanmerkkien pitäisi siirtyä automaattisesti. Jostain syystä tämä ei nyt ole onnistunut, joten kokeile sammuttaa Chromium, poista kansio ~/snap/chromium ja käynnistä selain uudelleen. Toimiiko sitten?

Voit myös kokeilla kopioida profiilin tiedostot manuaalisesti ~/.config/chromium -kansiosta ~/snap/chromium/current -kansioon, mutta tässä täytyy olla tarkkana, että tiedostot päätyvät oikeaan paikkaan hakemistorakenteessa.
Kokeilin kopioida kansion ~/config/chromium -> ~/snap/chromium/current mutta ei auttanut ja sitten kokeilin ~/snap/chromium kansion poistolla ei sekään auttanut, ko /current kansio on linkki jonnekin? poistin linkin ja tein uuden kansion, ei vaikutusta

Nautiluskin on piiloutunut ja Nemo valtasi sen paikan, se oli aikaisemmin nautiluksen rinnalla, eipä tuo nautilus/tiedostot ole päivittynyt? -2018?
| Pros. AMD Phemon(tm) 9950 :) (4cores) | Emo: ASUS M3A78 | Mem 8GT
| x86_64, gnome, ubuntu 18.04  | GeForce GTX 750 Ti/PC

Eesaurus

  • Käyttäjä
  • Viestejä: 3046
    • Profiili
Vs: update 18.4 >> 20.4 ARGH :( Chromium snap, python?
« Vastaus #4 : 30.09.20 - klo:16.58 »
Koodia: [Valitse]
eero@eero:~$ sudo apt full-upgrade
Luetaan pakettiluetteloita... Valmis
Muodostetaan riippuvuussuhteiden puu       
Luetaan tilatiedot... Valmis       
Käsitellään päivitystä... Valmis
Seuraavat paketit on alun perin asennettu automaattisesti, eikä niitä enää tarvita:
  app-install-data appmenu-gtk-module-common argyll argyll-ref blender-data
  cdparanoia cdrdao cdrskin command-not-found-data diffstat dvd+rw-tools
  fonts-dejavu fonts-hack-ttf g++-7 gcc-8-base:i386 geoclue geoclue-hostip
  geoclue-ubuntu-geoip geoip-database gir1.2-mutter-2
  gir1.2-networkmanager-1.0 gir1.2-nmgtk-1.0 glib-networking:i386 growisofs
  gstreamer1.0-plugins-base:i386 gstreamer1.0-plugins-good:i386
  gstreamer1.0-x:i386 guile-2.0-libs i965-va-driver:i386 icoutils
  indicator-applet-complete intel-media-va-driver:i386 iputils-arping ipython
  k3b k3b-data kde-l10n-fi kde-runtime-data kdelibs5-data kio-ldap kio-sieve
  libaa1:i386 libampache-browser libaom0:i386 libappmenu-gtk3-parser0
  libapt-pkg-perl libargon2-0 libarmadillo8 libasn1-8-heimdal:i386
  libasound2:i386 libasound2-plugins:i386 libasync-mergepoint-perl
  libasyncns0:i386 libaudqt2 libavahi-client3:i386 libavahi-common-data:i386
  libavahi-common3:i386 libavc1394-0:i386 libavdevice57 libavfilter6
  libavformat-ffmpeg56 libavresample3 libavutil56:i386
  libb-hooks-endofscope-perl libbind9-160 libblosc1 libbluray1
  libboost-locale1.71.0 libboost-regex1.65.1 libbrlapi0.6 libbrotli1:i386
  libburn4 libcaca0:i386 libcaf-openmpi-3 libcairo-gobject2:i386
  libcairo2:i386 libcamel-1.2-61 libcap2:i386 libcapi20-3:i386
  libcapture-tiny-perl libcdio-cdda1 libcdio13 libcdio17 libcdparanoia0:i386
  libcgi-fast-perl libcgi-pm-perl libcharls1 libclass-accessor-perl
  libclass-data-inheritable-perl libclass-xsaccessor-perl libcln6
  libclone-perl libcoarrays-openmpi-dev libcodec2-0.9:i386 libcoin80c
  libcollada-dom2.4-dp0 libcomerr2:i386 libcrypt-openssl-bignum-perl
  libcrypt-openssl-random-perl libcrypt-openssl-rsa-perl libcue1
  libcups2:i386 libdata-random-perl libdatrie1:i386 libdbus-1-3:i386
  libdcmtk14 libdevel-size-perl libdevmapper1.02.1:i386
  libdigest-bubblebabble-perl libdlrestrictions1 libdns-export1100 libdns1100
  libdouble-conversion1 libdv4:i386 libebook-contacts-1.2-2 libecal-1.2-19
  libedataserver-1.2-23 libemail-valid-perl libevent-2.1-6
  libevent-core-2.1-7 libevent-dev libevent-extra-2.1-7
  libevent-openssl-2.1-7 libevent-pthreads-2.1-7 libexif12:i386 libexiv2-14
  libexporter-tiny-perl libfabric1 libfcgi-perl libffi6:i386
  libfile-copy-recursive-perl libfile-find-rule-perl libfile-which-perl
  libflac8:i386 libflann1.9 libflickcurl0 libfluidsynth1 libfont-ttf-perl
  libfontconfig1:i386 libfreehand-0.1-1 libfreetype6:i386 libfribidi0:i386
  libfuse2:i386 libgd-perl libgd3:i386 libgdbm-compat4:i386 libgdbm5
  libgdbm6:i386 libgdcm2.8 libgdk-pixbuf2.0-0:i386 libgeoclue0 libgeoip1
  libgeos-3.6.2 libgeotiff2 libgfortran4 libgit2-26 libgl1-mesa-glx:i386
  libgl2ps1.4 libglew2.0 libglib2.0-0:i386 libglu1-mesa:i386 libgmime-3.0-0
  libgmp10:i386 libgnome-desktop-3-17 libgnutls30:i386 libgomp1:i386
  libgpaste9 libgpgme++2v5 libgphoto2-6:i386 libgphoto2-port12:i386 libgps20
  libgps23 libgraphite2-3:i386 libgsm1:i386 libgsoap-2.8.60 libgspell-1-1
  libgssapi-krb5-2:i386 libgssapi3-heimdal:i386 libgssdp-1.0-3
  libgstreamer-opencv1.0-0 libgstreamer-plugins-base1.0-0:i386
  libgstreamer-plugins-good1.0-0:i386 libgstreamer1.0-0:i386 libgtkimageview0
  libgudev-1.0-0:i386 libguess1 libgupnp-1.0-4 libgutenprint2
  libgutenprintui2-1 libgweather-3-15 libharfbuzz0b:i386
  libhcrypto4-heimdal:i386 libhdf5-openmpi-103 libheimbase1-heimdal:i386
  libheimntlm0-heimdal:i386 libhogweed4 libhogweed4:i386 libhogweed5:i386
  libhttp-parser2.7.1 libhttp-server-simple-perl libhwloc-dev
  libhwloc-plugins libhwloc15 libhwloc5 libhx509-5-heimdal:i386
  libibverbs-dev libical2 libicu60:i386 libicu66:i386 libiec61883-0:i386
  libieee1284-3:i386 libigdgmm11:i386 libimport-into-perl libindicator7
  libio-async-loop-epoll-perl libio-async-perl libio-pty-perl
  libio-string-perl libip4tc0 libip6tc0 libipc-run-perl libiptc0 libirs160
  libisc-export169 libisc169 libisccc160 libisccfg160 libisl19 libiso9660-10
  libiso9660-11 libjack-jackd2-0:i386 libjbig0:i386 libjemalloc2
  libjpeg-turbo8:i386 libjpeg8:i386 libjson-c3 libjson-maybexs-perl
  libjson-perl libk3b7 libk3b7-extracodecs libk5crypto3:i386
  libkdecorations2private5v5 libkeyutils1:i386 libkf5akonadiagentbase5
  libkf5akonadicalendar-data libkf5akonadicalendar5abi2
  libkf5akonadicore5abi1 libkf5akonadinotes-data libkf5akonadinotes5
  libkf5akonadiprivate5 libkf5akonadiwidgets5 libkf5alarmcalendar-data
  libkf5alarmcalendar5abi2 libkf5calendarcore5abi1 libkf5calendarutils-bin
  libkf5calendarutils-data libkf5calendarutils5abi1 libkf5cddb-data
  libkf5cddb5 libkf5contacteditor-data libkf5imap-data libkf5imap5
  libkf5jsembed-data libkf5jsembed5 libkf5xmlrpcclient-data
  libkf5xmlrpcclient5 libkolabxml1v5 libkonq5-templates libkpimgapicalendar5
  libkpimgapicontacts5 libkpimgapitasks5 libkpimkdav-data libkpimkdav5abi2
  libkrb5-26-heimdal:i386 libkrb5-3:i386 libkrb5support0:i386 liblcms2-2:i386
  liblept5 liblinear3 liblinux-epoll-perl liblircclient0 liblist-compare-perl
  liblist-moreutils-perl liblivemedia62 liblog4cplus-1.1-9 liblouis14
  liblouisutdml8 libltdl7:i386 liblwres160 libmagick++-6.q16-7
  libmagickcore-6.q16-3 libmagickcore-6.q16-3-extra libmagickwand-6.q16-3
  libmicrodns0 libminiupnpc10 libmodule-implementation-perl libmoo-perl
  libmoox-aliases-perl libmouse-perl libmowgli-2-0 libmp3lame0:i386
  libmpg123-0:i386 libmspub-0.1-1 libmutter-2-0 libmypaint-1.3-0 libmysofa0
  libmysqlclient20 libmysqlclient21:i386 libnamespace-clean-perl
  libncurses5:i386 libnet-dns-perl libnet-dns-sec-perl libnet-domain-tld-perl
  libnet-dropbox-api-perl libnet-ip-perl libnet-oauth-perl libnetcdf-c++4
  libnettle6 libnettle6:i386 libnettle7:i386 libnfs11 libnghttp2-14:i386
  libnl-3-dev libnl-route-3-dev libnm-glib4 libnm-gtk0 libnm-util2
  libntfs-3g88 libntrack0 libnuma-dev libnuma1:i386 libnumber-compare-perl
  liboauth0 libodbc1:i386 libogg0:i386 libopenal1:i386 libopencolorio1v5
  libopencv-core3.2 libopencv-dnn4.2 libopencv-flann3.2 libopencv-imgproc3.2
  libopencv-ml3.2 libopencv-photo3.2 libopencv-photo4.2 libopencv-shape3.2
  libopencv-video3.2 libopencv-viz3.2 libopencv-viz4.2 libopengl0
  libopenjp2-7:i386 libopenmpi-dev libopenmpi2 libopenmpi3 libopenshot14
  libopenthreads21 libopenvdb5.0 libopenvdb6.2 libopus0:i386
  liborc-0.4-0:i386 libosdcpu3.4.0 libosdgpu3.4.0 libosinfo-1.0-0
  libosmesa6:i386 libp11-kit0:i386 libpackage-stash-perl
  libpackage-stash-xs-perl libpagemaker-0.0-0 libpanel-applet3
  libpango-1.0-0:i386 libpangocairo-1.0-0:i386 libpangoft2-1.0-0:i386
  libparse-debianchangelog-perl libpath-class-perl libpath-tiny-perl
  libpcap0.8:i386 libpci3:i386 libperl4-corelibs-perl libperl5.26
  libperl5.30:i386 libperlio-gzip-perl libpixman-1-0:i386 libplacebo4
  libplymouth4 libpmix2 libpng16-16:i386 libpodofo0.9.5 libpodofo0.9.6
  libpostproc54 libproc-processtable-perl libproc-simple-perl libprocps6
  libproj12 libprotobuf-lite10 libprotobuf10 libproxy1v5:i386 libpsl5:i386
  libpsm-infinipath1 libpsm2-2 libpulse0:i386 libpython3.6-dev libqpdf21
  libqrencode3 libqt5networkauth5 libqxp-0.0-0 libraw1394-11:i386 libre2-4
  libreadonly-perl libref-util-perl libref-util-xs-perl
  libreoffice-style-tango libroken18-heimdal:i386 librsvg2-2:i386
  librsvg2-common:i386 librtmp1:i386 libruby2.5 libsamplerate0:i386 libsane1
  libsdl2-2.0-0:i386 libsereal-decoder-perl libsereal-encoder-perl
  libsereal-perl libshine3:i386 libshout3:i386 libslang2:i386
  libsnappy1v5:i386 libsndfile1:i386 libsndio6.1:i386 libsndio7.0:i386
  libsnmp35:i386 libsort-naturally-perl libsoup2.4-1:i386 libsoxr0:i386
  libspeex1:i386 libspeexdsp1:i386 libspiro0 libspnav0 libsqlite3-0:i386
  libsquish0 libssh-4:i386 libssl1.1:i386 libstb0:i386 libstdc++-7-dev
  libstreamanalyzer0v5 libstreams0v5 libstrictures-perl libstruct-dumb-perl
  libsub-exporter-progressive-perl libsub-identify-perl libsub-quote-perl
  libswresample3:i386 libtag1v5:i386 libtag1v5-vanilla:i386 libtagc0
  libtasn1-6:i386 libtesseract4 libtest-fatal-perl libtest-refcount-perl
  libtext-glob-perl libtext-levenshtein-perl libthai0:i386 libtheora0:i386
  libtiff5:i386 libtinfo5:i386 libtwolame0:i386 libtype-tiny-perl
  libtype-tiny-xs-perl libunicode-utf8-perl libunique-1.0-0 libupnp6
  libusb-1.0-0:i386 libusbmuxd4 libv4l-0:i386 libv4lconvert0:i386
  libva-drm2:i386 libva-x11-2:i386 libva2:i386 libvariable-magic-perl
  libvcdinfo0 libvdpau1:i386 libvisual-0.4-0:i386 libvkd3d1:i386
  libvorbis0a:i386 libvorbisenc2:i386 libvpx6:i386 libvtk6.3 libwavpack1:i386
  libwayland-cursor0:i386 libwayland-egl1:i386 libwayland-egl1-mesa
  libwayland-server0:i386 libwebp6:i386 libwebpmux3:i386
  libwind0-heimdal:i386 libwrap0:i386 libwww-mechanize-perl libwxgtk3.0-0v5
  libx11-protocol-other-perl libx264-155:i386 libx265-179:i386 libx86emu1
  libxcb-render0:i386 libxcb-shm0:i386 libxcb-xfixes0:i386
  libxcomposite1:i386 libxcursor1:i386 libxi6:i386 libxinerama1:i386
  libxkbcommon0:i386 libxml-simple-perl libxml-writer-perl libxml2:i386
  libxpm4:i386 libxrandr2:i386 libxrender1:i386 libxslt1.1:i386 libxss1:i386
  libxv1:i386 libxvidcore4:i386 libyaml-cpp0.5v5 libyaml-cpp0.6
  libyaml-libyaml-perl libzeitgeist-1.0-1 libzip4 libzmf-0.0-0 libzvbi0:i386
  lintian marble-data mda-lv2 mesa-va-drivers:i386 mesa-vdpau-drivers:i386
  nepomuk-core-data nplan ntrack-module-libnl-0 ocl-icd-libopencl1:i386
  openmpi-bin openmpi-common osinfo-db patchutils
  phonon-backend-gstreamer-common php7.2-bcmath php7.2-cli php7.2-common
  php7.2-curl php7.2-json php7.2-opcache php7.2-readline php7.2-xml
  printer-driver-gutenprint python-asn1crypto
  python-backports-shutil-get-terminal-size python-configobj python-decorator
  python-dnspython python-dulwich python-fastimport python-gtkspell
  python-ipython python-ipython-genutils python-pathlib2 python-pexpect
  python-pickleshare python-prompt-toolkit python-psutil python-ptyprocess
  python-pygments python-qrencode python-scandir python-simplegeneric
  python-simplejson python-svn python-talloc python-traitlets python-wcwidth
  python-zeitgeist python3-asn1crypto python3-feedparser python3-libvoikko
  python3-oauth python3-zope.interface python3.6 python3.6-dev
  python3.6-minimal qml-module-org-kde-extensionplugin
  qml-module-qtquick-controls-styles-breeze qpdf qtcore4-l10n
  ruby-did-you-mean ruby2.5 scribus-data sox t1utils transcode transcode-doc
  twolame unity-lens-applications unity-lens-files unity-lens-music
  unity-lens-video unity-scope-calculator unity-scope-chromiumbookmarks
  unity-scope-colourlovers unity-scope-devhelp unity-scope-firefoxbookmarks
  unity-scope-manpages unity-scope-openclipart unity-scope-texdoc
  unity-scope-tomboy unity-scope-video-remote unity-scope-virtualbox
  unity-scope-yelp unity-scope-zotero unity-scopes-runner va-driver-all:i386
  vcdimager vdpau-driver-all:i386
Suorita 'sudo apt autoremove' poistaaksesi ne.
Nämä paketit on jätetty odottamaan:
  cjs
Nämä paketit päivitetään:
  skypeforlinux
1 päivitetty, 0 uutta asennusta, 0 poistettavaa ja 1 päivittämätöntä.
Noudettavaa arkistoa 84,3 Mt.
Toiminnon jälkeen käytetään 963 k t lisää levytilaa.
Haluatko jatkaa? [K/e]
Nouda:1 https://repo.skype.com/deb stable/main amd64 skypeforlinux amd64 8.65.0.76 [84,3 MB]
Noudettiin 84,3 Mt ajassa 6s (14,8 Mt/s) 
(Luetaan tietokantaa... 429053 tiedostoa ja hakemistoa asennettu tällä hetkellä
.)
Valmistaudutaan purkamaan .../skypeforlinux_8.65.0.76_amd64.deb ...
Puretaan skypeforlinux (8.65.0.76) version (8.64.0.81) päälle...
Tehdään asetuksia: skypeforlinux (8.65.0.76) ...
Käsitellään paketin desktop-file-utils (0.24-1ubuntu3) liipaisimia...
Käsitellään paketin mime-support (3.64ubuntu1) liipaisimia...
Käsitellään paketin hicolor-icon-theme (0.17-2) liipaisimia...
Käsitellään paketin gnome-menus (3.36.0-1ubuntu1) liipaisimia...
Käsitellään paketin bamfdaemon (0.5.3+18.04.20180207.2-0ubuntu2) liipaisimia...
Rebuilding /usr/share/applications/bamf-2.index...
eero@eero:~$

Huh, pitkälista :O
Uskaltaako tuota autoremovea käyttää?

Autoremoven tarjoilemat paketit kuuluu poistaa välittömästi ja lukematta. :P Ei vaiskaan... Versiopäivityksen jäljiltä on paljon poistettavaa, kuuluu asiaan. Mutta kannattaa vähän silmäillä listaa, ennen kuin hyväksyy. Muistaakseni autoclean vasta oikeasti poistaa paketit systeemistä, joten poistetut voinee palauttaakin, jos tarvis.

LeHiX

  • Käyttäjä
  • Viestejä: 470
    • Profiili
Vs: update 18.4 >> 20.4 ARGH :( Chromium snap, python?
« Vastaus #5 : 30.09.20 - klo:19.42 »
Koodia: [Valitse]
eero@eero:~$ sudo apt full-upgrade
Luetaan pakettiluetteloita... Valmis
Muodostetaan riippuvuussuhteiden puu       
Luetaan tilatiedot... Valmis       
Käsitellään päivitystä... Valmis
Seuraavat paketit on alun perin asennettu automaattisesti, eikä niitä enää tarvita:
  app-install-data appmenu-gtk-module-common argyll argyll-ref blender-data
  cdparanoia cdrdao cdrskin command-not-found-data diffstat dvd+rw-tools
  fonts-dejavu fonts-hack-ttf g++-7 gcc-8-base:i386 geoclue geoclue-hostip
  geoclue-ubuntu-geoip geoip-database gir1.2-mutter-2
  gir1.2-networkmanager-1.0 gir1.2-nmgtk-1.0 glib-networking:i386 growisofs
  gstreamer1.0-plugins-base:i386 gstreamer1.0-plugins-good:i386
  gstreamer1.0-x:i386 guile-2.0-libs i965-va-driver:i386 icoutils
  indicator-applet-complete intel-media-va-driver:i386 iputils-arping ipython
  k3b k3b-data kde-l10n-fi kde-runtime-data kdelibs5-data kio-ldap kio-sieve
  libaa1:i386 libampache-browser libaom0:i386 libappmenu-gtk3-parser0
  libapt-pkg-perl libargon2-0 libarmadillo8 libasn1-8-heimdal:i386
  libasound2:i386 libasound2-plugins:i386 libasync-mergepoint-perl
  libasyncns0:i386 libaudqt2 libavahi-client3:i386 libavahi-common-data:i386
  libavahi-common3:i386 libavc1394-0:i386 libavdevice57 libavfilter6
  libavformat-ffmpeg56 libavresample3 libavutil56:i386
  libb-hooks-endofscope-perl libbind9-160 libblosc1 libbluray1
  libboost-locale1.71.0 libboost-regex1.65.1 libbrlapi0.6 libbrotli1:i386
  libburn4 libcaca0:i386 libcaf-openmpi-3 libcairo-gobject2:i386
  libcairo2:i386 libcamel-1.2-61 libcap2:i386 libcapi20-3:i386
  libcapture-tiny-perl libcdio-cdda1 libcdio13 libcdio17 libcdparanoia0:i386
  libcgi-fast-perl libcgi-pm-perl libcharls1 libclass-accessor-perl
  libclass-data-inheritable-perl libclass-xsaccessor-perl libcln6
  libclone-perl libcoarrays-openmpi-dev libcodec2-0.9:i386 libcoin80c
  libcollada-dom2.4-dp0 libcomerr2:i386 libcrypt-openssl-bignum-perl
  libcrypt-openssl-random-perl libcrypt-openssl-rsa-perl libcue1
  libcups2:i386 libdata-random-perl libdatrie1:i386 libdbus-1-3:i386
  libdcmtk14 libdevel-size-perl libdevmapper1.02.1:i386
  libdigest-bubblebabble-perl libdlrestrictions1 libdns-export1100 libdns1100
  libdouble-conversion1 libdv4:i386 libebook-contacts-1.2-2 libecal-1.2-19
  libedataserver-1.2-23 libemail-valid-perl libevent-2.1-6
  libevent-core-2.1-7 libevent-dev libevent-extra-2.1-7
  libevent-openssl-2.1-7 libevent-pthreads-2.1-7 libexif12:i386 libexiv2-14
  libexporter-tiny-perl libfabric1 libfcgi-perl libffi6:i386
  libfile-copy-recursive-perl libfile-find-rule-perl libfile-which-perl
  libflac8:i386 libflann1.9 libflickcurl0 libfluidsynth1 libfont-ttf-perl
  libfontconfig1:i386 libfreehand-0.1-1 libfreetype6:i386 libfribidi0:i386
  libfuse2:i386 libgd-perl libgd3:i386 libgdbm-compat4:i386 libgdbm5
  libgdbm6:i386 libgdcm2.8 libgdk-pixbuf2.0-0:i386 libgeoclue0 libgeoip1
  libgeos-3.6.2 libgeotiff2 libgfortran4 libgit2-26 libgl1-mesa-glx:i386
  libgl2ps1.4 libglew2.0 libglib2.0-0:i386 libglu1-mesa:i386 libgmime-3.0-0
  libgmp10:i386 libgnome-desktop-3-17 libgnutls30:i386 libgomp1:i386
  libgpaste9 libgpgme++2v5 libgphoto2-6:i386 libgphoto2-port12:i386 libgps20
  libgps23 libgraphite2-3:i386 libgsm1:i386 libgsoap-2.8.60 libgspell-1-1
  libgssapi-krb5-2:i386 libgssapi3-heimdal:i386 libgssdp-1.0-3
  libgstreamer-opencv1.0-0 libgstreamer-plugins-base1.0-0:i386
  libgstreamer-plugins-good1.0-0:i386 libgstreamer1.0-0:i386 libgtkimageview0
  libgudev-1.0-0:i386 libguess1 libgupnp-1.0-4 libgutenprint2
  libgutenprintui2-1 libgweather-3-15 libharfbuzz0b:i386
  libhcrypto4-heimdal:i386 libhdf5-openmpi-103 libheimbase1-heimdal:i386
  libheimntlm0-heimdal:i386 libhogweed4 libhogweed4:i386 libhogweed5:i386
  libhttp-parser2.7.1 libhttp-server-simple-perl libhwloc-dev
  libhwloc-plugins libhwloc15 libhwloc5 libhx509-5-heimdal:i386
  libibverbs-dev libical2 libicu60:i386 libicu66:i386 libiec61883-0:i386
  libieee1284-3:i386 libigdgmm11:i386 libimport-into-perl libindicator7
  libio-async-loop-epoll-perl libio-async-perl libio-pty-perl
  libio-string-perl libip4tc0 libip6tc0 libipc-run-perl libiptc0 libirs160
  libisc-export169 libisc169 libisccc160 libisccfg160 libisl19 libiso9660-10
  libiso9660-11 libjack-jackd2-0:i386 libjbig0:i386 libjemalloc2
  libjpeg-turbo8:i386 libjpeg8:i386 libjson-c3 libjson-maybexs-perl
  libjson-perl libk3b7 libk3b7-extracodecs libk5crypto3:i386
  libkdecorations2private5v5 libkeyutils1:i386 libkf5akonadiagentbase5
  libkf5akonadicalendar-data libkf5akonadicalendar5abi2
  libkf5akonadicore5abi1 libkf5akonadinotes-data libkf5akonadinotes5
  libkf5akonadiprivate5 libkf5akonadiwidgets5 libkf5alarmcalendar-data
  libkf5alarmcalendar5abi2 libkf5calendarcore5abi1 libkf5calendarutils-bin
  libkf5calendarutils-data libkf5calendarutils5abi1 libkf5cddb-data
  libkf5cddb5 libkf5contacteditor-data libkf5imap-data libkf5imap5
  libkf5jsembed-data libkf5jsembed5 libkf5xmlrpcclient-data
  libkf5xmlrpcclient5 libkolabxml1v5 libkonq5-templates libkpimgapicalendar5
  libkpimgapicontacts5 libkpimgapitasks5 libkpimkdav-data libkpimkdav5abi2
  libkrb5-26-heimdal:i386 libkrb5-3:i386 libkrb5support0:i386 liblcms2-2:i386
  liblept5 liblinear3 liblinux-epoll-perl liblircclient0 liblist-compare-perl
  liblist-moreutils-perl liblivemedia62 liblog4cplus-1.1-9 liblouis14
  liblouisutdml8 libltdl7:i386 liblwres160 libmagick++-6.q16-7
  libmagickcore-6.q16-3 libmagickcore-6.q16-3-extra libmagickwand-6.q16-3
  libmicrodns0 libminiupnpc10 libmodule-implementation-perl libmoo-perl
  libmoox-aliases-perl libmouse-perl libmowgli-2-0 libmp3lame0:i386
  libmpg123-0:i386 libmspub-0.1-1 libmutter-2-0 libmypaint-1.3-0 libmysofa0
  libmysqlclient20 libmysqlclient21:i386 libnamespace-clean-perl
  libncurses5:i386 libnet-dns-perl libnet-dns-sec-perl libnet-domain-tld-perl
  libnet-dropbox-api-perl libnet-ip-perl libnet-oauth-perl libnetcdf-c++4
  libnettle6 libnettle6:i386 libnettle7:i386 libnfs11 libnghttp2-14:i386
  libnl-3-dev libnl-route-3-dev libnm-glib4 libnm-gtk0 libnm-util2
  libntfs-3g88 libntrack0 libnuma-dev libnuma1:i386 libnumber-compare-perl
  liboauth0 libodbc1:i386 libogg0:i386 libopenal1:i386 libopencolorio1v5
  libopencv-core3.2 libopencv-dnn4.2 libopencv-flann3.2 libopencv-imgproc3.2
  libopencv-ml3.2 libopencv-photo3.2 libopencv-photo4.2 libopencv-shape3.2
  libopencv-video3.2 libopencv-viz3.2 libopencv-viz4.2 libopengl0
  libopenjp2-7:i386 libopenmpi-dev libopenmpi2 libopenmpi3 libopenshot14
  libopenthreads21 libopenvdb5.0 libopenvdb6.2 libopus0:i386
  liborc-0.4-0:i386 libosdcpu3.4.0 libosdgpu3.4.0 libosinfo-1.0-0
  libosmesa6:i386 libp11-kit0:i386 libpackage-stash-perl
  libpackage-stash-xs-perl libpagemaker-0.0-0 libpanel-applet3
  libpango-1.0-0:i386 libpangocairo-1.0-0:i386 libpangoft2-1.0-0:i386
  libparse-debianchangelog-perl libpath-class-perl libpath-tiny-perl
  libpcap0.8:i386 libpci3:i386 libperl4-corelibs-perl libperl5.26
  libperl5.30:i386 libperlio-gzip-perl libpixman-1-0:i386 libplacebo4
  libplymouth4 libpmix2 libpng16-16:i386 libpodofo0.9.5 libpodofo0.9.6
  libpostproc54 libproc-processtable-perl libproc-simple-perl libprocps6
  libproj12 libprotobuf-lite10 libprotobuf10 libproxy1v5:i386 libpsl5:i386
  libpsm-infinipath1 libpsm2-2 libpulse0:i386 libpython3.6-dev libqpdf21
  libqrencode3 libqt5networkauth5 libqxp-0.0-0 libraw1394-11:i386 libre2-4
  libreadonly-perl libref-util-perl libref-util-xs-perl
  libreoffice-style-tango libroken18-heimdal:i386 librsvg2-2:i386
  librsvg2-common:i386 librtmp1:i386 libruby2.5 libsamplerate0:i386 libsane1
  libsdl2-2.0-0:i386 libsereal-decoder-perl libsereal-encoder-perl
  libsereal-perl libshine3:i386 libshout3:i386 libslang2:i386
  libsnappy1v5:i386 libsndfile1:i386 libsndio6.1:i386 libsndio7.0:i386
  libsnmp35:i386 libsort-naturally-perl libsoup2.4-1:i386 libsoxr0:i386
  libspeex1:i386 libspeexdsp1:i386 libspiro0 libspnav0 libsqlite3-0:i386
  libsquish0 libssh-4:i386 libssl1.1:i386 libstb0:i386 libstdc++-7-dev
  libstreamanalyzer0v5 libstreams0v5 libstrictures-perl libstruct-dumb-perl
  libsub-exporter-progressive-perl libsub-identify-perl libsub-quote-perl
  libswresample3:i386 libtag1v5:i386 libtag1v5-vanilla:i386 libtagc0
  libtasn1-6:i386 libtesseract4 libtest-fatal-perl libtest-refcount-perl
  libtext-glob-perl libtext-levenshtein-perl libthai0:i386 libtheora0:i386
  libtiff5:i386 libtinfo5:i386 libtwolame0:i386 libtype-tiny-perl
  libtype-tiny-xs-perl libunicode-utf8-perl libunique-1.0-0 libupnp6
  libusb-1.0-0:i386 libusbmuxd4 libv4l-0:i386 libv4lconvert0:i386
  libva-drm2:i386 libva-x11-2:i386 libva2:i386 libvariable-magic-perl
  libvcdinfo0 libvdpau1:i386 libvisual-0.4-0:i386 libvkd3d1:i386
  libvorbis0a:i386 libvorbisenc2:i386 libvpx6:i386 libvtk6.3 libwavpack1:i386
  libwayland-cursor0:i386 libwayland-egl1:i386 libwayland-egl1-mesa
  libwayland-server0:i386 libwebp6:i386 libwebpmux3:i386
  libwind0-heimdal:i386 libwrap0:i386 libwww-mechanize-perl libwxgtk3.0-0v5
  libx11-protocol-other-perl libx264-155:i386 libx265-179:i386 libx86emu1
  libxcb-render0:i386 libxcb-shm0:i386 libxcb-xfixes0:i386
  libxcomposite1:i386 libxcursor1:i386 libxi6:i386 libxinerama1:i386
  libxkbcommon0:i386 libxml-simple-perl libxml-writer-perl libxml2:i386
  libxpm4:i386 libxrandr2:i386 libxrender1:i386 libxslt1.1:i386 libxss1:i386
  libxv1:i386 libxvidcore4:i386 libyaml-cpp0.5v5 libyaml-cpp0.6
  libyaml-libyaml-perl libzeitgeist-1.0-1 libzip4 libzmf-0.0-0 libzvbi0:i386
  lintian marble-data mda-lv2 mesa-va-drivers:i386 mesa-vdpau-drivers:i386
  nepomuk-core-data nplan ntrack-module-libnl-0 ocl-icd-libopencl1:i386
  openmpi-bin openmpi-common osinfo-db patchutils
  phonon-backend-gstreamer-common php7.2-bcmath php7.2-cli php7.2-common
  php7.2-curl php7.2-json php7.2-opcache php7.2-readline php7.2-xml
  printer-driver-gutenprint python-asn1crypto
  python-backports-shutil-get-terminal-size python-configobj python-decorator
  python-dnspython python-dulwich python-fastimport python-gtkspell
  python-ipython python-ipython-genutils python-pathlib2 python-pexpect
  python-pickleshare python-prompt-toolkit python-psutil python-ptyprocess
  python-pygments python-qrencode python-scandir python-simplegeneric
  python-simplejson python-svn python-talloc python-traitlets python-wcwidth
  python-zeitgeist python3-asn1crypto python3-feedparser python3-libvoikko
  python3-oauth python3-zope.interface python3.6 python3.6-dev
  python3.6-minimal qml-module-org-kde-extensionplugin
  qml-module-qtquick-controls-styles-breeze qpdf qtcore4-l10n
  ruby-did-you-mean ruby2.5 scribus-data sox t1utils transcode transcode-doc
  twolame unity-lens-applications unity-lens-files unity-lens-music
  unity-lens-video unity-scope-calculator unity-scope-chromiumbookmarks
  unity-scope-colourlovers unity-scope-devhelp unity-scope-firefoxbookmarks
  unity-scope-manpages unity-scope-openclipart unity-scope-texdoc
  unity-scope-tomboy unity-scope-video-remote unity-scope-virtualbox
  unity-scope-yelp unity-scope-zotero unity-scopes-runner va-driver-all:i386
  vcdimager vdpau-driver-all:i386
Suorita 'sudo apt autoremove' poistaaksesi ne.
Nämä paketit on jätetty odottamaan:
  cjs
Nämä paketit päivitetään:
  skypeforlinux
1 päivitetty, 0 uutta asennusta, 0 poistettavaa ja 1 päivittämätöntä.
Noudettavaa arkistoa 84,3 Mt.
Toiminnon jälkeen käytetään 963 k t lisää levytilaa.
Haluatko jatkaa? [K/e]
Nouda:1 https://repo.skype.com/deb stable/main amd64 skypeforlinux amd64 8.65.0.76 [84,3 MB]
Noudettiin 84,3 Mt ajassa 6s (14,8 Mt/s) 
(Luetaan tietokantaa... 429053 tiedostoa ja hakemistoa asennettu tällä hetkellä
.)
Valmistaudutaan purkamaan .../skypeforlinux_8.65.0.76_amd64.deb ...
Puretaan skypeforlinux (8.65.0.76) version (8.64.0.81) päälle...
Tehdään asetuksia: skypeforlinux (8.65.0.76) ...
Käsitellään paketin desktop-file-utils (0.24-1ubuntu3) liipaisimia...
Käsitellään paketin mime-support (3.64ubuntu1) liipaisimia...
Käsitellään paketin hicolor-icon-theme (0.17-2) liipaisimia...
Käsitellään paketin gnome-menus (3.36.0-1ubuntu1) liipaisimia...
Käsitellään paketin bamfdaemon (0.5.3+18.04.20180207.2-0ubuntu2) liipaisimia...
Rebuilding /usr/share/applications/bamf-2.index...
eero@eero:~$

Huh, pitkälista :O
Uskaltaako tuota autoremovea käyttää?

Autoremoven tarjoilemat paketit kuuluu poistaa välittömästi ja lukematta. :P Ei vaiskaan... Versiopäivityksen jäljiltä on paljon poistettavaa, kuuluu asiaan. Mutta kannattaa vähän silmäillä listaa, ennen kuin hyväksyy. Muistaakseni autoclean vasta oikeasti poistaa paketit systeemistä, joten poistetut voinee palauttaakin, jos tarvis.

Eikös noi *:i386 olleet intellin prosessorille ja täs on adm:n prossa, hm
Joo laitetaas remove pyöriin...
| Pros. AMD Phemon(tm) 9950 :) (4cores) | Emo: ASUS M3A78 | Mem 8GT
| x86_64, gnome, ubuntu 18.04  | GeForce GTX 750 Ti/PC

nm

  • Käyttäjä
  • Viestejä: 13695
    • Profiili
Vs: update 18.4 >> 20.4 ARGH :( Chromium snap, python?
« Vastaus #6 : 30.09.20 - klo:21.38 »
Eikös noi *:i386 olleet intellin prosessorille ja täs on adm:n prossa

i386-paketit ovat 32-bittisiä, sekä Intelin että AMD:n prosessoreille. Saattavat olla riippuvuuksia esimerkiksi jostain aiemmasta Wine-asennuksesta tai muista 32-bittisistä sovelluksista, joita järjestelmään on asennettu.

juyli

  • Käyttäjä / moderaattori
  • Viestejä: 320
    • Profiili
Vs: update 18.4 >> 20.4 ARGH :( Chromium snap, python?
« Vastaus #7 : 30.09.20 - klo:21.41 »
Eikös noi *:i386 olleet intellin prosessorille ja täs on adm:n prossa, hm
Joo laitetaas remove pyöriin...
i386-paketit ovat ohjelmia 32-bittisille prosessoreille PC-arkkitehtuurissa. Toimivat niin AMD:n kuin Intelinkin prosessoreilla.
Ehkä käytössäsi on 32-bittisiä sovellutuksia (Esim. vanhat Wine:llä pyöritettävät pelit käyttävät ko. arkkitehtuuria).

Jos mielipidettäni kysytään ... vastaan silti: snap on paholaisen keksintö. Paketinhallinta ja sen tarjoamat sovellutukset ovat suositeltavia.

[Lisäys] Nm ehti taas kerran muutama minuutti aikaisemmin ... Ehkä kaiku vakuuttaa paremmin. [/Lisäys]
« Viimeksi muokattu: 30.09.20 - klo:21.44 kirjoittanut juyli »

LeHiX

  • Käyttäjä
  • Viestejä: 470
    • Profiili
Vs: update 18.4 >> 20.4 ARGH :( Chromium snap, python?
« Vastaus #8 : 30.09.20 - klo:22.54 »
Huoh, sain palautettua chromiumin kirjanmerkit ja näköjään myös salasanat :O tää siis vahingossa löytynyt ratkaisu tuohon ongelmaan.
Piti vaan ottaa syngronointi käyttöön ja kirjautua googlen tilille, siltä osin asia on ratkennut  ;D
...
mutta esim nautilus/tiedostot, kun sen saa viimein auki ja yrittää liittää cairo-dockiin niin siihen tulee valinnaksi joku 'org' ja siitä Discover kuvake, no kokeilin ja se on jokin ohjelmien asennus/poisto mutta miten se tulee cairo-dockiin nautilusta kiinnitettäessä? ei jummarra :O Tiedostot on jaoteltu samalla tavalla kuin cairon päävalikossa, hm...
Poistin ja asensin sitten tuosta päätteen ja sain sen liitettyä cairon dockkiin, tämäkin siis ratkaistu :)
...
mistä tuleekin mieleen että jostain syystä Evolution avautuu cairon kuvakkeesta kalenteriin sähköpostin sijasta, vaikka sen poistaa ja liittää sähköpostina sen nimi muuttuu Evolution - kalenteri, häiritsevää ja tämä siis jo ennen päivitystä
...
Sitten nuo yläpalkkiin tulevat gnome extensionit, aika monessa on error, esim "Freon" ja "OpenWeather" ja muutama myös, olisko odotella jos ne korjattaisiin?
| Pros. AMD Phemon(tm) 9950 :) (4cores) | Emo: ASUS M3A78 | Mem 8GT
| x86_64, gnome, ubuntu 18.04  | GeForce GTX 750 Ti/PC

mpiso

  • Käyttäjä
  • Viestejä: 459
    • Profiili
Vs: update 18.4 >> 20.4 ARGH :( Chromium snap, python?
« Vastaus #9 : 30.09.20 - klo:23.41 »
Discover on Kubuntun mukana tuleva ohjelma. Kuvakkeet ovat tuossa vain hiukan erinäköisiä.

juyli

  • Käyttäjä / moderaattori
  • Viestejä: 320
    • Profiili
Vs: update 18.4 >> 20.4 ARGH :( Chromium snap, python?
« Vastaus #10 : 01.10.20 - klo:00.15 »
Pitäisikö muistuttaa, että Ubuntu poistaa versiopäivityksissä käytöstä ohjelmavarastot/ohjelmalähteet, joita ei virallisesti tueta.
Tämä tarkoittanee sitä, ettei jakelupäivityksissä päivitetä ohjelmia/kirjastoja, jotka eivät ole tuettuja.
Koska ohjelmia ei toki poisteta, voi olla, etteivät ne toimi toivotusti uudessa jakeluversiossa.
Yleensä ko. ohjelmat saa toimimaan, kunhan näihin epävirallisiin ohjelmalähteisiin on lisätty tarvittavat paketit tukemaan ko. versiota.

Haluaisin muistuttaa, että puhuttaessa vapaista, avoimista ohjelmista, ovat muutokset parin vuoden välein melkoinen hyppäys.
Tukemattomat, epävirallisista lähteistä noudetut ohjelmat, eivät välttämättä uusimmassa jakeluversiossa toimi päivittämättä ne ajantasalle.

LeHiX

  • Käyttäjä
  • Viestejä: 470
    • Profiili
Vs: update 18.4 >> 20.4 ARGH :( Chromium snap, python?
« Vastaus #11 : 01.10.20 - klo:02.16 »
Discover tuli varmaan digikam.n mukana muiden kde lisukkeiden kanssa.

Mutta tuo chromium ärsyttää taas, tässä versiossa(?) se on ottanut omat hiiren kursorit käyttöön  >:( ja minulla kun on mieleiset kursorit jo systeemissä, myös chromiumin värit ja teemat :( ei hyvää päivää, se ei kunnioita järjestelmän säätöjä vai onko ne piilotettu syvemmälle?
| Pros. AMD Phemon(tm) 9950 :) (4cores) | Emo: ASUS M3A78 | Mem 8GT
| x86_64, gnome, ubuntu 18.04  | GeForce GTX 750 Ti/PC

Eesaurus

  • Käyttäjä
  • Viestejä: 3046
    • Profiili
Vs: update 18.4 >> 20.4 ARGH :( Chromium snap, python?
« Vastaus #12 : 01.10.20 - klo:09.23 »
Mutta tuo chromium ärsyttää taas, tässä versiossa(?) se on ottanut omat hiiren kursorit käyttöön  >:( ja minulla kun on mieleiset kursorit jo systeemissä, myös chromiumin värit ja teemat :( ei hyvää päivää, se ei kunnioita järjestelmän säätöjä vai onko ne piilotettu syvemmälle?

Muistelen Chromiumin Snap -versiossa tuota olleen, ei kunnioita käyttöjärjestelmän teemajuttuja välttämättä ihan kaikilta osin. Universaalien pakettien pieni kauneusvirhe, pätee enemmän tai vähemmän myös Flatpakeihin ja AppImageihin.

Ehkä yllättävää, että Chromiumissa olisi tuota vieläkin. Päivitä Snapit varmuuden vuoksi:
Koodia: [Valitse]
sudo snap refresh Vai olikos niissä automaattinen päivitys... No, jos ei auta, niin lienee vaan odotettava, että paketin ylläpitäjä korjaa ongelman seuraavassa päivityksessä. Tai siirtyä toiseen selaimeen.

MUOK: Tai asentaa Chromium normaalina deb:inä PPA:sta, niin kuin nm ehdotti.
« Viimeksi muokattu: 01.10.20 - klo:11.46 kirjoittanut Eesaurus »

LeHiX

  • Käyttäjä
  • Viestejä: 470
    • Profiili
Vs: update 18.4 >> 20.4 ARGH :( Chromium snap, python?
« Vastaus #13 : 01.10.20 - klo:11.47 »
Noi nyt tuli extensionit yläpalkkiin, kerkesin jo huolestua kun pulseaudion äänenvoikakkuus ikkunaan ei tullut mitään ja selaimessa ei äänet toimineet joten käynnistin koneen uudelleen.
Ennen käynnistystä ja sen jälkeen ei gimp suostunut käynnistymään vaan valittaa että GEGL on liian vanha mutta kun uudempi on asennettu onko tuo vanha jossain gimpin kansioissa kun sitä ei synapticissa näy?

Minulla taitaa olla edelleen GTKssa ongelmia, joidenkin teemojen värit olisi muuten ok mutta sitten tekstit on taustan yleensä valkoisen värisiä eivätkä erotu, voi suositella kokeiltavaksi jotain teemaa
| Pros. AMD Phemon(tm) 9950 :) (4cores) | Emo: ASUS M3A78 | Mem 8GT
| x86_64, gnome, ubuntu 18.04  | GeForce GTX 750 Ti/PC

LeHiX

  • Käyttäjä
  • Viestejä: 470
    • Profiili
Vs: update 18.4 >> 20.4 ARGH :( Chromium snap, python?
« Vastaus #14 : 17.10.20 - klo:22.16 »
esim chromium ei, sen verran ehdin nähdä että se asentui snap:stä ja tuli heti mieleen että miten kirjan merkin? No ne oli tirtysti kadonneet avatessani chromiumin, olisikop ne vielä tallessa jos (ja miten) poistan snap chromiumin ja asennan sen uudestaan ilman snap:ä (mahdollista?)

Canonicalin puolesta Chromium on saatavilla Ubuntu 20.04:ään vain Snap-pakettina. Omalla vastuulla voit kuitenkin käyttää esimerkiksi tätä PPA:ta: https://launchpad.net/~saiarcot895/+archive/ubuntu/chromium-beta

Chromium asennettu ylläolevasta PPAsta ja muuten tuntuu toimivan, jopa kirjan merkkini sain takaisin paitsi ne jotka merkkasin snap-chromiumissa ja rakas kursorinikin on taas käytössä :D 
Vain jotain avaimia kaipaa, jotain toimintoja (en tiedä mitä) on poisa käytöstä, mitä avaimia?
Antoi linkin josta en tule hullua hurskaammaksi :O
https://www.chromium.org/developers/how-tos/api-keys

Toinen juttu on tuon chromiumin snap paketir näkyi aikaisemmin myös synapticissa nyt näkyy vain nämä uuden PPAn chromiumi

| Pros. AMD Phemon(tm) 9950 :) (4cores) | Emo: ASUS M3A78 | Mem 8GT
| x86_64, gnome, ubuntu 18.04  | GeForce GTX 750 Ti/PC