Kirjoittaja Aihe: yledl and Ubuntu 16.04  (Luettu 401 kertaa)

Ganymedes

  • Käyttäjä
  • Viestejä: 3515
    • Profiili
yledl and Ubuntu 16.04
« : 08.04.20 - klo:17.47 »
Yritin asentaa, pitkästä aikaa, yledl-ohjelmaa Ubuntuun ja ei tunnu onnistuvan. Ehkä ensimmäinen kysymys on se, että pitäisikö käyttää 18.04 konetta ja unohtaa tämä 16.04?

Komento, jolla yritin:
pip3 install --user --upgrade yle-dl

Herjat lopusta:
    Complete output from command python setup.py egg_info:
    Traceback (most recent call last):
      File "<string>", line 1, in <module>
    ImportError: No module named 'setuptools'
   
    ----------------------------------------
Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-build-6aplx55j/ConfigArgParse/
You are using pip version 8.1.1, however version 20.0.2 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.

---

Komento - sudo pip3 install yle-dl
- valittaa .cache/pip/http hakemiston oikeuksista (jotka mielestäni annoin koko .cache polulle) ja pip-versiosta eikä esitetty upgrade komentokaan tee mitään järkevää

Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-build-3at2ghyj/future/
You are using pip version 8.1.1, however version 20.0.2 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.

Lopputulema on se, että yledl - command not found

Yritänkö turhaan näillä versioilla?


Eesaurus

  • Käyttäjä
  • Viestejä: 2962
    • Profiili
Vs: yledl and Ubuntu 16.04
« Vastaus #1 : 08.04.20 - klo:18.28 »
En tiedä 16:04:n tilannetta yle-dl:n suhteen, mutta kokeile kumminkin virallista asennusohjetta:

En tiedä, onko tarpeen, mutta ehkä varmuuden vuoksi. Poista ensin asennettuna oleva:
Koodia: [Valitse]
sudo pip uninstall yle-dl
Koodia: [Valitse]
sudo apt-get install rtmpdump wget ffmpeg python3-dev python3-setuptools \
    python3-pip python3-crypto python3-requests python3-lxml \
    php-cli php-curl php-xml php-bcmath

ja

Koodia: [Valitse]
pip3 install yle-dl
Ubuntun suhteen tekisin itse niin, että sinnittelisin 16.04:llä jonnekin kesään asti, heinäkuuhun tms. ja asentaisin sitten 20.04:n.
« Viimeksi muokattu: 08.04.20 - klo:18.31 kirjoittanut Eesaurus »

Ganymedes

  • Käyttäjä
  • Viestejä: 3515
    • Profiili
Vs: yledl and Ubuntu 16.04
« Vastaus #2 : 08.04.20 - klo:18.52 »
Kiitokset vinkeistä. Kokeillaan.

Ganymedes

  • Käyttäjä
  • Viestejä: 3515
    • Profiili
Vs: yledl and Ubuntu 16.04
« Vastaus #3 : 08.04.20 - klo:20.20 »
Juu ei, Ubuntu 16.04 ei ymmärrä noista pythoneista samalla tavalla. Jotainhan noissa herjoissa kerrotaan muutoksista Pythonissa.

Asensin Ubuntu Studio 18.04 koneelle ja siihen asentui komentojesi kanssa. Tuli ihan ymmärrettäviä herjoja, kuten yle-dl "not in path" jms.

Näyttäisi myös toimivan ja lataavan Areenasta - joten Kiitokset Avusta Eesaurus!
« Viimeksi muokattu: 08.04.20 - klo:20.22 kirjoittanut Ganymedes »

Eesaurus

  • Käyttäjä
  • Viestejä: 2962
    • Profiili
Vs: yledl and Ubuntu 16.04
« Vastaus #4 : 08.04.20 - klo:20.59 »
Ohje 18.04:ään on tosin vähäsen erilainen, mutta pääasia, että toimii.

Riippuvuudet asentuvat näin:
Koodia: [Valitse]
sudo apt-get install rtmpdump wget ffmpeg python3-dev python3-setuptools \
    python3-pip python3-pycryptodome python3-requests python3-lxml \
    php-cli php-curl php-xml php-bcmath

Taitaa tuo python3-pycryptodome -paketti olla eri. Itse yle-dl:n asennus menee samalla tavalla.