Kirjoittaja Aihe: Päivitys ongelma 18.04 lts  (Luettu 1485 kertaa)

Wiking

  • Käyttäjä
  • Viestejä: 9
    • Profiili
Päivitys ongelma 18.04 lts
« : 16.03.19 - klo:15.48 »
Hei, poistin juuri cinnamonin, koska se kaatui ja en saanut sitä enää toimimaan (en itseasiassa saanut cinnamonin puolella enää edes terminaalia auki). Nyt kun tarkistan päivitykset, niin tuolla näyttäisi olvean kaksi pakettia päivitettävissä, mutta en tiedä miten nuo paketit voi päivittää.

 
Koodia: [Valitse]
apt list --upgradable
Listataan... Valmis
apturl/bionic,bionic 0.5.2+linuxmint7-201811221942~ubuntu18.04.1 amd64 [päivitettävissä versiosta: 0.5.2ubuntu14.2]
apturl-common/bionic,bionic 0.5.2+linuxmint7-201811221942~ubuntu18.04.1 amd64 [päivitettävissä versiosta: 0.5.2ubuntu14.2]

...eli jos jollain on tietoa miten nuo päivitetään, niin kertokaa toki.

kamara

  • Käyttäjä
  • Viestejä: 2035
    • Profiili
Vs: Päivitys ongelma 18.04 lts
« Vastaus #1 : 16.03.19 - klo:16.03 »
Eikös ne päivitetä ihan normaalisti ?

Koodia: [Valitse]
sudo apt upgrade

Tai pitemmän kaavan mukaan...
Koodia: [Valitse]
sudo apt update
sudo apt upgrade
sudo apt dist-upgrade

juylii

  • Käyttäjä
  • Viestejä: 84
    • Profiili
Vs: Päivitys ongelma 18.04 lts
« Vastaus #2 : 16.03.19 - klo:20.50 »
Koodia: [Valitse]
apt list --upgradable
apturl/bionic,bionic 0.5.2+linuxmint7-201811221942~ubuntu18.04.1 amd64 [päivitettävissä versiosta: 0.5.2ubuntu14.2]
apturl-common/bionic,bionic 0.5.2+linuxmint7-201811221942~ubuntu18.04.1 amd64 [päivitettävissä versiosta: 0.5.2ubuntu14.2]
Ubuntu ei tarjoa virallisilta ohjelmalähteiltään linuxmint -paketteja. Jos jakelusi on Ubuntu, kannattaa tarkistaa ohjelmalähteet.
Esim. /etc/apt/sources.list
Jos käytät Mint-jakelua, kannattanee jättää virallisen Ubuntun jakelulähteet käyttämättä, ja käyttää yksinomaan virallisia Mint-lähteitä.
Mint ei ole Ubuntu, vaikka sen Ubuntu-versio perustuisikin Ubuntu-jakeluun.

Wiking

  • Käyttäjä
  • Viestejä: 9
    • Profiili
Vs: Päivitys ongelma 18.04 lts
« Vastaus #3 : 17.03.19 - klo:12.30 »
Eikös ne päivitetä ihan normaalisti ?

Koodia: [Valitse]
sudo apt upgrade

Tai pitemmän kaavan mukaan...
Koodia: [Valitse]
sudo apt update
sudo apt upgrade
sudo apt dist-upgrade

Valitettavasti ei onnistu... enkä ymmärrä miksi.

Koodia: [Valitse]
sudo apt update
 
Löytyi:1 http://fi.archive.ubuntu.com/ubuntu bionic InRelease
Löytyi:2 http://fi.archive.ubuntu.com/ubuntu bionic-updates InRelease         
Löytyi:3 http://fi.archive.ubuntu.com/ubuntu bionic-backports InRelease       
Löytyi:4 http://ppa.launchpad.net/clipgrab-team/ppa/ubuntu bionic InRelease   
Nouda:5 http://security.ubuntu.com/ubuntu bionic-security InRelease [88,7 kB] 
Löytyi:6 http://ppa.launchpad.net/trebelnik-stefina/cinnamon/ubuntu bionic InRelease
Siv:7 http://repo.vivaldi.com/stable/deb stable InRelease                     
Löytyi:8 http://repo.vivaldi.com/stable/deb stable Release
Noudettiin 88,7 kt ajassa 2s (43,7 kt/s)
Luetaan pakettiluetteloita... Valmis
Muodostetaan riippuvuussuhteiden puu       
Luetaan tilatiedot... Valmis       
2 pakettia voidaan päivittää. Suorita 'apt list --upgradable' nähdäksesi ne.

 sudo apt upgrade

Luetaan pakettiluetteloita... Valmis
Muodostetaan riippuvuussuhteiden puu       
Luetaan tilatiedot... Valmis       
Käsitellään päivitystä... Valmis
Nämä paketit on jätetty odottamaan:
  apturl apturl-common
0 päivitetty, 0 uutta asennusta, 0 poistettavaa ja 2 päivittämätöntä.

 sudo apt dist-upgrade

Luetaan pakettiluetteloita... Valmis
Muodostetaan riippuvuussuhteiden puu       
Luetaan tilatiedot... Valmis       
Käsitellään päivitystä... Valmis
Nämä paketit on jätetty odottamaan:
  apturl apturl-common
0 päivitetty, 0 uutta asennusta, 0 poistettavaa ja 2 päivittämätöntä.

Wiking

  • Käyttäjä
  • Viestejä: 9
    • Profiili
Vs: Päivitys ongelma 18.04 lts
« Vastaus #4 : 17.03.19 - klo:12.33 »
Koodia: [Valitse]
apt list --upgradable
apturl/bionic,bionic 0.5.2+linuxmint7-201811221942~ubuntu18.04.1 amd64 [päivitettävissä versiosta: 0.5.2ubuntu14.2]
apturl-common/bionic,bionic 0.5.2+linuxmint7-201811221942~ubuntu18.04.1 amd64 [päivitettävissä versiosta: 0.5.2ubuntu14.2]
Ubuntu ei tarjoa virallisilta ohjelmalähteiltään linuxmint -paketteja. Jos jakelusi on Ubuntu, kannattaa tarkistaa ohjelmalähteet.
Esim. /etc/apt/sources.list
Jos käytät Mint-jakelua, kannattanee jättää virallisen Ubuntun jakelulähteet käyttämättä, ja käyttää yksinomaan virallisia Mint-lähteitä.
Mint ei ole Ubuntu, vaikka sen Ubuntu-versio perustuisikin Ubuntu-jakeluun.

Täältä olen aikoinaan asentanut ubuntun https://ubuntu-fi.org/lataa-ubuntu/ ja sen jälkeen olen cinnamon 4.0 rinnalle asentanut, jonka jouduin poistamaan kun se kaatui. Sen jälkeen ollut tuo ongelma... itse olen sen verran tietämätön, että en ymmärrä miksi se tuota minttiä tällä hetkellä herjaa.

jekku

  • Käyttäjä
  • Viestejä: 1916
    • Profiili
Vs: Päivitys ongelma 18.04 lts
« Vastaus #5 : 17.03.19 - klo:15.01 »
Näytäpä mitä on tiedostossa /etc/apt/sources.list

Koodia: [Valitse]

more /etc/apt/sources.list


juylii

  • Käyttäjä
  • Viestejä: 84
    • Profiili
Vs: Päivitys ongelma 18.04 lts
« Vastaus #6 : 17.03.19 - klo:23.41 »
... sen jälkeen olen cinnamon 4.0 rinnalle asentanut, jonka jouduin poistamaan kun se kaatui. Sen jälkeen ollut tuo ongelma...
Eiköhän se tuolta tuo ongelmasi löydy. Ubuntuun on virallisistakin lähteistä vaivatonta asentaa Cinnamon, jonka versionumero on vielä 3.8.xx:
https://packages.ubuntu.com/search?keywords=cinnamon&searchon=names&suite=all&section=all
(Toki tuo versio ko. sivustolta päivittyy päivien, kuukausien ja vuosien varrella!)
Olet mahdollisesti asennellut pitkin nettiä sopivia PPA-repoja, joiden toimivuus ei ole ollut haluttu.
Ubuntu ei tarjoa mitään *mintlinux* -versioita!
Koita poistaa ohjelma, poista sen jälkeen ylimääräiset repot, ja asenna haluamasi Cinnamon Ubuntun virallisista lähteistä.
Jos haluat välttämättä käyttää jakelun tukemattomia ohjelmistoja, olet omillasi - eikä niiden toimimattomuudesta kannata kysellä.

Tomin

  • Palvelimen ylläpitäjä
  • Käyttäjä / moderaattori+
  • Viestejä: 10604
    • Profiili
    • Tomin kotisivut
Vs: Päivitys ongelma 18.04 lts
« Vastaus #7 : 18.03.19 - klo:08.27 »
Oletko ehkä laittanut nuo paketit pitoon (hold)?

Koodia: [Valitse]
apt-mark showhold
Automaattinen allekirjoitus:
Lisäisitkö [RATKAISTU] ketjun ensimmäisen viestin aiheeseen ongelman ratkettua, kiitos.

Wiking

  • Käyttäjä
  • Viestejä: 9
    • Profiili
Vs: Päivitys ongelma 18.04 lts
« Vastaus #8 : 20.03.19 - klo:12.23 »
Näytäpä mitä on tiedostossa /etc/apt/sources.list

Koodia: [Valitse]

more /etc/apt/sources.list


Tällaista näyttää...

Koodia: [Valitse]
more /etc/apt/sources.list
# deb cdrom:[Ubuntu 18.04.1 LTS _Bionic Beaver_ - Release amd64 (20180725)]/ bio
nic main restricted

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://fi.archive.ubuntu.com/ubuntu/ bionic main restricted
# deb-src http://fi.archive.ubuntu.com/ubuntu/ bionic main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://fi.archive.ubuntu.com/ubuntu/ bionic-updates main restricted
# deb-src http://fi.archive.ubuntu.com/ubuntu/ bionic-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://fi.archive.ubuntu.com/ubuntu/ bionic universe
# deb-src http://fi.archive.ubuntu.com/ubuntu/ bionic universe
deb http://fi.archive.ubuntu.com/ubuntu/ bionic-updates universe
# deb-src http://fi.archive.ubuntu.com/ubuntu/ bionic-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://fi.archive.ubuntu.com/ubuntu/ bionic multiverse
# deb-src http://fi.archive.ubuntu.com/ubuntu/ bionic multiverse
deb http://fi.archive.ubuntu.com/ubuntu/ bionic-updates multiverse
# deb-src http://fi.archive.ubuntu.com/ubuntu/ bionic-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://fi.archive.ubuntu.com/ubuntu/ bionic-backports main restricted univer
se multiverse
# deb-src http://fi.archive.ubuntu.com/ubuntu/ bionic-backports main restricted
universe multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
# deb http://archive.canonical.com/ubuntu bionic partner
# deb-src http://archive.canonical.com/ubuntu bionic partner

deb http://security.ubuntu.com/ubuntu bionic-security main restricted
# deb-src http://security.ubuntu.com/ubuntu bionic-security main restricted
deb http://security.ubuntu.com/ubuntu bionic-security universe
# deb-src http://security.ubuntu.com/ubuntu bionic-security universe
deb http://security.ubuntu.com/ubuntu bionic-security multiverse
# deb-src http://security.ubuntu.com/ubuntu bionic-security multiverse

Wiking

  • Käyttäjä
  • Viestejä: 9
    • Profiili
Vs: Päivitys ongelma 18.04 lts
« Vastaus #9 : 20.03.19 - klo:12.26 »
Oletko ehkä laittanut nuo paketit pitoon (hold)?

Koodia: [Valitse]
apt-mark showhold

Jostain syystä ei tapahdu mitään kun yritän tuolla... ?

Wiking

  • Käyttäjä
  • Viestejä: 9
    • Profiili
Vs: Päivitys ongelma 18.04 lts
« Vastaus #10 : 20.03.19 - klo:12.31 »
... sen jälkeen olen cinnamon 4.0 rinnalle asentanut, jonka jouduin poistamaan kun se kaatui. Sen jälkeen ollut tuo ongelma...
Eiköhän se tuolta tuo ongelmasi löydy. Ubuntuun on virallisistakin lähteistä vaivatonta asentaa Cinnamon, jonka versionumero on vielä 3.8.xx:
https://packages.ubuntu.com/search?keywords=cinnamon&searchon=names&suite=all&section=all
(Toki tuo versio ko. sivustolta päivittyy päivien, kuukausien ja vuosien varrella!)
Olet mahdollisesti asennellut pitkin nettiä sopivia PPA-repoja, joiden toimivuus ei ole ollut haluttu.
Ubuntu ei tarjoa mitään *mintlinux* -versioita!
Koita poistaa ohjelma, poista sen jälkeen ylimääräiset repot, ja asenna haluamasi Cinnamon Ubuntun virallisista lähteistä.
Jos haluat välttämättä käyttää jakelun tukemattomia ohjelmistoja, olet omillasi - eikä niiden toimimattomuudesta kannata kysellä.

Joo, PPA:lla tuli asennettua. Täältä katsoin ohjeet asennukseen https://www.youtube.com/watch?v=OqsNtlLh1lA

P.S. tuo sinun linkkisi ei toiminut kun yritin tsekata..

EDIT: itseasiaasa linkki toimi!
« Viimeksi muokattu: 20.03.19 - klo:12.33 kirjoittanut Wiking »

nm

  • Käyttäjä
  • Viestejä: 12885
    • Profiili
Vs: Päivitys ongelma 18.04 lts
« Vastaus #11 : 20.03.19 - klo:12.42 »
Koodia: [Valitse]
Nämä paketit on jätetty odottamaan:
  apturl apturl-common
0 päivitetty, 0 uutta asennusta, 0 poistettavaa ja 2 päivittämätöntä.

Odottamaan jätetty apturl:n versio on siis peräisin käyttämästäsi PPA:sta https://launchpad.net/~trebelnik-stefina/+archive/ubuntu/cinnamon

Syynä lienee jokin rikkinäinen riippuvuusketju tai paketin oma asetus. En suosittele pakottamaan asennusta, ja tuo PPA saattaa muutenkin aiheuttaa epävakautta tai odottamattomia ongelmia, koska se korvaa keskeisiä GTK-kirjastoja omilla versioillaan. Lisäksi kyseessä on tuore kehitysversio Cinnamonista. Tulenarkaa tavaraa. :)


Oletko ehkä laittanut nuo paketit pitoon (hold)?

Koodia: [Valitse]
apt-mark showhold

Jostain syystä ei tapahdu mitään kun yritän tuolla... ?

Tarkoittaa, ettei paketteja ole asetettu holdiin Apt:n kautta.