Kirjoittaja Aihe: Ati Radeon ei toimi oikein 18.04. Voinko asentaa 16.04 ajurit ?  (Luettu 1334 kertaa)

Frank Zappa

  • Käyttäjä
  • Viestejä: 270
    • Profiili
Ruudun päivitys on ihan hukassa, ilmeisesti yrittää heittää 100 hz kun HP 22" ei siihen pysty. 18.04 ei osaa ajaa 1600x1050 vaikka 16.04 osaa.

T: Frank Zappa  8)

Frank Zappa

  • Käyttäjä
  • Viestejä: 270
    • Profiili
Hä oliko liian vaikee kysymys ?   Noh asensin rinnalle Lubuntun 18.04 niin sen käynnistys grubbi paransi vähän tilannetta. Eli Lubuntu toimii hyvin.

Mutta Upuntu 18.04.1 ei. Nyt se pääsee käynnistyksestä ohi, mutta juuttuu sisäänkirjaumis sivulle, joka on ihan vinossa ja lukemattomissa.
Siinä täytyy käyttää cnrl - alt - F2 ja terminaalissa kirjautua sisään ja sitten käyttää startxää.

En tiedä kumpi on vaikuttanu parannukseen Lubuntun sytyttämä näyttö vaikko se että on niin monta kertaa käynnistäny ja rebuutannu, että palikoita on menny
osittain paikoilleen, koska nyt löytyy 1680x1050 resoluutio.

Mutta onko xrandr niin huono ettei se pysty muuttaan virkistystaajuutta esim. 60 -> 72 tai 80:een ??? Ainakaan mitään ei tapahu....

Pistin myös grubin käynnistys splashiin  jotain "--mode radeon =1", mutta sekään ei tuntunu vaikuttavan mihinkään.

Eli nyt pitäis saaha sisäänkirjautumis sivun resoluutio ja virkistystaajuus oikeaksi, mutta miten ihmeessä ?

Radeon V570   x1950

T:Frank Zappa  8)




lauritx

  • Käyttäjä
  • Viestejä: 254
    • Profiili
https://support.hpe.com/hpsc/doc/public/display?docId=emr_na-a00021847en_us

Eli /etc/default/grub tiedostoon noi rimpsut ja sudo update-grub

Mut tossa vehkeessä just lubuntu on ehkä paras vaihtoehto

« Viimeksi muokattu: 17.12.18 - klo:17.13 kirjoittanut lauritx »

Frank Zappa

  • Käyttäjä
  • Viestejä: 270
    • Profiili
Tein Edit "/etc/default/grub"     GRUB_CMDLINE_LINUX:"amdgpu.ip_block_mask=0xeff"

$ grub-mkconfig -o /boot/grub/grub.cfg
$ cat /proc/cmdline

Tämä ohje on ilmeisesti black screenille. Mun ongelma on vääristyneet värit sgreen.

Käynnistys grub> vbeinfo antaa 1400 x 1050 32 (tätä xrandr ei anna)
                              vbeinfo sanoo default should be 1680x1050

eli tässä vaiheessa pitäisi antaa tuo arvo mutta miten? xorg.confia ei löydy X11 kansiosta niinkuin ennen.

Lisäksi käynnistysvalikossa - advanced options - resume normal boot - kirjaudu sisään - startx
käynnistyy työpöytä, mutta köyhänä versiona (ilm. debian pöytä) resoluutio oikein.

Toisaalta advance option - recovery mode - pääsee graafiseen sisäänkirjautumiseen mutta 1280x1024,
mutta tällöin ei löyvy isompia vaihtoehto resoja.

Eli mun mielestä pitäisi siinä vaiheessa kun graafinen sisään kirjautuminen aktivoituu, niin siloin pitäisi jo
olla oikea resoluutio ja virkistystaajuus. Pitäiskö löytää tuo xorg.conf - mutta miten ?

tai grub>  pistää oikeat arvot?

EDIT: tälläistä löytyi:


käynnistys - advanced options - recovery mode - resume normal boot

xrandr --verbose
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 640 x 400, current 1280 x 1024, maximum 1280 x 1024
default connected primary 1280x1024+0+0 (0x2a9) normal (normal) 0mm x 0mm
   Identifier: 0x2a8
   Timestamp:  124186
   Subpixel:   no subpixels
   Clones:   
   CRTC:       0
   CRTCs:      0
   Transform:  1.000000 0.000000 0.000000
               0.000000 1.000000 0.000000
               0.000000 0.000000 1.000000
              filter:
   _MUTTER_PRESENTATION_OUTPUT: 0
  1280x1024 (0x2a9)  0.000MHz *current
        h: width  1280 start    0 end    0 total 1280 skew    0 clock   0.00KHz
        v: height 1024 start    0 end    0 total 1024           clock   0.00Hz
  1152x864 (0x2aa)  0.000MHz
        h: width  1152 start    0 end    0 total 1152 skew    0 clock   0.00KHz
        v: height  864 start    0 end    0 total  864           clock   0.00Hz
  1024x768 (0x2ab)  0.000MHz
        h: width  1024 start    0 end    0 total 1024 skew    0 clock   0.00KHz
        v: height  768 start    0 end    0 total  768           clock   0.00Hz
  800x600 (0x2ac)  0.000MHz
        h: width   800 start    0 end    0 total  800 skew    0 clock   0.00KHz
        v: height  600 start    0 end    0 total  600           clock   0.00Hz
  640x480 (0x2ad)  0.000MHz
        h: width   640 start    0 end    0 total  640 skew    0 clock   0.00KHz
        v: height  480 start    0 end    0 total  480           clock   0.00Hz
  720x400 (0x2ae)  0.000MHz
        h: width   720 start    0 end    0 total  720 skew    0 clock   0.00KHz
        v: height  400 start    0 end    0 total  400           clock   0.00Hz

xrandr
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 640 x 400, current 1280 x 1024, maximum 1280 x 1024
default connected primary 1280x1024+0+0 0mm x 0mm
   1280x1024      0.00*
   1152x864       0.00 
   1024x768       0.00 
   800x600        0.00 
   640x480        0.00 
   720x400        0.00 

----

sudo hwinfo --framebuffer
02: None 00.0: 11001 VESA Framebuffer                           
  [Created at bios.459]
  Unique ID: rdCR.MXtMmE50ztA
  Hardware Class: framebuffer
  Model: "(C) 1988-2005, ATI RV570"
  Vendor: "(C) 1988-2005, ATI Technologies Inc."
  Device: "RV570"
  SubVendor: "ATI ATOMBIOS"
  SubDevice:
  Revision: "01.00"
  Memory Size: 16 MB
  Memory Range: 0x00000000-0x00ffffff (rw)
  Config Status: cfg=new, avail=yes, need=no, active=unknown


-------

T: Frank Zappa  8)




« Viimeksi muokattu: 18.12.18 - klo:19.39 kirjoittanut Frank Zappa »

raimo

  • Käyttäjä
  • Viestejä: 3213
    • Profiili
Voit tehdä /etc/X11/xorg.conf tiedoston jolloin se otetaan käyttöön.
So long and thanks for all the fish!

nm

  • Käyttäjä
  • Viestejä: 12703
    • Profiili
Hä oliko liian vaikee kysymys ?   Noh asensin rinnalle Lubuntun 18.04 niin sen käynnistys grubbi paransi vähän tilannetta. Eli Lubuntu toimii hyvin.

[...]

Radeon V570   x1950

Tuo 12 vuotta vanha Radeon alkaa olla jo sellaista ikäpolvea, että epämääräisiä ongelmia voi tulla vastaan, kun ajureita kehitetään huomattavasti uudemmalla raudalla. GNOME Shell ja Mutter-ikkunointimanageri käyttävät komposointia ja muita vaativampia piirtotekniikoita, joten ne voivat helposti tuoda esiin ajuribugeja, jotka eivät ilmene esim. LXDE:ssä.

Ongelma voisi olla hyvä raportoida Launchpadissa, mutta ratkaisuja ei välttämättä enää tule. Tuossa koneessa on paras käyttää jotain kevyempää työpöytää, kuten MATE:a, Xfce:tä tai LXDE:tä. Jos välttämättä haluat GNOME Shellin, pitänee vaihtaa näytönohjain uudempaan.


Lisäksi käynnistysvalikossa - advanced options - resume normal boot - kirjaudu sisään - startx
käynnistyy työpöytä, mutta köyhänä versiona (ilm. debian pöytä) resoluutio oikein.

Jep. GNOME Shell / Mutter ei siis toimi kunnolla, mutta startx:llä käynnistyvä kevyempi työpöytä ja ikkunamanageri toimii.


Toisaalta advance option - recovery mode - pääsee graafiseen sisäänkirjautumiseen mutta 1280x1024,
mutta tällöin ei löyvy isompia vaihtoehto resoja.

Recovery-tilassa on käytössä geneerinen vesa-ajuri ja softapohjainen piirto. Sillä kombinaatiolla GNOME-työpöytä saadaan piirrettyä, mutta ajuri ei tue kaikkia näyttötiloja ja grafiikka toimii hitaasti.

Frank Zappa

  • Käyttäjä
  • Viestejä: 270
    • Profiili
Resoluutio toimii nyt, mutta graafinen sisäänkirjautumis sivu ei. Startxn jälkeen 1680x1050 ok m utta työpöytä köyhä.

/etc/default/grub:


GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash modprobe radeon.modeset=1""
GRUB_CMDLINE_LINUX="amdgpu.ip_block_mask=0xeff"

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
GRUB_GFXMODE=1680x1050X32
GRUB_GFXPAYLOAD_LINUX=1680x1050x32

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

-----

update-grub antaa

/usr/sbin/grub-mkconfig: 35: /etc/default/grub: Syntax error: EOF in backquote substitution   ????

T:Frank Zappa  8)


nm

  • Käyttäjä
  • Viestejä: 12703
    • Profiili
Resoluutio toimii nyt, mutta graafinen sisäänkirjautumis sivu ei. Startxn jälkeen 1680x1050 ok m utta työpöytä köyhä.

Juu. Ehdotetut parametrit tuskin ratkaisevat grafiikkaongelmaa, eikä googlaamalla oikein löytynyt vastaavaa, joten etenemisvaihtoehdot ovat edellisessä viestissä mainitsemani: bugiraporttia Ubuntun kehittäjille ja unohda GNOME Shell tai päivitä näytönohjain.


GRUB_CMDLINE_LINUX_DEFAULT="quiet splash modprobe radeon.modeset=1""
GRUB_CMDLINE_LINUX="amdgpu.ip_block_mask=0xeff"

Ylempi rivi päättyy kahteen lainausmerkkiin, joka aiheuttaa syntaksivirheen. Lisäksi siellä on ylimääräinen komento modprobe, joka ei kuulu kernelin komentoriville. Alemman rivin amdgpu-parametri on turha. Amdgpu on uudempien Radeonien ajuri, eikä parametrilla ole mitään vaikutusta näytönohjaimeesi.

Eli korjaa rivit tällaisiksi:

Koodia: [Valitse]
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash radeon.modeset=1"
GRUB_CMDLINE_LINUX=""

Frank Zappa

  • Käyttäjä
  • Viestejä: 270
    • Profiili
Eipä auttanu nuo aikasemmat ohjeet vaikka tein korjaukset.

Nyt tehty    /etc/X11/xorg.conf  mutta vaikuttaa siltä että kone ei löyvä sitä ?
Täytyykö se jotenkin aktivoida ?

Toisaalta ratkasu vois olla sekin, kun pistäis LIVE-asetukset päälle, koska livenä 18.04.1 toimii ihan hyvin,
mutta pitäis tietää mitkä on sen asetukset ja mihin ne tiedostoon aktivois ????

T:Frank Zappa  8)

nm

  • Käyttäjä
  • Viestejä: 12703
    • Profiili
Toisaalta ratkasu vois olla sekin, kun pistäis LIVE-asetukset päälle, koska livenä 18.04.1 toimii ihan hyvin,
mutta pitäis tietää mitkä on sen asetukset ja mihin ne tiedostoon aktivois ????

Kyseessä oleva ajuribugi voi hyvinkin olla johonkin kernelin päivitysten mukana tuleva regressio. Jos nyt edelleen haluat selvitellä sitä (eli omalla ajankäytölle ei tässä lasketa arvoa  ;)), voisit asentaa Ubuntun uudelleen puhtaana asennuksena siten, ettet salli mitään päivityksiä asennuksen aikana, etkä tee niitä heti asennuksen jälkeen. Onnistuu varmimmin estämällä järjestelmän kytkeytyminen internetiin asennuksen ja käytön aikana.

Sitten kun olet varmistanut, että asennettu päivittämätön järjestelmä toimii oikein, voit kokeilla asentaa uusimman kernelin, mutta ei mitään muita päivityksiä. Jos ongelma ilmenee uudelleenkäynnistyksen jälkeen uudella kernelillä, vika on kernelissä, ja sitä on hieman helpompaa lähteä etsimään tarkemmin kernelin eri versioita kokeilemalla.

Frank Zappa

  • Käyttäjä
  • Viestejä: 270
    • Profiili
Annoin sittenkin hiukan väärää tietua: Lukee se X11/xorg.confia kun tein kirjoitus virheen  ;)

Mutta eikö silti olisi nopeampaa (helpompaa) ajaa LIVE asetuksilla konetta ?

Tein tälläisen Xorg.confin:

#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Device"
   Identifier   "Radeon"
        Driver       "ATI"
         Option      "Monitor-DVI-0" "External DVI"
        BusID        "PCI:1:0:0"              
EndSection

Section "Monitor"
   Identifier   "HP"
        Option          "DPMS"
         HorizSync      31-60
         VertRefresh    47.5-124
           # Modeline "1680x1050_60.00"  146.25  1680 1784 1960 2240  1050 1053 1059 1089 -hsync +vsync
           # Modeline "1680x1050_64.00"  157.50  1680 1792 1968 2256  1050 1053 1059 1092 -hsync +vsync
           # Modeline "1680x1050_72.00"  179.25  1680 1800 1976 2272  1050 1053 1059 1097 -hsync +vsync
           # Modeline "1280x1024_60.00"  109.00  1280 1368 1496 1712  1024 1027 1034 1063 -hsync +vsync
EndSection

Section "Screen"
   Identifier   "HPLP"
   Monitor      "HP"
   Device      "Radeon"
        DefaultDepth    24

         SubSection "Display"
              Depth        16
              Modes        "1024x768"
         EndSubSection

         SubSection "Display"
              Depth        24
              Modes        "1680x1050_60.00"
         EndSubSection

EndSection

Nuita # Modelinejä oon kokeillu mutta ei toimi. Eikä myöskään # käytettäessä.

Startx:llä yhä sisään

Asennus on puhdas ilman verkkua -

T:Frank Zappa  8)

nm

  • Käyttäjä
  • Viestejä: 12703
    • Profiili
Annoin sittenkin hiukan väärää tietua: Lukee se X11/xorg.confia kun tein kirjoitus virheen  ;)

Mutta eikö silti olisi nopeampaa (helpompaa) ajaa LIVE asetuksilla konetta ?

Livetilaa vastaavat asetukset ovat käytössä, jos olet tehnyt täysin puhtaan asennuksen ilman päivityksiä, eikä xorg.confia tai mitään muitakaan manuaalisia säätöjä ole tehty.

On kyllä mahdollista, että livetilassa on käytössä erilaiset kernelin parametrit tai eri X.orgin ajuri. Tarkista ainakin että kernelin komentorivi täsmää asennetussa järjestelmässä livetilan käyttämiin parametreihin ja kernelin versioon:

Koodia: [Valitse]
cat /proc/cmdline

Vika saattaa johtua jollain tavalla myös gdm:stä (GNOME-työpöydän kirjautumispalvelu/-näyttö). Se ei taida olla käytössä livetilassa, eikä myöskään käynnistettäessä ikkunointi startx:llä. Kokeile korvata GDM LightDM:llä:

Koodia: [Valitse]
sudo apt purge gdm3
Koodia: [Valitse]
sudo apt install lightdm

Lightdm on ratkaissut vanhojen Radeonien grafiikkaongelmia ainakin tämän keskustelun mukaan: https://ubuntuforums.org/showthread.php?t=2390536&page=2
« Viimeksi muokattu: 03.01.19 - klo:15.54 kirjoittanut nm »