Kirjoittaja Aihe: ArchLabs-2018.02  (Luettu 360 kertaa)

fossiili

  • Käyttäjä
  • Viestejä: 770
    • Profiili
ArchLabs-2018.02
« : 05.05.18 - klo:15.15 »
Joskus kauan sitten yritin minäkin Arch-Linuxin asentamista. Ei onnistunut. Nyt vanhoilla päivilläni ajattelin yrittää uudelleen. LINUX  FORMAT  lehden  toukokuun 2018 numerossa oli DVD, josta asensin  linux jakelun ArchLabs-2018.02. Sujui helposti. Asennusohjelma  oli helppo ja monipuolinen. Valintoja oli paljon, mutta ne eivät olleet vaikeita, koska aina oli nähtävissä lyhyt selittävä teksti. Olin aivan täpinöissäni, minä osasinkin tehdä Arch-asennuksen  8)

Nyt harkittuani asiaa perusteellisesti ymmärrän riehaantuneeni. Arch-jengi on uudistunut markkinahenkiseksi.  Tarjotaan  helppoa (minullekin)  :-*
_ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _  _  _ _ _ _ _ _ _  _  _ _  _  _

Silti tuli kysyttävää. Olen tottunut käyttämään pakettipalvelua Pacman muiden jakeluiden kanssa. Jostain syystä se ei toimi yhtä jouhevasti kuin vanha kunnon  Apt.
Niinpä nytkin tuli vastaan ongelma:
Koodia: [Valitse]
ukki@uusitalo ~ % sudo pacman -Syu       
[sudo] salasana henkilölle ukki:
:: Päivitetään pakettitietokantoja...
 core on ajan tasalla
 extra on ajan tasalla
 community on ajan tasalla
 multilib on ajan tasalla
 archlabs_repo on ajan tasalla
:: Aloitetaan järjestelmäpäivitys...
selvitetään riippuvuuksia...
etsitään ristiriitaisia paketteja...

Paketit (5) archlabs-pipemenus-2.6-1  archlabs-user-skel-1.6-1  goffice-0.10.40-1  js52-52.7.3-2  python2-2.7.15-1

Asennettavan yhteiskoko:  143,54 MiB
Päivityksen yhteiskoko:    0,54 MiB

:: Jatketaanko asentamista? [K/e] K
(5/5) tarkistetaan avainrenkaan avaimia                                  [-----------------------------------------] 100%
(5/5) tarkastetaan pakettien virheettömyyttä                             [-----------------------------------------] 100%
(5/5) ladataan paketteja                                                 [-----------------------------------------] 100%
(5/5) tarkastetaan tiedostoristiriitojen syntymistä                      [-----------------------------------------] 100%
virhe: latauksen suorittaminen epäonnistui (ristiriidassa olevia tiedostoja)
js52: tiedosto /usr/lib/libmozjs-52.so.0 on jo asennettuna tiedostojärjestelmään
Yhtään pakettia ei päivitetty tapahtuneiden virheiden vuoksi.
1 ukki@uusitalo ~ %                           

Paketit (5) archlabs-pipemenus-2.6-1  archlabs-user-skel-1.6-1  goffice-0.10.40-1  js52-52.7.3-2  python2-2.7.15-1
aiheuttavat ongelmia. Tarviiko niistä välittää?

Toinen hienojen Linuxien ongelma on esimerkiksi Facebookin videoiden näkyminen. Ne eivät suostu käynnistymään.

Tein Arch-jakelun kanssa sen virheen, että asensin sen suomenkielisenä. Jotta voisin kysyä neuvoa maailmalta pitäisi osata kääntää teksti englanniksi tai saksaksi. Onko jossakin suomenkielistä foorumia Arch-linuxille tai Pacman-järjestelmälle?


Tomin

  • Palvelimen ylläpitäjä
  • Käyttäjä / moderaattori+
  • Viestejä: 10259
    • Profiili
    • Tomin kotisivut
Vs: ArchLabs-2018.02
« Vastaus #1 : 05.05.18 - klo:16.15 »
 
Koodia: [Valitse]
virhe: latauksen suorittaminen epäonnistui (ristiriidassa olevia tiedostoja)
js52: tiedosto /usr/lib/libmozjs-52.so.0 on jo asennettuna tiedostojärjestelmään
Katsoppas onko tuo tiedosto jo jonkun omistuksessa (luultavasti ei, koska pacman ei väittänyt sellaista):
Koodia: [Valitse]
pacman -Qo /usr/lib/libmozjs-52.so.0ja jos tuossa ei ole ongelmaa, niin joka poistaa tuon tiedoston ensin (tosin kannattaa olla varma ettei sitä tarvita) tai käyttää --force-vipua:
Koodia: [Valitse]
sudo pacman -Syu --force
 
Paketit (5) archlabs-pipemenus-2.6-1  archlabs-user-skel-1.6-1  goffice-0.10.40-1  js52-52.7.3-2  python2-2.7.15-1
aiheuttavat ongelmia. Tarviiko niistä välittää?
Kyllähän ne kannattaa päivittää. Yksittäisen paketin voi jättää pois käyttämällä vipua --ignore=paketti.

 
Tein Arch-jakelun kanssa sen virheen, että asensin sen suomenkielisenä. Jotta voisin kysyä neuvoa maailmalta pitäisi osata kääntää teksti englanniksi tai saksaksi.
Jos koet, että jakelun suomenkielisyys on tässä se ongelma, niin voit ajaa komentoja sopivin LANGUAGE (tai joskus LANG) muuttujan arvoin, esim:
Koodia: [Valitse]
LANGUAGE=C sudo pacman -SyuTässä C tarkoittaa ohjelman alkuperäistä kieltä, joka on yleensä englanti. Voit myös käyttää mitä tahansa järjestelmään asennettua kieltä, jotka näet locale-komennolla:
Koodia: [Valitse]
locale -aJa nyt Iso-Britannian englanniksi suorittaminen käy näin:
Koodia: [Valitse]
LANGUAGE=en_GB.utf8 sudo pacman -Syu
Automaattinen allekirjoitus:
Lisäisitkö [RATKAISTU] ketjun ensimmäisen viestin aiheeseen ongelman ratkettua, kiitos.

fossiili

  • Käyttäjä
  • Viestejä: 770
    • Profiili
Vs: ArchLabs-2018.02
« Vastaus #2 : 06.05.18 - klo:16.14 »
KIITOS, olipa hyviä neuvoja. On tämä Ubuntun foorumi ylivoimainen  :D

fossiili

  • Käyttäjä
  • Viestejä: 770
    • Profiili
Vs: ArchLabs-2018.02
« Vastaus #3 : 10.05.18 - klo:09.33 »
ArchLabs linuxin foorumilta vastasivat, että poistetaan  /usr/lib/libmozjs-52.so.0 eli
Koodia: [Valitse]
sudo rm /usr/lib/libmozjs-52.so.0 Sillä hyvä.