Kirjoittaja Aihe: Bitcoind:n hankinta ja asennus  (Luettu 1245 kertaa)

Azekriel

  • Käyttäjä
  • Viestejä: 14
    • Profiili
Bitcoind:n hankinta ja asennus
« : 06.08.17 - klo:13.30 »
Elikkä, kun koitan ajaa komennon: add-apt-repository ppa:bitcoin/bitcoin

Saan tekstin:

Stable Channel of bitcoin-qt and bitcoind for Ubuntu, and their dependencies

Note that you should prefer to use the official binaries, where possible, to limit trust in Launchpad/the PPA owner.

No longer supports precise, due to its ancient gcc and Boost versions.
 More info: https://launchpad.net/~bitcoin/+archive/ubuntu/bitcoin
Press [ENTER] to continue or ctrl-c to cancel adding it

Tämän jälkeen painan ENTER niinku pyytääkin, sen jälkeen komento apt-get update.

Jonka jälkeen koitan ajaa komennon: apt-get install bitcoind

Joka jälkeen tulee teksti:

Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package bitcoind



Elikkä kysymys nyt tässä kuuluu niin, että mistä saan tuon bitcoind:n asennettua Ubuntu Serverilleni?

mrl586

  • Käyttäjä
  • Viestejä: 4380
    • Profiili
Vs: Bitcoind:n hankinta ja asennus
« Vastaus #1 : 06.08.17 - klo:14.23 »
Mitä seuraava komento tulostaa?
Koodia: [Valitse]
lsb_release -rd

Azekriel

  • Käyttäjä
  • Viestejä: 14
    • Profiili
Vs: Bitcoind:n hankinta ja asennus
« Vastaus #2 : 06.08.17 - klo:16.07 »
Description:    Ubuntu 15.10
Release:        15.10

Eesaurus

  • Käyttäjä
  • Viestejä: 2590
    • Profiili
Vs: Bitcoind:n hankinta ja asennus
« Vastaus #3 : 06.08.17 - klo:16.59 »
More info: https://launchpad.net/~bitcoin/+archive/ubuntu/bitcoin

Sivun perusteella 15.10 Ubuntu ei olisi tuettu.

Kyseinen Ubuntu ei ole muutenkaan enää tuettu, joten kannattaisi päivittää se joka tapauksessa 16.04:ksi. Tai tehdä kokonaan uusi 16.04 -asennus. Siinä ohjelman pitäisi toimia. Itse kokeilin asennusta 17.04:ään, ei ollut ongelmia.

Azekriel

  • Käyttäjä
  • Viestejä: 14
    • Profiili
Vs: Bitcoind:n hankinta ja asennus
« Vastaus #4 : 06.08.17 - klo:17.15 »
Täytynee siis asentaa 16.04 koska se on viimeisin mitä VPS:n tarjoajani tarjoaa.