Kirjoittaja Aihe: Pdf-lomakkeita ei voi täyttää (Ratkaistu päivityksellä)  (Luettu 684 kertaa)

Jukki

  • Käyttäjä
  • Viestejä: 397
    • Profiili
https://www.vero.fi/contentassets/66a69c4a969d4a6a9d66fce3c5e93044/3308v15.pdf

Millä pdf-lukijalla onnistuisi noitten verotoimiston lomakkeitten täyttö? Tiedosto aukeaa kyllä mutta siihen ei voi kirjoittaaa. Tallettaakin pitäisi. Tässä koneessa on xubuntu 12.04.
« Viimeksi muokattu: 10.07.17 - klo:23.30 kirjoittanut Jukki »

Tomin

  • Palvelimen ylläpitäjä
  • Käyttäjä / moderaattori+
  • Viestejä: 9886
    • Profiili
    • Tomin kotisivut
Vs: Pdf-lomakkeita ei voi täyttää
« Vastaus #1 : 10.07.17 - klo:22.14 »
Gnomen asiakirjakatselin näyttäisi osaavan. Tunnetaan myös nimellä eye of gnome (lyhenne ja komento eog) ja löytyy Ubuntuissa paketista eog. Saattaa Xubuntussa näyttää vähän hassulta, koska saattaa piirtää kahdet sulkemisruksit, mutta pitäisi toimia. Tallentaminen onnistuu Tallenna kopio -toiminnolla.

Muokkaus: Sori, evince on oikea ohjelma, kuten muut alla kirjoittivatkin. Mikähän aivopieru tämäkin oli. Pitäisi kai keskittyä moderointiin ja jättää neuvominen niille, joilta se sujuu.
« Viimeksi muokattu: 10.07.17 - klo:22.45 kirjoittanut Tomin »
Automaattinen allekirjoitus:
Lisäisitkö [RATKAISTU] ketjun ensimmäisen viestin aiheeseen ongelman ratkettua, kiitos.

Eesaurus

  • Käyttäjä
  • Viestejä: 2553
    • Profiili
Vs: Pdf-lomakkeita ei voi täyttää
« Vastaus #2 : 10.07.17 - klo:22.19 »
Minulla 17.04 Ubuntussa tuota voi täytellä sekä Ubuntun oletus PDF -ohjelmalla (Asiakirjakatselin = Evince) että Chromella, jossa on sisäänrakennettuna PDF -tuki.
 

Jukki

  • Käyttäjä
  • Viestejä: 397
    • Profiili
Vs: Pdf-lomakkeita ei voi täyttää
« Vastaus #3 : 10.07.17 - klo:22.28 »
Ubuntun sovellusvalikoimassa on "Kuvakatselin (eog). Onko se tuo ohjelma? Tämän 12.04.n Asiakirjakatselin ei anna kirjoittaa tuohon verotoimiston pdf-tiedostoon.

« Viimeksi muokattu: 10.07.17 - klo:22.33 kirjoittanut Jukki »

nm

  • Käyttäjä
  • Viestejä: 10738
    • Profiili
Vs: Pdf-lomakkeita ei voi täyttää
« Vastaus #4 : 10.07.17 - klo:22.34 »
Ubuntun sovellusvalikoimassa on "Kuvakatselin (eog). Onko se tuo ohjelma? Tämän 12.04.n Asiakirjakatselin ei anna kirjoittaa tuohon verotoimiston pdf-tiedostoon.

evince on oikea ohjelma PDF-tiedostojen katseluun ja lomakkeiden täyttöön.

Jukki

  • Käyttäjä
  • Viestejä: 397
    • Profiili
Vs: Pdf-lomakkeita ei voi täyttää
« Vastaus #5 : 10.07.17 - klo:22.48 »
Evince on tässä 12.04:ssä tuo "Asiakirjakatselin" eikä anna kirjoittaa lomake-pdf:ään. Eipä nuo muutkaan pdf-katselijat toimi. Koko käyttiskö pitäisi päivittää?

Tomin

  • Palvelimen ylläpitäjä
  • Käyttäjä / moderaattori+
  • Viestejä: 9886
    • Profiili
    • Tomin kotisivut
Vs: Pdf-lomakkeita ei voi täyttää
« Vastaus #6 : 10.07.17 - klo:22.52 »
Sotkin tuossa aiemmin nimiä eli evince on tuo tarkoittamani ohjelma ei eog (korjattu aiempaan viestiini). Voi olla toki, että 12.04 on jo liian vanha. Sen tukikin on päättynyt, joten suosittelen päivitystä uudempaan, jotta saat myös tietoturvapäivitykset. Käytännössä tässä päivitys olisi uusi asennus uudempaan versioon (säilytettävistä tiedostoista tietenkin varmuuskopiot ensin).

Testasin, että ainakin Arch Linuxin varsin tuore versio osaa ja melko varmasti se toimii myös Ubuntu (tai Xubuntu) 16.04:lläkin.
« Viimeksi muokattu: 10.07.17 - klo:22.54 kirjoittanut Tomin »
Automaattinen allekirjoitus:
Lisäisitkö [RATKAISTU] ketjun ensimmäisen viestin aiheeseen ongelman ratkettua, kiitos.

nm

  • Käyttäjä
  • Viestejä: 10738
    • Profiili
Vs: Pdf-lomakkeita ei voi täyttää
« Vastaus #7 : 10.07.17 - klo:22.56 »
Evince on tässä 12.04:ssä tuo "Asiakirjakatselin" eikä anna kirjoittaa lomake-pdf:ään. Eipä nuo muutkaan pdf-katselijat toimi. Koko käyttiskö pitäisi päivittää?

No olisi kyllä aika, kun 12.04:n tuki on loppunut huhtikuussa. Voit vielä kokeilla vanhalla Acrobat Readerillä, jonka saat 12.04:ään Canonical Partners -lähteestä: http://www.krizna.com/ubuntu/how-to-install-adobe-reader-ubuntu-12-04-command-line/

Xournal-ohjelmalla voi myös kirjoitella tekstiä ja piirrellä mihin tahansa PDF:ään, mutta siistimpää ja helpompaa olisi käyttää lomakkeita tukevaa lukijaa.


Jukki

  • Käyttäjä
  • Viestejä: 397
    • Profiili
Vs: Pdf-lomakkeita ei voi täyttää
« Vastaus #8 : 10.07.17 - klo:23.28 »
ok päivitetään siis... kitos nopeista vastauksista

Jukki

  • Käyttäjä
  • Viestejä: 397
    • Profiili
Xubuntu 14.04:n asiakirjakatselimessa toimii nyt pdf lomakkeitten täyttö kuten pitääkin. Päivitys onnistui ohjelmistopäivityksen kautta.

jekku

  • Käyttäjä
  • Viestejä: 1442
    • Profiili
Vs: Pdf-lomakkeita ei voi täyttää
« Vastaus #10 : 18.07.17 - klo:07.07 »
....
Xournal-ohjelmalla voi myös kirjoitella tekstiä ja piirrellä mihin tahansa PDF:ään, mutta siistimpää ja helpompaa olisi käyttää lomakkeita tukevaa lukijaa.

Kiitos vinkistä/muistutuksesta.
Virastojen kupongeille on lukija helpompi, mutta oma käyttönsä tälläkin :)