Kirjoittaja Aihe: Ubuntun mukana tuleva vs. uusin ohjelmaversio (tapaus hplip) [ratkaistu]  (Luettu 4956 kertaa)

AimoE

  • Käyttäjä
  • Viestejä: 1815
    • Profiili
HP:n tulostin lakkasi toimimasta kun tein tasonnoston 14.10 => 15.04, ja syy löytyi julkaisutiedoista: Vivid Vervetin mukana tulee hplip-versio 3.15.2 jossa ei vielä ole mukana Vivid Vervet -tuki. Pitäisi siis asentaa uusin hplip-versio, eli 3.15.4. Kokeilin ensin onko se proposed-listalla, mutta eipä ole, joten lataus ja asennus pitää tehdä itse.

En ole aikaisemmin asentanut pakettia tällä tavalla, siis niin että periaatteessa ohjelmisto tulee Ubuntun mukana, mutta tarvitsenkin uudemman version, jolle ei ole ppa:ta vaan joudun tekemään sekä latauksen että asennuksen itse. Asennusohje on sinänsä ihan selvä, mutta siinä kerrotaan vain asennus. Ennen kuin teen asennuksen, haluaisin lisäksi tietää
- miten itse tehty asennus poistetaan tarvittaessa?
- mitä pitää tehdä jos/kun uusi paketti tulee mukaan Ubuntun pakettivarastoon ja ohjelmistopäivitys alkaa tarjota sitä?
- mistä löytyy uutta hplip-versiota vastaava hplip-gui, jota ei mainita hplip-sivustolla?
« Viimeksi muokattu: 13.05.15 - klo:18.16 kirjoittanut AimoE »

nm

  • Käyttäjä
  • Viestejä: 13752
    • Profiili
HP:n tulostin lakkasi toimimasta kun tein tasonnoston 14.10 => 15.04, ja syy löytyi julkaisutiedoista: Vivid Vervetin mukana tulee hplip-versio 3.15.2 jossa ei vielä ole mukana Vivid Vervet -tuki.

Kyllä Ubuntu 15.04:n HPLIP 3.15.2-paketoinnissa on Ubuntu 15.04 -tuki! Jakeluiden omat paketoinnit ovat lähes aina hieman kustomoituja. Tämän hplip-version tapauksessa paketointiin on tehty aika paljonkin uusia muutoksia.

Tulostusongelmasi johtuu todennäköisesti jostain muusta tekijästä kuin HPLIPin ja jakelun epäyhteensopivuudesta. Oletko jo poistanut tulostimen tulostusasetuksista ja lisännyt sen uudelleen? Mikä tulostinmalli on kyseessä?

Voisit myös kokeilla poistaa hplipin asetuksineen ja asentaa sen sitten takaisin:

Koodia: [Valitse]
sudo apt-get purge "hplip*"
sudo apt-get install hplip hplip-gui
« Viimeksi muokattu: 09.05.15 - klo:11.25 kirjoittanut nm »

AimoE

  • Käyttäjä
  • Viestejä: 1815
    • Profiili
Annoin jo linkin julkaisutietoihin, ja siellä 15.04-tuki selvästi tulee vasta versiossa 3.15.4, joten jos löydät tiedon Vivid-tuesta versiossa 3.15.2 jostain muualta niin kerro ihan tarkkaan missä se kerrotaan.

Olin jo yrittänyt päivitystä Ubuntun repoista, mutta varmuuden vuoksi suoritin nuo antamasi apt-get -komennot vielä kerran. Lisäksi poistin kotihakemistostani alihakemiston .hplip. Lopputulos on sama kuin ennenkin, eli kun kytken tulostimen USB-kaapelin (tässä mallissa USB-kaapelia pitää käyttää asennusten aikana), niin ruudulle tulee pop-up joka sanoo että
Lainaus
HP Device plug-in version mismatch or some files are corrupted. Click 'Next' to install required plug-in.
ja joka kerta kun plug-in-asennusta yrittää, se keskeytyy virheeseen "Plug-in install failed" ilman mitään lisäselityksiä. Ekan kerran tämä pop-up tuli silloin kun ekan kerran yritin tulostusta tasonnoston jälkeen (jolloin käytössä oli WLAN-yhteys, koska en ollut asentamassa mitään, yritin vaan tulostaa).

En ole ainoa jolla on tämä (tai ainakin samantapainen) ongelma version 3.15.2 kanssa: https://bugs.launchpad.net/hplip/+bug/1442734

AimoE

  • Käyttäjä
  • Viestejä: 1815
    • Profiili
Hieman edistystä. Käynnistin asennuksen päätteessä, ja se päättyi virheeseen:
Koodia: [Valitse]
error: Python gobject/dbus may be not installed
error: Plug-in install failed.

Ja joka tapauksessa, kysymykseni oli yleisempi, koski ylipäätään tilannetta jossa joutuu hakemaan tuoreemman version jostain ohjelmistosta valmistajan sivustolta. Olisikohan mahdollista saada siihen varsinaiseen kyssäriin vastaus, kävi tämän erityistapauksen kanssa nyt miten tahansa?

AimoE

  • Käyttäjä
  • Viestejä: 1815
    • Profiili
Minulla on asennuslähteenä "Palvelin maalle: Suomi". Mitä muuta palvelinta minun kannattaisi kokeilla siltä varalta että niillä on eri versiot?

joonas60

  • Käyttäjä
  • Viestejä: 255
  • Tietotekniikan kanssa puuhastelua yli 30 vuotta
    • Profiili
Ja joka tapauksessa, kysymykseni oli yleisempi, koski ylipäätään tilannetta jossa joutuu hakemaan tuoreemman version jostain ohjelmistosta valmistajan sivustolta. Olisikohan mahdollista saada siihen varsinaiseen kyssäriin vastaus, kävi tämän erityistapauksen kanssa nyt miten tahansa?

Ohjeet tälläisessä tapauksessa pitäisi löytyä valmistajalta. Esimerkiksi hplip-tapauksessa hplipin poistoon löytyy ohjeet täältä How to Uninstall HPLIP

Kokeilin ubuntu 15.04:sta USB-tikulle asennetulla liveCD:llä ja tulostusta hplipiä käyttäen wanhalla HP:n monitoimilaitteella ja sekä tulostus että skannaus toimi OK. Olisiko näin, että päivitys 14.04:sta 15.04:ään aiheuttaa tämän ongelmasi? Ja tämän virherapsan hplip 13.15.4 fails with Ubuntu 15.04 perusteella uudempi hplip 3.15.4 toimi vältämättä sen paremmin...
terv. joonas60
Asus X4909F, Windows 10
Työkone Windows 10, Virtualboxissa Ubuntu 18.04

nm

  • Käyttäjä
  • Viestejä: 13752
    • Profiili
Annoin jo linkin julkaisutietoihin, ja siellä 15.04-tuki selvästi tulee vasta versiossa 3.15.4, joten jos löydät tiedon Vivid-tuesta versiossa 3.15.2 jostain muualta niin kerro ihan tarkkaan missä se kerrotaan.

Ubuntun kehittäjät ovat paikanneet Ubuntussa olevan hplip-version niin, että siinä on tuki Vividille. Ubuntun hplip 3.15.2 ei ole kaikilta osin sama ohjelmisto kuin virallinen hplip 3.15.2 vaan se on kustomoitu Ubuntuun sopivaksi. Tätä ei kerrota missään erikseen, koska kyseessä on normaali paketointiprosessi. Paketoinnin ylläpitäjät varmistavat toimivuuden ja muokkaavat ohjelmia tarvittaessa jakeluun sopivaksi. Linkittämästäni muutoslokista näet osan muutoksista, joita paketoinnissa on tehty alkuperäisen version päälle.

Olin jo yrittänyt päivitystä Ubuntun repoista, mutta varmuuden vuoksi suoritin nuo antamasi apt-get -komennot vielä kerran. Lisäksi poistin kotihakemistostani alihakemiston .hplip. Lopputulos on sama kuin ennenkin, eli kun kytken tulostimen USB-kaapelin (tässä mallissa USB-kaapelia pitää käyttää asennusten aikana), niin ruudulle tulee pop-up joka sanoo että
Lainaus
HP Device plug-in version mismatch or some files are corrupted. Click 'Next' to install required plug-in.
ja joka kerta kun plug-in-asennusta yrittää, se keskeytyy virheeseen "Plug-in install failed" ilman mitään lisäselityksiä. Ekan kerran tämä pop-up tuli silloin kun ekan kerran yritin tulostusta tasonnoston jälkeen (jolloin käytössä oli WLAN-yhteys, koska en ollut asentamassa mitään, yritin vaan tulostaa).

Kokeile asentaa liitännäinen hp-pluginin avulla sekä Python 2.7:llä että Python 3:lla. Muutoslokin perusteella Ubuntun hplip-paketoinnissa on keskitytty erityisesti Python 3 -tukeen, joten se on saattanut aiheuttaa sivuoireita.

Koodia: [Valitse]
sudo python2 hp-plugin -i -g

Koodia: [Valitse]
sudo python3 hp-plugin -i -g

Havaitsemasi virheilmoitus "Python gobject/dbus may be not installed" viittaa siihen, että hp-pluginia ajetaan oletuksena Python 3:lla ja se ei toimi kunnolla.

En ole ainoa jolla on tämä (tai ainakin samantapainen) ongelma version 3.15.2 kanssa: https://bugs.launchpad.net/hplip/+bug/1442734

On toki mahdollista, että kohtaamasi bugi on korjattu 3.15.4:ssä. Jos kokeilet uutta versiota ja toteat, että homma toimii, asiasta kannattaa ilmoitella Ubuntun hplip-ylläpitäjille. Tällöin he todennäköisesti paikkaavat nykyistä 3.15.2-versiota tarvittavilta osin.


En ole aikaisemmin asentanut pakettia tällä tavalla, siis niin että periaatteessa ohjelmisto tulee Ubuntun mukana, mutta tarvitsenkin uudemman version, jolle ei ole ppa:ta vaan joudun tekemään sekä latauksen että asennuksen itse. Asennusohje on sinänsä ihan selvä, mutta siinä kerrotaan vain asennus. Ennen kuin teen asennuksen, haluaisin lisäksi tietää
- miten itse tehty asennus poistetaan tarvittaessa?

Tämä on täysin tapauskohtaista, kun kyseessä ei ole deb-paketoitu palikka. HPLIPin poisto-ohje on täällä: How to Uninstall HPLIP.

- mitä pitää tehdä jos/kun uusi paketti tulee mukaan Ubuntun pakettivarastoon ja ohjelmistopäivitys alkaa tarjota sitä?

Ubuntun versio pitää poistaa kokonaan ennen kuin asennat oman version. Ohjelmistopäivitys ei siis tarjoa päivitystä vaan joudut itse seuraamaan tilannetta. Sitten kun korjaus tulee, poista itse asennettu versio ja asenna Ubuntun paketti takaisin.

- mistä löytyy uutta hplip-versiota vastaava hplip-gui, jota ei mainita hplip-sivustolla?

Se sisältyy HPLIP-sivuston asennuspakettiin.
« Viimeksi muokattu: 09.05.15 - klo:13.00 kirjoittanut nm »

AimoE

  • Käyttäjä
  • Viestejä: 1815
    • Profiili
Kiitos joonas60 ja nm, hyviä neuvoja.uninstall-ohje oli minulta jäänyt huomaamatta HP:n sivustolla.

Tosin
Koodia: [Valitse]
sudo python2 hp-plugin -i -g ei ihan toimi (pitää olla /usr/bin/hp-plugin).

Kun kokeilin python2:sta, komento kaatui heti, ja kun kokeilin python3:sta, niin hp-plugin lähti käyntiin, mutta kaatui samaan virheeseen kuin ennenkin (error: Python gobject/dbus may be not installed). Toisin sanoen kyse ei  nyt ole python-version valintaongelmasta (jonka pitikin olla jo korjattu), vaan vika on joku muu. Joko järjestelmästä tosiaan puuttuu joku riippuvuus tai sitten joku vielä kummallisempi juttu.

Pystyn tulostamaan tiedostot Windows-koneellani, joten tämä ilmeisesti jää lepäämään kunnes korjaus löytyy.

nm

  • Käyttäjä
  • Viestejä: 13752
    • Profiili
Kun kokeilin python2:sta, komento kaatui heti, ja kun kokeilin python3:sta, niin hp-plugin lähti käyntiin, mutta kaatui samaan virheeseen kuin ennenkin (error: Python gobject/dbus may be not installed). Toisin sanoen kyse ei  nyt ole python-version valintaongelmasta (jonka pitikin olla jo korjattu), vaan vika on joku muu.

Itse veikkaan edelleen ongelmaa Python 3:n kanssa. 3.15.4:ssä voi olla jotain lisäkorjauksia tähän.

AimoE

  • Käyttäjä
  • Viestejä: 1815
    • Profiili
Itse veikkaan edelleen ongelmaa Python 3:n kanssa. 3.15.4:ssä voi olla jotain lisäkorjauksia tähän.

Mutta kuten joonas60 huomautti, uusikaan versio ei välttämättä toimi sen paremmin.

joonas60

  • Käyttäjä
  • Viestejä: 255
  • Tietotekniikan kanssa puuhastelua yli 30 vuotta
    • Profiili
Vs: Ubuntun mukana tuleva vs. uusin ohjelmaversio (tapaus hplip)
« Vastaus #10 : 09.05.15 - klo:13.41 »
Jeps, näyttäs python version käyttö olevan se root-cause. Katsoin uudelleen liveCD:tä ja siellä tuli tämmöstä:
Koodia: [Valitse]
ls  /usr/bin/python -l
lrwxrwxrwx 1 root root 9 tammi 13 18:31 /usr/bin/python -> python2.7

Ilmeisesti asennetussa/päivitetyssä 15.04:ssa on linkitetty python3?

Arch-wikissä oli neuvo, että poistaisi symbolisen linkin ja loisi uuden, joka linkitettäisiin vanhempaan versioon: HPLIP: "Syntax error: invalid syntax" installing HP LaserJet 1018. Tuosta tosin taitaa tulla ongelmia sellaisten ohjelmien kanssa, jotka tarvitsevat uudempaa versiota.
terv. joonas60
Asus X4909F, Windows 10
Työkone Windows 10, Virtualboxissa Ubuntu 18.04

nm

  • Käyttäjä
  • Viestejä: 13752
    • Profiili
Vs: Ubuntun mukana tuleva vs. uusin ohjelmaversio (tapaus hplip)
« Vastaus #11 : 09.05.15 - klo:13.49 »
Jeps, näyttäs python version käyttö olevan se root-cause. Katsoin uudelleen liveCD:tä ja siellä tuli tämmöstä:
Koodia: [Valitse]
ls  /usr/bin/python -l
lrwxrwxrwx 1 root root 9 tammi 13 18:31 /usr/bin/python -> python2.7

Ilmeisesti asennetussa/päivitetyssä 15.04:ssa on linkitetty python3?

15.04:ssä on edelleen oletuksena Python 2.7, eli tuo linkki on samanlainen myös asennetussa ja päivitetyssä versiossa. Sen sijaan HPLIP-paketoinnissa olevat python-skriptit on 15.04:ssä muutettu käyttämään Python3-tulkkia. Tämä on osa järjestelmänlaajuista siirtymistä Python 3.een ennen Ubuntu 16.04:n julkaisua.
« Viimeksi muokattu: 09.05.15 - klo:13.50 kirjoittanut nm »

joonas60

  • Käyttäjä
  • Viestejä: 255
  • Tietotekniikan kanssa puuhastelua yli 30 vuotta
    • Profiili
Vs: Ubuntun mukana tuleva vs. uusin ohjelmaversio (tapaus hplip)
« Vastaus #12 : 11.05.15 - klo:22.09 »
15.04:ssä on edelleen oletuksena Python 2.7, eli tuo linkki on samanlainen myös asennetussa ja päivitetyssä versiossa. Sen sijaan HPLIP-paketoinnissa olevat python-skriptit on 15.04:ssä muutettu käyttämään Python3-tulkkia. Tämä on osa järjestelmänlaajuista siirtymistä Python 3.een ennen Ubuntu 16.04:n julkaisua.

Olet oikeassa. Kun vilkaisin 15.04:sen hplipin pythonskriptejä niin niistä löytyi tämä aloitusrivi:
Koodia: [Valitse]
#!/usr/bin/python3
Kokelin virtuaaliboxissa viikonloppuna HPLI:n asennusskriptiä hplip-3.15.4.run, joka löytyi täältä HP Linux Imaging and Printing - Installer Walkthrough. Kun ajoin onnistuneesti tuon, niin hplip-skripteissä on nyt vastaavasti aloitusrivi:
Koodia: [Valitse]
#!/usr/bin/env python
Näin ollen skriptien ajo ei enää ole riippuvainen siitä python-versiosta, joka on määritelty oletukseksi.

Muuten , AimoE:n aloitusviestissä on Asennusohje-linkki rikki, pitäis varmaan sojottaa jonnekin muualle kuin http://3.15.4/ ...
« Viimeksi muokattu: 11.05.15 - klo:22.27 kirjoittanut joonas60 »
terv. joonas60
Asus X4909F, Windows 10
Työkone Windows 10, Virtualboxissa Ubuntu 18.04

AimoE

  • Käyttäjä
  • Viestejä: 1815
    • Profiili
Vs: Ubuntun mukana tuleva vs. uusin ohjelmaversio (tapaus hplip)
« Vastaus #13 : 12.05.15 - klo:06.23 »
Muuten , AimoE:n aloitusviestissä on Asennusohje-linkki rikki, pitäis varmaan sojottaa jonnekin muualle kuin http://3.15.4/ ...
Kiitos huomautuksesta. Korjasin linkin.

AimoE

  • Käyttäjä
  • Viestejä: 1815
    • Profiili
Vs: Ubuntun mukana tuleva vs. uusin ohjelmaversio (tapaus hplip)
« Vastaus #14 : 13.05.15 - klo:18.16 »
Toisessa viestissäni mainitsin bugin https://bugs.launchpad.net/hplip/+bug/1442734 ja siellä neuvottiin asentamaan viimeisin versio (3.15.4). Tein sen ja nyt tulostin toimii. Toivottavasti sen asennuksesta ei sitten myöhemmin tule mitään murheita.

AimoE

  • Käyttäjä
  • Viestejä: 1815
    • Profiili
Vs: Ubuntun mukana tuleva vs. uusin ohjelmaversio (tapaus hplip)
« Vastaus #15 : 13.05.15 - klo:19.09 »
- mistä löytyy uutta hplip-versiota vastaava hplip-gui, jota ei mainita hplip-sivustolla?

Se sisältyy HPLIP-sivuston asennuspakettiin.

Vaan eipä tullut mukana tuo hplip-gui. No ehkä sitä ilmankin pärjää.

nm

  • Käyttäjä
  • Viestejä: 13752
    • Profiili
Vs: Ubuntun mukana tuleva vs. uusin ohjelmaversio (tapaus hplip)
« Vastaus #16 : 13.05.15 - klo:19.51 »
Vaan eipä tullut mukana tuo hplip-gui. No ehkä sitä ilmankin pärjää.

Kokeile käynnistää päätteen kautta komennolla

Koodia: [Valitse]
hp-toolbox

AimoE

  • Käyttäjä
  • Viestejä: 1815
    • Profiili
Vs: Ubuntun mukana tuleva vs. uusin ohjelmaversio (tapaus hplip)
« Vastaus #17 : 13.05.15 - klo:20.10 »
Vaan eipä tullut mukana tuo hplip-gui. No ehkä sitä ilmankin pärjää.

Kokeile käynnistää päätteen kautta komennolla

Koodia: [Valitse]
hp-toolbox
En löytänyt HP-ohjelmia Dashin kautta, eikä "HP Device Manager" käynnistynyt yläpalkin kuvakkeen valikosta, joten päättelin että gui ei tullut mukana. Komento hp-toolbox toimii, ja löytyy nyt muistakin paikoista kun kirjauduin ulos ja sisään. Kiitos.