Kirjoittaja Aihe: Spotify ja 15.04 (RATKAISTU)  (Luettu 3506 kertaa)

Jula

  • Käyttäjä
  • Viestejä: 328
    • Profiili
Spotify ja 15.04 (RATKAISTU)
« : 01.05.15 - klo:18.07 »
Heips.

Törmäsin ensimmäisen kerran pitkään aikaan ongelmaan Ubuntun kanssa ja olen melkeimpä sydänkohtauksen partaalla järkytyksestä.  :-X
Päivitin 14.10:n 15.04:n ja nyt Spotify ei lähde käyntiin. Koetan käynnistää kuvakkeesta sivupalkissa tai hakemalla tuon sivupalkin Ubuntu-kuvakkeesta (mikä sen oikea nimi onkaan).

Mistä apu ??

« Viimeksi muokattu: 03.05.15 - klo:11.50 kirjoittanut Jula »

Tomin

  • Palvelimen ylläpitäjä
  • Käyttäjä / moderaattori+
  • Viestejä: 11296
    • Profiili
    • Tomin kotisivut
Vs: Spotify ja 15.04
« Vastaus #1 : 01.05.15 - klo:18.37 »
Aloita vaikka siitä, että avaat päätteen ja komennat sillä "spotify" (kirjoitetaan ilman lainausmerkkejä, entteriä perään), jolloin näet josko tulee jotain virheilmoituksia. Kopioi ne sitten tänne, niin voidaan katsoa, missä vika mahtaa olla.

Pitää itsekin päivittää pöytäkone, niin voin sitten kertoa, jos kävi samalla tavalla ja mahdollisesti mikä oli korjaus.
Automaattinen allekirjoitus:
Lisäisitkö [RATKAISTU] ketjun ensimmäisen viestin aiheeseen ongelman ratkettua, kiitos.

Jula

  • Käyttäjä
  • Viestejä: 328
    • Profiili
Vs: Spotify ja 15.04
« Vastaus #2 : 01.05.15 - klo:18.52 »
Koodia: [Valitse]
spotify: error while loading shared libraries: libgcrypt.so.11: cannot open shared object file: No such file or directory

Tuolta näyttää. Jotain uupuu eli pitääkö spotify asentaa uusiksi vai menikö päivityksessä jotain rikki ??

Tomin

  • Palvelimen ylläpitäjä
  • Käyttäjä / moderaattori+
  • Viestejä: 11296
    • Profiili
    • Tomin kotisivut
Vs: Spotify ja 15.04
« Vastaus #3 : 01.05.15 - klo:19.19 »
Tarkistaisin ekana, että Spotifyn lähde on käytössä ja sitten tarkistaisin päivitykset. Eli Ohjelmalähteistä Kolmas osapuoli ja sieltä Spotify takaisin käyttöön, koska nuo otetaan julkaisupäivityksessä pois.

Ilmeisesti Utopicissa on libgcrypt11 ja libgcrypt20, mutta Vividissä on vain libgcrypt20. Spotify pitäisi kääntää uudempaa kirjastoa vasten, mutta katselen vielä jos tuohon olisi joku toinen ratkaisu. Tuota kääntämistä ei siis voi tehdä muut kuin Spotify itse.
Automaattinen allekirjoitus:
Lisäisitkö [RATKAISTU] ketjun ensimmäisen viestin aiheeseen ongelman ratkettua, kiitos.

Jula

  • Käyttäjä
  • Viestejä: 328
    • Profiili
Vs: Spotify ja 15.04
« Vastaus #4 : 01.05.15 - klo:21.18 »
No oli unohtunut ottaa kolmannen osapuolen lähteet käyttöön, muttei auttanut mitään..

mrl586

  • Käyttäjä
  • Viestejä: 4638
    • Profiili
Vs: Spotify ja 15.04
« Vastaus #5 : 02.05.15 - klo:03.15 »
Ratkaisu on käyttää Utopicin libgcrypt11 -pakettia Vividissä.

Tomin

  • Palvelimen ylläpitäjä
  • Käyttäjä / moderaattori+
  • Viestejä: 11296
    • Profiili
    • Tomin kotisivut
Vs: Spotify ja 15.04
« Vastaus #6 : 03.05.15 - klo:09.54 »
Näyttää siltä, että en tänä viikonloppuna ehdi päivittää pöytäkonettani vaan menee ainakin seuraavaan, mutta jos haluat kokeilla mrl586:n ehdotusta niin tässä ohjeet:
Lataa tuo libgcrypt11-paketti käsin (selaimella).
64-bittinen paketti: http://security.ubuntu.com/ubuntu/pool/main/libg/libgcrypt11/libgcrypt11_1.5.4-2ubuntu1.1_amd64.deb
32-bittinen paketti: http://security.ubuntu.com/ubuntu/pool/main/libg/libgcrypt11/libgcrypt11_1.5.4-2ubuntu1.1_i386.deb

En nyt muista onko Spotifyn paketointi vain 32-bittinen vai saiko siitä 64-bittisen version, joten saatat joutua kokeilemaan molempia. Jos Ubuntusi on 32-bittinen, niin valitse 32-bittinen versio, muuten aloita 64-bittisestä.
Asennus tapahtuu tuplaklikkaamalla pakettia tiedostoselaimessa ja sitten sovellusvalikoiman avauduttua klikkaa sieltä asenna.

Huonoa tässä ratkaisussa on se, että tuo paketti ei päivity itsestään ja tuo on kuitenkin jossain määrin tietoturvan kannalta oleellinen paketti.

Ja tosiaan, en ole testannut tätä ratkaisua. Käsittääkseni tuon ei kuitenkaan pitäisi aiheuttaa mitään ongelmia.

Muokkaus: Utopicin tuki loppui ja linkit eivät enää toimi, mutta Trustyn version pitäisi olla käypä ja ne voi ladata tuolta: http://packages.ubuntu.com/trusty/libgcrypt11
Valitse vain sivulta Imuroi-kohdan alta oma versiosi (amd64 64-bittiselle ja i386 32-bittiselle) ja sitten avautuvalta sivulta latauspalvelin eli käytännössä security.ubuntu.com.
« Viimeksi muokattu: 12.11.15 - klo:18.57 kirjoittanut Tomin »
Automaattinen allekirjoitus:
Lisäisitkö [RATKAISTU] ketjun ensimmäisen viestin aiheeseen ongelman ratkettua, kiitos.

Jula

  • Käyttäjä
  • Viestejä: 328
    • Profiili
Vs: Spotify ja 15.04
« Vastaus #7 : 03.05.15 - klo:11.50 »
Ja taas poppi raikaa. Eikun nupit kaakkoon :D. Kiitos paljon avusta.