Kirjoittaja Aihe: Raspberry: Midori ei lataa verkkosivuja  (Luettu 2828 kertaa)

MarkoN

  • Käyttäjä
  • Viestejä: 555
    • Profiili
Raspberry: Midori ei lataa verkkosivuja
« : 15.04.15 - klo:08.53 »
Moro.

Eilen käytin Midori selainta ongelmitta ja ennen Raspin sulkemista ajoin päätteessä apt-get upgrade komennon.

Tänään ei midori enää löydä mitään osoitteita. Ei edes sisäverkosta löydä mitään. Yritin asentaa midorin uudelleen mutta sain ilmoituksen että on jo uusin versio.

Tällä hetkellä olen toisella selaimella tätä kirjoittamassa joka siis toimii normaalisti. ainoa heikkous on ettei tämä selain osaa näyttää kaikkia sivuja oikein ja siksi haluaisin tuon midorin toimimaan.

Tietysti jos chromium pyörii kunnolla Raspissa niin voin siirtyä käyttämään sitä...
Ubuntu 16.04.1 LTS
Asus P8P67, i5-2500K 3,3GHz(->4,6GHz),
8Gt 1600MHz DDR3, Gigabyte GeForce GTX970 G1 Gaming

Ubuntu 16.04.1 LTS
ACER Aspire M3-581T, i3-2367M 1,4GHz, 4Gt 1333MHz

Ubuntu 14.04.5 LTS
Asus P5K, Q6600 3,0GHz, 8Gt 800MHz,
Gigabyte GTX780oc

Lepotila zZ

  • Käyttäjä
  • Viestejä: 336
    • Profiili
Vs: Raspberry: Midori ei lataa verkkosivuja
« Vastaus #1 : 15.04.15 - klo:09.27 »
Ehkä Midorin voisi asentaa uudelleen, jos ensiksi poistaisi sen kokonaan kaikkine asetustiedostoineen?

Jos sinulla on raspi 2, kannattaa kokeilla Chromiumia. Varhaisemmille malleille oletan sen olevan turhan raskas, mutta voin olla väärässäkin, koska en ole kokeillut.

joonas60

  • Käyttäjä
  • Viestejä: 255
  • Tietotekniikan kanssa puuhastelua yli 30 vuotta
    • Profiili
Vs: Raspberry: Midori ei lataa verkkosivuja
« Vastaus #2 : 16.04.15 - klo:10.43 »
En tiedä onko syy vai seuraus, mutta Midori ei taida olla enää oletusselain Raspbianissa, sen korvaa Epiphany-selain:

Web browser released! | Raspberry Pi

Asennusohje löytyy ko. linkin takaa, mutta laitetaan se tähänkin:
Koodia: [Valitse]
sudo apt-get update
sudo apt-get dist-upgrade
sudo apt-get install epiphany-browser
terv. joonas60
Asus X4909F, Windows 10
Työkone Windows 10, Virtualboxissa Ubuntu 18.04

MarkoN

  • Käyttäjä
  • Viestejä: 555
    • Profiili
Vs: Raspberry: Midori ei lataa verkkosivuja
« Vastaus #3 : 16.04.15 - klo:12.21 »
Näyttää noi Midori ja Epiphany selaimet toimivan mut todella hitaasti.

Ennen päivitystä toi midori toimi todella hyvin... Nyt käytän "Dillo" selainta joka on todella kevyt, sivut näkyy vähän miten sattuu.

Mitäs tähän nyt keksisi... onko jotain hyvää ja kevyttä selainta joka osaisi näyttää sivutkin oikein...???
Ubuntu 16.04.1 LTS
Asus P8P67, i5-2500K 3,3GHz(->4,6GHz),
8Gt 1600MHz DDR3, Gigabyte GeForce GTX970 G1 Gaming

Ubuntu 16.04.1 LTS
ACER Aspire M3-581T, i3-2367M 1,4GHz, 4Gt 1333MHz

Ubuntu 14.04.5 LTS
Asus P5K, Q6600 3,0GHz, 8Gt 800MHz,
Gigabyte GTX780oc

nm

  • Käyttäjä
  • Viestejä: 15242
    • Profiili
Vs: Raspberry: Midori ei lataa verkkosivuja
« Vastaus #4 : 16.04.15 - klo:13.33 »
Oletko kokeillut poistaa Midorin asetustiedostot ja profiilit kotihakemistostasi? Ne sijaitsevat ilmeisesti hakemistoissa .config/midori ja .local/share/midori

MarkoN

  • Käyttäjä
  • Viestejä: 555
    • Profiili
Vs: Raspberry: Midori ei lataa verkkosivuja
« Vastaus #5 : 16.04.15 - klo:18.44 »
Oletko kokeillut poistaa Midorin asetustiedostot ja profiilit kotihakemistostasi? Ne sijaitsevat ilmeisesti hakemistoissa .config/midori ja .local/share/midori

Kokeilin tuota... .local/share/midori kansiota ei ollut.

Ei auttanut. Nyt piruuttani kellotin kauanko kestää ladata sivuja että pääsen vastaamaan Midorilla tai Epiphanyllä.

Sivun lataus 1min10sek, sisäänkirjautuminen 40sek, vastaa sivun latautuminen  1min20sek...
Ubuntu 16.04.1 LTS
Asus P8P67, i5-2500K 3,3GHz(->4,6GHz),
8Gt 1600MHz DDR3, Gigabyte GeForce GTX970 G1 Gaming

Ubuntu 16.04.1 LTS
ACER Aspire M3-581T, i3-2367M 1,4GHz, 4Gt 1333MHz

Ubuntu 14.04.5 LTS
Asus P5K, Q6600 3,0GHz, 8Gt 800MHz,
Gigabyte GTX780oc

joonas60

  • Käyttäjä
  • Viestejä: 255
  • Tietotekniikan kanssa puuhastelua yli 30 vuotta
    • Profiili
Vs: Raspberry: Midori ei lataa verkkosivuja
« Vastaus #6 : 19.04.15 - klo:14.21 »
Kokeilin nyt viikonlopun aikana B-version Raspberryllä  Midoria. Aiemmat kokemukset Midorista ovat vuoden-parin takaa ja silloin käytettävyys oli kyllä onnetonta.

Testailin muutamaa PC:ltä löytyvää Raspbian OS-imagea (2014-01-07-wheezy-raspbian, 2014-09-09-wheezy-raspbian ja 2015-02-16-raspbian-wheezy). Kahdessa tuoreemmassa versiossa oli midori tiputettu pois ja sen joutui asentamaan käsin. Uusimmassa versiossa Midorin käyttö oli onnistuttu tekemään äärimmäisen vaikeaksi. Syyskuussa julkistetussa versiossa Midori toimi oikein hyvin. Verrattuna vanhoihin kokemuksiini se toimi suhtkoht nopeasti eikä esim. tämän foorumin sivujen latailussa ollut hidastelua.

Vanhin versio toimi sitten parhaiten. Vaikka päivitin systeeemin apt-get upgrade-komennolla ja reboottasin Raspberryn, niin Midori käynnistyi nopeasti eikä tämän foorumin sivujen latailussa ollut viivettä.

Kaikissa kolmessa imagessa oli sama Midori-versio 0.4.3 eikä arm-pohjaisille linuxeille tuoreempaa käännettyä versiota ole tarjolla. Näin ollen Markon ongelmat eivät ilmeisesti johdu itse Midorista vaan jostain muusta. Etsiessäni ongelmaan syytä, törmäsin Raspberry virallisen foorumin keskusteluun Epiphanyn hitaudesta. Sen mukaan webkit-pohjaisilla selaimilla on ollut ongelmia Raspberryn kanssa ja syynä ilmeisesti jokin härö nimipalvelimen kanssa:
Epiphany Browser Painfully Slow

Minulla ei siis ollut hitausongelmia. Internetpalvelun tarjoaja on Elisa, ADSL-purkki on Pace A2100. Langallinen verkko käytössä.

Edit: Taidan jättää päivitetyn 2014-01-07-wheezy-raspbian-imagen muistikortille. Eihän nämä vanhemmat Raspberryt mitään Internet-surffilautoja ole, mutta tällä kyllä toimeen tulee...
« Viimeksi muokattu: 19.04.15 - klo:15.19 kirjoittanut joonas60 »
terv. joonas60
Asus X4909F, Windows 10
Työkone Windows 10, Virtualboxissa Ubuntu 18.04