Kirjoittaja Aihe: Network Service-ilmoitus [Ratkaistu]  (Luettu 4846 kertaa)

Aliengrey

  • Käyttäjä
  • Viestejä: 539
    • Profiili
Network Service-ilmoitus [Ratkaistu]
« : 21.03.15 - klo:00.44 »
Saan kuvan mukaisen ilmoituksen kun pääsen graafiseen ympäristöön ja netti tulee ethernetin kautta. Wlan tukiasemaa käytettäessä tätä ei ilmene. Onko mulla joku asetus väärin.

« Viimeksi muokattu: 22.03.15 - klo:08.03 kirjoittanut Aliengrey »

nm

  • Käyttäjä
  • Viestejä: 13197
    • Profiili
Vs: Network Service-ilmoitus
« Vastaus #1 : 21.03.15 - klo:01.03 »
Internet-palveluntarjoajasi verkossa on määritelty .local-domain, josta Avahi ei pidä. Tämä on melko yleinen ja pitkäaikainen ongelma, jonka ratkaisusta ei olla päästy yhteisymmärrykseen.

https://bugs.launchpad.net/ubuntu/+source/avahi/+bug/327362

Aliengrey

  • Käyttäjä
  • Viestejä: 539
    • Profiili
Vs: Network Service-ilmoitus
« Vastaus #2 : 21.03.15 - klo:01.04 »
Onko tästä mitään haittaa minulle.

poiuyt

  • Käyttäjä
  • Viestejä: 106
    • Profiili
Vs: Network Service-ilmoitus
« Vastaus #3 : 21.03.15 - klo:10.08 »
Minulla on tuo tullut alusta saakka, kun aloin käyttämään Ubuntua 2010 alussa. Olen poistanut sen seuraavasti:

Koodia: [Valitse]
sudo gedit /etc/default/avahi-daemon
jossa muutetaan AVAHI_DAEMON_DETECT_LOCAL=1 muotoon:

AVAHI_DAEMON_DETECT_LOCAL=0
« Viimeksi muokattu: 21.03.15 - klo:10.10 kirjoittanut poiuyt »

AimoE

  • Käyttäjä
  • Viestejä: 1618
    • Profiili
Vs: Network Service-ilmoitus
« Vastaus #4 : 21.03.15 - klo:10.35 »
Minulla on tuo tullut alusta saakka, kun aloin käyttämään Ubuntua 2010 alussa. Olen poistanut sen seuraavasti:

Koodia: [Valitse]
sudo gedit /etc/default/avahi-daemon
jossa muutetaan AVAHI_DAEMON_DETECT_LOCAL=1 muotoon:

AVAHI_DAEMON_DETECT_LOCAL=0

Vinkki: Tää on varmaan aika makuasia, mutta omissa muistiinpanoissani olen huomannut helpoimmaksi ilmaista nämä editointikohdat sillä tavalla että kirjoitan koodiblokin jossa tehdään varmuuskopio, avataan editori, ja kolmantena komentona on diff jolla näytän mikä oli editoinnin tulos. Sillä tavalla kaikki on siististi samassa koodiblokissa. Mutta ihan makuasia tosiaan.

ajaaskel

  • Palvelimen ylläpitäjä
  • Käyttäjä
  • Viestejä: 3392
    • Profiili
Vs: Network Service-ilmoitus
« Vastaus #5 : 21.03.15 - klo:11.04 »
Tuo näyttää ilmeiseltä toteutusvirheeltä operaattorin DNS-palvelussa. Oman käsitykseni ja IETF-dokumentin mukaan julkisella puolella ei pitäisi tulla "resolved"-vastausta "local."-kyselylle eli tuo asia on tarkoitettu sisäverkon puolelle.  Tuo näkyy esimerkiksi tästä:

https://tools.ietf.org/html/draft-ietf-dnsind-local-names-02 

Asia pitäisi korjata siellä missä ongelma on.  Muut vaihtoehdot ovat ongelman kiertelyä.

Ongelman kiertelyyn tulee mieleen vaihtoehdot:

1)  Ei käytetä ongelmallista DNS-palvelua.  Tuo tarkoittaa että vaihdetaan DNS-palvelimien osoitteet johonkin julkiseen DNS-palveluun (Google, OpenDNS).
2)  Pakotetaan oma kone "jatka vaikka virhe olemassa" eli muutetaan tuo arvo nollaksi /etc/default/avahi-daemon tiedostossa kuten yllä
3)  (Ei testattu: ajetaan /hosts -tiedoston avulla local. yli)

Kaikessa ongelman kiertelyssä on vaivaa käyttäjälle, muutoksen joutuu tekemään konekohtaisesti.  Tuolla "nm": n linkissä näkyy olevan kätevä "sed"-komento joka tekee kohta kahden muutoksen kätevästi kun kopioi hiirellä komennon päätteeseen ja antaa Enter: in perään:

Koodia: [Valitse]
sudo sed -i -e'/AVAHI_DAEMON_DETECT_LOCAL/s/1/0/' /etc/default/avahi-daemon
« Viimeksi muokattu: 21.03.15 - klo:11.11 kirjoittanut ajaaskel »
Autamme ilolla ja ilmaiseksi omalla ajallamme.  Ethän vaadi, uhoa tai isottele näin saamasi palvelun johdosta.

nm

  • Käyttäjä
  • Viestejä: 13197
    • Profiili
Vs: Network Service-ilmoitus
« Vastaus #6 : 21.03.15 - klo:12.51 »
Tuo näyttää ilmeiseltä toteutusvirheeltä operaattorin DNS-palvelussa. Oman käsitykseni ja IETF-dokumentin mukaan julkisella puolella ei pitäisi tulla "resolved"-vastausta "local."-kyselylle eli tuo asia on tarkoitettu sisäverkon puolelle.  Tuo näkyy esimerkiksi tästä:

https://tools.ietf.org/html/draft-ietf-dnsind-local-names-02 

Virallisesti .local on kai varattu vasta RFC 6762:ssa vuonna 2013. Tätä voisi yrittää viestittää ainakin Soneralle, jonka DNS-palvelu taitaa edelleen selvittää nämä kyselyt. Itse käytän Soneran verkossa muita DNS-palveluja osittain tästä syystä, ja myös siksi, että Soneran DNS:ssä oli jossain vaiheessa ajoittaisia katkoksia.

ajaaskel

  • Palvelimen ylläpitäjä
  • Käyttäjä
  • Viestejä: 3392
    • Profiili
Vs: Network Service-ilmoitus
« Vastaus #7 : 21.03.15 - klo:15.43 »
Lainaus
dig soa local. @192.89.123.26

; <<>> DiG 9.9.2-P1 <<>> soa local. @192.89.123.26
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 52850
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 3

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;local.            IN   SOA

;; ANSWER SECTION:
local.         43200   IN   SOA   localhost. hostmaster.sonera.fi. 20130911 14400 7200 604800 900

;; AUTHORITY SECTION:
local.         43200   IN   NS   localhost.

;; ADDITIONAL SECTION:
localhost.      43200   IN   A   127.0.0.1
localhost.      43200   IN   AAAA   ::1

;; Query time: 6 msec
;; SERVER: 192.89.123.26#53(192.89.123.26)
;; WHEN: Sat Mar 21 15:42:45 2015
;; MSG SIZE  rcvd: 157

host 192.89.123.26
26.123.89.192.in-addr.arpa domain name pointer ns.inet.fi.

Tuo "aa" lippu tuolla "Flags" rivillä kertoo että vastauksen antanut nimipalvelin on vastuussa kyseisestä alueesta (zone) eli "alkuperäinen auktoriteetti".
« Viimeksi muokattu: 21.03.15 - klo:15.47 kirjoittanut ajaaskel »
Autamme ilolla ja ilmaiseksi omalla ajallamme.  Ethän vaadi, uhoa tai isottele näin saamasi palvelun johdosta.

Aliengrey

  • Käyttäjä
  • Viestejä: 539
    • Profiili
Vs: Network Service-ilmoitus
« Vastaus #8 : 22.03.15 - klo:08.03 »
Minulla on tuo tullut alusta saakka, kun aloin käyttämään Ubuntua 2010 alussa. Olen poistanut sen seuraavasti:

Koodia: [Valitse]
sudo gedit /etc/default/avahi-daemon
jossa muutetaan AVAHI_DAEMON_DETECT_LOCAL=1 muotoon:

AVAHI_DAEMON_DETECT_LOCAL=0



Korjasin ongelman näillä ohjeilla. Merkkaan ratkaistuksi