Kirjoittaja Aihe: Miten toistat suojattuja/salattuja Blu-Ray -elokuvalevyjä (ratk.)  (Luettu 6280 kertaa)

v1gor

  • Käyttäjä
  • Viestejä: 11
    • Profiili
Olet ostanut Blu-Ray elokuvan ja haluat katsoa sen koneeltasi. Blu-Ray asema on luonnollisesti oltava ensinnäkin.

1. Asennamme tarvittavat paketit ja lisäämme PPA:t (yksityiset pakettiarkistot). Pääte auki ja sisään yksitellen käskyt (käytä kopioi-liimaa metodia) -->

sudo add-apt-repository ppa:n-muench/vlc

sudo apt-get update

sudo apt-get install vlc libaacs0 libbluray-bdj libbluray1


2. Nyt tulee luoda kansio nimeltä "aacs" salattuun ".config" -kansioon kotikansiossasi ja asentaa "aacs" avaimet sinne.
Syötämme siis päätekäskyt:

mkdir -p ~/.config/aacs/

sekä vielä:

cd ~/.config/aacs/ && wget http://vlc-bluray.whoknowsmy.name/files/KEYDB.cfg

3. Nyt kun käytät VLC mediasoitinta Blu-Ray levyjen toistamiseen, avaa siis VLC ja valitse ylävalikosta Media --> Avaa levy --> poista mahdollisesti vakiona ruksattu valinta "ei menu-valikoita" ja paina selaa (browse), valiten Blu-Ray juurilevykansio (yleensä elokuvan nimi tiedostojärjestelmän alapuolella) ja klikkaa avaa (open).

Ps. jos tähän on suoraviivaisempi / helpompi ratkaisu (monet sanovat että asentaa vain XBMC -ohjelman). Niin lisätkääpä perään.

Tomin

  • Palvelimen ylläpitäjä
  • Käyttäjä / moderaattori+
  • Viestejä: 11238
    • Profiili
    • Tomin kotisivut
Ihan mielenkiintoista, että onnistuu nykyään. Toimiiko tuo kaikkien levyjen kanssa vai onko tuo jollekin yksittäiselle salaukselle tai käyttävätkö eri Blu-Ray-levyt edes erilaisia salauksia? Muistaakseni sitä oli ainakin kahta erilaista. 

Saako noita avaimia jaella eteenpäin?

2. Nyt tulee luoda kansio nimeltä "aacs" salattuun ".config" -kansioon kotikansiossasi ja asentaa "aacs" avaimet sinne.

Salattuun? Tarkoitatko piilotettua?
Automaattinen allekirjoitus:
Lisäisitkö [RATKAISTU] ketjun ensimmäisen viestin aiheeseen ongelman ratkettua, kiitos.

MarkoN

  • Käyttäjä
  • Viestejä: 555
    • Profiili
No ei tää ainakaan mulla toiminu...
Ubuntu 16.04.1 LTS
Asus P8P67, i5-2500K 3,3GHz(->4,6GHz),
8Gt 1600MHz DDR3, Gigabyte GeForce GTX970 G1 Gaming

Ubuntu 16.04.1 LTS
ACER Aspire M3-581T, i3-2367M 1,4GHz, 4Gt 1333MHz

Ubuntu 14.04.5 LTS
Asus P5K, Q6600 3,0GHz, 8Gt 800MHz,
Gigabyte GTX780oc

JaniAlander

  • Käyttäjä / moderaattori+
  • Viestejä: 3104
    • Profiili
  Saako noita avaimia jaella eteenpäin?
Suomessa luultavasti kyllä. Sinullahan on jo se elokuva, ja toistolaite. Avain on vain sitä varten että ylipäätään kykenet ostamasi median toistamaan.
Core i5-9400F 2.9ghz 32GB Ram, Nvidia RTX2060 Kubuntu 20.04.01-64bit, Windows 10 Pro 64-bit Samsung Series 5, AMD A-6 2.1 GHz 4 Gt Ram, Ubuntu 18.04 64-bit.
Lenovo T60 Core2Duo 2GB Ram Ati Mobility Radeon 128 MB Ubuntu Mate 16.04-64bit
Commodore Amiga 500 1MB Ram.

nm

  • Käyttäjä
  • Viestejä: 14711
    • Profiili
No ei tää ainakaan mulla toiminu...

v1gorin linkistä latautuva KEYDB.cfg on vuodelta 2012, eikä muutenkaan kovin kattava. Paremman version saa vaikkapa täältä: http://www.labdv.com/aacs/advanced-users.php

Lisäksi monissa levyissä on BD+-suojaus, jonka avaamiseen tarvitaan libbdplus ja virtuaalikoneen tiedostot. Ubuntu 15.10:ssä ja uudemmissa libbdplus0 on mukana virallisissa repositorioissa, ja paketin asentamisen lisäksi vain vm0-paketti pitää ladata ja purkaa paikalleen:

Koodia: [Valitse]
cd .config
wget http://www.labdv.com/aacs/libbdplus/bdplus-vm0.bz2
tar -jxvf bdplus-vm0.bz2

Ubuntu 15.04:ssä ja vanhemmissa jakeluversioissa libbdplus ja VLC pitäisi kääntää itse, ja se on kohtalaisen hankala operaatio VLC:n riippuvuuksien vuoksi.


Jos haluaa päästä helpommalla, MakeMKV:n betaversio purkaa Blu-ray-levyt suoraan ja tekee niistä salaamattomia MKV-tiedostoja, jotka toistuvat mm. VLC:llä. MakeMKV on toistaiseksi ilmainen, mutta vaatii uudelleenaktivoinnin foorumilta löytyvällä avaimella parin kuukauden välein.

MakeMKV:n purkukirjaston voi myös asentaa järjestelmään siten, että VLC käyttää sitä levyjen toistossa.
« Viimeksi muokattu: 22.11.15 - klo:13.17 kirjoittanut nm »

MarkoN

  • Käyttäjä
  • Viestejä: 555
    • Profiili
No ei tää ainakaan mulla toiminu...

No niin onnistuihan se... Jes!!
Ubuntu 16.04.1 LTS
Asus P8P67, i5-2500K 3,3GHz(->4,6GHz),
8Gt 1600MHz DDR3, Gigabyte GeForce GTX970 G1 Gaming

Ubuntu 16.04.1 LTS
ACER Aspire M3-581T, i3-2367M 1,4GHz, 4Gt 1333MHz

Ubuntu 14.04.5 LTS
Asus P5K, Q6600 3,0GHz, 8Gt 800MHz,
Gigabyte GTX780oc

MarkoN

  • Käyttäjä
  • Viestejä: 555
    • Profiili
Jahas... Mitäs tämä tällaisia alkoi ilmoittamaan apt-get update:ssa??

Koodia: [Valitse]
W: The repository 'http://ppa.launchpad.net/n-muench/vlc/ubuntu xenial Release' does not have a Release file.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: Tiedoston http://ppa.launchpad.net/n-muench/vlc/ubuntu/dists/xenial/main/binary-amd64/Packages nouto ei onnistunut  404  Not Found
E: Some index files failed to download. They have been ignored, or old ones used instead.
Ubuntu 16.04.1 LTS
Asus P8P67, i5-2500K 3,3GHz(->4,6GHz),
8Gt 1600MHz DDR3, Gigabyte GeForce GTX970 G1 Gaming

Ubuntu 16.04.1 LTS
ACER Aspire M3-581T, i3-2367M 1,4GHz, 4Gt 1333MHz

Ubuntu 14.04.5 LTS
Asus P5K, Q6600 3,0GHz, 8Gt 800MHz,
Gigabyte GTX780oc

mrl586

  • Käyttäjä
  • Viestejä: 4638
    • Profiili
Onko kyseinen repo tarkoitettu Xenialille vai ei?

Eesaurus

  • Käyttäjä
  • Viestejä: 3255
    • Profiili
Onko kyseinen repo tarkoitettu Xenialille vai ei?

Ei, on tuettu näköjään vain Ubuntu 15:10:een saakka. https://launchpad.net/~n-muench/+archive/ubuntu/vlc

MarkoN

  • Käyttäjä
  • Viestejä: 555
    • Profiili
Onko kyseinen repo tarkoitettu Xenialille vai ei?

Ei, on tuettu näköjään vain Ubuntu 15:10:een saakka. https://launchpad.net/~n-muench/+archive/ubuntu/vlc

Ok. Eli johtunee siitä... Ei varmaan tarvitse tehdä mitään?? vai löytyykö oikea repo jostakin??
Ubuntu 16.04.1 LTS
Asus P8P67, i5-2500K 3,3GHz(->4,6GHz),
8Gt 1600MHz DDR3, Gigabyte GeForce GTX970 G1 Gaming

Ubuntu 16.04.1 LTS
ACER Aspire M3-581T, i3-2367M 1,4GHz, 4Gt 1333MHz

Ubuntu 14.04.5 LTS
Asus P5K, Q6600 3,0GHz, 8Gt 800MHz,
Gigabyte GTX780oc

Eesaurus

  • Käyttäjä
  • Viestejä: 3255
    • Profiili
Onko kyseinen repo tarkoitettu Xenialille vai ei?

Ei, on tuettu näköjään vain Ubuntu 15:10:een saakka. https://launchpad.net/~n-muench/+archive/ubuntu/vlc

Ok. Eli johtunee siitä... Ei varmaan tarvitse tehdä mitään?? vai löytyykö oikea repo jostakin??

Voit tietysti poistaa sen lähteen, jos haluat. Sehän ei nyt tee mitään, antaa vain virheilmoitusta.

MarkoN

  • Käyttäjä
  • Viestejä: 555
    • Profiili
Voit tietysti poistaa sen lähteen, jos haluat. Sehän ei nyt tee mitään, antaa vain virheilmoitusta.

Ok... Teen näin.
Ubuntu 16.04.1 LTS
Asus P8P67, i5-2500K 3,3GHz(->4,6GHz),
8Gt 1600MHz DDR3, Gigabyte GeForce GTX970 G1 Gaming

Ubuntu 16.04.1 LTS
ACER Aspire M3-581T, i3-2367M 1,4GHz, 4Gt 1333MHz

Ubuntu 14.04.5 LTS
Asus P5K, Q6600 3,0GHz, 8Gt 800MHz,
Gigabyte GTX780oc