Kirjoittaja Aihe: MySQL uninstall asentaa uusia paketteja?  (Luettu 721 kertaa)

Sami Lehtinen

  • Käyttäjä
  • Viestejä: 726
  • Techie
    • Profiili
    • Sami Lehtinen
MySQL uninstall asentaa uusia paketteja?
« : 03.02.14 - klo:16.53 »
Mulle ei mene ihan jakeluun, miksi näin. Googlasin, eikä selvinnyt sittenkään. Mun mielestä on outoa, että MySQL installi asentaa PostgreSQL:n tilalle. Mutta miksi näin? Tällä hetkellä käytössä on vain sellaisia sovelluksia jotka käyttävät SQLite3:sta. Joku pakottava syy, jota vain en tiedä, miksi pitää olla joku SQL serveri asennettuna? Purge tarjosi ihan samat optiot, luonnollisesti.

Koodia: [Valitse]
apt-get remove mysql-client mysql-common
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  libpq5 php-mdb2-driver-pgsql php5-pgsql postgresql-client
  postgresql-client-9.1 postgresql-client-common roundcube-pgsql
Suggested packages:
  postgresql-9.1 postgresql-doc-9.1 postgresql-server
The following packages will be REMOVED:
  libdbd-mysql-perl libmysqlclient18 mysql-client mysql-client-5.5
  mysql-common php-mdb2-driver-mysql php5-mysql roundcube-mysql
The following NEW packages will be installed:
  libpq5 php-mdb2-driver-pgsql php5-pgsql postgresql-client
  postgresql-client-9.1 postgresql-client-common roundcube-pgsql
0 upgraded, 7 newly installed, 8 to remove and 0 not upgraded.
Need to get 1192 kB of archives.
After this operation, 31.1 MB disk space will be freed.
Do you want to continue [Y/n]?

nm

  • Käyttäjä
  • Viestejä: 12920
    • Profiili
Vs: MySQL uninstall asentaa uusia paketteja?
« Vastaus #1 : 03.02.14 - klo:17.20 »
The following extra packages will be installed:
  libpq5 php-mdb2-driver-pgsql php5-pgsql postgresql-client
  postgresql-client-9.1 postgresql-client-common roundcube-pgsql
Suggested packages:
  postgresql-9.1 postgresql-doc-9.1 postgresql-server
The following packages will be REMOVED:
  libdbd-mysql-perl libmysqlclient18 mysql-client mysql-client-5.5
  mysql-common php-mdb2-driver-mysql php5-mysql roundcube-mysql
The following NEW packages will be installed:
  libpq5 php-mdb2-driver-pgsql php5-pgsql postgresql-client
  postgresql-client-9.1 postgresql-client-common roundcube-pgsql

Roundcube riippuu paketeista roundcube-mysql tai roundcube-sqlite3 tai roundcube-pgsql: http://packages.ubuntu.com/saucy/roundcube-core

Ilmeisesti et kuitenkaan ole asentanut roundcube-sqlite3-pakettia, kun Apt arpoo MySQL-riippuvuuden tilalle roundcube-pgsql:n?

Sami Lehtinen

  • Käyttäjä
  • Viestejä: 726
  • Techie
    • Profiili
    • Sami Lehtinen
Vs: MySQL uninstall asentaa uusia paketteja?
« Vastaus #2 : 03.02.14 - klo:17.33 »
Ilmeisesti et kuitenkaan ole asentanut roundcube-sqlite3-pakettia, kun Apt arpoo MySQL-riippuvuuden tilalle roundcube-pgsql:n?

Hyvin todennäköistä, koska olen jossain vaiheessa päivittänyt roundcube:n viimeisimpään versioon, jota repoista ei löytynyt. Ja tuo versio joka on repojen kautta asennettu, ei vielä tukenut edes sqlite3:sta, tämän takia siis puukotuspäivitys.

Eli konfiguraation tila on vähän epämääräinen. Pitäs varmaan pistää kamat talteen ja poistaa koko roundcuben repot ja heittää se hansmanual paikalleen.

lompolo

  • Käyttäjä
  • Viestejä: 849
    • Profiili
Vs: MySQL uninstall asentaa uusia paketteja?
« Vastaus #3 : 03.02.14 - klo:17.34 »
Pari asiaa mitkä voivat vaikuttaa ovat suositeltujen pakettien käyttäminen riippuvuuksina sekä ns. tai riippuvuudet. Joku paketti vaatii riippuvuutena jomman kumman sql-common paketin tms.

Pelkän mysql-client paketin poistaminen saattaa olla helpompaa kuin mysql-common paketin.

Koodia: [Valitse]
aptitude why mysql-commonvoisi kertoa miksi kyseinen paketti vaaditaan.