Kirjoittaja Aihe: Xubuntun kieliasetuksissa vaikeuksia [RATKAISTU]  (Luettu 6837 kertaa)

Hajakenttä

  • Käyttäjä / moderaattori
  • Viestejä: 1387
    • Profiili
Xubuntu 12.04 ei taida olla mikään finnishremix enkä täyttä suomenkielisyyttä odota muutenkaan kaikilta sovelluksilta, mutta kun jotkin sovellukset ovat espanjankielisiä niin menee hiukan haasteelliseksi. Espanjan kielipaketteja ei ole koskaan olut tässä koneessa, pelkät suomi ja englanti. Kieliasetuksien tekeminen vaikka järjestelmänlaajuisesti ei auta. Onko jotain tehtävissä vai pitääkö asennus tehdä kokonaan uudestaan?

Paneelissa olevat kello ja muistinkäytön ilmaisin ovat asetusvalikoiltaan espanjaksi. Mail-notification on asetuksiltaan ja ilmoituksiltaan espanjaksi. Muu paneelien toiminta on suomeksi.

Sovelluksista Parole pääosin espanjaksi ja muutama nappi suomeksi. Ritretto on kolmikielinen, pääosin espanjaksi mutta osin myös englanniksi ja suomeksi. Pääosa sovelluksistakin on suomeksi sentään, muutama suomentamaton englanniksi.

Äsken latasin sovellusvalikosta Ardour äänityöaseman, jonka opettelu on haasteellista jo muutenkin, ja se on kokonaan espanjankielinen. (Kehittäjän sivuston valokuvissa se on englanniksi.) Nuo edelliset voi pitää kauneusvirheinä ja niiden kanssa pärjään mutta tässä tuo espanjan opettelu tuo vaikeusastetta vähän liikaa, vaikka onkin suuri maailmankieli ja kuuluisi kai yleissivistykseen osata siinä missä englantikin.

Jossain on kuitenkin jotain vialla. Uusi Xubuntun asennus vaikka samalla uuteen jakeluun kummittelee mielessä, mutta se olisi ehkä liian helppoa ja periksi antamista. Olen kahlannut aina joutessani erilaisia asetustiedostoja, mutta ei tämä summamutikassa tunnu onnistuvan. Onko siis jotain neuvoa tähän?
« Viimeksi muokattu: 06.10.13 - klo:13.32 kirjoittanut Hajakenttä »
DELL Latitude E6220, Xubuntu 20.04
– Memento Vivere – Terv: Timo

welmar

  • Käyttäjä
  • Viestejä: 1582
    • Profiili
Vs: Xubuntun kieliasetuksissa vaikeuksia
« Vastaus #1 : 02.08.13 - klo:15.28 »
Miltä näyttää tiedostot
Koodia: [Valitse]
/etc/default/localeja
Koodia: [Valitse]
etc/locale.genJos locale.gen tiedoston #es_ES.UTF-8 UTF-8 kohdassa ei ole risuaitaa lisää se ja aja komento
Koodia: [Valitse]
sudo locale-gen Ja ota myös risuaita suomen kohdalta pois ennen tätä jos haluat suomeksi tai jos suomi puuttuu kokonaan lisää se  fi_FI.UTF-8 UTF-8

Hajakenttä

  • Käyttäjä / moderaattori
  • Viestejä: 1387
    • Profiili
Vs: Xubuntun kieliasetuksissa vaikeuksia
« Vastaus #2 : 02.08.13 - klo:16.36 »
Tämmöinen on /etc/default/locale
Lainaus
LANG="fi_FI.UTF-8"
LC_NUMERIC="fi_FI.UTF-8"
LC_TIME="fi_FI.UTF-8"
LC_MONETARY="fi_FI.UTF-8"
LC_PAPER="fi_FI.UTF-8"
LC_IDENTIFICATION="fi_FI.UTF-8"
LC_NAME="fi_FI.UTF-8"
LC_ADDRESS="fi_FI.UTF-8"
LC_TELEPHONE="fi_FI.UTF-8"
LC_MEASUREMENT="fi_FI.UTF-8"
LANGUAGE="fi:es_ES:en"
Tuo viimeinen rivi näyttää epäilyttävältä.

etc/locale.gen tiedostoa ei ole. On vaan etc/locale.alias. Siinä on lueteltu paljon kieliä ja niissä missään ei ole # merkkiä edessä.

Pitäisiköhän tehdä /etc kansioon tiedosto locale.gen? Mitähän sille sisällöksi?


EDIT:
Ajoin komennon "sudo locale-gen" ja se listasi monta en_EN.UTF-8 ja yhden fi_FI.UTF-8 eikä ytään es.

EDIT: Typo
« Viimeksi muokattu: 02.08.13 - klo:17.12 kirjoittanut Hajakenttä »
DELL Latitude E6220, Xubuntu 20.04
– Memento Vivere – Terv: Timo

welmar

  • Käyttäjä
  • Viestejä: 1582
    • Profiili
Vs: Xubuntun kieliasetuksissa vaikeuksia
« Vastaus #3 : 02.08.13 - klo:17.22 »
Kokeile muuttaa tuota viimeistä riviä LANGUAGE="fi:es_ES:en" niin että siihen jää ainoastaa suomi vaihtoehdoksi eli muotoon LANGUAGE="fi". Jos etc/locale.gen tiedostoa ei ole niin sen voi kyllä luoda ja sisällöksi riittää fi_FI.UTF-8 UTF-8 Uskon kuitenkin että riittää kun muokkaat tuon /etc/default/locale tiedoston kuntoon.

Hajakenttä

  • Käyttäjä / moderaattori
  • Viestejä: 1387
    • Profiili
Vs: Xubuntun kieliasetuksissa vaikeuksia
« Vastaus #4 : 02.08.13 - klo:21.02 »
Kaikkea kokeilin mitä keksin mutta espanjana säilyy kaikki mikä sitä oli. :(

Koska monet tätä lukevat niin kerron mitä tein:

Avasin tiedoston  /etc/default/locale pääkäyttäjänä koska muuten sitä ei voi editoida. (Tai voi editoida mutta tallennusnappi pysyy harmaana.) Käytin päätettä ja komentoa:
Koodia: [Valitse]
sudo gedit /etc/default/localeLaitoin ensin # merkin tuon viimeisen rivin eteen, jolloin se on kuin sitä ei olisikaan.
Muistin vielä tallettaa tiedoston.
Sammutin koneen ja boottasin uudelleen.
Totesin, että mikään ei mennyt epäkuntoon, mutta poistamalla ja uudelleenasentamalla Parole ja Ristretto pysyivät espanjankielisenä.

Samalla menettelyllä muutin viimeisen rivin muotoon LANGUAGE="fi"
Sammutin koneen ja käynnistin uudelleen ja kokeilin taas poistaa ja asentaa uudelleen sovelluksia. Ei parannusta.

Vielä kerran editoin muotoon LANGUAGE="fi:en" ikään kuin varmuuden vuoksi. Ei parannusta.

Loin tiedoston /etc/locale.gen pääkäyttäjänä (koska muuten hakemiston komento "luo uusi tyhjä asiakirja" on harmaana.) Käytin taas päätettä ja komentoa:
Koodia: [Valitse]
sudo nautilus /etcTyökalurivin "Tiedosto" pudotusvalikosta loin uuden asiakirjan ja sen ilmestyttyä näkyviin nimesin sen uudelleen nimellä "locale.gen" ja avasin sen Geditillä ja kirjoitin sisällöksi "fi_FI.UTF-8 UTF-8".
Nyt varmuuden vuoksi poistin em. sovellukset Synapticilla asetustiedostoineen. En tiedä onko sillä merkitystä. Vasta sitten sammutin koneen ja käynnistin uudelleen. Asensin sovellukset sovellusvarastosta ja totesin niiden olevan edelleen espanjaksi.

Mikään ei kyllä tunnu menneen rikkikään. Äänenmuokkaus työpöydäksi vaihdoin Audasityn. Se on ainakin pääosin suomeksi ja hiukan englanniksi. Olen sillä autettu tässä akuutissa ongelmassa, etenkin kun siinä on mainio ohjeistus. Tuo kummallinen espanjankielen esiintyminen silti kiusaa edelleen. Se ei poistunut noista yläpaneelin appleteistakaan vaikka niitä kuinka poistaa ja asentaa uudelleen.
DELL Latitude E6220, Xubuntu 20.04
– Memento Vivere – Terv: Timo

Jallu59

  • Käyttäjä
  • Viestejä: 3430
    • Profiili
Vs: Xubuntun kieliasetuksissa vaikeuksia
« Vastaus #5 : 02.08.13 - klo:22.08 »
Miten olisi ihan Asetukset>Kieliasetukset ja siellä suomi ylimmäiseksi. Ja sitten vielä "toteuta järjestelmänlaajuisesti". Luultavimmin ehdottaa sen jälkeen kielipakettien päivitystä.

T:Jallu59
« Viimeksi muokattu: 02.08.13 - klo:22.09 kirjoittanut Jallu59 »
Jari J. Lehtinen, Wanhempi (iki?)tietoteekkari & tietotekniikkakonsultti Turust, P4-HT / 3,0 GHz, Intel945 IGP 226MB & 4GBram & UbuntuStudio 14.04. Toshiba Satellie 50-C, i5 dual-core 2,3GHz, ubuntu-mate 16.04 LTS

oobetimer

  • Käyttäjä
  • Viestejä: 1470
    • Profiili
Vs: Xubuntun kieliasetuksissa vaikeuksia
« Vastaus #6 : 02.08.13 - klo:22.13 »
Jallun ehdotus lienee paras ja helpoin,  mutta tässä vielä lisää ohjeistusta ..  :D

http://hexample.com/2012/02/05/fixing-locale-problem-debian/

apt-get install locales
sudo locale
sudo locale -a
sudo dpkg-reconfigure locales


13/2/2009 and friday....

http://debian-fi.dy.fi/

Hajakenttä

  • Käyttäjä / moderaattori
  • Viestejä: 1387
    • Profiili
Vs: Xubuntun kieliasetuksissa vaikeuksia
« Vastaus #7 : 03.08.13 - klo:11.51 »
Normaalia asetukset > kieliasetukset sovellusta olen komentanut jo moneen kertaan ja järjestelmänlaajuisesti myös. Tein sen varmuuden vuoksi jälleen kerran kun on tässä tehty noita muutoksiakin. Siitä näkyy ensimmäisenä suomi ja toisena englanti, espanjaa ei ole. Sen jälkeen sammutin koneen ja käynnistin. Ei muutosta.  :(

Koodia: [Valitse]
apt-get install localesTämä tietysti näyttää ainakin tilanteen, joten ajoin sen. Sehän tarvitsee myös sudon eteensä, mutta tein oheisella tavalla, jotta näette asian hassun puolen.
Koodia: [Valitse]
timo@timpat:~$ apt-get install locales
E: Lukkotiedostoa /var/lib/dpkg/lock ei voitu avata - open (13: Lupa evätty)
E: No se encontró un archivo de réplica «/var/lib/dpkg/»
timo@timpat:~$ sudo apt-get install locales
[sudo] password for timo:
Luetaan pakettiluetteloita... Valmis
Muodostetaan riippuvuussuhteiden puu      
Luetaan tilatiedot... Valmis        
locales on jo uusin versio.
0 päivitetty, 0 uutta asennusta, 0 poistettavaa ja 0 päivittämätöntä.
timo@timpat:~$
Hassua siis on tuo espanjaksi esitetty huomautus.

Seuraavaksi ajoin sudo locale komennon ja siitä näkyykin jo virheen jälkiä: "LANGUAGE=fi:es_ES:en".
Koodia: [Valitse]
timo@timpat:~$ sudo locale
LANG=fi_FI.UTF-8
LANGUAGE=fi:es_ES:en
LC_CTYPE="fi_FI.UTF-8"
LC_NUMERIC=fi_FI.UTF-8
LC_TIME=fi_FI.UTF-8
LC_COLLATE="fi_FI.UTF-8"
LC_MONETARY=fi_FI.UTF-8
LC_MESSAGES="fi_FI.UTF-8"
LC_PAPER=fi_FI.UTF-8
LC_NAME=fi_FI.UTF-8
LC_ADDRESS=fi_FI.UTF-8
LC_TELEPHONE=fi_FI.UTF-8
LC_MEASUREMENT=fi_FI.UTF-8
LC_IDENTIFICATION=fi_FI.UTF-8
LC_ALL=
timo@timpat:~$

sudo locale -a näyttää aika johdonmukaiselta. Ainakaan siinä ei espanjaa esiinny.
Koodia: [Valitse]
timo@timpat:~$ sudo locale -a
C
C.UTF-8
en_AG
en_AG.utf8
en_AU.utf8
en_BW.utf8
en_CA.utf8
en_DK.utf8
en_GB.utf8
en_HK.utf8
en_IE.utf8
en_IN
en_IN.utf8
en_NG
en_NG.utf8
en_NZ.utf8
en_PH.utf8
en_SG.utf8
en_US.utf8
en_ZA.utf8
en_ZM
en_ZM.utf8
en_ZW.utf8
fi_FI.utf8
POSIX
zh_CN.utf8
zh_SG.utf8
timo@timpat:~$

Seuraavaksi ajoin sudo dpkg-reconfigure locales ja heti perään sudo locale nähdäkseni tekikö reconfigure mitään, ei tainnut tehdä.
Koodia: [Valitse]
timo@timpat:~$ sudo dpkg-reconfigure locales
Generating locales...
  en_AG.UTF-8... up-to-date
  en_AU.UTF-8... up-to-date
  en_BW.UTF-8... up-to-date
  en_CA.UTF-8... up-to-date
  en_DK.UTF-8... up-to-date
  en_GB.UTF-8... up-to-date
  en_HK.UTF-8... up-to-date
  en_IE.UTF-8... up-to-date
  en_IN.UTF-8... up-to-date
  en_NG.UTF-8... up-to-date
  en_NZ.UTF-8... up-to-date
  en_PH.UTF-8... up-to-date
  en_SG.UTF-8... up-to-date
  en_US.UTF-8... up-to-date
  en_ZA.UTF-8... up-to-date
  en_ZM.UTF-8... up-to-date
  en_ZW.UTF-8... up-to-date
  fi_FI.UTF-8... up-to-date
Generation complete.
timo@timpat:~$ sudo locale
LANG=fi_FI.UTF-8
LANGUAGE=fi:es_ES:en
LC_CTYPE="fi_FI.UTF-8"
LC_NUMERIC=fi_FI.UTF-8
LC_TIME=fi_FI.UTF-8
LC_COLLATE="fi_FI.UTF-8"
LC_MONETARY=fi_FI.UTF-8
LC_MESSAGES="fi_FI.UTF-8"
LC_PAPER=fi_FI.UTF-8
LC_NAME=fi_FI.UTF-8
LC_ADDRESS=fi_FI.UTF-8
LC_TELEPHONE=fi_FI.UTF-8
LC_MEASUREMENT=fi_FI.UTF-8
LC_IDENTIFICATION=fi_FI.UTF-8
LC_ALL=
timo@timpat:~$

Koitin vielä mitä tekee tuo locale-gen ja sen perään katsoin muuttuiko sudo locale luettelo, ei muuttunut.
Koodia: [Valitse]
timo@timpat:~$ sudo locale-gen fi_FI.UTF-8
Generating locales...
  fi_FI.UTF-8... up-to-date
Generation complete.
timo@timpat:~$ sudo locale-gen en_EN.UTF-8
timo@timpat:~$ sudo locale
LANG=fi_FI.UTF-8
LANGUAGE=fi:es_ES:en
LC_CTYPE="fi_FI.UTF-8"
LC_NUMERIC=fi_FI.UTF-8
LC_TIME=fi_FI.UTF-8
LC_COLLATE="fi_FI.UTF-8"
LC_MONETARY=fi_FI.UTF-8
LC_MESSAGES="fi_FI.UTF-8"
LC_PAPER=fi_FI.UTF-8
LC_NAME=fi_FI.UTF-8
LC_ADDRESS=fi_FI.UTF-8
LC_TELEPHONE=fi_FI.UTF-8
LC_MEASUREMENT=fi_FI.UTF-8
LC_IDENTIFICATION=fi_FI.UTF-8
LC_ALL=
timo@timpat:~$

Nyt lähetän tämän ja teen uuden käynnistyksen ja jatkan tähän sitten.

JATKOA:
Ei tullut muutosta näillä konsteilla. Katsoin myös /etc/default/locale tiedoston ja sen sisältö oli jälleen tässä muodossa vaikka sen juuri korjasin viimeisen rivin osalta. Onkohan vielä joku tiedosto, josta asiaa voisi vääntää kohdalleen?
Koodia: [Valitse]
LANG="fi_FI.UTF-8"
LC_NUMERIC="fi_FI.UTF-8"
LC_TIME="fi_FI.UTF-8"
LC_MONETARY="fi_FI.UTF-8"
LC_PAPER="fi_FI.UTF-8"
LC_IDENTIFICATION="fi_FI.UTF-8"
LC_NAME="fi_FI.UTF-8"
LC_ADDRESS="fi_FI.UTF-8"
LC_TELEPHONE="fi_FI.UTF-8"
LC_MEASUREMENT="fi_FI.UTF-8"
LANGUAGE="fi:es_ES:en"

EDIT: Typo

EDIT 2: Niin, tosiaankaan ei tule mitään virheilmoituksia missään, kielet vaan ovat jotenkin väärin lajiltaan, eivät vissiinkään asetustavaltaan, tai sitten on jokin ristiriita, josta väärä kieli on olevinaan ensisijainen. ::)
« Viimeksi muokattu: 03.08.13 - klo:12.13 kirjoittanut Hajakenttä »
DELL Latitude E6220, Xubuntu 20.04
– Memento Vivere – Terv: Timo

oobetimer

  • Käyttäjä
  • Viestejä: 1470
    • Profiili
Vs: Xubuntun kieliasetuksissa vaikeuksia
« Vastaus #8 : 03.08.13 - klo:16.15 »
/etc/default/locale tiedostossa riittää kun on vain yksi rivi, jossa sisältönä on LANG="fi_FI.UTF-8"
13/2/2009 and friday....

http://debian-fi.dy.fi/

Hajakenttä

  • Käyttäjä / moderaattori
  • Viestejä: 1387
    • Profiili
Vs: Xubuntun kieliasetuksissa vaikeuksia
« Vastaus #9 : 03.08.13 - klo:20.09 »
/etc/default/locale tiedostossa riittää kun on vain yksi rivi, jossa sisältönä on LANG="fi_FI.UTF-8"

Joo, huomasin tuon kun lunttasin toisesta koneesta. Muutin sen sisällön tuollaiseksi ja poistin Parolen ja käynnistin koneen uudelleen ja asensin Parolen takaisin ja se on edelleen espanjaksi.

Tarkistin vielä, että /etc/default/locale sisältö on varmasti tuo muutettu yksirivinen. Sitten tein asetukset > kieliasetukset > järjestelmänlaajuisesti asetuksen ja katsoin heti perään taas locale tiedoston ja sepä olikin palautunut entiselleen. Vain rivien järjestys on muuttunut. Entinen viimeinen rivi, se murheenkryyni, on nyt toiseksi ylimpänä.   :(
Koodia: [Valitse]
LANG="fi_FI.UTF-8"
LANGUAGE="fi:es_ES:en"
LC_NUMERIC="fi_FI.UTF-8"
LC_TIME="fi_FI.UTF-8"
LC_MONETARY="fi_FI.UTF-8"
LC_PAPER="fi_FI.UTF-8"
LC_IDENTIFICATION="fi_FI.UTF-8"
LC_NAME="fi_FI.UTF-8"
LC_ADDRESS="fi_FI.UTF-8"
LC_TELEPHONE="fi_FI.UTF-8"
LC_MEASUREMENT="fi_FI.UTF-8"

Joku asetus varmaankin määrää tuon sisällön jostain muualta, mutta mikä?
DELL Latitude E6220, Xubuntu 20.04
– Memento Vivere – Terv: Timo

Hajakenttä

  • Käyttäjä / moderaattori
  • Viestejä: 1387
    • Profiili
Vs: Xubuntun kieliasetuksissa vaikeuksia
« Vastaus #10 : 03.08.13 - klo:21.31 »
Tein sellaisen epätoivoisen yritelmän, että asensin asetukset > kieliasetukset > lisää/poista kieliä työkalulla espanjan yhdeksi lisäkieleksi. Hyvin se sinne tuli suomen ja englannin väliin. Sitten poistin sen siinä toivossa, että se poistaminen ylettyisi noihin kuokkavieraisiinkin, mutta epä se mitään muuttanut.  :(
DELL Latitude E6220, Xubuntu 20.04
– Memento Vivere – Terv: Timo

oobetimer

  • Käyttäjä
  • Viestejä: 1470
    • Profiili
Vs: Xubuntun kieliasetuksissa vaikeuksia
« Vastaus #11 : 03.08.13 - klo:22.33 »
 ::) :o --->
http://askubuntu.com/questions/162391/how-do-i-fix-my-locale-issue

 
Lainaus
Nothing suggested above worked in my case (Ubuntu Server 12.04LTS). What finally helped was putting to the file /etc/environment:
LC_ALL=en_US.UTF-8
LANG=en_US.UTF-8

For some reason it was missing. The outputs for locale and other commands appeared like the variables were properly defined. In other words don't take for granted all the basic stuff is declared where it should be declared.
13/2/2009 and friday....

http://debian-fi.dy.fi/

Hajakenttä

  • Käyttäjä / moderaattori
  • Viestejä: 1387
    • Profiili
Vs: Xubuntun kieliasetuksissa vaikeuksia
« Vastaus #12 : 04.08.13 - klo:22.14 »
Tuo mainittu /etc/environment tiedosto on oheisen näköinen:
Koodia: [Valitse]
PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games"
LC_NUMERIC="fi_FI.UTF-8"
LC_TIME="fi_FI.UTF-8"
LC_MONETARY="fi_FI.UTF-8"
LC_PAPER="fi_FI.UTF-8"
LC_IDENTIFICATION="fi_FI.UTF-8"
LC_NAME="fi_FI.UTF-8"
LC_ADDRESS="fi_FI.UTF-8"
LC_TELEPHONE="fi_FI.UTF-8"
LC_MEASUREMENT="fi_FI.UTF-8"
LANGUAGE="fi:es_ES:en"
LANG="fi_FI.UTF-8"
Siinäkin kummittelee tuo rivi LANGUAGE="fi:es_ES:en" joka kovasti kummastuttaa. Muutin sen kuten muutin myös /etc/default/locale tiedostosta saman rivin. Oikeastaan sen tiedoston tyhjensin kokonaan ja tein vain sen ainoan ja oikean rivin sinne. Se ei vielä muuttanut mitään.

Ajoin päätteessä vielä komenneon:
Koodia: [Valitse]
sudo dpkg-reconfigure localesSekään ei muuttanut vielä mitään, vaikka sen tuloste näyttikin ihan asialliselta. Espanjan kieli siis jäi silti paikkoihin, joihinn se ei kuulu.

Sammutin koneen ja käynnistin uudelleen ja tilanne pysyi smana. Tarkistin vielä em. tiedostojen sisällöt ja ne olivat edelleen korjatussa muodossaan.

Kun en muutakaan keksinyt niin avasin asetukset > kieliasetukset ja painoin painiketta "toteuta järjestelmänlaajuisesti". Kielet eivät muuttuneet miksikään, mutta nuo em. tiedostot "locale" ja "environment" palautuivat jälleen alkuperäiseen asuunsa, eli niissä on taas tuo rivi LANGUAGE="fi:es_ES:en".  :(

Tämä kauneusvika on ollut tässä koneessa alusta asti, siis viime syksystä kun asennuksen tein. Mitään virheilmoituksia se ei ole aiheuttanut. Olen sitä aina välillä yrittänyt selvittää, mutta olemattomalla menestyksellä. Ilmeisesti aivan tällaista ei muissa Xubuntuissa ole ollut. Asennuksen tein Ubuntu-Suomen sivulta ladatusta 12.04 Xubuntun .iso tiedostosta SD-kortti-asennuksena. Sillä kortilla on asennettu toinenkin kone ja siinä ei ole tätä vikaa.
DELL Latitude E6220, Xubuntu 20.04
– Memento Vivere – Terv: Timo

Hajakenttä

  • Käyttäjä / moderaattori
  • Viestejä: 1387
    • Profiili
Vs: Xubuntun kieliasetuksissa vaikeuksia
« Vastaus #13 : 18.08.13 - klo:16.17 »
Koodia: [Valitse]
Heh! Myös pääte näyttää toisinaan vaihtavan kieltä.
[code0 päivitetty, 0 uutta asennusta, 1 poistettavaa ja 0 päivittämätöntä.
Toiminnon jälkeen vapautuu 32,8 k t levytilaa.
Haluatko jatkaa [K/e]? k
(Luetaan tietokantaa... 192850 ficheros o directorios instalados actualmente.)
Poistetaan pakettia jackd...
Luetaan pakettiluetteloita... Valmis
Muodostetaan riippuvuussuhteiden puu       
Luetaan tilatiedot... Valmis       
Del firefox-locale-es 22.0+build2-0ubuntu0.12.04.2 [1 032 kB]
]

"firefox-locale-es 22.0+build2-0ubuntu0.12.04.2" pakettia ei järjestelmässä ole, eikä muutakaan "firefox-locale-es" pakettia, eikä myöskään mitään "locale-es" pakettia.
DELL Latitude E6220, Xubuntu 20.04
– Memento Vivere – Terv: Timo

Master

  • Vieras
Vs: Xubuntun kieliasetuksissa vaikeuksia
« Vastaus #14 : 18.08.13 - klo:19.48 »
Koodia: [Valitse]
Heh! Myös pääte näyttää toisinaan vaihtavan kieltä.
[code0 päivitetty, 0 uutta asennusta, 1 poistettavaa ja 0 päivittämätöntä.
Toiminnon jälkeen vapautuu 32,8 k t levytilaa.
Haluatko jatkaa [K/e]? k
(Luetaan tietokantaa... 192850 ficheros o directorios instalados actualmente.)
Poistetaan pakettia jackd...
Luetaan pakettiluetteloita... Valmis
Muodostetaan riippuvuussuhteiden puu       
Luetaan tilatiedot... Valmis       
Del firefox-locale-es 22.0+build2-0ubuntu0.12.04.2 [1 032 kB]
]

"firefox-locale-es 22.0+build2-0ubuntu0.12.04.2" pakettia ei järjestelmässä ole, eikä muutakaan "firefox-locale-es" pakettia, eikä myöskään mitään "locale-es" pakettia.

Tässä Ubuntu koneessa olen käyttänyt alla olevaa komentoa.
Välilyönnillä merkkaan suomi komponentit ja muut poistetaan aina asennuksissa ja päivityksissä.
Kieli asetuksissa on vain Suomi ja Suomi näkyy valikoissa aina jos ne on käännetty Suomeksi.

sudo apt-get install localepurge

Hajakenttä

  • Käyttäjä / moderaattori
  • Viestejä: 1387
    • Profiili
Vs: Xubuntun kieliasetuksissa vaikeuksia
« Vastaus #15 : 06.10.13 - klo:13.32 »
Palasin taas tähän aiheeseen kun taas uutta sovellusta asentaessa se tuli espanjankielisenä. Pientä kauneusvirhettä olen tässä sietänyt ja olin jo asennoitunut asentamaan uuden Ubuntun (SS) kunhan se kohta julkaistaan. Nyt en löydäkään mitään kunnon syytä jakelun vaihtoon, koska sain vian korjattua. Kiitos siitä Masterille.  :)

Koodia: [Valitse]
sudo apt-get install localepurge
Tämä komento korjasi asian. Siitä aukesi tekstipohjainen sovellus (espanjaksi) ja siinä oli ruksit aivan oikeissa paikoissa vain suomen kohdalla. Mitään en muuttanut. Painoin vain enteriä.

Muutama sovellus muuttui heti suomeksi/englanniksi, kuten kellon asetukset ja totem. Muutamat piti asentaa uusiksi ja vieläpä siten, että ensin poistin ja tein koneelle uudelleenkäynnistyksen ja asensin takaisin. Vasta sitten, useiden kokeilujen jälkeen, sain korjattua suomeksi/englanniksi sellaiset, kuten mail-notification, keepassx, ristretto.

Nyt on asia ratkaistu. Kiitos kaikille avusta ja anteeksi kun vähän meni aikaa.  ;D
DELL Latitude E6220, Xubuntu 20.04
– Memento Vivere – Terv: Timo