Kirjoittaja Aihe: [Ratkaistu]Kaffeine ja Dvb ei näytä tv kuvaa  (Luettu 2156 kertaa)

matsukan

  • Käyttäjä
  • Viestejä: 2024
    • Profiili
Mikään kanava ei toimi mutta kanavalistaus haetaan kyllä. Kanavien vaihtamien ei toimi.

Lainaus
dmesg | grep -i dvb
[   10.854585] DVB: registering new adapter (Mantis DVB adapter)
[   11.736184] DVB: registering adapter 0 frontend 0 (Philips TDA10023 DVB-C)...

ja
Lainaus
lscpi

05:00.0 Multimedia controller: Twinhan Technology Co. Ltd Mantis DTV PCI Bridge Controller [Ver 1.0] (rev 01)

Onko kellään vinkkiä siitä mistä pitäisi lähteä purkamaan ja etsimään vikaa?

Mitään virhelokia ei tulostu ainakaan dmesg ja syslogiin.

Lainaus
scan -c
using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'
WARNING: filter timeout pid 0x0011
WARNING: filter timeout pid 0x0000
dumping lists (0 services)
Done.
« Viimeksi muokattu: 17.06.12 - klo:22.06 kirjoittanut syrtek66 »
Pohjois-pohjanmaa
-- motto:  backupin tarve huomataan aina liian myöhään

jarmala

  • Käyttäjä
  • Viestejä: 468
    • Profiili
Vs: Kaffeine ja Dvb ei näytä tv kuvaa
« Vastaus #1 : 29.05.12 - klo:00.43 »
Mikään kanava ei toimi mutta kanavalistaus haetaan kyllä. Kanavien vaihtamien ei toimi.

Enpä tiedä, mutta minulla on ikivanha kortti ja toimii kuin junan vessa.

ari@ari:~$ dmesg | grep -i dvb
[   11.780129] DVB: registering new adapter (FlexCop Digital TV device)
[   13.659523] b2c2-flexcop: found 'Zarlink MT352 DVB-T' .
[   13.659526] DVB: registering adapter 0 frontend 0 (Zarlink MT352 DVB-T)...
[   13.659581] b2c2-flexcop: initialization of 'Air2PC/AirStar 2 DVB-T' at the 'PCI' bus controlled by a 'FlexCopIIb' complete
ari@ari:~$ lspci
03:00.0 Network controller: Techsan Electronics Co Ltd B2C2 FlexCopII DVB chip / Technisat SkyStar2 DVB card (rev 02)

T. Ari

Ubuntu 18.04 LTS, Gnome Flashback Metacity, Xeon E3-1245 V2, 8 GB

welmar

  • Käyttäjä
  • Viestejä: 1582
    • Profiili
Vs: Kaffeine ja Dvb ei näytä tv kuvaa
« Vastaus #2 : 29.05.12 - klo:11.03 »
Veikkaisin ettei modulit lataudu kokeile
Koodia: [Valitse]
sudo modprobe tda10023; sudo modprobe mantisJos tämä autaa lisää tda10023 ja mantis /etc/modules tiedostoon. Lspci:llä saat tarkempaa tietoa mitkä ajurit ja modulit on käytössä kun lisäät -vvn loppuun
Koodia: [Valitse]
lspci -vvn Mutta ajurit taitaa olla kunnossa jos kaffeine löytää kortin.
« Viimeksi muokattu: 29.05.12 - klo:11.29 kirjoittanut welmar »

matsukan

  • Käyttäjä
  • Viestejä: 2024
    • Profiili
Vs: Kaffeine ja Dvb ei näytä tv kuvaa
« Vastaus #3 : 29.05.12 - klo:11.35 »
Juu kanavia löytyy mutta program guide on tyhjä.
esim tässä kaffeine ilmoittaa yle:sta :
Pohjois-pohjanmaa
-- motto:  backupin tarve huomataan aina liian myöhään

welmar

  • Käyttäjä
  • Viestejä: 1582
    • Profiili
Vs: Kaffeine ja Dvb ei näytä tv kuvaa
« Vastaus #4 : 29.05.12 - klo:12.08 »
Tuli sellainenkin mieleen että tuolla kortilla ei saa muistaakseni minkäänlaista kuvaa jos kortinlukija on kiinni. Kyseessä lienee terratec cinergy C kortti?

matsukan

  • Käyttäjä
  • Viestejä: 2024
    • Profiili
Vs: Kaffeine ja Dvb ei näytä tv kuvaa
« Vastaus #5 : 29.05.12 - klo:12.30 »
Juu muttei kortinlukijaa.

Missä olisi ohjeet channel.conf:n tekemiseen koska asun alueella jossa ei varsinaisesti ole valmiiksi tuota fi-*** tiedostoa.
Pohjois-pohjanmaa
-- motto:  backupin tarve huomataan aina liian myöhään

matsukan

  • Käyttäjä
  • Viestejä: 2024
    • Profiili
Vs: Kaffeine ja Dvb ei näytä tv kuvaa
« Vastaus #6 : 02.06.12 - klo:22.26 »
Loppujen lopuksi tein tuon fi-* tiedoston ja sen jälkeen tein mplayerille channels.conf tiedoston ohjeiden mukaisesti ja teevee kuvaa ulos kortista.

Mtv3 tuotti seuraavankaltaista tekstiä mutta FOX toistui ongelmitta


Lainaus
VIDEO MPEG2(pid=1259) AUDIO MPA(pid=3276) NO SUBS (yet)!  PROGRAM N. 0
VIDEO:  MPEG2  720x576  (aspect 3)  25.000 fps  4000.0 kbps (500.0 kbyte/s)
Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file or directory
[vdpau] Error when calling vdp_device_create_x11: 1
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
libavcodec version 53.35.0 (external)
Mismatching header version 53.32.2
Selected video codec: [ffmpeg2] vfm: ffmpeg (FFmpeg MPEG-2)
==========================================================================
==========================================================================
Requested audio codec family [mpg123] (afm=mpg123) not available.
Enable it at compilation.
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 48000 Hz, 2 ch, floatle, 256.0 kbit/8.33% (ratio: 32000->384000)
Selected audio codec: [ffmp2float] afm: ffmpeg (FFmpeg MPEG layer-1 and layer-2 audio)
==========================================================================
AO: [pulse] 48000Hz 2ch floatle (4 bytes per sample)
Starting playback...
Unsupported PixelFormat 61
Unsupported PixelFormat 53
Unsupported PixelFormat 81
Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
VO: [xv] 720x576 => 1024x576 Planar YV12
A:2167.2 V:2167.7 A-V: -0.452 ct: -0.080  24/ 24 15%  0% 49.5% 10 0
[mp2float @ 0x7f2b1d7784c0]Header missing
[mp2float @ 0x7f2b1d7784c0]Header missing
[mpeg2video @ 0x7f2b1d7784c0]ac-tex damaged at 6 13
[mpeg2video @ 0x7f2b1d7784c0]Warning MVs not available
[mpeg2video @ 0x7f2b1d7784c0]concealing 0 DC, 0 AC, 0 MV errors
A:2172.3 V:2169.3 A-V:  2.950 ct: -0.244  65/ 65  9%  0% 208.1% 50 0


           ************************************************
           **** Your system is too SLOW to play this!  ****
           ************************************************

Possible reasons, problems, workarounds:
- Most common: broken/buggy _audio_ driver
  - Try -ao sdl or use the OSS emulation of ALSA.
  - Experiment with different values for -autosync, 30 is a good start.
- Slow video output
  - Try a different -vo driver (-vo help for a list) or try -framedrop!
- Slow CPU
  - Don't try to play a big DVD/DivX on a slow CPU! Try some of the lavdopts,
    e.g. -vfm ffmpeg -lavdopts lowres=1:fast:skiploopfilter=all.
- Broken file
  - Try various combinations of -nobps -ni -forceidx -mc 0.
- Slow media (NFS/SMB mounts, DVD, VCD etc)
  - Try -cache 8192.
- Are you using -cache to play a non-interleaved AVI file?
  - Try -nocache.
Read DOCS/HTML/en/video.html for tuning/speedup tips.
If none of this helps you, read DOCS/HTML/en/bugreports.html.

A:2179.6 V:2171.8 A-V:  7.780 ct: -0.488 126/126  7%  0% 248.0% 111 0
No bind found for key 'MOUSE_BTN2'.
A:2260.7 V:2198.7 A-V: 61.992 ct: -0.529 800/800  5%  0% 287.0% 785 0

Exiting... (Quit)
i:~/.mplayer$ mplayer "dvb://FOX"MPlayer svn r34540 (Ubuntu), built with gcc-4.6 (C) 2000-2012 MPlayer Team
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing dvb://FOX.
dvb_tune Freq: 250000000
TS file format detected.
VIDEO MPEG2(pid=2000) AUDIO MPA(pid=2100) NO SUBS (yet)!  PROGRAM N. 0
VIDEO:  MPEG2  720x576  (aspect 3)  25.000 fps  10000.0 kbps (1250.0 kbyte/s)
Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file or directory
[vdpau] Error when calling vdp_device_create_x11: 1
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
libavcodec version 53.35.0 (external)
Mismatching header version 53.32.2
Selected video codec: [ffmpeg2] vfm: ffmpeg (FFmpeg MPEG-2)

Kortti ainakin toimii mikä on tärkeintä.
Pohjois-pohjanmaa
-- motto:  backupin tarve huomataan aina liian myöhään

matsukan

  • Käyttäjä
  • Viestejä: 2024
    • Profiili
Vs: Kaffeine ja Dvb ei näytä tv kuvaa
« Vastaus #7 : 04.06.12 - klo:22.02 »
Niin tietenkin terminaalissa tulee tätä kun käynnistää kaffeine :

Lainaus
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave
.

Oisko kenelläkkään korjausehdostusta:

https://bugs.launchpad.net/ubuntu/+source/kde4libs/+bug/959151
https://git.reviewboard.kde.org/r/103699/
Pohjois-pohjanmaa
-- motto:  backupin tarve huomataan aina liian myöhään

matsukan

  • Käyttäjä
  • Viestejä: 2024
    • Profiili
Vs: Kaffeine ja Dvb ei näytä tv kuvaa
« Vastaus #8 : 17.06.12 - klo:22.06 »
solved

poistin .kde hakemiston ja ilmeisesti se ratkaisi ongelman.
Pohjois-pohjanmaa
-- motto:  backupin tarve huomataan aina liian myöhään