Kirjoittaja Aihe: DraftSight ei asennu  (Luettu 2599 kertaa)

pemo

  • Käyttäjä
  • Viestejä: 111
    • Profiili
DraftSight ei asennu
« : 12.04.12 - klo:18.36 »
Minulla on Ubuntu 11.10 johonka halusin asentaa autocad ohjelman, PC on 32 bittinen kone.
Latasin draftsight 2012.1.1177 paketin, mutta se ei suostu asentumaa olenkaan. Antaa virhe
ilmoituksia, mutta ne kertova hyvin vähän. Tarvitsen apua / neuvoja kunka sen saisi asentumaan.

Virhe ilmoitus:
Luetaan tietokantaa... 275602 files and directories currently installed.)
Puretaan pakettia dassault-systemes-draftsight (.../Lataukset/draftSight.deb)...
No protocol specified

(ShowLicence:2230): Gtk-WARNING **: cannot open display: :0.0
dpkg: virhe ksiteltess /home/linpemo/Lataukset/draftSight.deb (--install):
 aliprosessi uusi pre-installation-komentosarja palautti virhetilakoodin 1
Ksittelyss tapahtui liian monta virhett:
 /home/linpemo/Lataukset/draftSight.deb

SuperOscar

  • Käyttäjä
  • Viestejä: 3581
  • Tänään täällä, huomenna poissa
    • Profiili
    • Legisign.org
Vs: DraftSight ei asennu
« Vastaus #1 : 12.04.12 - klo:18.48 »
Miten yrität pakettia asentaa? ”sudo dpkg -i paketin_nimi” vai jollakin graafisella kikkareella? Virheilmoitus ”cannot open display: :0.0” viittaa siihen, että (ilmeisesti sudona käyttämäsi) pääkäyttäjätunnus ei saa yhteyttä X:ään.
openSUSE Leap 15.2 (pöytäkone 1, kannettavat 1, 2 & 3), openSUSE Tumbleweed (pöytäkone 2), LibreELEC 8.2.5 (RPi 1), Raspbian GNU/Linux 10 (RPi 2)

pemo

  • Käyttäjä
  • Viestejä: 111
    • Profiili
Vs: DraftSight ei asennu
« Vastaus #2 : 12.04.12 - klo:20.31 »
Taisin avata sen "graafisella kikkareella", komentopohjainen tapahtuma ei ole
niin hyvin hallussa että uskaltis käyttää sitä. Tämä file "draftSight.deb" on
oletuskansiossa, eli "Lataukset". Pitäskö sen file olla jossain toisessa kansiossa?

SuperOscar

  • Käyttäjä
  • Viestejä: 3581
  • Tänään täällä, huomenna poissa
    • Profiili
    • Legisign.org
Vs: DraftSight ei asennu
« Vastaus #3 : 12.04.12 - klo:21.10 »
Taisin avata sen "graafisella kikkareella", komentopohjainen tapahtuma ei ole
niin hyvin hallussa että uskaltis käyttää sitä. Tämä file "draftSight.deb" on
oletuskansiossa, eli "Lataukset". Pitäskö sen file olla jossain toisessa kansiossa?

Kansiolla ei (välttämättä) ole merkitystä, mutta käsittääkseni juuri graafisesta kikkareesta käsin voi käydä noin: root-oikeudetkaan eivät ikään kuin riitä siihen, että sinulta varastettaisiin X-ikkunoiden käyttöoikeus. Sen sai korjatuksi ainakin xset-komennolla – mutta tämä pitää antaa komentoriviltä :)

Äkkiseltään sanoisin, että helpoimmalla pääset uskaltautumalla hitusen komentoriville. Luultavasti käyttämästäsi tiedostonhallinnasta (Nautilus?) saa helposti avatuksi päätteen oikeaan kansioon. Sitten päätteeseen vain komento:

Koodia: [Valitse]
sudo dpkg -i draftSight.deb
Jos saat päätteen avattua oikeaan kansioon, deb-tiedostoon ei tarvitse eteen kirjoittaa polkuakaan.
openSUSE Leap 15.2 (pöytäkone 1, kannettavat 1, 2 & 3), openSUSE Tumbleweed (pöytäkone 2), LibreELEC 8.2.5 (RPi 1), Raspbian GNU/Linux 10 (RPi 2)

pemo

  • Käyttäjä
  • Viestejä: 111
    • Profiili
Vs: DraftSight ei asennu
« Vastaus #4 : 12.04.12 - klo:21.31 »
Suuret kiitokset Autocadi lähti tomimaan. Taidot riitti
siirtymiseen oikaan kansioon. Komentopohjainen kokemus
oli dos "cd" ajalta siitä oli apua. Pitää harjotella linux komentoja
saavuttaakseen autavan tason, eiköhän tulevaisuudessa pärjätä
paremmin.

Jukki

  • Käyttäjä
  • Viestejä: 407
    • Profiili
Vs: DraftSight ei asennu
« Vastaus #5 : 16.04.12 - klo:11.39 »
Kiva kun pääsit meidän DraftSight-käyttäjien joukkoon. Ihan loistava ohjelma. En ole tarvinnut AutoCadLT:täni enää asennettuani DraftSightin. Yhtäkaikki tekee samat peruspiirtämiset.

Minulla oli ongelma näytönohjaimen hitauden kanssa. Panorointi ja zuumaus oli yhtä tökkimistä. Ongelma poistui vaihtamalla ATI-ohjaimen linux-ajuri suljettuihin.

pemo

  • Käyttäjä
  • Viestejä: 111
    • Profiili
Vs: DraftSight ei asennu
« Vastaus #6 : 03.11.13 - klo:12.24 »
Mikä nyt menee pielen asennuksessa? Onko tämä paketti "libexpat1" ok, vai onko
DraftSight.deb paketissa jotain ongelmaa?
Alla kopiot pakettihallinasta ja terminallista.

Xfce-työympäristö
Versio: 4.10, jakelu Xubuntu
---------------------------------------------------
Synaptic pakettihalinta
(Luetaan tietokantaa... 518006 files and directories currently installed.)
Valmistellaan paketin libexpat1:amd64 2.1.0-1ubuntu1 vaihtamista (käyttäen pakettia .../libexpat1_2.1.0-1ubuntu1_amd64.deb)...
Puretaan korvaavaa libexpat1:amd64-pakettia...
Tehdään asetuksia: libexpat1:amd64 (2.1.0-1ubuntu1) ...
Suoritetaan kohteen libc-bin liipaisimia...
ldconfig deferred processing now taking place
-----------------------------------------------------
sudo dpkg -i draftSight.deb
dpkg: regarding draftSight.deb containing dassault-systemes-draftsight, pre-dependency problem:
 Paketin dassault-systemes-draftsight asennus tarvitsee paketin libexpat1 (>= 2.0.1-4)

dpkg: error processing draftSight.deb (--install):
 asennusriippuvuusongelma - ei asenneta dassault-systemes-draftsight
Käsittelyssä tapahtui liian monta virhettä:
 draftSight.deb
permor@permor-EB1012:~/Lataukset$ sudo dpkg -i draftSight.deb
dpkg: regarding draftSight.deb containing dassault-systemes-draftsight, pre-dependency problem:
 Paketin dassault-systemes-draftsight asennus tarvitsee paketin libexpat1 (>= 2.0.1-4)

dpkg: error processing draftSight.deb (--install):
 asennusriippuvuusongelma - ei asenneta dassault-systemes-draftsight
Käsittelyssä tapahtui liian monta virhettä:
 draftSight.deb

nm

  • Käyttäjä
  • Viestejä: 13709
    • Profiili
Vs: DraftSight ei asennu
« Vastaus #7 : 03.11.13 - klo:13.27 »
Mikä nyt menee pielen asennuksessa? Onko tämä paketti "libexpat1" ok, vai onko
DraftSight.deb paketissa jotain ongelmaa?

draftSight.deb on 32-bittinen paketti, joten se vaatii 32-bittiset riippuvuudet. 64-bittisessä järjestelmässä pakettien nimiin on lisättävä määre ":i386":

Koodia: [Valitse]
sudo apt-get install libexpat1:i386

pemo

  • Käyttäjä
  • Viestejä: 111
    • Profiili
Vs: DraftSight ei asennu
« Vastaus #8 : 03.11.13 - klo:15.05 »
Nyt pyytää vielä lisää paketteja "libglib2", Synaptic pakettihalinta en löytänyt tämän nimistä
pakettia.
Onko Xfce-työympäristö liian kevyt ubuntu, kun tuntuu puuttuvan tärkeitä paketteja?
-----------------------------------------------------------------------------------
dpkg: regarding draftSight.deb containing dassault-systemes-draftsight, pre-dependency problem:
 Paketin dassault-systemes-draftsight asennus tarvitsee paketin libglib2.0-0 (>= 2.22.3-0)

dpkg: error processing draftSight.deb (--install):
 asennusriippuvuusongelma - ei asenneta dassault-systemes-draftsight
Käsittelyssä tapahtui liian monta virhettä:
 draftSight.deb

nm

  • Käyttäjä
  • Viestejä: 13709
    • Profiili
Vs: DraftSight ei asennu
« Vastaus #9 : 03.11.13 - klo:15.44 »
Nyt pyytää vielä lisää paketteja "libglib2", Synaptic pakettihalinta en löytänyt tämän nimistä
pakettia.

Tarvittava paketti on libglib2.0-0:n 32-bittinen versio, joten asennus onnistuu komennolla sudo apt-get install libglib2.0-0:i386

Yksittäisten pakettien sijaan voit halutessasi asentaa paketin ia32-libs-multiarch, jonka kautta asentuu suurin osa tarvittavista riippuvuuksista.

Asennusta voisi kokeilla myös Ubuntu Software Centerillä (kaksoisklikkaa deb-pakettia tiedostoselaimessa) tai Gdebillä, joiden pitäisi osata asentaa oikeat 32-bittiset riippuvuudet automaattisesti.


Onko Xfce-työympäristö liian kevyt ubuntu, kun tuntuu puuttuvan tärkeitä paketteja?

Ongelmana on se, että DraftSightista ei ole saatavilla 64-bittistä Linux-versiota. Kaikissa 64-bittisissä jakeluissa on asennettava paljon 32-bittisiä riippuvuuksia. Ne eivät sisälly oletuksena myöskään mihinkään tavalliseen Ubuntu-asennukseen.
« Viimeksi muokattu: 03.11.13 - klo:15.51 kirjoittanut nm »