Kirjoittaja Aihe: Fast Track Pro ei toimi kunnolla  (Luettu 8797 kertaa)

Arello

  • Käyttäjä
  • Viestejä: 215
    • Profiili
Fast Track Pro ei toimi kunnolla
« : 23.03.12 - klo:17.46 »
Elikkäs en saa Fast Track Pro äänikorttia kunnolla toimimaan Linuxilla. ALSA tunnistaa laitteen, mutta siitä huolimatta se käyttäytyy randomisti (välillä volat on pilvissä, kohinaa tulee soittaessa/soittamatta jne.). M-Audiolla ei ole Linux-ajureita. Jotkut ovat käsittääkseni saaneet ilmankin niitä toimimaan. Auttaisiko jokin päivitetympi Ubuntu ongelmaan?

Minulla on Ubuntu 10.04 netbook remix (Ubuntu studio lisäkkeillä varustettu) käyttis miniläppärillä Acer AspireOne D255E. Kunhan mono ja stereokin edes toimisivat niin pitäisi miniläppärin sellaiseen äänittämiseen riittää.

Audacitylla, Jaskalla ja kumppaneilla olen jo aikani pelleillyt ja ideat alkavat olla lopussa, kun jopa koneeni Windows pistää (ajureidenkin kanssa) jotain naksahteluja välillä, mitä ei saa pois. Apu olisi tarpeen, etten joutuisi musaharrastustani tällaisten takaiskujen takia lopettamaan.
Läppäri Acer Swift 5 OS: Ubuntu Studio (xfce4) 18.04 LTS & Win10
Pöytis OS: Debian 10 & WinXP

uhappo

  • Käyttäjä
  • Viestejä: 1029
  • Sissos
    • Profiili
    • Urkin sivut
Vs: Fast Track Pro ei toimi kunnolla
« Vastaus #1 : 23.03.12 - klo:18.14 »
Ensimmäinen suositus on asentaa vaikka uusin ubuntu, voip olla ajurituki pikkasen parempi.

Tossa on asiaa kyseistä audioraudasta:
https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/569932
HP i7-pohjainen desktop ja itsekasattu i7-pohjainen desktop, uusin ubuntu 64bit
Ubuntu since 2008 Feb

Arello

  • Käyttäjä
  • Viestejä: 215
    • Profiili
Vs: Fast Track Pro ei toimi kunnolla
« Vastaus #2 : 23.03.12 - klo:18.40 »
Mites, kannattaisiko odottaa seuraavan LTS:n ilmestymistä?
Läppäri Acer Swift 5 OS: Ubuntu Studio (xfce4) 18.04 LTS & Win10
Pöytis OS: Debian 10 & WinXP

uhappo

  • Käyttäjä
  • Viestejä: 1029
  • Sissos
    • Profiili
    • Urkin sivut
Vs: Fast Track Pro ei toimi kunnolla
« Vastaus #3 : 23.03.12 - klo:18.49 »
12.04 rupee jos sen verta vakaa olemaan että eikun se vaan lataukseen, siis daily build, asentele ja eikun ihmettelemään
HP i7-pohjainen desktop ja itsekasattu i7-pohjainen desktop, uusin ubuntu 64bit
Ubuntu since 2008 Feb

Heikki Ketoharju

  • Käyttäjä
  • Viestejä: 716
  • Tee enemmän, harmittaa vähemmän!
    • Profiili
    • heikki.ketoharju.info
Vs: Fast Track Pro ei toimi kunnolla
« Vastaus #4 : 27.03.12 - klo:11.35 »
Eikös tuo Fast Track Pro toimi class compliant -tilassa rajoitetuin ominaisuuksin (tyyliin 16bittisenä ym)? Linuxissa class compliant -raudan pitäisi kyllä toimia ilman mitään. M-Audion korteista toki joskus on ollut vähän huonoja kokemuksia: joitakin vuosia sitten Profire Lightbridge ei vaan toiminut OS X:n kanssa, vaikka miten päin niitä ajureja asenteli. Yhtäkaikki: onko varmaa, että kortissa ei ole kehno firmware tai jotain?

Fast Track Prolle on kuulemma olemassa patch, joka saa sen toimimaan paremmin. Onkohan se mukana uusissa kerneleissä? Tässä tuorein viittaus, mitä asiaan liittyen löytyi: http://yomix.org/info/blog/2011/07/14/m-audio-fast-track-pro-special-features-now-enabled-linux/

Viime viikolla muuten juuri ostin Fast Track Ultran, ja toimii mukavasti. Eipä tämä tieto tietysti paljoa taida lohduttaa, koska Fast Track Pro:ssa on vissiin eri sisuskalut.
-
Minä kirjoittelen suomenkielisiä ohjeita Linux-musiikintekoon:
http://linux.fi/wiki/Musiikinteko_Linuxilla
-
Kansainvälinen Linux-audio -wiki, sovellusluettelo ja äänikorttitietokanta:
http://wiki.linuxaudio.org

Heikki Ketoharju

  • Käyttäjä
  • Viestejä: 716
  • Tee enemmän, harmittaa vähemmän!
    • Profiili
    • heikki.ketoharju.info
Vs: Fast Track Pro ei toimi kunnolla
« Vastaus #5 : 27.03.12 - klo:11.44 »
Pitää heti vastata itselle: luin tuon artikkelin kommentteja, ja sieltähän vastaus löytyikin: http://yomix.org/info/blog/2011/07/14/m-audio-fast-track-pro-special-features-now-enabled-linux/#comment_55

Tuon kommentoijan Fast Track Pro toimi heittämällä ytimen 3.1.5 -versiossa.
Lainaus
So, in summary: stock 3.1.5 kernel, with 'threadirqs', and jackd 0.121.3, I get duplex 24-Bit Big-endian, 48K with 256 periods at a pretty stable 5.3ms
24-bittinen duplex 48 kHz:n näytteenottotaajuudella on mun mielestä mukavan kuuloinen saavutus. Latenssitkin siinä viiden millisekunnin tietämillä.
-
Minä kirjoittelen suomenkielisiä ohjeita Linux-musiikintekoon:
http://linux.fi/wiki/Musiikinteko_Linuxilla
-
Kansainvälinen Linux-audio -wiki, sovellusluettelo ja äänikorttitietokanta:
http://wiki.linuxaudio.org

uhappo

  • Käyttäjä
  • Viestejä: 1029
  • Sissos
    • Profiili
    • Urkin sivut
Vs: Fast Track Pro ei toimi kunnolla
« Vastaus #6 : 27.03.12 - klo:14.58 »
Lainaus
So, in summary: stock 3.1.5 kernel, with 'threadirqs', and jackd 0.121.3, I get duplex 24-Bit Big-endian, 48K with 256 periods at a pretty stable 5.3ms
Lainaus
24-bittinen duplex 48 kHz:n näytteenottotaajuudella on mun mielestä mukavan kuuloinen saavutus. Latenssitkin siinä viiden millisekunnin tietämillä.
EIköhän 24bit, 48khz ja 5ms latenssi oo niitä ihan minimikriteereitä nowadays..
HP i7-pohjainen desktop ja itsekasattu i7-pohjainen desktop, uusin ubuntu 64bit
Ubuntu since 2008 Feb

Arello

  • Käyttäjä
  • Viestejä: 215
    • Profiili
Vs: Fast Track Pro ei toimi kunnolla
« Vastaus #7 : 27.03.12 - klo:16.09 »
Ytimeni näyttäisi tällä hetkellä olevan jokin 2.6.32-40-generic. Pitäisikö siis jotenkin päivittää tuohon 3.1.5 ytimeen, ja jos niin miten?
Läppäri Acer Swift 5 OS: Ubuntu Studio (xfce4) 18.04 LTS & Win10
Pöytis OS: Debian 10 & WinXP

uhappo

  • Käyttäjä
  • Viestejä: 1029
  • Sissos
    • Profiili
    • Urkin sivut
Vs: Fast Track Pro ei toimi kunnolla
« Vastaus #8 : 27.03.12 - klo:17.03 »
Ytimeni näyttäisi tällä hetkellä olevan jokin 2.6.32-40-generic. Pitäisikö siis jotenkin päivittää tuohon 3.1.5 ytimeen, ja jos niin miten?

Asenna uudempi ubuntujulkaisu, otat tiedot talteen ja eikun uutta softaa sisään
HP i7-pohjainen desktop ja itsekasattu i7-pohjainen desktop, uusin ubuntu 64bit
Ubuntu since 2008 Feb

Heikki Ketoharju

  • Käyttäjä
  • Viestejä: 716
  • Tee enemmän, harmittaa vähemmän!
    • Profiili
    • heikki.ketoharju.info
Vs: Fast Track Pro ei toimi kunnolla
« Vastaus #9 : 28.03.12 - klo:00.44 »
Mulla on uusin Ubu, eli 11.10, ja siinä on vasta 3.0-kerneli. Yks vaihtoehto on päivittää siihen 3.1.4-kerneli tuolta kanonicalin repoista: http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.1.4-oneiric/

Tai sitten voit testata sitä 12.04 betaa. Uhappo sano, jotta aika vakaa olisi jo? Itse en oo koskaan Ubuntun betoja testaillut.

MUOKS: Tango Studion repoista taitais muuten löytyä just Ubuntu 10.04:lle löytyvä kerneli Fast Track Pro -patcheilla. Näin neuvoo Jeremy Jongepier kuukausi takaperin: http://linuxaudio.org/mailarchive/lau/2011/2/19/178968
« Viimeksi muokattu: 28.03.12 - klo:01.28 kirjoittanut Heikki Ketoharju »
-
Minä kirjoittelen suomenkielisiä ohjeita Linux-musiikintekoon:
http://linux.fi/wiki/Musiikinteko_Linuxilla
-
Kansainvälinen Linux-audio -wiki, sovellusluettelo ja äänikorttitietokanta:
http://wiki.linuxaudio.org

Arello

  • Käyttäjä
  • Viestejä: 215
    • Profiili
Vs: Fast Track Pro ei toimi kunnolla
« Vastaus #10 : 31.03.12 - klo:22.47 »
Päivitin nyt käyttikseni 11.10 Oneiric Ocelottiin eikä tarvinnut edes perusteellista uudelleenasennusta tehdä. Siinä on nyt 3.0.0-17-generic kerneli. Aluksi FTP näytti tekevän samoja temppuja kuin aiemminkin, mutta käynnistin laitteen uudelleen ja sitten se äänitti normaalisti. Sitten koitin äänittää toista trackia päälle, mutta Audacity herjasikin:
Lainaus käyttäjältä: Don Quote
Latency Correction setting has caused the recorded audio to be hidden before zero.
Audacity has brought it back to start at zero.
You may have to use the Time Shift Tool (<---> or F5) to drag the track to the right place.
Olen muistaakseni hoitanut nuo latenssiasetukset kuntoon, mutta ehkä niihin täytyy vielä palata. En ole myöskään muilla ohjelmilla, kuten Ardourilla koittanut. Olisi silti kiva saada Audacity toimimaan, kun sillä olen tottunut miksaamaan enkä melkein osaakaan masteroida millään muulla softalla. Joka tapauksessa pitää vielä testailla kuitenkin lisää.
Yks vaihtoehto on päivittää siihen 3.1.4-kerneli tuolta kanonicalin repoista: http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.1.4-oneiric/
Mites hoituisi tuohon 3.1.4 kerneliin päivittäminen? En osaa siis rakennella mitään ytimiä itse saati koodailla ja sitä rataa. Voisihan vielä toki tuohon LTS-päivitykseen odottaa.
« Viimeksi muokattu: 31.03.12 - klo:22.51 kirjoittanut Arello »
Läppäri Acer Swift 5 OS: Ubuntu Studio (xfce4) 18.04 LTS & Win10
Pöytis OS: Debian 10 & WinXP

Heikki Ketoharju

  • Käyttäjä
  • Viestejä: 716
  • Tee enemmän, harmittaa vähemmän!
    • Profiili
    • heikki.ketoharju.info
Vs: Fast Track Pro ei toimi kunnolla
« Vastaus #11 : 03.04.12 - klo:22.40 »
Olen muistaakseni hoitanut nuo latenssiasetukset kuntoon, mutta ehkä niihin täytyy vielä palata. En ole myöskään muilla ohjelmilla, kuten Ardourilla koittanut. Olisi silti kiva saada Audacity toimimaan, kun sillä olen tottunut miksaamaan enkä melkein osaakaan masteroida millään muulla softalla. Joka tapauksessa pitää vielä testailla kuitenkin lisää.
No kyllä melkein suosittelisin Ardouriin vaihtamista. Audacity ei ole moniraitaäänitykseen tehty softa, ja ainakin mulla on aina ollut ongelmia juuri noiden latenssien kanssa. Toki jos jaksat säätää, niin mikäs siinä, mut Ardourissa ei pitäis mitään tuollaisia latenssiongelmia olla.

Mites hoituisi tuohon 3.1.4 kerneliin päivittäminen? En osaa siis rakennella mitään ytimiä itse saati koodailla ja sitä rataa. Voisihan vielä toki tuohon LTS-päivitykseen odottaa.
Tuosta linkistähän nuo deb-paketit löytyy. Latailet vaan ja asennat. Ydin on paketeissa, joiden nimi on linux-image, eli listauksen viimeiset kaksi. 32-bittiselle järjestelmälle ladataan i386-loppuinen paketti ja 64-bittiselle järjestelmälle amd64.

Ytimen headerit taas on noissa linux-headers -paketeissa, jotka on nimetty samalla logiikalla. Jos et tiedä onko sulla 64-bittinen vai 32-bittinen järjestelmä käytössä, niin senhän saa selville System settingsistä, kun menee sinne System info -kohtaan. Tai komentoriviltä saman infon saa sanomalla uname -i.

Jos sulla kuitenkin nyt toimii ihan ok, niin miksipä päivittää? Saattaa tulla kummallisia ongelmia.
-
Minä kirjoittelen suomenkielisiä ohjeita Linux-musiikintekoon:
http://linux.fi/wiki/Musiikinteko_Linuxilla
-
Kansainvälinen Linux-audio -wiki, sovellusluettelo ja äänikorttitietokanta:
http://wiki.linuxaudio.org

welmar

  • Käyttäjä
  • Viestejä: 1582
    • Profiili
Vs: Fast Track Pro ei toimi kunnolla
« Vastaus #12 : 03.04.12 - klo:23.34 »
Mites hoituisi tuohon 3.1.4 kerneliin päivittäminen? En osaa siis rakennella mitään ytimiä itse saati koodailla ja sitä rataa. Voisihan vielä toki tuohon LTS-päivitykseen odottaa.
Yksinkertaisin tapa olisi päivittää 12.04
Koodia: [Valitse]
gksu update-manager -dTäältä voi ladata daily build deb-pakettina. http://kernel.ubuntu.com/~kernel-ppa/mainline/daily/ Lataa esim paketit http://kernel.ubuntu.com/~kernel-ppa/mainline/daily/2012-03-31-precise/linux-headers-3.3.0-999_3.3.0-999.201203310435_all.deb  http://kernel.ubuntu.com/~kernel-ppa/mainline/daily/2012-03-31-precise/linux-headers-3.3.0-999-generic_3.3.0-999.201203310435_amd64.deb   http://kernel.ubuntu.com/~kernel-ppa/mainline/daily/2012-03-31-precise/linux-image-3.3.0-999-generic_3.3.0-999.201203310435_amd64.deb
Ja asenna ne TÄSSÄ järjestyksessä ja käynnistä kone uudelleen. On tärkeää että asennat ne juuri tässä järjestyksessä eli ensin header.all paketti sitten headers järjestelmäsi mukaan ja viimeisenä image. Esimerkki linkkeilläni pitäisi asentua 3.3.0-999-generic.
« Viimeksi muokattu: 04.04.12 - klo:00.00 kirjoittanut welmar »

Arello

  • Käyttäjä
  • Viestejä: 215
    • Profiili
Vs: Fast Track Pro ei toimi kunnolla
« Vastaus #13 : 04.04.12 - klo:12.04 »
Vielä en varmaan tee kernelipäivitystä, kun softistakaan ei meinaa ottaa tolkkua. Audacityssä mainitsemani virheilmoitus latensseista estää minua ylipäätään äänittämästä, mikä on aika outoa, koska aiemmin tuota ei ole tapahtunut. Artun sain juuri toimimaan, mutta Jaska temppuilee: Se ottaa sisääntulon tietokoneen mikistä vaikka olen asettanut FTP:n siihen. Sama tulos muillakin sisääntuloasetuksilla.

Jos Ardour toimisi optimaalisesti saisin varmaan selkeämmin selville, onko vika oikeasti laitteissa ja onko tarvetta kernelin päivitykselle. En nyt kovin syvälle aio tässä uppoutua, kun tuo LTS-päivityskin on tulossa ja sitten varmaa tarvitsee taas joka tapauksessa katsoa järjestelyjä uusiksi.

Sitä mietin, että kun sain Artun käynnistymään vasta sen jälkeen, kun olin ladannut sen kotisivulta; Olisiko Jaskalla sama vika? Sitä en tosin ole asentanutkaan uudelleen edellisten julkaisupäivitysten jälkeen.

EDIT: Uusin versio JACKista näemmä on. Ardourissa menee kuitenkin pelleilyksi. "Enable recording" toimintoa ränkläämällä ääntä välillä tulee tietokoneen mikistä tai sitä ei tule ollenkaan. FTP:stä ei jälkeäkään...
« Viimeksi muokattu: 05.04.12 - klo:17.06 kirjoittanut Arello »
Läppäri Acer Swift 5 OS: Ubuntu Studio (xfce4) 18.04 LTS & Win10
Pöytis OS: Debian 10 & WinXP

Heikki Ketoharju

  • Käyttäjä
  • Viestejä: 716
  • Tee enemmän, harmittaa vähemmän!
    • Profiili
    • heikki.ketoharju.info
Vs: Fast Track Pro ei toimi kunnolla
« Vastaus #14 : 05.04.12 - klo:23.26 »
Sun täytyy laittaa Jackin asetukset eka kuntoon. Ardourhan ei välitä raudasta suuremmin, koska Jack hoitaa sen. Kun laitat ton rec-nappulan päälle Ardourissa sellaisesta raidasta, joka  on kytketty äänikorttis sisäänmenoon, niin silloin pitäisi ääntä kuulua.

Tässä on kirjoittamani lyhyt käyttöohje Jack Controlia varten: http://linux.fi/wiki/Qjackctl
Siinä näkyy, että tärkein valinta tuolla asetuksissa on interface, johon siis pitäisi se Fast Track Pro vaihtaa.

Sama asia toisin sanoin: http://myy.haaga-helia.fi/~a1000119/jarjestelmaprojekti/ohjelmat.html

Jälkimmäisestä oppaasta löytyy myös ohjeet Ardourin käyttöön, helpottaisiko opettelua: http://myy.haaga-helia.fi/~a1000119/jarjestelmaprojekti/ardour.html

Suosittelen *todella lämpimästi* Audacityä paremman äänitysohjelman opettelua. Hankalaahan se aluksi on, mutta sen jälkeen kaikki on vaan niin paljon helpompaa ja voi oikeesti keskittyä musiikin tekemiseen.
-
Minä kirjoittelen suomenkielisiä ohjeita Linux-musiikintekoon:
http://linux.fi/wiki/Musiikinteko_Linuxilla
-
Kansainvälinen Linux-audio -wiki, sovellusluettelo ja äänikorttitietokanta:
http://wiki.linuxaudio.org

Arello

  • Käyttäjä
  • Viestejä: 215
    • Profiili
Vs: Fast Track Pro ei toimi kunnolla
« Vastaus #15 : 06.04.12 - klo:13.11 »
Nyt sain äänen kuulumaan. Olin siinä uskossa, että JACK-asetukset olivat oikeassa, mutta eipä näemmä olleet. Muistaakseni sain ennen äänen kuulumaan sisääntuloasetuksella hw:1,1 (USB Audio #1), mutta nyt homma lähti toimimaan valitsemalla toisen vaihtoehdon hw:1 (Fast Track Pro). (Ulostulon otan tietokoneen äänikortista. Joskus aiemmin FTP:n käyttäminen sekä sisään- että ulostulona pahensi vain asioita.) Piti myös vähän seikkailla JACKin kanssa ennen kuin alkoi juttu hahmottumaan. Latasin joskus joidenkin ohjeiden mukaan jonkin PulseAudio liitännäisen, mutta en itseasiassa tiedä, mitä se tekee ja se vähän monimutkaisti Connections näkymää.

Joka tapauksessa taisin saada systeemit toimimaan vaikka vähän vaikea sitä on vielä uskoa, kun olen jo kolmisen kuukautta näiden kanssa sorkkinut. Ehkä tästä viisastuneena voisi soveltaa ratkaisuja Audacityynkin ja saada sekin toimimaan. Nyt kuitenkin aion tehdä jotain miksauksia Ardourilla. Masteroinnissa olen Audacityssä vielä valovuosia edellä, mutta Artun plugareihin syventyminen onkin varmaan sitten seuraava opeteltava alue.

Katsotaan nyt vielä jonkin aikaa, josko ongelmat olisi viimein ratkaistu...
Läppäri Acer Swift 5 OS: Ubuntu Studio (xfce4) 18.04 LTS & Win10
Pöytis OS: Debian 10 & WinXP

Arello

  • Käyttäjä
  • Viestejä: 215
    • Profiili
Vs: Fast Track Pro ei toimi kunnolla
« Vastaus #16 : 08.04.12 - klo:12.45 »
Samat asetukset edelleen, mutta äänen ulostulo olikin nyt seuraavalla kerralla kadonnut. Kokeilemallakaan muita vaihtoehtoja en saa ääntä mistään JACKissa kuulumaan. On kyllä nyt luottamus koetuksella tähänkin, kun ei asetukset voi toimia edes seuraavaan päivään...

Sisään- ja ulostulossa signaalit siis toimivat kyllä. Ääntä ei vaan kuulu mistään.
« Viimeksi muokattu: 08.04.12 - klo:13.11 kirjoittanut Arello »
Läppäri Acer Swift 5 OS: Ubuntu Studio (xfce4) 18.04 LTS & Win10
Pöytis OS: Debian 10 & WinXP

Heikki Ketoharju

  • Käyttäjä
  • Viestejä: 716
  • Tee enemmän, harmittaa vähemmän!
    • Profiili
    • heikki.ketoharju.info
Vs: Fast Track Pro ei toimi kunnolla
« Vastaus #17 : 08.04.12 - klo:17.58 »
Mitä tarkoitat, et äänen ulostulo oli kadonnut? Siis onko se ulostuloon käyttämäsi sisäänrakennettu äänikortti kadonnut näkyvistä? Vai onko Jack capture modessa duplex moden sijaan? Vai lähteekö se ihan normaalisti käyntiin, mut Ardourista ei vaan kuulu mitään? Ootko testannut, et äänikortista yleensä kuuluu?

Monesti mulla äänilaitteet sotkeentuu, mikäli USB-laitteet vaihtaa järjestystä. Alsahan indeksoi laitteet vissiin tunnistamisjärjestyksessä, jolloin hw:0 on ekaks tunnistettu laite ja hw:1 taas sitten seuraavaksi tunnistettu. Muistaakseni midikiipparit esim sotkee tuota järjestystä, samoin kuin tietysti emolevyyn integroitu äänikortti.

Tällöin Jack kieltäytyy täysin käynnistymästä, ja äänikortti pitää käydä vaihtamassa asetuksista oikeaksi. Ongelman saa kierrettyä kertomalla Jackille äänikortin nimen rautanumeron sijaan. Tästä oli joskus Linux Audio Users -listalla keskustelua, mutta äkikseltään en nyt muista miten se meni. Voin toki kysäistä, jos haluat. Minä en ole ongelman kanssa juuri paininut, koska mulla ei oo ollu ulkoista USB-äänikorttia yleensä käytössä.

Toinen vaihtoehto on, et Ubuntun mukana tuleva buginen Ardour syystä tai toisesta on hukannut kytkennät. Ardourhan tekee reitityksen Jackin kautta, ainakin Ubussa ollut Ardour 2 on joskus aina heittänyt kokonaan kaikki kanavat kytkemättä Masteriin. Jos näin käy, pitää vetää piuhat Jackin Connections-ikkunassa uusiksi. Mikäli hommaan kyllästyy, voi ottaa tilanteesta snapshotin Patchbayn avulla, ja jatkossa kytkennät palautuu automaattisesti kun vaan lataa oikean patchbayn.

Mitä tulee PulseAudio -siltaukseen, niin en ole sitä koskaan käsin testannut. KXStudion Cadence-softassa sen sai päälle napinpainalluksella, ja ihan kätevähän se oli muistaakseni.
-
Minä kirjoittelen suomenkielisiä ohjeita Linux-musiikintekoon:
http://linux.fi/wiki/Musiikinteko_Linuxilla
-
Kansainvälinen Linux-audio -wiki, sovellusluettelo ja äänikorttitietokanta:
http://wiki.linuxaudio.org

Arello

  • Käyttäjä
  • Viestejä: 215
    • Profiili
Vs: Fast Track Pro ei toimi kunnolla
« Vastaus #18 : 08.04.12 - klo:19.12 »
JACKin asetuksissa ei muutoksia. Kaikki tarvittava on näkyvissä ja pitäisi olla ok: Connections-näkymä niin kuin pitääkin, äänikortissa ääni kuuluu, kuten tietokoneessakin ilman JACKia. Mikään ei nähdäkseni ole muuttunut siitä asti, kun sain toimimaan. Ääni ei vain enää tule. En ymmärrä.

EDIT: Nyt tilanne palautui alkupisteeseen. Ääni tulee, mutta sisääntulon JACK ottaa asetuksesta riippumatta tietokoneen mikistä. Enkä taaskaan ymmärrä.

...Nyt koitin taas tehdä uudelleen asetuksia, mutta tuloksena tuli vain virheilmoitusten tulitus, että JACK oli pakko sammuttaa kokonaan. Ei tästä tule yhtään mitään.
« Viimeksi muokattu: 08.04.12 - klo:19.50 kirjoittanut Arello »
Läppäri Acer Swift 5 OS: Ubuntu Studio (xfce4) 18.04 LTS & Win10
Pöytis OS: Debian 10 & WinXP

Heikki Ketoharju

  • Käyttäjä
  • Viestejä: 716
  • Tee enemmän, harmittaa vähemmän!
    • Profiili
    • heikki.ketoharju.info
Vs: Fast Track Pro ei toimi kunnolla
« Vastaus #19 : 08.04.12 - klo:19.54 »
Siis mitä tarkoitat, että "ääni ei tule"? ulos vai sisään koneesta?

Tässähän saattaa olla, et äänikortin ajureissa on jotain häikkää, jos se toimii ihan randomisti. Mikäli uskomme siihen Gentoo-käyttäjän kommentointiin (http://yomix.org/info/blog/2011/07/14/m-audio-fast-track-pro-special-features-now-enabled-linux/#comment_55), niin ton kortin pitäis alkaa toimimaan vasta 3.1-kernelin myötä.

Pitäiskö sun siis kokeilla päivitystä 12.04:ään? Toki jos haluut heittää Jackin hittoon ja koettaa sitä Audacityä, niin käyhän se niinkin, mut Jack on kyllä erittäin vakaa systeemi. Kun saa asetukset kohdilleen, ei se käyttäydy tolleen kuten sulla on nyt toiminut - eli jotain häikkää on jossain.

Mut haluisin kyllä nähdä ihan selkeitä kuvakaappauksia sun asetuksista, sekä cat /proc/asound/cards -komennon tulosteen. Toi rimpsu pitäis siis laittaa komentoriville. Aukaise terminaali Ctrl+Alt+t -näppäinyhdistelmällä tai valikon kautta ja liitä tuo rimpsu komennolla Ctrl+Shift+V.
-
Minä kirjoittelen suomenkielisiä ohjeita Linux-musiikintekoon:
http://linux.fi/wiki/Musiikinteko_Linuxilla
-
Kansainvälinen Linux-audio -wiki, sovellusluettelo ja äänikorttitietokanta:
http://wiki.linuxaudio.org