Kirjoittaja Aihe: Kieliongelma (Ratkaistu)  (Luettu 4246 kertaa)

Matzi

  • Käyttäjä
  • Viestejä: 249
  • Linux Mint 14 Nadia
    • Profiili
Kieliongelma (Ratkaistu)
« : 31.03.11 - klo:10.53 »
Tuli tärkeä tietoturvapäivitys, jonka asensin, ja kuis ollakkaan: Pääkäyttäjän ohjelmat pysyivät suomenkielisinä, mutta muiden käyttäjien kieleksi vaihtui englanninkieli.  Kuinka saa nämätkin muutettua suomenkielisiksi?

t.matti
« Viimeksi muokattu: 02.04.11 - klo:12.11 kirjoittanut Matzi »

SuperOscar

  • Käyttäjä
  • Viestejä: 4002
  • Ocatarinetabellatsumtsum!
    • Profiili
    • Legisign.org
Vs: Kieliongelma
« Vastaus #1 : 31.03.11 - klo:13.20 »
Vika voi olla Gnomen asetuksissakin, mutta kurkkaapa alkuun, saavatko tavalliset käyttäjät lukea suomalaisten lokalisointien kansiota /usr/share/locale-langpack/fi (sekä sen alikansiota LC_MESSAGES, missä .mo-tiedostot varsinaisesti sijaitsevat). Kansioiden oikeuksien pitäisi olla 755 = rwxr-xr-x ja tiedostojen 644 = rw-r--r--.
pöytäkone 1, kannettavat 1–3: Debian GNU/Linux 12; pöytäkone 2: openSUSE Tumbleweed; NUC: openSUSE Leap 15.5; RPi 1: FreeBSD 14-RELEASE; RPi 2: LibreELEC 11

shelby

  • Käyttäjä
  • Viestejä: 1865
    • Profiili
Vs: Kieliongelma
« Vastaus #2 : 31.03.11 - klo:14.21 »
Samat täällä. Paitsi pääkäyttäjänä Lontooksi ja guestina Suomeksi. Eipä tuo haittaa. 11.04 ei vaihtanut. No, kohtahan siihen mennään. Pitää katella nuo Oscarin jutut.
Ubu Gnome 20.04.3 LTS
Win 8.1 laptop I
Win 10 laptop II
Ubu Mate 20.04.3 LTS
Kubu 20.04.3 LTS

Matzi

  • Käyttäjä
  • Viestejä: 249
  • Linux Mint 14 Nadia
    • Profiili
Vs: Kieliongelma
« Vastaus #3 : 31.03.11 - klo:21.39 »
Vika voi olla Gnomen asetuksissakin, mutta kurkkaapa alkuun, saavatko tavalliset käyttäjät lukea suomalaisten lokalisointien kansiota /usr/share/locale-langpack/fi (sekä sen alikansiota LC_MESSAGES, missä .mo-tiedostot varsinaisesti sijaitsevat). Kansioiden oikeuksien pitäisi olla 755 = rwxr-xr-x ja tiedostojen 644 = rw-r--r--.
Näyttäisi, ettei vika ole tuolla, jos oikein nyt ymmärsin.  Tuntuu jotenkin omituiselta, osan ohjelmista sain meidän kielelle, kuten Openoffice,  mutta esim. Evolution ja Inkscape täysin enkuksi.  Samoin työpöydän paneeleissa englantia, mutta löytyypi sentään yksi meikäläinen sana System/Administration/kieliasetukset  ;D
t.matti

SuperOscar

  • Käyttäjä
  • Viestejä: 4002
  • Ocatarinetabellatsumtsum!
    • Profiili
    • Legisign.org
Vs: Kieliongelma
« Vastaus #4 : 31.03.11 - klo:22.35 »
Tuntuu jotenkin omituiselta, osan ohjelmista sain meidän kielelle, kuten Openoffice,  mutta esim. Evolution ja Inkscape täysin enkuksi.  Samoin työpöydän paneeleissa englantia, mutta löytyypi sentään yksi meikäläinen sana System/Administration/kieliasetukset  ;D

Tuota, kun tuolla aluksi sanoit, että ”pääkäyttäjän ohjelmat pysyivät suomenkielisinä”, tarkoitatko:

a) että jokin ohjelma X, jota käytät vain pääkäyttäjänä, on suomenkielinen VAI

b) että jokin ohjelma X, jota käytät sekä pääkäyttäjänä että tavallisena käyttäjänä, on suomenkielinen pääkäyttäjälle mutta englanninkielinen tavikselle?

Jos a, niin kyseessä tuntuisi olevan päivityksen yhteydessä poistunut kielipaketti, mutta jos b, vika on ilmeisesti Gnomen asetuksissa, jos kerran kansioiden oikeudet ovat kunnossa. (Ellei sitten jokin oleellinen lokalisointiin liittyvä tiedosto esim. /etc-puussa ole samalla tavoin sekoittanut oikeuksiaan :P Tässä on kieltämättä turhan paljon muuttujia!)
pöytäkone 1, kannettavat 1–3: Debian GNU/Linux 12; pöytäkone 2: openSUSE Tumbleweed; NUC: openSUSE Leap 15.5; RPi 1: FreeBSD 14-RELEASE; RPi 2: LibreELEC 11

Matzi

  • Käyttäjä
  • Viestejä: 249
  • Linux Mint 14 Nadia
    • Profiili
Vs: Kieliongelma
« Vastaus #5 : 01.04.11 - klo:09.00 »
Tuota, kun tuolla aluksi sanoit, että ”pääkäyttäjän ohjelmat pysyivät suomenkielisinä”, tarkoitatko:
a) että jokin ohjelma X, jota käytät vain pääkäyttäjänä, on suomenkielinen VAI
b) että jokin ohjelma X, jota käytät sekä pääkäyttäjänä että tavallisena käyttäjänä, on suomenkielinen pääkäyttäjälle mutta englanninkielinen tavikselle?
Jos a, niin kyseessä tuntuisi olevan päivityksen yhteydessä poistunut kielipaketti, mutta jos b, vika on ilmeisesti Gnomen asetuksissa, jos kerran kansioiden oikeudet ovat kunnossa. (Ellei sitten jokin oleellinen lokalisointiin liittyvä tiedosto esim. /etc-puussa ole samalla tavoin sekoittanut oikeuksiaan :P Tässä on kieltämättä turhan paljon muuttujia!)
Oikea vastaus on: B
Pääkäyttäjänä kaikki on suomeksi, mutta kumpikin tavis on englanniksi.  OpenOffice muuttui suomeksi kielivalinnasta, mutta esim. Inkspace ei.  Eli kaikki muut taviksilla selaimia lukuun ottamatta englantia.
Huomasin sellaisen seikan, kun aukaisee taviksena Kieliasetukset-valikon, siellä on aktiivisena Englanti, ja pääkäyttäjällä on Suomi.  En tiedä, olisiko syy tässä, ja jos on, niin miten voisi korjata?

t.matti

shelby

  • Käyttäjä
  • Viestejä: 1865
    • Profiili
Vs: Kieliongelma
« Vastaus #6 : 01.04.11 - klo:10.01 »
Heh, minulla toisinpäin, kuten yllä kirjoitin. Kieliasetusten muutto ei vaikuta mulla mtn. Ylävalikko ja muut asetukset Enkuksi pääkäyttäjänä. Guestina taas Suomesi. Ei auttanut poisto Enkun paketit Synapticistakaan. Siinähän tuli turv.päivityksen jälkeen info, että vajava kielipaketti. Ei auttanut sekään asennus????
Ubu Gnome 20.04.3 LTS
Win 8.1 laptop I
Win 10 laptop II
Ubu Mate 20.04.3 LTS
Kubu 20.04.3 LTS

luntti

  • Käyttäjä
  • Viestejä: 35
    • Profiili
Vs: Kieliongelma
« Vastaus #7 : 01.04.11 - klo:11.36 »
Tuota joo tuttavan koneelle kävi sama homma,oli päivittänyt ja muuttui täysin englannin kieliseksi.
Lisä mausteena alkoi työpöydältä häviämään kansioita ja pikakuvakkeita.
No mut mitään ratkaisua ei ilmeisesti ole vielä tullut?
Vähän paha koittaa puhelimessa neuvoa tietämätöntä miten saisi koneensa kuntoon.

Anssi

  • Käyttäjä
  • Viestejä: 1342
    • Profiili
Vs: Kieliongelma
« Vastaus #8 : 01.04.11 - klo:21.14 »
Kieli ongelma täälläkin. Koneella on vain yksi käyttäjä ja nyt valikot on englantia alkoi jo ehdotella kansioiden nimien muuttamista.

-Edit-

Kolmannella uusinta käynnistyksellä palasi takaisin. en tiedä oliko vaikutusta kun asentelin noi kielipaketit uusiksi ja varmuuden vuoksi poistin turhia lähteitä pois.
« Viimeksi muokattu: 01.04.11 - klo:21.21 kirjoittanut Anssi »

shelby

  • Käyttäjä
  • Viestejä: 1865
    • Profiili
Vs: Kieliongelma
« Vastaus #9 : 02.04.11 - klo:05.42 »
Nonnyt tuli takaisin Suomikieli, kun päivityksissä oli takaisinsovellus. Piti vaan bootata kerran. Qt:llä monta turvallissuuspäivitystä myös.
Ubu Gnome 20.04.3 LTS
Win 8.1 laptop I
Win 10 laptop II
Ubu Mate 20.04.3 LTS
Kubu 20.04.3 LTS

Maula

  • Käyttäjä
  • Viestejä: 84
    • Profiili
Vs: Kieliongelma
« Vastaus #10 : 02.04.11 - klo:11.25 »
Sama ongelma täällä paitsi että en tunnu saavan toimimaan. Postia ei pysty lähettämään mikäli liitetiedosto on .../Työpötä -paikassa. Veikkaan ongelmaksi "Työpöytä" sanassa olevia ääkkösiä.

Harmittaa kun pitäisi olla stabiili systeemi työjuttujen vuoksi. Siksi olen pitäytynyt 10.04LTS-versiossa. Pieni asiahan tämä lopulta on mutta antaa epävarman kuvan vakaudesta.

Matzi

  • Käyttäjä
  • Viestejä: 249
  • Linux Mint 14 Nadia
    • Profiili
Vs: Kieliongelma
« Vastaus #11 : 02.04.11 - klo:12.16 »
Nonnyt tuli takaisin Suomikieli, kun päivityksissä oli takaisinsovellus. Piti vaan bootata kerran. Qt:llä monta turvallissuuspäivitystä myös.

No tällähän se korjaantui. Suur kiitokset ahdingossa tukena olleille!  :D

t.matti

luntti

  • Käyttäjä
  • Viestejä: 35
    • Profiili
Vs: Kieliongelma (Ratkaistu)
« Vastaus #12 : 02.04.11 - klo:16.33 »
Ongelma kuittaantu kans täällä päin, hyvä homma :)