Kirjoittaja Aihe: Mikä Mozillaa riivaa... [Ratkaistu]  (Luettu 2600 kertaa)

Ked

  • Käyttäjä
  • Viestejä: 394
    • Profiili
Mikä Mozillaa riivaa... [Ratkaistu]
« : 18.05.10 - klo:06.40 »
Jonkin aikaa sitten muistaisin nähneeni jonkun ihmetelleen samaa, mutta laitetaan nyt uudestaan kun en löydä sitä viestiä mistään.

Miksiköhän Mozilla Firefox 3.6.3. (Lucid 64bit) näyttää jotkut sivut näin!?! (liitteenä esimerkkikuvat). Kokeilin poistaa ja asentaa uudelleenkin mutta ei vaikuta mitään. Muilla koneilla toimii ok, mutta tällä yhdellä koneella näin.

[ylläpito on poistanut liitteen]
« Viimeksi muokattu: 10.06.10 - klo:04.39 kirjoittanut Ked »

ilu

  • Käyttäjä
  • Viestejä: 384
    • Profiili
Vs: Mikä Mozillaa riivaa...
« Vastaus #1 : 18.05.10 - klo:08.08 »
Täälläkin riivaa http://www.flcenter.net/ukkostutka.html kun klikkaa suuri tutkakuva niin aukeava ikkuna on täysin musta, vilahtaa vain hetken kuva, on lucid 32bit 1600x900 tarkkuudella.
Pienemmällä tarkkuudella toimii?

turkka80

  • Käyttäjä
  • Viestejä: 110
  • Archisti
    • Profiili
Vs: Mikä Mozillaa riivaa...
« Vastaus #2 : 18.05.10 - klo:10.03 »
Jonkin aikaa sitten muistaisin nähneeni jonkun ihmetelleen samaa, mutta laitetaan nyt uudestaan kun en löydä sitä viestiä mistään.

Miksiköhän Mozilla Firefox 3.6.3. (Lucid 64bit) näyttää jotkut sivut näin!?! (liitteenä esimerkkikuvat). Kokeilin poistaa ja asentaa uudelleenkin mutta ei vaikuta mitään. Muilla koneilla toimii ok, mutta tällä yhdellä koneella näin.

En nyt ihan vannomaan mene, mutta kokeiles asentaa siihen firefoxiin (tai koko ubuntuun) toinen teema. Ohikiitävän hetken ajan ainakin vaikuttaisi siltä että värivalinnat on vaan turhan ennakkoluulottomat...

Edittiä... Toisaalla pohditaan Skypen osalta vähän samaa asiaa, joka on korjaantunut värimäärittelyllä, joten voisi olettaa entistä tanakammin että Lucidin vakioteema ei ole värimaailmaltaan oikein hyvin onnistunut...
« Viimeksi muokattu: 18.05.10 - klo:10.05 kirjoittanut turkka80 »
-- Vaan kun multa suussa maistuu / On katkeruus jäänyt taa... --

Ked

  • Käyttäjä
  • Viestejä: 394
    • Profiili
Vs: Mikä Mozillaa riivaa...
« Vastaus #3 : 18.05.10 - klo:23.52 »
Huomasin että asialla on jotain tekemistä sivun tyylien kanssa. Kun ottaa selaimen asetuksista tyylimäärittelyt pois, tulee tekstit näkyviin. Tietysti sivu näyttää silloin aika hauskalta...

edit; täytyypä kokeilla vaihtaa Gnomen tyyliä jos se tosiaan vaikuttaisi.

Edittiä... Toisaalla pohditaan Skypen osalta vähän samaa asiaa, joka on korjaantunut värimäärittelyllä, joten voisi olettaa entistä tanakammin että Lucidin vakioteema ei ole värimaailmaltaan oikein hyvin onnistunut...

Gnomessa värien vaihtaminen on sikälikin ongelmallista, että yksi asetus vaikuttaa välillä turhan moneen. Moni suosii tummia teemoja, mutta kuka haluaa silti käyttää taulukkolaskentaa mustalla ruudukolla!?

edit-edit: ei vaikuta teeman vaihtaminen asiaan mitenkään.
« Viimeksi muokattu: 19.05.10 - klo:03.08 kirjoittanut Ked »

turkka80

  • Käyttäjä
  • Viestejä: 110
  • Archisti
    • Profiili
Vs: Mikä Mozillaa riivaa...
« Vastaus #4 : 19.05.10 - klo:10.01 »
Ok arvelin vaan, että näin olisi koska Mint 9:llä ei vastaavaa ilmene vaikka teemakin on tumma kuin... No parempi kun en jatka tästä sen enempää... ;D

Gnomessa värien vaihtaminen on sikälikin ongelmallista, että yksi asetus vaikuttaa välillä turhan moneen. Moni suosii tummia teemoja, mutta kuka haluaa silti käyttää taulukkolaskentaa mustalla ruudukolla!?

Vaikka hivenen uhkaakin offtopic-osastolle mennä, niin tuo edellinen on tunnettu OpenOfficen bugi http://www.openoffice.org/issues/show_bug.cgi?id=80636.

Tämän bugin voipi kiertää tällä hetkellä seuraavanlaisesti, eli poistetaan GTK-yhteensopivuus ja gnome-yhteensopivuus, jolloin OpenOffice käyttää omaa vakioteemaansa. http://ubuntuforums.org/showthread.php?t=880094

Eli siis:
Koodia: [Valitse]
sudo apt-get remove openoffice.org-gtk openoffice.org-gnome
-- Vaan kun multa suussa maistuu / On katkeruus jäänyt taa... --

SuperOscar

  • Käyttäjä
  • Viestejä: 3869
  • Tänään täällä, huomenna poissa
    • Profiili
    • Legisign.org
Vs: Mikä Mozillaa riivaa...
« Vastaus #5 : 19.05.10 - klo:12.22 »
Huomasin että asialla on jotain tekemistä sivun tyylien kanssa.

Totta kai, ja nimenomaan virheellisesti suunniteltujen tyylien. Kunnolla suunniteltu CSS määrittää aina sekä tekstin että taustan värin, muuten käy helposti niin, että ne lankeavat yhteen.

Voit kokeilla pakottaa tekstivärin mustaksi: Muokkaa | Asetukset > Värit... -painike > aseta väri tekstille ja taustalle ja poista rasti kohdasta ”Käytä järjestelmän värejä”. Jos tämä toimii, vian syy on löytynyt, mutta ratkaisuksi tämä on turhan ronski.

Parempi ratkaisu on asentaa Firefoxiin Stylish-laajennus, jolla voi helposti säätää yksittäisten sivustojen tai jopa sivujen tyyliasetuksia mieleisikseen.
Debian GNU/Linux 11 (pöytäkone 1 & kannettavat 1 & 3), openSUSE Tumbleweed (pöytäkone 2), openSUSE Leap 15.4 (kannettava 2), Ubuntu 20.04 LTS (RPi 2 B), LibreELEC 10 (RPi 4 B)

Ked

  • Käyttäjä
  • Viestejä: 394
    • Profiili
Vs: Mikä Mozillaa riivaa...
« Vastaus #6 : 20.05.10 - klo:00.20 »
Totta kai, ja nimenomaan virheellisesti suunniteltujen tyylien. Kunnolla suunniteltu CSS määrittää aina sekä tekstin että taustan värin, muuten käy helposti niin, että ne lankeavat yhteen.

Miksi kyseiset sivut sitten aukeaa muilla koneilla oikein, mutta tuolla yhdellä koneella väärin  ??? Kahdessa muussa koneessa on kuitenkin sama käyttöjärjestelmä ja sama selainversio jne...

SuperOscar

  • Käyttäjä
  • Viestejä: 3869
  • Tänään täällä, huomenna poissa
    • Profiili
    • Legisign.org
Vs: Mikä Mozillaa riivaa...
« Vastaus #7 : 20.05.10 - klo:00.37 »
Miksi kyseiset sivut sitten aukeaa muilla koneilla oikein, mutta tuolla yhdellä koneella väärin  ???

Veikkaisin erilaisia asetuksia joko selaimessa tai sitä ympäröivässä järjestelmässä.
Debian GNU/Linux 11 (pöytäkone 1 & kannettavat 1 & 3), openSUSE Tumbleweed (pöytäkone 2), openSUSE Leap 15.4 (kannettava 2), Ubuntu 20.04 LTS (RPi 2 B), LibreELEC 10 (RPi 4 B)

Ked

  • Käyttäjä
  • Viestejä: 394
    • Profiili
Vs: Mikä Mozillaa riivaa...
« Vastaus #8 : 10.06.10 - klo:04.39 »
Ratkaistu:
Ongelma ei ollut teemoissa vaan järjestelmän yhden fontti-kansion oikeudet oli jostain syystä 700 -> kyseiset sivut käyttivät fonttia joka oli juuri siinä kansiossa.