Kirjoittaja Aihe: [RATKAISTU] Ongelmia flashin kanssa  (Luettu 1440 kertaa)

Jouko-Pouko

  • Käyttäjä
  • Viestejä: 40
    • Profiili
[RATKAISTU] Ongelmia flashin kanssa
« : 04.04.09 - klo:13.00 »
Nyt on ilmennyt suuria ongelmia kaikkien flash-tiedostojen kanssa.

Minulla oli ensin asennettuna Macromedia Flash -liitännäinen, jonka asensin Lisää/Poista sovelluksia -ohjelman kautta. Sen kanssa ilmeni kuitenkin jonkin verran ongelmia, joten poistin sen ja asensin Swfdec-Flash-soittimen Lisää/Poistan kautta. Se asensi oman liitännäisensä asennuksen jälkeen myös Firefoxiin. Se kuitenkin toimi entistä huonommin.

Yritin välillä poistaa jo sen ja asentaa Macromedia Flash -liitännäisen uudestaan, mutta se ei toiminut. Nyt olen poistanut tuon Swfdec-ohjelman, mutta sen liitännäinen on vieläkin Firefoxissa, enkä saa sitä poistettua mistään.

Nyt sitten asensin Synapticin kautta ubuntu-restricted-extras-paketin, mutta flashit eivät toimi vieläkään. Swfdecin liitännäinen (Shockwave Flash 9.0 r999) on otettu pois käytöstä Firefoxissa ja liitännäisistä löytyy Shockwave Flash 10.0 r22, joka on siis sama kuin Lisää/Poistan "Macromedia Flash -liitännäinen". Voisi siis luulla, että se toimisi, mutta ei. Itse asiassa tällä hetkellä flashit eivät näy ollenkaan, niiden tilalla on vain tyhjää.

Osaako kukaan antaa hyviä neuvoja? ??? Miten tuon ylimääräisen liitännäisen saa poistettua Firefoxista?
« Viimeksi muokattu: 04.04.09 - klo:17.44 kirjoittanut Jouko-Pouko »
Asus M2N68-VM
AMD Athlon 64 X2 7750 Black Edition
Kingston Valueram 4GB 800MHz
MSI N9400GT-MD512H-n

Ubuntu 9.04 x86_64 (Jaunty Jackalope)

gdm

  • Sitä saa mitä tilaa...
  • Käyttäjä
  • Viestejä: 4363
    • Profiili
    • Keskustelualueiden säännöt
Vs: Ongelmia flashin kanssa
« Vastaus #1 : 04.04.09 - klo:13.07 »
Sinne on jäänyt konfiguraatio-tiedostoja jotka aiheuttavat hieman närää.

Poistetaan kaikki "--purge remove" avulla
Koodia: [Valitse]
sudo apt-get --purge remove swfdec-* gnash* flashplugin-nonfree
ja asennetaan uusiksi tuo adoben flash
Koodia: [Valitse]
sudo apt-get --reinstall install flashplugin-nonfree
Lisää [Ratkaistu] aloitusviestiin jos ongelmasi selviää!
Saamasi tuki on ilmaista, joten älä vaadi tai uhkaile saadaksesi apua!

Jouko-Pouko

  • Käyttäjä
  • Viestejä: 40
    • Profiili
Vs: Ongelmia flashin kanssa
« Vastaus #2 : 04.04.09 - klo:13.26 »
Sinne on jäänyt konfiguraatio-tiedostoja jotka aiheuttavat hieman närää.

Poistetaan kaikki "--purge remove" avulla
Koodia: [Valitse]
sudo apt-get --purge remove swfdec-* gnash* flashplugin-nonfree
En nyt saanut tuota jostain syystä toimimaan. ???

Koodia: [Valitse]
joukopouko@joukopouko-desktop:~$ sudo apt-get --purge remove swfdec-* gnash* flashplugin-nonfree
Luetaan pakettiluetteloita... Valmis
Muodostetaan riippuvuussuhteiden puu       
Luetaan tilatiedot... Valmis       
Huomautus, valitaan libswfdec-0.6-90-dbg lausekkeella "swfdec-*"
Huomautus, valitaan libswfdec-0.6-0 lausekkeella "swfdec-*"
Huomautus, valitaan libswfdec-0.7-1 lausekkeella "swfdec-*"
Huomautus, valitaan libswfdec-0.8-0 lausekkeella "swfdec-*"
Huomautus, valitaan libswfdec-0.7-dev lausekkeella "swfdec-*"
Huomautus, valitaan libswfdec-0.7-1-dbg lausekkeella "swfdec-*"
Huomautus, valitaan swfdec-mozilla lausekkeella "swfdec-*"
Huomautus, valitaan libswfdec-0.8-0-dbg lausekkeella "swfdec-*"
Huomautus, valitaan libswfdec-0.8-dev lausekkeella "swfdec-*"
Huomautus, valitaan libswfdec-dev lausekkeella "swfdec-*"
Huomautus, valitaan libswfdec-0.6-0-dbg lausekkeella "swfdec-*"
Huomautus, valitaan libswfdec-0.6-90 lausekkeella "swfdec-*"
Huomautus, valitaan libswfdec-0.6-dev lausekkeella "swfdec-*"
Huomautus, valitaan swfdec-gnome lausekkeella "swfdec-*"
Huomautus, valitaan gnash-cygnal lausekkeella "gnash*"
Huomautus, valitaan mozilla-plugin-gnash lausekkeella "gnash*"
Huomautus, valitaan konqueror-plugin-gnash lausekkeella "gnash*"
Huomautus, valitaan gnash-common lausekkeella "gnash*"
Huomautus, valitaan libgnash0 lausekkeella "gnash*"
Huomautus, valitaan gnash lausekkeella "gnash*"
Huomautus, valitaan gnash-tools lausekkeella "gnash*"
E: Pakettia gnash* ei löytynyt
Asus M2N68-VM
AMD Athlon 64 X2 7750 Black Edition
Kingston Valueram 4GB 800MHz
MSI N9400GT-MD512H-n

Ubuntu 9.04 x86_64 (Jaunty Jackalope)

juyli

  • Vieras
Vs: Ongelmia flashin kanssa
« Vastaus #3 : 04.04.09 - klo:14.20 »
Koodia: [Valitse]
Huomautus, valitaan gnash-cygnal lausekkeella "gnash*"
Huomautus, valitaan mozilla-plugin-gnash lausekkeella "gnash*"
Huomautus, valitaan konqueror-plugin-gnash lausekkeella "gnash*"
Huomautus, valitaan gnash-common lausekkeella "gnash*"
Huomautus, valitaan libgnash0 lausekkeella "gnash*"
Huomautus, valitaan gnash lausekkeella "gnash*"
Huomautus, valitaan gnash-tools lausekkeella "gnash*"
E: Pakettia gnash* ei löytynyt

Todennäköisesti sinulle ei ole enää gnash:ia asennettuna, kuten ei pitäisikään olla, kun haluat vain toimivan Adoben Flash:in.
Voit toki yksitellenkin koittaa poistella noita gnash-paketteja: http://packages.ubuntu.com/search?keywords=gnash&searchon=names&suite=intrepid&section=all vaikka ne lähtee kauniisti kerralla.
Synaptic on selkeä graafinen paketinhallintatyökalu, vaikka vain tarkistamaan, mitä koneella on - ja mitä ei.
« Viimeksi muokattu: 04.04.09 - klo:14.22 kirjoittanut juyli »

Jouko-Pouko

  • Käyttäjä
  • Viestejä: 40
    • Profiili
Vs: Ongelmia flashin kanssa
« Vastaus #4 : 04.04.09 - klo:14.43 »
Todennäköisesti sinulle ei ole enää gnash:ia asennettuna, kuten ei pitäisikään olla, kun haluat vain toimivan Adoben Flash:in.
Voit toki yksitellenkin koittaa poistella noita gnash-paketteja: http://packages.ubuntu.com/search?keywords=gnash&searchon=names&suite=intrepid&section=all vaikka ne lähtee kauniisti kerralla.
Synaptic on selkeä graafinen paketinhallintatyökalu, vaikka vain tarkistamaan, mitä koneella on - ja mitä ei.
Ei ollut mitään gnash-paketteja enää asennettuna Synapticin mukaan, mutta sitten tajusin (vihdoin) katsoa Synapticista onko mitään Swfdec-paketteja asennettuna, ja sieltähän löytyi tuo swfdec-mozilla, jonka poistamalla ainakin suurin osa flasheista lähti toimimaan. Ilmoittelen, jos ongelmia vielä ilmenee.

Minkähän ihmeen takia Firefoxista ei saa poistettua noita liitännäisiä ollenkaan? Pitää tuolla tavalla Synapticin kautta poistaa. Melko omituista minusta.

Olen niin tottunut käyttämään tuota Lisää/Poista sovelluksia -ohjelmaa, että ei meinaa muistaakaan, että tuollainen Synaptic-pakettienhallintakin on olemassa. :-[

Kiitokset gdm:lle ja juyli:lle nopeista vastauksista!
Asus M2N68-VM
AMD Athlon 64 X2 7750 Black Edition
Kingston Valueram 4GB 800MHz
MSI N9400GT-MD512H-n

Ubuntu 9.04 x86_64 (Jaunty Jackalope)

juyli

  • Vieras
Vs: Ongelmia flashin kanssa
« Vastaus #5 : 04.04.09 - klo:16.08 »
Minkähän ihmeen takia Firefoxista ei saa poistettua noita liitännäisiä ollenkaan? Pitää tuolla tavalla Synapticin kautta poistaa. Melko omituista minusta.
Yleensä pluginit löytyvät selaimen plugins-hakemistosta esim. /usr/lib/mozilla/plugins, /usr/lib/plugins tms. joko linkkeinä tai ihan fyysisesti. Poistamalla (toki pakentinhallintatyökaluilla) ohjelma/plugin tms. se hävitetään/poistetaan ko. hakemistoista.