Kirjoittaja Aihe: Python 3.0 IDE hakusessa  (Luettu 1775 kertaa)

Lepotila zZ

  • Käyttäjä
  • Viestejä: 318
    • Profiili
Python 3.0 IDE hakusessa
« : 28.01.09 - klo:18.51 »
Terve, ja anteeksi laiskuuteni kun kyselen täältä, vaikka nämä varmasti voisi selvittää itselleen muutenkin.

Olen joskus kauan sitten ohjelmoinut jotakin pientä pythonia käyttäen. Silloin alustana oli windows, mutta nyt reilun viikon verran olen käyttänyt ubuntua. Huomasin, että pythonista on tullut uusi versio (3.0), jota tahtoisin käyttää. Kysymykseni kuuluukin, kuinka saan viriteltyä itselleni sopivan ohjelmointiympäristön käyttämään python 3.0:a.

Asensin jo ohjelmistohallinnasta python 3.0:n, mutta en tiedä miten pääsen siihen käsiksi. Päätteen komennolla "python -V" saan vastaukseksi vanhan pythonin (2.5.2). Ehkä onkin hyvä, että se vanha versio on päällimmäisenä näkyvissä, ettei mikään käytössä olevista python sovelluksista lakkaa toimimasta.

Olisin tyytyväinen, jos saisin jonkin mukavan IDE:n ajamaan kirjoittamani ohjelman pythonin 3.0 tulkilla. Lisäksi olisi hienoa, jos IDE muutenkin ymmärtäisi uutta pythonia. Spe vaikutti oikein hyvältä, mutta en löytänyt sen asetuksista, millä muuttaa sen ohjelmien ajamiseen käyttämää tulkkia. Toisekseen en ole edes varma mistä hakemistosta kyseinen tulkki ubuntussa löytyy (olen tosiaan aloittelija linuxinja ubuntun kanssa).

Mitä minun tulisi tehdä? Voiko Spe:tä käyttää python 3.0:n kanssa vai onko etsittävä jokin toinen IDE? Onko olemassa jotakin ominaisuuksiltaan ja helppokäyttöisyydeltään Spe:tä vastaavaa IDE:tä, joka tukee python 3.0: syntaksia ja on konfiguroitavissa toimivaksi python 3.0:n kanssa?

Kiitos.


SuperOscar

  • Käyttäjä
  • Viestejä: 3456
  • Tänään täällä, huomenna poissa
    • Profiili
    • Legisign.org
Vs: Python 3.0 IDE hakusessa
« Vastaus #1 : 28.01.09 - klo:19.08 »
Asensin jo ohjelmistohallinnasta python 3.0:n, mutta en tiedä miten pääsen siihen käsiksi. Päätteen komennolla "python -V" saan vastaukseksi vanhan pythonin (2.5.2).

Komennolla

Koodia: [Valitse]
python-3.0
käynnistyy Python 3.0. Tarpeen vaatiessa tiedostosta /usr/bin/python voisi kai tehdä symbolisen linkin /usr/bin/python-3.0:aan, mutta tähän lienee kyllä jokin oikeampikin tapa, jota en tiedä :)
openSUSE Leap 15.1 (pöytäkone 1, kannettavat 1 & 2), openSUSE Tumbleweed (pöytäkone 2, kannettava 3), LibreELEC 8.2.5 (RPi 1), Raspbian GNU/Linux 10 (RPi 2)

Lepotila zZ

  • Käyttäjä
  • Viestejä: 318
    • Profiili
Vs: Python 3.0 IDE hakusessa
« Vastaus #2 : 28.01.09 - klo:19.33 »
Kiitos vastauksesta!

Nyt löytyy oikea tulkki.
Oikea nimi tosin oli
Koodia: [Valitse]
python3.0

Nyt voisin tekstieditorin kanssa toimia, vaikka mukavampaa olisi, jos on jo olemassa jokin (ilmainen) IDE, joka tukee uutta pythonia. Ohjelmoin niin harvoin, että IDE:n antama tuki on mukavaa, vaikka se ei sinänsä ole niin tarpeellista kuin javan kanssa.

SuperOscar

  • Käyttäjä
  • Viestejä: 3456
  • Tänään täällä, huomenna poissa
    • Profiili
    • Legisign.org
Vs: Python 3.0 IDE hakusessa
« Vastaus #3 : 28.01.09 - klo:20.28 »
Oikea nimi tosin oli
Koodia: [Valitse]
python3.0

Uups, sori... En päässyt oikealta koneelta tarkistamaan. (Pythonin kolmosversiota ei ole tullut tämän läppärin Kubuntu 8.04.2:een.)
openSUSE Leap 15.1 (pöytäkone 1, kannettavat 1 & 2), openSUSE Tumbleweed (pöytäkone 2, kannettava 3), LibreELEC 8.2.5 (RPi 1), Raspbian GNU/Linux 10 (RPi 2)

Lepotila zZ

  • Käyttäjä
  • Viestejä: 318
    • Profiili
Vs: Python 3.0 IDE hakusessa
« Vastaus #4 : 29.01.09 - klo:15.19 »
Sain Geany ohjelmointiympäristön käyttämään python3.0:sta, mutta Geanyssä ei ole sitä koodintäydennys-toimintoa, jota kaipaisin.

Taidan jättää ajatukset python3.0:n käyttämisestä tällä erää, koska pikku ohjelmani tulee tarvitsemaan graafista käyttöliittymää ja sen suhteen on ongelmia. Mikään katsomistani vaihtoehdoista graafisen käyttöliittymän tekemiseen (wxWidgets, pyGTK, pyQt) ei vielä tue python3.0:aa. Tkinter olisi riittävä, mutta senkään saaminen toimimaan ei ilmeisesti onnistu ubuntun ohjelmistohallinnalla (luultavasti minun tarvitsisi asentaa python-tk python3.0:lle eli ilmeisesti python3.0-tk, joka ei ole Synapticin mukaan asennettavissa).

Joten pitäydyn toistaiseksi vanhassa pythonissa.

SuperOscar

  • Käyttäjä
  • Viestejä: 3456
  • Tänään täällä, huomenna poissa
    • Profiili
    • Legisign.org
Vs: Python 3.0 IDE hakusessa
« Vastaus #5 : 29.01.09 - klo:16.13 »
Joten pitäydyn toistaiseksi vanhassa pythonissa.

Varmaankin hyvä ratkaisu toistaiseksi. Jopa Python.org näyttää pitävän versiota 2.6 ”nykyisenä”, koska docs.python.org osoittaa 2.6-version dokumentaatioon ja 3.0:n löytääkseen on lisättävä loppuun versionumero (docs.python.org/3.0).

Itse asiassa Python 2.6 olisi muutenkin hyvä väliversio, koska siinä 3.0 on otettu jo monin tavoin huomioon. Saakos sitä vain Ubuntun repoista 8.10:llekään? Ei ainakaan 8.04.2:sta löydy.
openSUSE Leap 15.1 (pöytäkone 1, kannettavat 1 & 2), openSUSE Tumbleweed (pöytäkone 2, kannettava 3), LibreELEC 8.2.5 (RPi 1), Raspbian GNU/Linux 10 (RPi 2)

Lepotila zZ

  • Käyttäjä
  • Viestejä: 318
    • Profiili
Vs: Python 3.0 IDE hakusessa
« Vastaus #6 : 29.01.09 - klo:17.19 »
Itse asiassa Python 2.6 olisi muutenkin hyvä väliversio, koska siinä 3.0 on otettu jo monin tavoin huomioon. Saakos sitä vain Ubuntun repoista 8.10:llekään? Ei ainakaan 8.04.2:sta löydy.

Ei löydy 8.10:stäkään.

janne

  • Käyttäjä
  • Viestejä: 5150
    • Profiili
Vs: Python 3.0 IDE hakusessa
« Vastaus #7 : 29.01.09 - klo:19.27 »
Itse asiassa Python 2.6 olisi muutenkin hyvä väliversio, koska siinä 3.0 on otettu jo monin tavoin huomioon. Saakos sitä vain Ubuntun repoista 8.10:llekään? Ei ainakaan 8.04.2:sta löydy.

Ei löydy 8.10:stäkään.

löytyy sieltä python3.0 versiota 3.0~rc1+20081027-0ubuntu1, mutta ei uudempaa. tosin tuo kyseinen paketti voi olla hyvinkin lähellä sitä lopullista
Janne

Lepotila zZ

  • Käyttäjä
  • Viestejä: 318
    • Profiili
Vs: Python 3.0 IDE hakusessa
« Vastaus #8 : 29.01.09 - klo:19.58 »
löytyy sieltä python3.0 versiota 3.0~rc1+20081027-0ubuntu1, mutta ei uudempaa. tosin tuo kyseinen paketti voi olla hyvinkin lähellä sitä lopullista

Tarkoitin, että python2.6 ei löydy. 3.0:n asensin jo ja huomasin myös, että se on vasta rc1. Ongelmana oli saada Tkinter (tai jokin muu tapa tehdä graafinen käyttöliittymä) toimimaan 3.0:n kanssa. Jotain ohjeita löysin, mutta en lähtenyt niitä kokeilemaan, koska en vielä ymmärrä paljoa linuxin ja ubuntun suhteen. Ilmeisesti kuitenkaan ubuntun ohelmistohallinnalla ei ole asennettavissa python 2.6:sta lainkaan, eikä 3.0:a, jossa toimisi Tkinter.