Kirjoittaja Aihe: Thinkpad T60, tappiohjaimen keskinappi vieritys ei toimi. Ubuntu 8.10[RATKAISTU]  (Luettu 3645 kertaa)

T_T_R

  • Käyttäjä
  • Viestejä: 4
    • Profiili
Asensin Windows XP:n rinnalle Ubuntu 8.10 ja nyt pitäisi saada tappiohjaimella keskinapin vieritys toimimaan.
Kyseinen ominaisuus toimii Windows:in puolella moitteettomasti.
Löysin kyllä jotain aiheeseen viittaavaa englannin kielisiltä foorumeilta, mutta kielitaitoni ja Linux asiantuntemukseni ei riitä ratkaisemaan tätä ongelmaa niiden ohjeiden perusteella...
Löytyiskö keneltäkään ensikädentietoa, jolla ongelma korjaantuisi?
« Viimeksi muokattu: 10.01.09 - klo:08.19 kirjoittanut T_T_R »

Eetu_

  • Käyttäjä
  • Viestejä: 261
    • Profiili
Minulla on sama ongelma T41:ssa, ja olisin myös kiitollinen, jos saisin tuon toimimaan.

Bysmyyr

  • Käyttäjä
  • Viestejä: 212
    • Profiili
Minulla on serverinä joku thinkpädi jossa tappi toimii ihan hyvin suoraan lennosta. Vaikka et itse niistä enkkufoorumeista selvää saakaa, ne kannattaa tänne laittaa niin joku saattaa niitäkin vilkasta.

T_T_R

  • Käyttäjä
  • Viestejä: 4
    • Profiili
Minulla on serverinä joku thinkpädi jossa tappi toimii ihan hyvin suoraan lennosta. Vaikka et itse niistä enkkufoorumeista selvää saakaa, ne kannattaa tänne laittaa niin joku saattaa niitäkin vilkasta.

Alla lainaus osoitteesta: http://psung.blogspot.com/2008/09/scrolling-with-thinkpads-trackpoint-in.html

26 September 2008
Scrolling with the Thinkpad's TrackPoint in Ubuntu 8.10 Intrepid

Ubuntu Intrepid (8.10) switches to evdev for X server input, which has the unfortunate side effect of breaking old EmulateWheel configurations. So scrolling using the middle button + TrackPoint (which I absolutely love) was broken for a while. However, the version of evdev in Intrepid has now caught up and supports these features. Instead of modifying your xorg.conf, create a new file called /etc/hal/fdi/policy/mouse-wheel.fdi with the following contents:

<match key="info.product" string="TPPS/2 IBM TrackPoint">
 <merge key="input.x11_options.EmulateWheel" type="string">true</merge>
 <merge key="input.x11_options.EmulateWheelButton" type="string">2</merge>
 <merge key="input.x11_options.XAxisMapping" type="string">6 7</merge>
 <merge key="input.x11_options.YAxisMapping" type="string">4 5</merge>
 <merge key="input.x11_options.ZAxisMapping" type="string">4 5</merge>
 <merge key="input.x11_options.Emulate3Buttons" type="string">true</merge>
</match>

(Based on code from Michael Vogt and adapted to support both vertical and horizontal scrolling.)

In only tangentially related news, Lenovo recently announced the Thinkpads X200 and (more recently) X200s. The general consensus among reviewers is that if you love the X61, you'll love the X200. It's basically an update of the X61 with newer Intel chips and a widescreen display (with better pixel density); consequently, it is a bit wider and not as deep and has a full size keyboard. Shame I'm nowhere near the end of an upgrade cycle.

Update, 4 Jan 2009: Fixed an apparently inconsequential(?) typo in the policy file. You'll have to restart hal and gdm for the changes to take effect. Log in on a console (e.g. Ctrl+Alt+F1) and then do:

    sudo /etc/init.d/hal restart
    sudo /etc/init.d/gdm restart

An update to Ubuntu Intrepid (subsequent to my original post) breaks TrackPoint scrolling either completely or possibly only after suspending and resuming. A comment on Ubuntu bug 282387 gives instructions for downloading and installing a fixed version from upstream:

    sudo apt-get install build-essential git-core
    sudo apt-get build-dep xserver-xorg-input-evdev
    git clone git://git.freedesktop.org/git/xorg/driver/xf86-input-evdev
    cd xf86-input-evdev
    git reset --hard 5f2c8a2dcdf98b39997ee5e7c9a9ace3b640bfa3
    ./autogen.sh --prefix=/usr
    make
    sudo make install

Jaunty's version of xserver-xorg-input-evdev also fixes this problem, supposedly.

I've tested the policy file and workaround above on an X61s. People have indicated that it seems to work on at least the R31, T41, T42, T60, T61, X31, X40, X61, and X200 (thanks to everyone who provided feedback!). The X300 and X301 Thinkpads seem to have different TrackPoint hardware. On those machines you may need to disable the touchpad in the BIOS to make the above workaround work.

jp1

  • Käyttäjä
  • Viestejä: 333
    • Profiili
Kokeilin T41:llä irroittamalla ulkoisen hiiren ja ainakin minulla toimii sekä tapilla että laatalla niinkuin pitääkin. Asennuksen jälkeen en ole tehnyt omia virityksiä. Ubuntu 8.04lts.
Ota neuvoja vastaan pääasiassa vain heiltä, jotka ovat jo olleet siellä mihin sinäkin olet menossa.

IBM ThinkPad T41 Pentium M 745 / Ubuntu 8.04LTS & XP Pro
HP Omnibook xe3 / Xubuntu 8.04LTS & Win98E

pekkis

  • Käyttäjä
  • Viestejä: 48
    • Profiili
IBämmän tappihiiren olen saanut toimimaan lisäämälla /etc/X11/xorg.conf tiedostoon hiirelle optiot EmulateWheel ja EmulateWheelButton 2.  Tämän jälkeen X uudelleen käyntiin ja jo scrollaa.. 

Koodia: [Valitse]
Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
        Option      "EmulateWheel"           "on"
        Option      "EmulateWheelButton" "2"
EndSection

Lisää säätöjä löytyy thinkwikistä.
http://www.thinkwiki.org/wiki/How_to_configure_the_TrackPoint

T_T_R

  • Käyttäjä
  • Viestejä: 4
    • Profiili
Ongelma ratkaistu, tässä ohje:

- avaa Pääte
- kirjoita komento: sudo gedit /etc/hal/fdi/policy/mouse-wheel.fdi , tällä komennolla kyseinen tiedosto luodaan
- kopioi tiedostoon alla oleva teksti
<match key="info.product" string="TPPS/2 IBM TrackPoint">
 <merge key="input.x11_options.EmulateWheel" type="string">true</merge>
 <merge key="input.x11_options.EmulateWheelButton" type="string">2</merge>
 <merge key="input.x11_options.XAxisMapping" type="string">6 7</merge>
 <merge key="input.x11_options.YAxisMapping" type="string">4 5</merge>
 <merge key="input.x11_options.ZAxisMapping" type="string">4 5</merge>
 <merge key="input.x11_options.Emulate3Buttons" type="string">true</merge>
</match>

-käynnistä tietokone uudelleen
Mulla ainakin alkoi toimimaan näillä ohjeilla.