Kirjoittaja Aihe: Ubuntu 8.10: äänet eivät toimi [ratkaistu]  (Luettu 40250 kertaa)

TheDuck

  • Käyttäjä
  • Viestejä: 18
    • Profiili
Ubuntu 8.10: äänet eivät toimi [ratkaistu]
« : 31.10.08 - klo:14.57 »
Eli asentelin tässä eilen illalla tämän uuden version ubuntusta ja nyt äänet eivät toimi ollenkaan. Kaikkea oon yrittäny säätää, mut mitään ei kuulu. Käytössä jotkut philipsin pikkukajarit, mut oishan kiva jos peleissä olis äänet -.-

Kuvakaappaukset ääniasetuksista:

http://i.servut.us/i/Kuvakaappausk.png
http://i.servut.us/i/Kuvakaappaus1uz.png

Alkaa jo pikkuhiljaa vituttamaan... >.<

EDIT: niin ja 8.04 toimi äänet mahtavasti...
« Viimeksi muokattu: 01.11.08 - klo:21.58 kirjoittanut TheDuck »

TheDuck

  • Käyttäjä
  • Viestejä: 18
    • Profiili
Vs: Ubuntu 8.10: äänet eivät toimi
« Vastaus #1 : 31.10.08 - klo:18.41 »
Eikö kukaan muka tiedä?  :-X

TheDuck

  • Käyttäjä
  • Viestejä: 18
    • Profiili
Vs: Ubuntu 8.10: äänet eivät toimi
« Vastaus #2 : 31.10.08 - klo:20.38 »
Ei näköjään..

Minna S

  • Käyttäjä
  • Viestejä: 1053
    • Profiili
Vs: Ubuntu 8.10: äänet eivät toimi
« Vastaus #3 : 31.10.08 - klo:20.43 »
Ei minullakaan toimi äänet 8.10.

Linux user # 406601

TheDuck

  • Käyttäjä
  • Viestejä: 18
    • Profiili
Vs: Ubuntu 8.10: äänet eivät toimi
« Vastaus #4 : 31.10.08 - klo:20.45 »
No mistähän tää siis johtuu? Kun pelit on aika tylsiä ilman ääniä. Ja windows on raskas paska.

EDIT: ja mahdollista jotenkin säätää kuntoon?
« Viimeksi muokattu: 31.10.08 - klo:20.47 kirjoittanut TheDuck »

Minna S

  • Käyttäjä
  • Viestejä: 1053
    • Profiili
Vs: Ubuntu 8.10: äänet eivät toimi
« Vastaus #5 : 31.10.08 - klo:20.47 »
Eipä toimi oikein mikään muukaan päivityksen jälkeen :(
Kannatti päivittää.

Linux user # 406601

gdm

  • Sitä saa mitä tilaa...
  • Käyttäjä
  • Viestejä: 4363
    • Profiili
    • Keskustelualueiden säännöt
Vs: Ubuntu 8.10: äänet eivät toimi
« Vastaus #6 : 31.10.08 - klo:20.53 »
Eikö kukaan muka tiedä?  :-X
Ei näköjään..

Aloitusviesti lähetetty: Lähetetty: tänään kello 14:57 Kirjoittanut: TheDuck 

Vastaus tulee kun joku kerkeää siihen vastaamaan.
Mutta ei helpota asiaa jos huutelet muutaman tunnin välein asiasta;)

Asiaan,
Koodia: [Valitse]
aplay /usr/share/sounds/question.wavToistaako tuo ääntä (pieni rummun päristely)

Koodia: [Valitse]
sudo apt-get install padevchooserValikko->Sovellukset->Ääni&Video->PulseAudio Device Chooser
Aukaisee ilmoitusalueelle pienen appletin jonka avulla voit säätää äänen voimakkuutta ja siirtää streamin eri laitteelle.

Koskeeko ongelma pelkästään pelejä?
Lisää [Ratkaistu] aloitusviestiin jos ongelmasi selviää!
Saamasi tuki on ilmaista, joten älä vaadi tai uhkaile saadaksesi apua!

TheDuck

  • Käyttäjä
  • Viestejä: 18
    • Profiili
Vs: Ubuntu 8.10: äänet eivät toimi
« Vastaus #7 : 31.10.08 - klo:21.00 »
Eikö kukaan muka tiedä?  :-X
Ei näköjään..

Aloitusviesti lähetetty: Lähetetty: tänään kello 14:57 Kirjoittanut: TheDuck 

Vastaus tulee kun joku kerkeää siihen vastaamaan.
Mutta ei helpota asiaa jos huutelet muutaman tunnin välein asiasta;)

Asiaan,
Koodia: [Valitse]
aplay /usr/share/sounds/question.wavToistaako tuo ääntä (pieni rummun päristely)

Koodia: [Valitse]
sudo apt-get install padevchooserValikko->Sovellukset->Ääni&Video->PulseAudio Device Chooser
Aukaisee ilmoitusalueelle pienen appletin jonka avulla voit säätää äänen voimakkuutta ja siirtää streamin eri laitteelle.

Koskeeko ongelma pelkästään pelejä?

Ei toi aplay-juttu toistanut mitään. Ja ei, kaiuttimista ei missään vaiheessa kuulu mitään. Pelatessa, musaa kuunnellessa ym.

gdm

  • Sitä saa mitä tilaa...
  • Käyttäjä
  • Viestejä: 4363
    • Profiili
    • Keskustelualueiden säännöt
Vs: Ubuntu 8.10: äänet eivät toimi
« Vastaus #8 : 31.10.08 - klo:21.05 »
Ei toi aplay-juttu toistanut mitään. Ja ei, kaiuttimista ei missään vaiheessa kuulu mitään. Pelatessa, musaa kuunnellessa ym.

Koodia: [Valitse]
sudo apt-get install libasound2 libasound2-plugins libao-pulse libsdl1.2debian-pulseaudioAsenna nuo, käynnistä uudelleen, mitä tapahtuu.

Lisää [Ratkaistu] aloitusviestiin jos ongelmasi selviää!
Saamasi tuki on ilmaista, joten älä vaadi tai uhkaile saadaksesi apua!

Ville Pöntinen

  • Käyttäjä
  • Viestejä: 2078
    • Profiili
Vs: Ubuntu 8.10: äänet eivät toimi
« Vastaus #9 : 31.10.08 - klo:21.09 »
Minullakin on ollut äänet kadoksissa päivityksen jälkeen. Ainoa meteli on kuulunut pojasta, joka tahtoisi kuunnella musiikkia...

aplay ei soita mitään minullakaan.

Enkä oikein usko, että tuo padevchooser liittyy tähän? Tai sitten en vaan osaa.

lspci antaa kortiksi 00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01) ja se siis toimi ennen päivitystä. Minulla ei ole niin kiire tämän asian kanssa, joten jään lueskelemaan, mitä keksitte.

Edit. eikä noiden gdm:n ehdottamien pakettien asennus muuttanut asiaa. Ääniasetuksissa mikään toisto-vaihtoehto ei tuota mitään kaiuttimiin asti... Ei myöskään virheilmoituksia.

TheDuck

  • Käyttäjä
  • Viestejä: 18
    • Profiili
Vs: Ubuntu 8.10: äänet eivät toimi
« Vastaus #10 : 31.10.08 - klo:21.12 »
Joop, asentelu ja buutti ei muuttanut asiaa.. Aika surkea homma :<

gdm

  • Sitä saa mitä tilaa...
  • Käyttäjä
  • Viestejä: 4363
    • Profiili
    • Keskustelualueiden säännöt
Vs: Ubuntu 8.10: äänet eivät toimi
« Vastaus #11 : 31.10.08 - klo:21.14 »

Enkä oikein usko, että tuo padevchooser liittyy tähän? Tai sitten en vaan osaa.


Tuon tarkoitus on vain tarjota graafinen sovellus jolla käsitellä äänivirtoja.

Kannattaa myös tarkistaa alsamixerin kautta onko äänet mykistetty.

Kokeilun arvoinen on myös asettaa pulseaudio oletukseksi.
Koodia: [Valitse]
asoundconf set-pulseaudio
Tunnista automaattisesti päälle gstreameria käyttäville sovelluksille
Koodia: [Valitse]
gstreamer-propertiesTuolla voi myös kokeilla tuleeko ääntä

Onko järjestelmät päivitetty vai puhtaalta pöydältä asennettu?
Lisää [Ratkaistu] aloitusviestiin jos ongelmasi selviää!
Saamasi tuki on ilmaista, joten älä vaadi tai uhkaile saadaksesi apua!

TheDuck

  • Käyttäjä
  • Viestejä: 18
    • Profiili
Vs: Ubuntu 8.10: äänet eivät toimi
« Vastaus #12 : 31.10.08 - klo:21.17 »
Mulla on alla päivitetty. Ja eipä tuu vieläkään ääntä vaikka tein nuo molemmat sanomasi :S

gdm

  • Sitä saa mitä tilaa...
  • Käyttäjä
  • Viestejä: 4363
    • Profiili
    • Keskustelualueiden säännöt
Vs: Ubuntu 8.10: äänet eivät toimi
« Vastaus #13 : 31.10.08 - klo:21.30 »
Mulla on alla päivitetty. Ja eipä tuu vieläkään ääntä vaikka tein nuo molemmat sanomasi :S

Tarkista alsamixer -Dhw onko äänet mykistetty, jatkan ihmettelyä...
Onko kotikansiossa tiedostot:
~/.asoundrc
~/.libao

Poistoon tai uudelleennimeäminen.

Tarkistakaa "pulseaudio-device-chooseria" (volume control) hyväksikäyttäen näkyykö siellä "playback" välilehdellä merkintää
kun yritätte toistaa ääntä sisältävää sisältöä.

[ylläpito on poistanut liitteen]
« Viimeksi muokattu: 31.10.08 - klo:21.38 kirjoittanut gdm »
Lisää [Ratkaistu] aloitusviestiin jos ongelmasi selviää!
Saamasi tuki on ilmaista, joten älä vaadi tai uhkaile saadaksesi apua!

TheDuck

  • Käyttäjä
  • Viestejä: 18
    • Profiili
Vs: Ubuntu 8.10: äänet eivät toimi
« Vastaus #14 : 31.10.08 - klo:21.37 »
Mulla on alla päivitetty. Ja eipä tuu vieläkään ääntä vaikka tein nuo molemmat sanomasi :S

Tarkista alsamixer -Dhw onko äänet mykistetty, jatkan ihmettelyä...
Onko kotikansiossa tiedostot:
~/.asoundrc
~/.libao

Poistoon tai uudelleennimeäminen.

Ei oo mun mielestä mykistetty, jos nyt selvää otin, screenshot http://i.servut.us/i/Kuvakaappaus2z.png.

ja ilmeisesti toi .asoundrc löyty mutta toista ei. Eikä kuulu vieläkään mitään.

gdm

  • Sitä saa mitä tilaa...
  • Käyttäjä
  • Viestejä: 4363
    • Profiili
    • Keskustelualueiden säännöt
Vs: Ubuntu 8.10: äänet eivät toimi
« Vastaus #15 : 31.10.08 - klo:21.42 »
Ei oo mun mielestä mykistetty, jos nyt selvää otin, screenshot http://i.servut.us/i/Kuvakaappaus2z.png.

Oletko kokeillut nostaa tuon "surround" kohdan tasoa.

Yhdellä Acerin läppärillä se oli ainoa kohta mikä nosti äänen voimakkuuta (että ääni kuului siis)
Kyseessä sinulla taitaa kuitenkin olla pöytäkone. onko mahdollista kokeilla toisilla kaiuttimilla?
Lisää [Ratkaistu] aloitusviestiin jos ongelmasi selviää!
Saamasi tuki on ilmaista, joten älä vaadi tai uhkaile saadaksesi apua!

TheDuck

  • Käyttäjä
  • Viestejä: 18
    • Profiili
Vs: Ubuntu 8.10: äänet eivät toimi
« Vastaus #16 : 31.10.08 - klo:21.46 »
Joo, surroundin säädin täältä graafisesta mikseristä täysille, ei vieläkään kuulu mitään :<

EDIT: eikä oo toisia kajareita..

TheDuck

  • Käyttäjä
  • Viestejä: 18
    • Profiili
Vs: Ubuntu 8.10: äänet eivät toimi
« Vastaus #17 : 31.10.08 - klo:21.49 »
http://i.servut.us/i/Kuvakaappaus3g.png <-- Tuolla kuva siitä playbackista

TheDuck

  • Käyttäjä
  • Viestejä: 18
    • Profiili
Vs: Ubuntu 8.10: äänet eivät toimi
« Vastaus #18 : 31.10.08 - klo:21.52 »
Hups! kun painoin tuolta volume controllista tuota alaspäin nuolta --> move stream... --> ALSA pcm on hw:1 (pcsp) via DMA --> koneen sisältä alkoi kuulua hiljaista musiikin ääntä O_O

Ei siis ollut kuunneltavissa, niin hiljaa kuului mutta kuulosti heviltä :D
« Viimeksi muokattu: 31.10.08 - klo:21.54 kirjoittanut TheDuck »

gdm

  • Sitä saa mitä tilaa...
  • Käyttäjä
  • Viestejä: 4363
    • Profiili
    • Keskustelualueiden säännöt
Vs: Ubuntu 8.10: äänet eivät toimi
« Vastaus #19 : 31.10.08 - klo:21.56 »
Hups! kun painoin tuolta volume controllista tuota alaspäin nuolta --> move stream... --> ALSA pcm on hw:1 (pcsp) via DMA --> koneen sisältä alkoi kuulua hiljaista musiikin ääntä O_O

Ei siis ollut kuunneltavissa, niin hiljaa kuului mutta kuulosti heviltä :D

Eli äänet toimii ;)

vika on siis kajareissa/liitännässä...
Lisää [Ratkaistu] aloitusviestiin jos ongelmasi selviää!
Saamasi tuki on ilmaista, joten älä vaadi tai uhkaile saadaksesi apua!