Kirjoittaja Aihe: Päivittäminen 7.10 (Gutsy) -> 8.04 (Hardy)  (Luettu 26314 kertaa)

papukaija

  • Käyttäjä
  • Viestejä: 100
  • Ubuntu 12.04
    • Profiili
Apua!

Aloin päivittää graafisella työkalulla (update-manager) Gutsyä Hardyyn. No, päivityksen valistelu ja ohjelmien lataus sujui hyvin.
   Kun ohjelmien asennus alkoi, ohjelma ilmoitteli vähän väliä, ainakin 20 kertaa, että
Lainaus
Pakettia "x" ei voitu asentaa. Päivitys jatkuu, mutta paketti "x" ei  välttämättä ole toimivassa tilassa. Harkitse virheraportin lähettämistä.

Tähän listaan kuuluu mm login, perl, passwd, python2.5, base-files, bash, aduser, fuse-utils, slocate, molocate, gconf2, metacity-common, alsa-utils, gnome-keyring ja sudo.

Lopullisesti päivitys tilttas, kun tuli tälläinen viesti:
Lainaus
Päivityksiä ei voitu asentaa. päivitys keskeytyy. Järjestelmäsi voi olla toimimmattomassa tilassa. Korjaustoimenpiteet suritettiin /dpkg --configure -a).
   Please report this bug against the 'update-manager' package and include the files in /var/log/dist-upgrade/ in the bugreport.
installArchives() failed

Siinä update-managerin pääte-syötteessä näkyy
"Asetustiedostoa '/etc/readahead/boot'
--> Muokattu sinun tai...
--> Paketin jakelija on julkaissut päivitetyn version.
--> Mitä haluaisit tehdä? Vaihtoehdot ovat:"

Ongelma  onkin: missä se valinta ikkuna on? Muutama tälläinen valintaikkuna tuli, muta ei readahead:ista.
Edit: käynnistin koneen uudelleen. tulos :näyttö musta, valkoinen x-kursori. Sitten käynnistin koneen recovery tilaan ja konensin dpkg --reconfigure -a ja heti kysyi mitä tehdään sille readahead tiedostolle. Sitten tulikin Setting up sitä ja tätä. Sitten valitti, että liika ongelmia (dpkg: too many errors,stopping). siteen ajoin gdm. ja kas kummaa, onnistuin kirjautumaan. Ruudulla näkyy vain kellertävää taustaa.

Edit2: Nyt toimii, bugiraportti, jossa myös ohjeita järjestelmän palautukseen täältä
« Viimeksi muokattu: 25.04.08 - klo:21.39 kirjoittanut papukaija »

ahteri

  • Käyttäjä
  • Viestejä: 6
    • Profiili
Päivityksessä kans ongelmia.

Tai siis päivitys tuntui sujuvan mallikkaasti siihen asti kun tuli uudelleen käynnistyksen vuoro...
Käynnistyi hienosti, työpöytä näytti samalta kun ennenkin, mut perskule, on melko hankalaa käyttää ilman hiirtä  :-\
Ei toimi PS/2 eikä USB hiiret. Ja lisää merkillisyyttä...
Onko normaalia, että nyt lukee käyttöjärjestelmän valintaruudussa "Ubuntu 8.04, kernel 2.6.24 - 16 - generic" JA "...2.6.24 - 14..."? Siis tuo ...16... on nyt oletuksena ja sillä ei toimi. Kun käynnistää ...14... toimii hiiret, mut sit taas sillä ei pysty säätään näytön tarkkuutta oikeeks - tai mä en ainaskaan osaa???

Timo Virtanen

  • Käyttäjä
  • Viestejä: 2082
    • Profiili
Nimimerkille Ahteri, hätäratkaisuna kokeile Ubuntun käynnistyksen jälkeen irrottaa ja liittää USB-hiiri uudestaan USB liittimeen. Tämä hätäratkaisu toimii kunnes kokeneemmat ehtivät apuun, terveisin Timo
"Linux, made in Finland"

T43, T61p, T500 kierrätysläppärit

ahteri

  • Käyttäjä
  • Viestejä: 6
    • Profiili
Nonnis sainkin sit iha itteksii toimiin jo ton kernel 16...  ::)

debug -> fix x server    (tai jtn sinne päin)

jimbo

  • Käyttäjä
  • Viestejä: 345
    • Profiili
testilevylle: ensin puhas levy, jolla xp ollut jonkun aikaa, sitten pq magic levyn loppuun palanen 8.04 varten, cd pesään ja asennus, meni ok (aiemmin uuden koneen intergr. nvidia ajurista ei nyt valittanut, jonka teki 7.10 kanssa eli ei tarvinnut "käytä turvallisia gaafisia ajureita") asennus kesti alle 10min (!) (5600+ prossu) asentui ok, äänet toimi, net toimi (lanka adsl pppoe) MUTTA   :o kun käynnistyi uudestaan ei tullut enää valikkoa, jossa voi valita kumpaa käyttää: xp vai 8.04 (vistaa ei tule, wintoosa vain koska PAKKO  :-\ joskus sitäkin...)
asennusohjelman lopussa näkyi (asennusteksteissä) että olisi luonut tämän käynnistysvalikon, mutta ei...
xp näyttäisi toimivan...ainakin vielä..normaalisti

aiemmin homma tehty samalla tavoin (monestikin) 7.10 kanssa, eikä ollut onkelmia käynnistysvalikon kanssa/muutenkaan,
parillakin eri raudalla

(runko nyt:  Asus M2N-VM HDMI/2x1Gb kingston DDR2, 800MHz/5600+ amd 64 X2/sata dvd poltto samsung SH-S203/intergr. Nvidia GeForce7050PV/nForce630a)



Pete N.

  • Käyttäjä
  • Viestejä: 56
    • Profiili
AARGH.

Kaikki sujui niin kauan hyvin kunnes kone kaynnistettiin uudelleen. X ei suostunut lahtemaan toimimaan, vaan kaynnisti ubuntun mustaan ruutuun. xfix auttoi, mutta nyt ei ole ilmeisesti ajureita alla, jonka takia kuva hieman krmh... kusee.

Nappaimistoasetukset nayttavat olevan aivan vaarin, helkkari sentaan. Uusi versio POISTI Xmodmapin jonka takia hiireni ei toimi oikein.

Nautilus tuntuu toimivan aivan vaarin, ei nayta tyopyotaa eika avaa itse ohjelman ikkunaa. Aanet sentaan toimivat... ei saakeli, kylla nyt kyrsii. Tuntuu kuin koko kone olisi lamaantunut.

manmanman

  • Käyttäjä
  • Viestejä: 11
    • Profiili
Päivityksessä kans ongelmia.

Tai siis päivitys tuntui sujuvan mallikkaasti siihen asti kun tuli uudelleen käynnistyksen vuoro...
Käynnistyi hienosti, työpöytä näytti samalta kun ennenkin, mut perskule, on melko hankalaa käyttää ilman hiirtä  :-\
Ei toimi PS/2 eikä USB hiiret.

Itsellänikin oli tuon kanssa ongelmia aluksi, ja vieläkin jos otan virrat pois koneesta. Eli Ubuntu hukkaa minun usb-hiiren (logitech mx510). Ubuntu vaihtaa tuon hiiren 'eventin' numeron bootatettaessa, ja sen joutuu vaihtamaan xorg.confiin.

Näitä ohjeita soveltaen olen saanut omani toimimaan. Kohta 1. Changing xorg.conf. on jutun ydin. http://ubuntuforums.org/showthread.php?t=674266

Tosin browser-napit sivuilla ei suostu toimimaan, mut ei jaksa alkaa säätämään vielä. :)
« Viimeksi muokattu: 24.04.08 - klo:21.38 kirjoittanut manmanman »
Ubuntu 8.04.1 - Kernel 2.6.26.3 - Athlon XP 2400 - ATI Radeon 9600

manke

  • Käyttäjä
  • Viestejä: 88
    • Profiili
laitoin ubuntu 7.10 uusiksi ja päivitin.... mut sitte buuttaus valikossa näkyy 8.04.kernel 2.6.24-16 generic ja alla 8.04.kernel 2.6.22-14 generic että onko noilla eroja vai ??? onko ubuntu tuplana vai muuten sama mut eri kernelillä???


sitte oli hävinny nettiasetukset

viel en ole muuta huomannu

Pete N.

  • Käyttäjä
  • Viestejä: 56
    • Profiili
Koodia: [Valitse]
pete@pete-desktop:~$ nautilus
seahorse nautilus module initialized
Initializing nautilus-share extension
nautilus: symbol lookup error: nautilus: undefined symbol: g_file_query_filesystem_info_async


Nautilus ei käynnisty lainkaan. Apua?

Risto H. Kurppa

  • Käyttäjä
  • Viestejä: 3024
  • Useita Kubuntuja ajossa.
    • Profiili
    • http://risto.kurppa.fi
laitoin ubuntu 7.10 uusiksi ja päivitin.... mut sitte buuttaus valikossa näkyy 8.04.kernel 2.6.24-16 generic ja alla 8.04.kernel 2.6.22-14 generic että onko noilla eroja vai ??? onko ubuntu tuplana vai muuten sama mut eri kernelillä???

Sama Ubuntu tuo on mutta eri kerneleillä, eli siinä listassa on myös pykälää vanhempi kernel. Lepo vaan, se on ihan ok :)

sitte oli hävinny nettiasetukset

Saitko korjattua?

r
UUSI UBUNTUN KÄYTTÄJÄ: SÄÄSTÄ AIKAASI LUKEMALLA  -> TÄMÄ <-

Risto H. Kurppa

  • Käyttäjä
  • Viestejä: 3024
  • Useita Kubuntuja ajossa.
    • Profiili
    • http://risto.kurppa.fi
Koodia: [Valitse]
pete@pete-desktop:~$ nautilus
seahorse nautilus module initialized
Initializing nautilus-share extension
nautilus: symbol lookup error: nautilus: undefined symbol: g_file_query_filesystem_info_async


Nautilus ei käynnisty lainkaan. Apua?

Löytyisikö näistä apua:
http://ubuntuforums.org/showthread.php?t=691954
http://ubuntuforums.org/showthread.php?t=694712
https://bugs.launchpad.net/ubuntu/+source/nautilus/+bug/190445
UUSI UBUNTUN KÄYTTÄJÄ: SÄÄSTÄ AIKAASI LUKEMALLA  -> TÄMÄ <-

juyli

  • Vieras
laitoin ubuntu 7.10 uusiksi ja päivitin.... mut sitte buuttaus valikossa näkyy 8.04.kernel 2.6.24-16 generic ja alla 8.04.kernel 2.6.22-14
Sama Ubuntu tuo on mutta eri kerneleillä, eli siinä listassa on myös pykälää vanhempi kernel.

Ubuntuhan säästää vanhat kernelit, ja lisää vain uusimman päivitetyn grub:in valikkoon. Tuosta mankelta vain puuttu versio 2.6.24-15, joka asentui aiemmin. 2.6.22-14 on Gutsyn kernel-versio, jonka varmasti voi poistaa, kunhan tiedät, että uusin toimii (myös langattoman laitteesi osalta) moitteettomasti.

Aleksi Hankalahti

  • Käyttäjä
  • Viestejä: 82
    • Profiili
laitoin ubuntu 7.10 uusiksi ja päivitin.... mut sitte buuttaus valikossa näkyy 8.04.kernel 2.6.24-16 generic ja alla 8.04.kernel 2.6.22-14 generic että onko noilla eroja vai ??? onko ubuntu tuplana vai muuten sama mut eri kernelillä???

Ei ole tuplana. Noi pienemmällä numerolla varustetut on vanhempia kerneleitä. Niitä pidetään siellä varmuuden vuoksi jonkin verran. Jos päivityksen jälkeen uusi kerneli ei toimisikaan voi kokeilla vanhemmalla. Niistä ei tartte huolestua.

Marbo

  • Käyttäjä
  • Viestejä: 427
    • Profiili
    • Toimi.org
Onkohan tämä ongelma tänne palstalle, vai pitäisikö muualle siirtää? Siirtäkää joku admin jos on väärällä puolella.

Eli ongelma on että Hardyssä WLAN ei vain löydä mitään buutin jälkeen. Joudun ottamaan USB-pulikan (A-Linkin usb-wlan) irti ja tunkemaan sen takaisin paikalleen. Sitten vasta löytyy langattomia verkkoja.

KDE:n puolella tunnistuu moitteetta, Gnomessa ei.

Mikähän voisi auttaa tähän ongelmaan?

Kubuntun puolella taas ongelma on, että jos käyttää KDE4:n loginmanageria ja loggaan ulos -> koko kone jää jumiin lähestulkoonsa (eli etäkoneelta saan ssh:n kautta sudo rebootilla buutittua koneen uusiksi, mutta paikallisena en mitenkään). Xorg vetää prossuajan täysin. ATIN suljetut ajurit.

Mikähän tähän voisi olla syynä? Ongelma siis vain Hardy Heronissa.

Mulla on varmaan sama A-linkin usb wlan palikka, ja netti on toiminu moitteettomasti koko ajan sen kautta. Jotain menny vikaan asennuksessa sulla?

Linux user #460798

Pete N.

  • Käyttäjä
  • Viestejä: 56
    • Profiili
Koodia: [Valitse]
pete@pete-desktop:~$ nautilus
seahorse nautilus module initialized
Initializing nautilus-share extension
nautilus: symbol lookup error: nautilus: undefined symbol: g_file_query_filesystem_info_async


Nautilus ei käynnisty lainkaan. Apua?

Löytyisikö näistä apua:
http://ubuntuforums.org/showthread.php?t=691954
http://ubuntuforums.org/showthread.php?t=694712
https://bugs.launchpad.net/ubuntu/+source/nautilus/+bug/190445

EDIT: Poistin /usr/local/lib kansion ja nyt nautilus tuntuu toimivan! Kiitos Risto!
« Viimeksi muokattu: 25.04.08 - klo:01.25 kirjoittanut Pete N. »

Dezeer

  • Käyttäjä
  • Viestejä: 6
    • Profiili
Bonobo virhe
« Vastaus #35 : 25.04.08 - klo:13.38 »
Sain tälläisen virheen kun päivitin ubuntun.
Koodia: [Valitse]
[b]Paneelissa tapahtui virhe[/b]

Paneelin rekistöröitymisessä bonobo-aktivointipalvelimelle oli ongelma (virhekoodi 3) ja se suljetaan.
Paneeli voidaan käynnistää automaattisesti uudestaan

Koodia: [Valitse]
[b]Nautilusta ei voinut käyttää odottamattoman virheen takia[/b]

Nautilusta ei voi käyttää nyt, koska bonobo ilmoitti odottamattomasta virheestä tidostonhallintanäkymäpalvelinta rekistöröitäessä

Löysin englanninkielisen keskustelun jossa neuvottiin seuraavasti:
Lainaus
When booting up into xsession under options as soon as you bootup. ( use safe x terminal) run the following commands.
1.) startx
2.) gnome-wm
this for some reason reset the display windows and when you type
3.) exit it will restart gnome.
4.) Select log in anyway.

Mutta kun laitan komennon startx niin se sanoo, että se on jo käynnissä eikä voi tehdä mitään.

eliasj

  • Käyttäjä
  • Viestejä: 4075
    • Profiili
Käynnistithän Ubuntun uudelleen päivityksen jälkeen? Jos kyllä, niin käynnistä koneesi recovery modessa (valitse grubista vaihtoehto) ja komenna
Koodia: [Valitse]
apt-get update
apt-get dist-upgrade
Jos ei auta niin mietitään ratkaisua.
alias vililikku

Dezeer

  • Käyttäjä
  • Viestejä: 6
    • Profiili
Käynnistithän Ubuntun uudelleen päivityksen jälkeen? Jos kyllä, niin käynnistä koneesi recovery modessa (valitse grubista vaihtoehto) ja komenna
Koodia: [Valitse]
apt-get update
apt-get dist-upgrade
Jos ei auta niin mietitään ratkaisua.
Komennot eivät auttaneet yhtään.

eliasj

  • Käyttäjä
  • Viestejä: 4075
    • Profiili
Vs: Bonobo virhe
« Vastaus #38 : 25.04.08 - klo:14.42 »
Mutta kun laitan komennon startx niin se sanoo, että se on jo käynnissä eikä voi tehdä mitään.
Kokeile tehdä tuo ohje Recovery modessa.
alias vililikku

Dezeer

  • Käyttäjä
  • Viestejä: 6
    • Profiili
Vs: Bonobo virhe
« Vastaus #39 : 25.04.08 - klo:15.00 »
Mutta kun laitan komennon startx niin se sanoo, että se on jo käynnissä eikä voi tehdä mitään.
Kokeile tehdä tuo ohje Recovery modessa.
Tein tuon ja 2. kohdan recovery modessa ja kirjauduin sisään, mutta valittaa edelleen samaa virhettä.