Kirjoittaja Aihe: Sampon uusi java-verkkopankki & Ubuntu  (Luettu 128797 kertaa)

p1ratE

  • Käyttäjä
  • Viestejä: 79
    • Profiili
Vs: Sampon uusi java-verkkopankki & Ubuntu
« Vastaus #220 : 06.07.08 - klo:02.41 »
Handelsbanken on toiminut moitteetta ja verkkopankin saa haluttuaan vaihtaa tekstimuotoon, mihin itsellä ei ole tullut tarvetta.

Daneli

  • Käyttäjä
  • Viestejä: 1036
  • Red Hat Chili Peppers
    • Profiili
    • www.daneli.org
Vs: Sampon uusi java-verkkopankki & Ubuntu
« Vastaus #221 : 08.07.08 - klo:17.35 »
Handelsbanken toimii...näin se vaan on, jotain ne ruotsalaisetkin osaa.

Piraja

  • Käyttäjä
  • Viestejä: 155
  • avatar on foorumissa
    • Profiili
Vs: Sampon uusi java-verkkopankki & Ubuntu
« Vastaus #222 : 01.08.08 - klo:12.23 »
Kiitokset tästä ketjusta ja erityisesti Repaleelle, GodDamnDevilille ja Rikulle, nämä ohjeet yhdistelemällä sain lopulta Sampo Pankin (jolla on nimikin kuin Hullunkurisista perheistä) myös hyväksymään maksut.

Pienenä lisäyksenä mainittakoon, että kokeilin tässä Linux Mintiä ja totesin, että ilmeisesti sen kanssa kaltaiseni tumpelo (joka on vastikään siirtynyt M$-maailmasta Linuxiin) säästää ainakin jonkun pähkäilyvaiheen, vaikka en nyt enää jaksanut viedä läpi noita suljettujen Java-versioiden asennuksia ja poistoja kun perus-ubuntussa homma toimii vihdoin. (Mutta onko ihan asiatonta kehua L. Mintiä täällä? No, onhan sekin Ubuntu-pohjainen distro.)

Piraja

  • Käyttäjä
  • Viestejä: 155
  • avatar on foorumissa
    • Profiili
Vs: Sampon uusi java-verkkopankki & Ubuntu
« Vastaus #223 : 17.08.08 - klo:21.05 »
Pieni lisäys vielä, jonka huomasin kun tein samat manööverit perheen uuteen Ubuntu-asennukseen. Työpöytätehosteet kannattaa ottaa kokonaan pois päältä, jotta maksujen hyväksyntä -ponnahdusikkuna (Java Applet Window) toimii oikein. Näin ainakin vähän vanhemmissa makkinoissa (itselläni Acer TM2354LC, 256MB RAM läppäri, jossa Compiz-tehosteet olivat poissa jo alun alkaenkin ja tämä "uusi" pöytäkone Compaq Evo D510, 512 MB RAM, WinXP sisäisellä kovalevyllä, Ubuntu Hardy asennettu puolestaan ulkoiselle kovolle).

Yhteenvetona siis: lue Repaleen, GodDamnDevilin ja Rikun ohjeet yltä ja poista käytöstä työpöytätehosteet (Järjestelmä > Asetukset > Ulkoasu > Visuaaliset tehosteet > Ei mitään). Näillä mennään.

EDIT: ... siihen asti että pankinvaihtoprosessi on käyty loppuun. Sitten voikin vaihtaa takaisin avoimen lähdekoodin javaan. Laitan tähän vielä koosteen yllä mainituista vaiheista jotka toimivat minun tapauksessani kahdessa vanhahkossa laitekokoonpanossa:

(1) Poista avoimen lähdekoodin Java 6 RE joko pakettienhallinnassa tai päätteessä (allaolevat voi vaikka peistata päätteeseen yksi kerrallaan, perään enteriä ja sudon vaatimaa salasanaa):

Koodia: [Valitse]
sudo apt-get --purge remove openjdk-6-jre icedtea-gcjwebplugin && sudo apt-get autoremove
(2) Asenna Sun Java 5:

Koodia: [Valitse]
sudo apt-get install sun-java5-bin sun-java5-jre sun-java5-plugin
Sun pyytää pakettien lataamisen jälkeen vahvistamaan käyttöehdot. Skrollaa nuolinäppäimillä alas, valitse tab-näppäilemällä OK-nappi, hyväksy enterillä ja valitse seuraavassa ikkunassa "Kyllä". Paketit purkautuvat, sitten ne asennetaan.

(3) Jos Sun Java 6 on asennettuna (se muistaakseni kuuluu esim. pakettiin ubuntu-restricted-extras), poista se:

Koodia: [Valitse]
sudo apt-get --purge remove sun-java6-bin sun-java6-jre sun-java6-plugin && sudo apt-get autoremove
(4) Poista työpöytätehosteet käytöstä. Se tapahtuu ainakin Ubuntu Hardyn Gnome-ympäristössä graafisesti näin:  Järjestelmä > Asetukset > Ulkoasu > Visuaaliset tehosteet > Ei mitään (och samma på svenska & esim. KDE:ssa puolestaan englanniksi näin: System Settings > Look and Feel  > Desktop > Desktop Effects, uncheck).

Jos Firefox (tm. selain; itse olen kokeillut tätä vain Firefoxilla) on auki, sulje se ja käynnistä uudelleen. Avaa verkkopankki (https://verkkopankki.sampopankki.fi).

Tässä vaiheessa Sampo Pankki saattaa heittää seuraavanlaista herjaa: "Kirjautuminen verkkopankkiin ei onnistunut. Käyttämässäsi tietokoneessa ei ole asennettuna tarvittavaa Java Runtime-ohjelmistoa. [Jne.]" Vieritä alas, aivan sivun alareunaan jossa lukee näin: "Joissain tapauksissa järjestelmä ei tunnista Java Runtime-ohjelmistoa oikein. Jos tiedät, että tietokoneessa on tarpeeksi uusi Java Runtime-ohjelmisto, voit ohittaa tämän ilmoituksen ja siirtyä kirjautumissivulle." Paina kirjautumissivun linkkiä. Seuraavaksi aukeaa sivu joka sanoo näin: "Kirjaudu verkkopankkiin. Ole hyvä ja odota... Tarkistamme, onko käyttämässäsi tietokoneessa turvaratkaisumme uusin versio. Jos saat ilmoituksen turvaratkaisun käyttöönotosta, hyväksy se ennen kuin kirjaudut verkkopankkiin. Turvaratkaisun käyttöönotto saattaa kestää useita minuutteja käyttämästäsi Internet-yhteydestä riippuen."

Seuraavaksi esiin pitäisi ponnahtaa "Security Warning" -ikkuna Java-logolla varustettuna. Kuittaa "OK". Nyt kirjautumisikkunan pitäisi aueta ja homman toimia.

Nämä ohjeet on siis koottu Repaleen, GodDamnDevilin ja Rikun ohjeista, joihin lisäsin oman huomioni työpöytätehosteista (en nyt selannut ketjua läpi, voi olla että joku muukin on huomannut tuon viimeisen vaiheen merkityksen).

P.S. Nyt tämä on testattu myös Intrepid Ibexin alfa-versiolla (26.9.2008).
« Viimeksi muokattu: 26.09.08 - klo:16.57 kirjoittanut Piraja »

Ryppy

  • Käyttäjä
  • Viestejä: 837
    • Profiili
Vs: Sampon uusi java-verkkopankki & Ubuntu
« Vastaus #224 : 18.08.08 - klo:00.15 »
Onko tuolla Sampo-pankilla todellakin niin loistavat ehdot,  että kannattaa sietää melkein mitä mitä tahansa heidän suunaltaan, jotta saa rahansa tungettua heidän huostaansa  ??? :o
Eihän se ole edes kotimainen.
Poistuu taka vasemmalle - - -

nsdfo

  • Käyttäjä
  • Viestejä: 23
    • Profiili
Vs: Sampon uusi java-verkkopankki & Ubuntu
« Vastaus #225 : 21.10.08 - klo:14.31 »
Jep, sampopankin tili poistuu käytöstä kunhan palkka tulee.

Suosii kotimaista,
suosii S-pankkia?

 

Risto H. Kurppa

  • Käyttäjä
  • Viestejä: 3024
  • Useita Kubuntuja ajossa.
    • Profiili
    • http://risto.kurppa.fi
Vs: Sampon uusi java-verkkopankki & Ubuntu
« Vastaus #226 : 21.10.08 - klo:18.05 »
kuten aikaisemminkin kejussa on mainittu, myös OP on kotimainen. Oisko säästöpankit myös?

r
UUSI UBUNTUN KÄYTTÄJÄ: SÄÄSTÄ AIKAASI LUKEMALLA  -> TÄMÄ <-

immoT

  • Käyttäjä
  • Viestejä: 435
    • Profiili
Vs: Sampon uusi java-verkkopankki & Ubuntu
« Vastaus #227 : 21.10.08 - klo:18.40 »
kuten aikaisemminkin kejussa on mainittu, myös OP on kotimainen. Oisko säästöpankit myös?
r
Tässä tietoa:
Suomessa toimivat pankit (sivuilta linkki Suomessa toimivat pankkikonsernit pdf)

Ulkomaalaiset ei pysty ostamaan S-pankkia, koska osuuskuntasysteemin omistuksessa, Tapiola ja OP kai myös.

« Viimeksi muokattu: 21.10.08 - klo:18.48 kirjoittanut immoT »

jartza

  • Käyttäjä
  • Viestejä: 2
    • Profiili
Vs: Sampon uusi java-verkkopankki & Ubuntu
« Vastaus #228 : 04.11.08 - klo:19.28 »
Moi! Onko kukaan saanut toimimaan maksun vahvistusta Sampopankin verkkopankissa Ubuntu 8.04:llä ja Firefox 3:lla? Itsellä Sun Java 5:lla aukeaa vahvistusikkuna mutta siinä näkyy vain harmaata ja valkoista mutta ei tekstiä.. (?). Sun Java 6:lla ei toiminut ollenkaan, ainakaan Firefox 3:n Beta 5:lla.. Jos joku tietää toimivan kombinaation, niin olisin kiitollinen.

Kokeilepa seuraavanlaista:

Koodia: [Valitse]
sudo nano /etc/profile

ja lisäät tiedoston loppuun:
Koodia: [Valitse]
export AWT_TOOLKIT=MToolkit

Tämän jälkeen uloskirjautuminen/sisäänkirjautuminen ja pitäisi toimia jopa Compiz Fusion päällä...

Toimii myös Ubuntu 8.10:llä ja sun java 5:llä, firefox 3:ssa.

--
//Jartza

fossiili

  • Käyttäjä
  • Viestejä: 785
    • Profiili
Vs: Sampon uusi java-verkkopankki & Ubuntu
« Vastaus #229 : 23.11.08 - klo:11.04 »
Pitäisi toki lukea, mitä asiasta on jo kirjoitettu tällä foorumilla, mutta kun väsyttää ja on kiire. Lisäksi ongelmia ja vinkkejä on 12 sivun verran tässäkin keskustelussa. Samoin käy jos yrittää erilaisilla hauilla.

Toki jokainen voi vaivatta käyttää Sampopankkia Mobiilisammolla. Kuitenkin toivoisin saavani edes alkuun toimivan Xubuntu 8.041 asennuksen täydellisen mikro- ja linux-ummikon koneeseen

 Flash-soittimen tms. sain jo haettua Adoben sivuilta, mutta vieläkään Ylen kaikki sivut eivät toimi eikä tietenkään Sampokaan. Tarvitaan oikea java. Linee niin, että monipuolisin on Sunin java, mikä kun lisää oikean  lähteen löytynee. Sampo taisi hyväksyä vain version 1.5?

Uudempiakin on kai 1.7 versioon saakka. Tylsää sakkia tanskalaiset, vai kuinka ???

Kiitos jos viitsitte vielä neuvoa!

jori52

  • Käyttäjä
  • Viestejä: 2047
    • Profiili
Vs: Sampon uusi java-verkkopankki & Ubuntu
« Vastaus #230 : 23.11.08 - klo:11.10 »
Pitäisi toki lukea, mitä asiasta on jo kirjoitettu tällä foorumilla, mutta kun väsyttää ja on kiire. Lisäksi ongelmia ja vinkkejä on 12 sivun verran tässäkin keskustelussa. Samoin käy jos yrittää erilaisilla hauilla.

Toki jokainen voi vaivatta käyttää Sampopankkia Mobiilisammolla. Kuitenkin toivoisin saavani edes alkuun toimivan Xubuntu 8.041 asennuksen täydellisen mikro- ja linux-ummikon koneeseen

 Flash-soittimen tms. sain jo haettua Adoben sivuilta, mutta vieläkään Ylen kaikki sivut eivät toimi eikä tietenkään Sampokaan. Tarvitaan oikea java. Linee niin, että monipuolisin on Sunin java, mikä kun lisää oikean  lähteen löytynee. Sampo taisi hyväksyä vain version 1.5?

Uudempiakin on kai 1.7 versioon saakka. Tylsää sakkia tanskalaiset, vai kuinka ???

Kiitos jos viitsitte vielä neuvoa!
Asenna xubuntu resticted extras paketti lisää/poista sovelluksesta, valitse ylhäältä kaikki saatavilla olevat sovellukset, sitten vasemmalta muut (tai other) riippuen suomennoksesta, saat javat ja muut härpäkkeet.

Terveisin jori52
Linux counter #348392
 Asus G750JW ja ubuntu 13.10

gdm

  • Sitä saa mitä tilaa...
  • Käyttäjä
  • Viestejä: 4363
    • Profiili
    • Keskustelualueiden säännöt
Vs: Sampon uusi java-verkkopankki & Ubuntu
« Vastaus #231 : 23.11.08 - klo:11.10 »
@fossiili, Sampopankin toimintaan vaaditaan sun-java5, ubuntun versiolla 8.04
http://forum.ubuntu-fi.org/index.php?topic=18093.0
Tuossa ohjeet siihen.

ubuntu-restricted-extras paketin asennus pitäisi riittää siihen että ylen sivut toimivat.
Yle ei käytä flash-pohjaista ratkaisua. Kyseinen paketti sisältää kylläkin myös flash-liitännäisen.
Mieluummin asenna tuo ensiksi sitten noudatat ensimmäisen linkin ohjeita.

Foorumilla on myös multimedia osastolla kattavat ohjeet kuinka saada ylen sivut toimimaan.
Mutta siihen en linkkaa sillä asentamalla tuon restricted-extras paketin, pitäisi riittää,
kunhan varmistat että käytät totem-gstreamer yhdistelmää.
(toimii myös muilla)
Lisää [Ratkaistu] aloitusviestiin jos ongelmasi selviää!
Saamasi tuki on ilmaista, joten älä vaadi tai uhkaile saadaksesi apua!

gdm

  • Sitä saa mitä tilaa...
  • Käyttäjä
  • Viestejä: 4363
    • Profiili
    • Keskustelualueiden säännöt
Vs: Sampon uusi java-verkkopankki & Ubuntu
« Vastaus #232 : 23.11.08 - klo:11.14 »
Pitäisi toki lukea, mitä asiasta on jo kirjoitettu tällä foorumilla, mutta kun väsyttää ja on kiire. Lisäksi ongelmia ja vinkkejä on 12 sivun verran tässäkin keskustelussa. Samoin käy jos yrittää erilaisilla hauilla.

Toki jokainen voi vaivatta käyttää Sampopankkia Mobiilisammolla. Kuitenkin toivoisin saavani edes alkuun toimivan Xubuntu 8.041 asennuksen täydellisen mikro- ja linux-ummikon koneeseen

 Flash-soittimen tms. sain jo haettua Adoben sivuilta, mutta vieläkään Ylen kaikki sivut eivät toimi eikä tietenkään Sampokaan. Tarvitaan oikea java. Linee niin, että monipuolisin on Sunin java, mikä kun lisää oikean  lähteen löytynee. Sampo taisi hyväksyä vain version 1.5?

Uudempiakin on kai 1.7 versioon saakka. Tylsää sakkia tanskalaiset, vai kuinka ???

Kiitos jos viitsitte vielä neuvoa!
Asenna xubuntu resticted extras paketti lisää/poista sovelluksesta, valitse ylhäältä kaikki saatavilla olevat sovellukset, sitten vasemmalta muut (tai other) riippuen suomennoksesta, saat javat ja muut härpäkkeet.

Terveisin jori52

Juu ei. kyseinen paketti ei yksinään riitä! Sampopankki ei toimi hardyssa muilla kuin sun-java5 versiolla.
Lisää [Ratkaistu] aloitusviestiin jos ongelmasi selviää!
Saamasi tuki on ilmaista, joten älä vaadi tai uhkaile saadaksesi apua!

Piraja

  • Käyttäjä
  • Viestejä: 155
  • avatar on foorumissa
    • Profiili
Vs: Sampon uusi java-verkkopankki & Ubuntu
« Vastaus #233 : 23.11.08 - klo:18.08 »
Hei huomio: Jos asennat ubuntu-restricted-extras paketin, Sammon verkkopankki tuskin toimii! Tämä johtuu siitä, että pakettiin sisältyy (tai ainaki on sisältynyt) Sun Java 6. Jos asennat paketin, voit sen jälkeen poistaa Java 6:n ja asentaa sen sijaan Java 5:n. Katso minun yhteenvetoni vähän ylempänä.

serola

  • Käyttäjä
  • Viestejä: 647
    • Profiili
Vs: Sampon uusi java-verkkopankki & Ubuntu
« Vastaus #234 : 24.11.08 - klo:10.22 »
Hei huomio: Jos asennat ubuntu-restricted-extras paketin, Sammon verkkopankki tuskin toimii! Tämä johtuu siitä, että pakettiin sisältyy (tai ainaki on sisältynyt) Sun Java 6. Jos asennat paketin, voit sen jälkeen poistaa Java 6:n ja asentaa sen sijaan Java 5:n. Katso minun yhteenvetoni vähän ylempänä.
Kuulostaa ristiriitaiselta, sillä minulla Hardy 32bit -versiossa lähti Sampopankki toimimaan nimenomaan jo tämän ketjun ekalla sivulla annetun ohjeen avulla:
Minulla alkoi toimia kun: Sampo-pankin java-applettien käyttämiseksi tulee ladata Synapticilla paketit: sun-java6-jre , sun-java6-bin ja sun-java6-plugin; niillä käyttö onnistuu ainakin mikäli selaimena on Firefox. Herra yksin tietää onko se tietoturvallinen tapa, eikä se pankki-asioinnissa ole hyväksyttävää; mutta toimiipa ainakin.
Tilanne Sampopankin sivujen osalta on siis oletettavasti muuttunut ja toimivat nyt myös Sun Java 6:lla (ainakin Firefoxissa, Opera voi olla edelleen eri juttu...). Tämä siis onnistui todistetusti viikko sitten asennetulla Hardylla.

Piraja

  • Käyttäjä
  • Viestejä: 155
  • avatar on foorumissa
    • Profiili
Vs: Sampon uusi java-verkkopankki & Ubuntu
« Vastaus #235 : 24.11.08 - klo:21.48 »
Kuulostaa ristiriitaiselta
Joo, niinhän se on. Itse asiassa monella, mukaan lukien Rahikaisella, Java 6:lla ei ole toiminut, vaan Java 6 on täytynyt poistaa (jos se on ollut asennettuna esim. ubuntu-restricted-extras -paketin osana) ja asentaa tilalle Java 5. En ollut tainnut huomata tuota ekasivun postia aiemmin. Mielenkiintoista.

harrykaa

  • Vieras
Vs: Sampon uusi java-verkkopankki & Ubuntu
« Vastaus #236 : 24.11.08 - klo:22.05 »
Juu ei. kyseinen paketti ei yksinään riitä! Sampopankki ei toimi hardyssa muilla kuin sun-java5 versiolla.

Gdm,

Eikö Hardyyn sitten saa pakettivarastosta asennettua Sun Java 6 update 10:ä?
Sillähän tuo SampoPankki toimii aivan yhtä mallikkaasti maksujen vahvistamista myöten kuin Windowsissa.

serola

  • Käyttäjä
  • Viestejä: 647
    • Profiili
Vs: Sampon uusi java-verkkopankki & Ubuntu
« Vastaus #237 : 24.11.08 - klo:22.27 »
Hei huomio: Jos asennat ubuntu-restricted-extras paketin, Sammon verkkopankki tuskin toimii! Tämä johtuu siitä, että pakettiin sisältyy (tai ainaki on sisältynyt) Sun Java 6. Jos asennat paketin, voit sen jälkeen poistaa Java 6:n ja asentaa sen sijaan Java 5:n. Katso minun yhteenvetoni vähän ylempänä.
Kuulostaa ristiriitaiselta, sillä minulla Hardy 32bit -versiossa lähti Sampopankki toimimaan nimenomaan jo tämän ketjun ekalla sivulla annetun ohjeen avulla:
Minulla alkoi toimia kun: Sampo-pankin java-applettien käyttämiseksi tulee ladata Synapticilla paketit: sun-java6-jre , sun-java6-bin ja sun-java6-plugin; niillä käyttö onnistuu ainakin mikäli selaimena on Firefox. Herra yksin tietää onko se tietoturvallinen tapa, eikä se pankki-asioinnissa ole hyväksyttävää; mutta toimiipa ainakin.
Tilanne Sampopankin sivujen osalta on siis oletettavasti muuttunut ja toimivat nyt myös Sun Java 6:lla (ainakin Firefoxissa, Opera voi olla edelleen eri juttu...). Tämä siis onnistui todistetusti viikko sitten asennetulla Hardylla.
Täytyypä pyörtää omat puheet. Eli Sun Java 6:lla toimii muutoin, mutta tosiaan laskujen vahvistus ei onnistu. Täytyypä koittaa java 5:sta Pirajan ohjeen mukaisesti, jahka ehdin.

harrykaa

  • Vieras
Vs: Sampon uusi java-verkkopankki & Ubuntu
« Vastaus #238 : 24.11.08 - klo:22.40 »
Täytyypä pyörtää omat puheet. Eli Sun Java 6:lla toimii muutoin, mutta tosiaan laskujen vahvistus ei onnistu. Täytyypä koittaa java 5:sta Pirajan ohjeen mukaisesti, jahka ehdin.

Mikä Sun Java 6 update versio sinulla on käytössä?
Oletko kokeillut update 10:ä. Sillä kun tuo SampoPankki toimii täysin (käytössä jatkuvasti Firefoxilla 3.0.3 ja 3.04).

serola

  • Käyttäjä
  • Viestejä: 647
    • Profiili
Vs: Sampon uusi java-verkkopankki & Ubuntu
« Vastaus #239 : 24.11.08 - klo:22.48 »
Täytyypä pyörtää omat puheet. Eli Sun Java 6:lla toimii muutoin, mutta tosiaan laskujen vahvistus ei onnistu. Täytyypä koittaa java 5:sta Pirajan ohjeen mukaisesti, jahka ehdin.

Mikä Sun Java 6 update versio sinulla on käytössä?
Oletko kokeillut update 10:ä. Sillä kun tuo SampoPankki toimii täysin (käytössä jatkuvasti Firefoxilla 3.0.3 ja 3.04).
Kyllä sen pitäisi olla ihan tuorein mikä Synapticin kautta on tarjolla, eli 10.3.2.1.