Kirjoittaja Aihe: wicd-ongelma (oli: Verkkojen vaihto nm-appletilla)  (Luettu 1694 kertaa)

dotsi

  • Käyttäjä
  • Viestejä: 112
    • Profiili
Terve,

Heti kärkeen pahoittelen ehkä lievästi harhaanjohtavaa otsikointia, mutta asiaani oli vaikea tiivistää yhdelle riville. Ongelmani on kuitenkin seuraavanlainen. Käytössäni on vanha kunnon IBM ThinkPad 600E ja siihen asennettuna Xubuntu 7.10. Langatonta käyttöä varten hommasin A-Linkin WL54PC -kortin, jonka jonkin aikaa säädettyäni tyydyin (väliaikaisesti) saattamaan toimintakuntoon ndiswrapperin ja Windows-ajureiden avulla.

Kortti siis toimii, ja löytää liudan verkkoja, mukaanlukien oman langattoman verkkoni. Verkkoon pääsen kyllä kiinni hienosti WPA2-salauksesta huolimatta, mutta ongelmaksi muodostuu IP-osoitteen saaminen, tai pikemminkin sen asettaminen. Olen jääräpäisesti päättänyt olla käyttämättä DHCP:tä omassa kotiverkossani, ja näin ollen asettanut IP-osoitteet kaikille laitteille (ihan kuin niitä nyt niin monta olisikaan) käsin.

Kiinteän, langallisen verkon kohdalla tämä ei mikään ongelma olekaan, etenkään kun käytän konetta vain kotiverkossa. Langattomalla puolella kysymyksiä kuitenkin herättää koneen käyttö mahdollisissa muissa verkoissa, pääasiassa paikkakunnalta löytyvässä avoimessa alueverkossa ja miksei myös muuallakin. Useimmitenhan langattomat verkot antavat päätelaitteille IP-osoitteen automaattisesti. Kuinka siis mahdollistan tällaisen verkkojen "sekakäytön"?
« Viimeksi muokattu: 16.11.07 - klo:10.41 kirjoittanut dotsi »

olasirtep

  • Käyttäjä
  • Viestejä: 91
    • Profiili
Vs: Verkkojen vaihto nm-appletilla
« Vastaus #1 : 15.11.07 - klo:13.21 »
Klikkaat applettia ja valitset 'Manual configuration...', sieltä valitset langattoman yhteyden ja klikkaat 'Properties'. Nyt voit asettaa kaiken haluamallasi tavalla.  ;)
"The Internet is running too slow. Could you reboot it please?"

dotsi

  • Käyttäjä
  • Viestejä: 112
    • Profiili
Vs: Verkkojen vaihto nm-appletilla
« Vastaus #2 : 15.11.07 - klo:13.32 »
Klikkaat applettia ja valitset 'Manual configuration...', sieltä valitset langattoman yhteyden ja klikkaat 'Properties'. Nyt voit asettaa kaiken haluamallasi tavalla.  ;)

Joo, mutta tämähän ratkaisee ongelmani vain käytettäessä omaa langatonta verkkoa. Avoimeen alueverkkoon tai toisaalle siirtyessäni joudun taas klikkaamaan ruksin "roaming" ruutuun, ja vastaavasti kotiverkkoon palatessani ruksimaan sen pois ja laittamaan asetukset uusiksi.

Lueskelin vähän ubuntuforumsilta samantyylisistä ongelmista, ja joku oli ratkaissut omansa käyttämällä staattista DHCP:tä kotiverkossa. Homma toimii käsittääkseni niin, että reititin antaa tietyn mac-osoitteen omaavalle verkkokortille aina saman IP:n. Tämä voisi toimia myös omalla kohdallani. Koetan kun pääsen töistä kotiin.

EDIT: wicd ratkaisi kaikki ongelmani  ;D
« Viimeksi muokattu: 15.11.07 - klo:19.07 kirjoittanut dotsi »

dotsi

  • Käyttäjä
  • Viestejä: 112
    • Profiili
Vs: wicd-ongelma (oli: Verkkojen vaihto nm-appletilla)
« Vastaus #3 : 16.11.07 - klo:10.45 »
Moninaisesta langattomasta käytöstä johtuen vaihdoin siis perinteisen network managerin nm-appletteineen wicdiin, johon saa huomattavasti näppärämmin talleteltua eri verkkoja ja käyttöympäristöjä koskevia profiileita.

wicd toimiikin hienosti ainakin paikallisessa avoimessa alueverkossa, jossa DHCP jakaa verkkoon liittyville koneille IP-osoitteet. Tilanne on kuitenkin tyystin toinen omassa kotiverkossani, jossa olen tykännyt antaa laitteille osoitteet käsin. Tämäkin toki wicdistä onnistuu, samaten kuin käytettävien DNS-palvelimien määrittely.

Ongelma kuitenkin esiintyy juuri DNS-palvelimissa, sillä vaikka ne on wicdissä määritelty ja näkyvät myös /etc/resolv.confissa ihan oikein, ei systeemi silti näyttäisi osaavan käyttää niitä. Esim. Firefox ei löydä ainoatakaan sivua tai palvelinta verkosta. Kotiverkko kyllä toimii, sillä langattoman yhteyden yli pääsen aina reitittimen hallintasivulle asti. Mikä neuvoksi?

EDIT: hämmennyksekseni huomasin juuri, että sillä aikaa kun kirjoittelin tätä postausta toisella koneella, oli DNS alkanut toimimaan läppärissä. Palvelimet siis "löytyivät" usean minuutin viiveellä, mikä ainakin jokapäiväisessä käytössä tuntuisi kieltämättä varsin hankalalta. Tätä ennen ehdin vielä pingata toista määrittelemääni DNS-palvelinta testatakseni verkon toimintaa. Pingi kulki hyvin, jonka jälkeen sivutkin alkoivat löytymään.
« Viimeksi muokattu: 16.11.07 - klo:10.48 kirjoittanut dotsi »