Kirjoittaja Aihe: Kompiz ongelmia...[ratkaistu vaihtamalla gnomeen]  (Luettu 4463 kertaa)

Corsair44

  • Käyttäjä
  • Viestejä: 98
    • Profiili
Joo ei se meikäläisen koneessa voi tietenkään toimia sukkana....

Eli Direct Rendering on YES eli pitäisi olla kunnossa ? (GF7600go pitäisi riittää potkua?)

Asensin Adeptilla: compiz-kde, compizconfig-settings-manager, compiz-fusion-plugins-main ja extra.

Ensimmäinen huomio oli että mitään työpöytä muutosta ei tapahtunu. Lisäksi wiki oppaaseen verrattuna ei valinnoista löydy kaikkia esim 3D Windows ja Cube atlantis puuttuu ?

Sitten löysin viestiketjusta että pitää päätteellä antaa  loitsu "compiz --replace" heh tän jälkeen menee homma mielenkiitoiseksi!
Copy paste päätteeltä:
Koodia: [Valitse]
compiz --replace
Checking for Xgl: not present.
Detected PCI ID for VGA: 01:00.0 0300: 10de:0398 (rev a1) (prog-if 00 [VGA])
Checking for texture_from_pixmap: present.
Checking for non power of two support: present.
Checking for Composite extension: present.
Comparing resolution (1280x800) to maximum 3D texture size (4096): Passed.
Checking for nVidia: present.
Checking for FBConfig: present.
Checking for Xgl: not present.
Starting emerald
/usr/bin/compiz.real (core) - Warn: No GLXFBConfig for depth 32
/usr/bin/compiz.real (resizeinfo) - Warn: Bind Pixmap to Texture failure
/usr/bin/compiz.real (core) - Warn: No GLXFBConfig for depth 32
/usr/bin/compiz.real (resizeinfo) - Warn: Bind Pixmap to Texture failure
/usr/bin/compiz.real (video) - Warn: No 8 bit GLX pixmap format, disabling YV12 image format

Pääte jää tähän jumiin.

Kaikista ikkunoista häviää otsakenttä myös ne - neliö ja ruksi. Muutenkin näyttää kummalta.
Buuttauksen jäkeen on nomitilanne mutta compiz ei selvästikkään ole päällä.


« Viimeksi muokattu: 21.11.07 - klo:20.09 kirjoittanut Corsair44 »

Nakkis

  • Käyttäjä
  • Viestejä: 154
    • Profiili
Vs: Kompiz ongelmia...
« Vastaus #1 : 04.11.07 - klo:22.29 »
Kokeile ajaa tämä komento komentorivillä, ja sitten paina Ctrl+Alt+Backspace käynnistääksesti graafisen käyttöliittymän uudestaan.

Koodia: [Valitse]
sudo nvidia-xconfig --add-argb-glx-visuals
Kokeile käynnistää compiz tämän jälkeen uudestaan.

Corsair44

  • Käyttäjä
  • Viestejä: 98
    • Profiili
Vs: Kompiz ongelmia...
« Vastaus #2 : 05.11.07 - klo:21.00 »
Kokeile ajaa tämä komento komentorivillä, ja sitten paina Ctrl+Alt+Backspace käynnistääksesti graafisen käyttöliittymän uudestaan.

Koodia: [Valitse]
sudo nvidia-xconfig --add-argb-glx-visuals
Kokeile käynnistää compiz tämän jälkeen uudestaan.

Tehty mutta ei parantunut ajoin ton koodin ja se teki jotain. Sitten compiz --- replace herjaa vielä että xgl not present. Voisko olla että noi nvidian ajurit ei ole kuitenkan asentunu ok?

jake

  • Käyttäjä
  • Viestejä: 1262
    • Profiili
Vs: Kompiz ongelmia...
« Vastaus #3 : 06.11.07 - klo:17.38 »
nVidian ajuri pitää paitsi asentaa niin ottaa myös käyttöön eli kerto (K)Ubuntulle, ett se alkais käyttää just sitä nVidian ajuria eikä enää sitä vanhaa kalua... ja tietty pitää olla asentanu oikea ajuri - siell kun on muistaakseni kaksi eri new ajuria. Oliks se toinen 'new' vai "new", tms

eli asennuksen jälkeen vielä komentoriltä sudo nvidia-glx-config enable

tai graafiselta puolelta klikkailemalla
Kaikille avoin standardi antaa mahdollisuuden valita itselle sopivin ohjelmisto käyttöön.
Millään taholla ei ole oikeutta pakottaa muita käyttämään jotain tiettyä sovellusta tietojen vaihdossa.
"Valitsin siis avointa standardia noudattavat sovellukset, esim: OpenOffice, Firefox ja tiett

Corsair44

  • Käyttäjä
  • Viestejä: 98
    • Profiili
Vs: Kompiz ongelmia...
« Vastaus #4 : 06.11.07 - klo:18.23 »
nVidian ajuri pitää paitsi asentaa niin ottaa myös käyttöön eli kerto (K)Ubuntulle, ett se alkais käyttää just sitä nVidian ajuria eikä enää sitä vanhaa kalua... ja tietty pitää olla asentanu oikea ajuri - siell kun on muistaakseni kaksi eri new ajuria. Oliks se toinen 'new' vai "new", tms

eli asennuksen jälkeen vielä komentoriltä sudo nvidia-glx-config enable

tai graafiselta puolelta klikkailemalla


Toi anto tällästä:
Error: your X configuration has been altered.
This script cannot proceed automatically. If you believe that this
not correct, you can update the md5sum entry executing the following
command:
md5sum /etc/X11/xorg.conf | sudo tee /var/lib/x11/xorg.conf.md5sum
otherwise edit manually /etc/X11/xorg.conf to change the Driver section
from nv to nvidia.

jonikoo

  • Käyttäjä
  • Viestejä: 14
    • Profiili
Vs: Kompiz ongelmia...
« Vastaus #5 : 06.11.07 - klo:20.01 »
gksudo gedit /etc/X11/xorg.conf ja etsi kohta

Section "Device"
   Identifier  "GeForce"            #Nimi (vapaavalintainen)
   Driver      "nvidia"             #Käytettävä ajuri (vaatii nvidia-nimisen ajurimoduulin) täs saattaa olla nv joten pitää vaihtaa nvidiaksi
EndSection

Corsair44

  • Käyttäjä
  • Viestejä: 98
    • Profiili
Vs: Kompiz ongelmia...
« Vastaus #6 : 06.11.07 - klo:21.14 »
Joo diriver on nvidia... Järkyttävän vaikee käyttää tätä kun,  ikkunoita ei voi siirtää ja toi yläpalkki uupuu... Ei auta muu kuin uninstalloida toi kompiz hässäkkä. Harmi kun ei skulaa.

Nakkis

  • Käyttäjä
  • Viestejä: 154
    • Profiili
Vs: Kompiz ongelmia...
« Vastaus #7 : 06.11.07 - klo:21.15 »
Mitä compiz-paketteja olet asentanut?

jake

  • Käyttäjä
  • Viestejä: 1262
    • Profiili
Vs: Kompiz ongelmia...
« Vastaus #8 : 06.11.07 - klo:23.33 »
Joo diriver on nvidia... Järkyttävän vaikee käyttää tätä kun,  ikkunoita ei voi siirtää ja toi yläpalkki uupuu... Ei auta muu kuin uninstalloida toi kompiz hässäkkä. Harmi kun ei skulaa.

Ikkunoita kyllä voi siirtää pitämällä alt-painike alhaalla ja vetämällä hiirellä ikkuna haluttuun paikkaan ja/tai suuntaan

olikoos se toi compiz-emerald-pakeettos, joka auttais ikkunoiden kehysten löytymiseen ja on kai siellä myös sopiva compiz-kde-pakettikin...
Kaikille avoin standardi antaa mahdollisuuden valita itselle sopivin ohjelmisto käyttöön.
Millään taholla ei ole oikeutta pakottaa muita käyttämään jotain tiettyä sovellusta tietojen vaihdossa.
"Valitsin siis avointa standardia noudattavat sovellukset, esim: OpenOffice, Firefox ja tiett

eliasj

  • Käyttäjä
  • Viestejä: 4075
    • Profiili
Vs: Kompiz ongelmia...
« Vastaus #9 : 08.11.07 - klo:14.13 »
Joo diriver on nvidia... Järkyttävän vaikee käyttää tätä kun,  ikkunoita ei voi siirtää ja toi yläpalkki uupuu... Ei auta muu kuin uninstalloida toi kompiz hässäkkä. Harmi kun ei skulaa.

Ikkunoita kyllä voi siirtää pitämällä alt-painike alhaalla ja vetämällä hiirellä ikkuna haluttuun paikkaan ja/tai suuntaan
Ei toi onnistu jos Compiz tai mikään muukaan ikkunamanageri ei oo käynnissä.

Mullakin on Nvidian kortti. Mun xorg.conf on tässä liitetiedostona. Sillä toimii ainakin mulla compiz.

[ylläpito on poistanut liitteen]
alias vililikku

Corsair44

  • Käyttäjä
  • Viestejä: 98
    • Profiili
Vs: Kompiz ongelmia...
« Vastaus #10 : 14.11.07 - klo:08.50 »
Lainaus
Mullakin on Nvidian kortti. Mun xorg.conf on tässä liitetiedostona. Sillä toimii ainakin mulla compiz.

xorg.conf näyttäs olevan melko samanlainen kun sulla. Jopa glx modulikin ladataan.
Uninstalloin compiz sälät pakettien hallinnasta ja nyt taas pystyy käyttämään Kubuntua. Sinänäsä viimeksi kun oli ubuntu 6.04 asennettuna, niin siinä ainakin Emerald toimi ihan sukkana.

Mutta olisko toi xgl juttu tässä ongelmana? Kun siitä tulee herjaa siinä compizin käynnistyksessä?  Mikä toi xgl edes on?

Muuten sellanen huomio että noi perusjutut toimii eli ikkunoiden läpinäkyvyys yms jotka on Kubuntun perussäädöissä.
« Viimeksi muokattu: 25.11.07 - klo:20.28 kirjoittanut EliasJ »

Corsair44

  • Käyttäjä
  • Viestejä: 98
    • Profiili
Vs: Kompiz ongelmia...
« Vastaus #11 : 19.11.07 - klo:20.47 »
Voi jee nyt meni systeemi sekasin. Poistin kaikki compiz paketit. Kubuntu toimi taas suht normaalisti.
No sitten ajattelin että koitan mitä Ubuntu desktop tekis toimisko compiz siellä? Asensin sen koodia: apt-get install ubuntu-desktop.
No se asenteli sitä jonkin aikaa. Sitten oli valmis ja käynnistin koneen uudestaan. Grub valikossa ei ollut muutosksia joten siitä normaali jatko. Käynnistys tapahtu Kubuntu taustakuvalla mutta kirjautumisvalikko olikin Ubuntun. Eli en päässyt missään välissä valitteen kumpi käynnistyy. No Ubuntu käyntiin ja se oli samassa jamassa kuin Kubuntu compiz asennettuna. Aukeavissa ikkunoissa ei ole otsikko ruutua. Ikkunoita ei pysty siirtämään / muuttamaan kokoa. Pääte on kokonaan valkoinen ei pysty käyttämään. Pakettien hallinnasta ei pysty asentaan / poistamaan mitään. Näppis ei ole skandinaavinen , osa valikoista on suomeks osa englanniksi. Kaikki asetusmuutokset pyytä loggautumaan roottina ja koittaan uudestaan.

Miten saan Kubuntun taas käyntiin vai olisko helpointa uudelleen asentaa Kubuntu tai Ubuntu? 
« Viimeksi muokattu: 19.11.07 - klo:20.50 kirjoittanut Corsair44 »