Näytä kirjoitukset

Tässä osiossa voit tarkastella kaikkia tämän jäsenen viestejä. Huomaa, että näet viestit vain niiltä alueilta, joihin sinulla on pääsy.


Viestit - Roberto

Sivuja: [1] 2
1
Voikko ei taida toimia nykyään mutta aspell toimii.
Koodia: [Valitse]
sudo apt update
sudo apt install claws-mail claws-mail-i18n aspell
wget http://ftp.gnu.org/gnu/aspell/dict/fi/aspell6-fi-0.7-0.tar.bz2
tar -xvjf ./aspell6-fi-0.7-0.tar.bz2
cd aspell6-fi-0.7-0
./configure
make
sudo make install
exit
Muokkaus:
Tarkennan vielä että tässä on siis käytössä Claws Mail niminen sähköposti ohjelma.

2
Kiitos vinkistä.
Waterfox vaikuttaa ihan mukavalta selaajalta pienen virittelyn jälkeen.
Ja kyllä suomen oikoluku toimii kun asentaa siihen finnish-spellchecker-2.0.1-signed.xpi lisäosan.
Käyttöliittymän saa suomeksi ja voi tuoda asetukset jostain muusta selaajasta.
Tässä teksti kentässäkin oikoluku toimii koko ajan kun kirjoitan.

3
Ei ole niin että ei saisi oikolukua toimimaan.
Minulla on Claws Mail käytössä ja suomenkielinen oikoluku toimii.
Ei ole voikko vaan aspell jonka asennus ohjeita en nyt valitettavasti ehdi tässä esittää.
Ubuntu MATE 18.04.2
Muokkaus:
Esim. Pluma teksturissa toimii myös oikoluku.
Nettiselaajissa en oikolukua käytä enkä tarvitse.
Muokkaus2 eli Claws Mail:
sudo apt update
sudo apt install claws-mail claws-mail-i18n
Muokkaus3:
Tämän ohjeen mukaisesti pitäisi onnistua.
Tämä on siis tehty ubuntu MATE ympäristössa.
Avaa pääte ja asenna aspell jos ei ole asennettu.
Koodia: [Valitse]
sudo apt update
sudo apt install aspell
wget http://ftp.gnu.org/gnu/aspell/dict/fi/aspell6-fi-0.7-0.tar.bz2
tar -xvjf ./aspell6-fi-0.7-0.tar.bz2
cd aspell6-fi-0.7-0
./configure
make
sudo make install
exit
Käynnistä uudelleen ja tee oikoluku asetukset ohjelmissa.

4
Tarvitsin nopeasti tämän hetken tietoja Vantaalta ja muokkasin tällaisen.
Käyttää gxmessage ohjelmaa.
Laitoin myös otsikot näkymään suomeksi foreca.py tiedostossa.
"null" on muodossa "- "
Koodia: [Valitse]
python3 ./foreca.py http://www.foreca.fi/Finland/Vantaa >/tmp/Vantaa.txt && \
tulos=$(awk 'NR >= 1 && NR <= 13' /tmp/Vantaa.txt >/tmp/Vantaa2.txt ) && \
gxmessage -center -title "Helsinki-Vantaa säätila" -timeout 60 -font "Monospace 10" -buttons "Valmis":1 \
-geometry 420x320 -file /tmp/Vantaa2.txt --wrap

5
Nauhoitin joskus 2012 VHS kamaa läppärille mencoder ohjelmalla.
Kone ei tosin ollut sama.
Kuva tuli USB portin kautta ja äänet tuli mikin kautta.

Löysin jostakin kuvauksesta tämän rivin.

HP EliteBook 840 G1 Notebook PC
Headphone/Microphone combo port - One

Muokkaus:
Laite oli ja on vieläkin kaapissa TERRATEC GRABBY

7
Multimedia ja grafiikka / Vs: Yle Areena nauhitus
« : 18.01.19 - klo:13.54 »
Latausohjelma on nyt päivitetty versioon 0.3

8
Ubuntu tietokoneissa / Vs: Kannettavan täysi jumi 16.04
« : 21.11.18 - klo:12.29 »
Minulla samantapaisia ongelmia aiheutti läppärin vioittunut muistipiiri.
Livetikulta ajettu muistitesti paljasti syyllisen.
Piirin vaihto poisti jumit.

9
Multimedia ja grafiikka / Vs: Yle Areena nauhitus
« : 14.11.18 - klo:17.02 »
Päivitin uuden version (v0.2) alkuperäisen tilalle.
Tallennuksen hallinta on nyt vähän helpompaa.

10
Multimedia ja grafiikka / Vs: Yle Areena nauhitus
« : 13.11.18 - klo:13.18 »
Uusin mkvtoolnix löytyy täältä.
Kakkosrivin lopussa oleva viiva täytyy olla mukana komennossa.

Koodia: [Valitse]
sudo sh -c 'echo "deb http://mkvtoolnix.download/ubuntu/ $(lsb_release -sc) main" >> /etc/apt/sources.list.d/bunkus.org.list'
wget -q -O - https://mkvtoolnix.download/gpg-pub-moritzbunkus.txt | sudo apt-key add -
sudo apt update
sudo apt install mkvtoolnix

11
Multimedia ja grafiikka / Vs: Yle Areena nauhitus
« : 13.11.18 - klo:07.35 »
Käytän allaolevaa ohjelmaa lataukseen.
Ohjelma on vielä kesken ja testivaiheessa eli ongelmia voi tulla mutta nyt ainakin toimii.
Tarvitsee mkvtoolnix paketin mahdollisten tekstitysten korjailuun.
Kun tekee ohjelmalle pikakuvakkeen niin sen käyttö on helppoa.
Ohjelman ei tarvitse pyöriä päätteessä vaan sen voi ajaa taustalla.

v0.3
Piilotettu turhia viestejä joita ei tausta ajossa tarvita.

Koodia: [Valitse]
#!/bin/bash

# v0.3
# 18.01.2019 Roberto

mkdir -p ~/Videot
cd ~/Videot

INPUT=$(zenity --title "Yle Areena lataus" --text "Anna ladattavan videon linkki" --width=400 --entry 2> >(grep -v 'GtkDialog' >&2) )

if [ -z $INPUT ] ; then
    exit 1
else

vnimi=$(zenity --file-selection --title="Anna videolle nimi(.mp4)" --filename="Video1.mp4" --save --confirm-overwrite 2> >(grep -v 'GtkDialog' >&2) )

if [ -d $vnimi ]; then
zenity --error --text="Anna videolle nimi(.mp4)" --title="Virhe!" --width=400 --height=50 2> >(grep -v 'GtkDialog' >&2)
    exit 1
fi

if [ -z $vnimi ]
then
zenity --error --text="Jos haluat tallentaa niin anna videolle nimi(.mp4)" --title="Nimi puuttuu!" --width=400 --height=50 2> >(grep -v 'GtkDialog' >&2)
    exit 1
fi

notify-send 'Video ladataan' 'Odota ilmoitusta latauksen valmistumisesta.'

OUTPUT="$vnimi"
touch "$OUTPUT"
BASE="$(echo $OUTPUT|cut -d'.' -f1)"
SUBTITLEFILE="$(echo $BASE).fin.srt"
SUBTITLEFILE2="$(echo $BASE).2.srt"
FINAALI="$(echo $BASE)_Tekstit.mp4"

yle-dl --maxbitrate 800 --sublang fin "$INPUT" -o "$OUTPUT" 2>/dev/null

if [ -f "$SUBTITLEFILE" ] ; then
    python -c "import sys;lines=sys.stdin.read();print lines.replace(' ―','')" < $SUBTITLEFILE > $SUBTITLEFILE2 2>/dev/null
    mkvmerge -o "$FINAALI" --default-track 0 --language 0:fin "$SUBTITLEFILE2" "$OUTPUT" 2>/dev/null
rm -f "$OUTPUT"
rm -f "$SUBTITLEFILE"
rm -f "$SUBTITLEFILE2"
fi
    notify-send 'Valmis' 'Video on ladattu ja tallennettu'
fi
# rm -f ./*Frag*
exit 0

12
Ja kielipaketti (.po) on myös 4.1.5 sorsista otettu eli luulis olevan uusin.

13
No minulla näkyy vain 4.0.1 versio ja siksi käytän uudempaa.
Ubuntu MATE 18.04.1

14
Myös Krita on mielenkiintoinen ohjelma.
Ohjelman suomennosten (krita.po -> krita.mo) korjailu/täydennys on aika haastavaa.
Ohjelma ei lue kaikkia käännöksiä vaikka ne olisivat aivan oikein.
Minulla on (satunnaisessa) käytössä krita-4.1.5-x86_64.appimage

https://download.kde.org/stable/krita/

15
Multimedia ja grafiikka / Vs: Pinta ei toimi
« : 07.09.18 - klo:15.15 »
Auttaisikohan alla oleva, joka minulla on asennettu.

Koodia: [Valitse]
sudo apt-get install libcanberra-gtk-module

synapticilla asennennu Pinta 1.6-2 ja toimii.
Ubuntu 18.04.1, MATE 1.20.1

16
UFRaw 0.222 ohjelma avaa DNG testikuvani ainakin.
Olen laittanut DNG kuvat avautumaan oletuksena siinä.
Monenlaisia säätöjä löytyy ohjelmasta.

Koodia: [Valitse]
sudo apt-get install ufraw gimp-ufraw ufraw-batch

17
Minulla Gimp asetuksissa on seuraavaa.
Kuvien tuonti ja vienti
Liitännäiset (Raw Image Importer)
file-darktable kohta
Valitsin ylempää
Color profile policy kohdasta:
Convert to preferred RGB Color Profile
Mitään herjaa ei tule testikuvalla.
Muita kuvia en ole nyt testannut.

Gimp tuli PPA lähteestä.
sudo add-apt-repository ppa:otto-kesselgulasch/gimp
Ubuntu MATE 18.04.1

18
Siihen tarvitaan lua scriptejä.
Koko paketti on paikassa /home/(koti)/.config/darktable/lua

https://github.com/darktable-org/lua-scripts
Kansio tallennettu siis lua nimellä.

Kokeilin juuri Gimp 2.10.04 ohjelman kanssa
Darktablella avattu joku esimerkki (Adobe-DNG) .dng kuva.
Darktablesta Edit with Gimp ja muotona oli png, mutta muitakin muotoja löytyy.
Kuva ilmestyi Gimp ohjelmaan.

En ole aiheen harrastaja mutta kokeilen silloin tällöin kaikenlaisia virityksiä.
En tiedä auttaako tämä, mutta se on vain omia kokeiluja.
Kokemukseni Darktable ohjelmasta ovat minimaaliset.

Muokkaus:
Päätteessä komento
echo 'require "contrib/gimp"' > ~/.config/darktable/luarc
Lisäksi gimp-ufraw on asennetu gimp ohjelman mukana.

19
Joo, nämä liittyivätkin tohon gtk-moduli herjaan, johon edellinen kysymyksesi viittasi.

20
Olen asentanut alla olevat paketit, eikä herjoja tule päätteessä.
Vaikka tämä on 18.04.1 niin asentuvat ongelmitta.

https://launchpad.net/ubuntu/+source/topmenu-gtk

libtopmenu-client-gtk2-0_0.2.1+git20151210.8c6108f-3_amd64.deb
libtopmenu-client-gtk3-0_0.2.1+git20151210.8c6108f-3_amd64.deb
topmenu-gtk2_0.2.1+git20151210.8c6108f-3_amd64.deb
topmenu-gtk3_0.2.1+git20151210.8c6108f-3_amd64.deb
topmenu-gtk-common_0.2.1+git20151210.8c6108f-3_all.deb

Muokkaus:
Näin asennettuna kannattaa antaa päätteessä komento:
sudo apt-get -f install

Sivuja: [1] 2