Kirjoittaja Aihe: Päivittäminen 6.10 (Edgy Eft) -> 7.04 (Feisty Fawn) - ohjeet ja ongelmat tänne!  (Luettu 31991 kertaa)

Risto H. Kurppa

  • Käyttäjä
  • Viestejä: 3024
  • Useita Kubuntuja ajossa.
    • Profiili
    • http://risto.kurppa.fi
HUOM! Ohje siirretty wikiin: http://www.ubuntu-fi.org/Wiki/Feistyyn_p%C3%A4ivitys



HUOM! Nämä ohjeet ovat vain Edgyn (6.10) käyttäjille (Dapper 6.06 täytyy ensiksi päivittää Edgyksi - mutta muista että LTS eli pitkäaikainen tuki Dapperille jatkuu vielä muutaman vuoden eli tarvetta päivittämiselle ei pitäisi olla!

HUOM! Päivittäminen ennen virallisen version julkaisua on RISKI - todennäköisyys joutua korjailemaan pieleen mennyttä päivitystä ovat suuret. Maltti on valttia. Mutta rohjea rokan syö ja jos taidot ja aika riittää niin kokeilemaan..


Koska ongelma/ohje-ketju 6.10:n päivittämisestä (kts http://forum.ubuntu-fi.org/index.php?topic=6272.0 ) keräsi valtaisan suosion, ajattelin aloittaa tässä vaiheessa uuden vastaavan, samoilla 'perusohjeilla'.

Seuraava *buntun versio julkaistaan noin kuukauden kuluttua (huhtikuun loppupuolella) ja päivittäminen lienee monella jo mielessä (HUOM - riskit rikkoa asennus ennen virallisen version julkaisua ovat suuret eli maltti on valttia ellei ole aikaa ja motivaatiota korjailla räjähtänyttä Ubuntuaan). Koitetaan keskittää vaikka tähän threadiin ohjeita ja ongelmia eli kysymyksiä feistyyn edgystä päivittämisessä. Ohjeita varten voinee wikiin rakentaa myös oman 'feisty-vinkit' - sivun (dokutiimi?)

PÄIVITYSOHJEITA

HUOM! Julkaisun jälkeen päivitysohjelma ilmoittaa sinulle automaattisesti uudesta versiota. Siihen asti päivittämisen joutuu tekemään käsin!

1) Varmuuskopioi xorg.conf (eli graafisen ympäristön asetustiedosto):
Koodia: [Valitse]
sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf_pre_feisty
- ja varmuuskopioi toki myös muut tärkeät tiedostosi!!!

2) Wiralliset päivitysohjeet lontooksi: https://help.ubuntu.com/community/FeistyUpgrades ja https://help.ubuntu.com/community/FeistyUpgradesManual

3) Jos ongelmat iskevät, käynnistä Ubuntusi recovery modeen (käynnistyksessä valikosta tai jos valikkoa ei näy niin paina ESC kun sitä pyydetään ja valitse sieltä)
  a) varmista että käytössäsi on Feistyn pakettivarasto (eli että /etc/apt/sources.list - tiedostossa ei lue missään edgy): http://fi.wikibooks.org/wiki/Ubuntu_tutuksi/Ohjelmien_asentaminen_ja_pakettivarastot HUOM, wikikirjassa ei vielä versiota Feistylle!!
  b) aja sudo aptitude update
  c) aja sudo apt-get -f install
  d) aja sudo dpkg --configure -a
  e) aja sudo apt-get dist-upgrade
 ja toista kohtia c) - e) kunnes e) menee läpi ilman virheilmoituksia tai asentamatta jääneitä paketteja.

Jos jokin yksittäinen paketti ei suostu tottelemaan, voit asentaa paketin uudelleen komennolla
 sudo apt-get reinstall paketinnimi

Jos jää vielä hiertämään, vilkaise tästä ketjusta olisiko muilla ollut samoja ongelmia ja kysy vinkkejä!

----

KUBUNTU
Kubuntun käyttäjät voivat yrittää myös uudella päivitystyökalulla ( https://wiki.kubuntu.org/KubuntuDistUpgrade ) mutta maaliskuun 22. päivä keräsin sillä ainakin itselleni harmia ja ohjelman kaaduttua homma meni komentorivileikiksi - jouduin poistelemaan apache2:n ja php5:n paketit (ei pelkkiä metoja vaan myös kirjastoja jne jne) dpkg:lla ja vasta tämän jälkeen homma lähti rullaamaan, apt-get install -a asensi ne uudelleen ja dist-upgrade lähti taas käyntiin. huom: 26.3. alkavalla viikolla ohjelmasta ilmestyy uusi versio repoihin, odota siihen saakka - nykyinen versio on rikki!!


Jostain syystä minulla on huonoja kokemuksia päivittämisen kanssa - aina olen omat asennukseni saanut rikki tavalla tai toisella.. Ainakin tilapäisesti. Tai ainakin päivittäminen on ollut turhan hankalaa vaikka käytännössä pitäisi olla helppoa ja näppärää. Kerran olen yhden breezyn päivittänyt täysin ilman ongelmia dapperiksi. Sekin oli kaverin kone.


r

Tämä ohje on Public Domain eli saa siirtää wikiin (ja saatanpa sen jossain vaiheessa itsekin tehdä) mutta keskustelua voi käydä täällä..
« Viimeksi muokattu: 22.03.07 - klo:14.24 kirjoittanut Risto H. Kurppa »
UUSI UBUNTUN KÄYTTÄJÄ: SÄÄSTÄ AIKAASI LUKEMALLA  -> TÄMÄ <-

larpa

  • Vieras
Ei ole kiire siirtyä tuohon, kun kaikki on nyt kohdallaan säädetty.
Mitä parempaa tuossa on, se kiinnostaakin sitten enemmän?

Regel

  • Käyttäjä
  • Viestejä: 1090
  • Lucid
    • Profiili
Älkää päivittäkö järjestelmäänne, ennenkuin Feisty on julkaistu. Se on vielä beta (vaiko alfa) asteella.


ja minulla päivitys meni onnistuneesti tällä komennolla:
Koodia: [Valitse]
gksudo “update-manager -c -d”-d siis etsii myös kehitysversioita. Tämä muuttaa sources.list:n (joitain epävirallisia varastoja menee nurinniskoin) ja päivittää järjestelmän.

Ja Dapperista päivitys pitäisi muistaakseni tehdä:
Dapper -> Edgy -> Feisty
eli ei suoraan feistyyn, vaan edgyn kautta.
« Viimeksi muokattu: 22.03.07 - klo:08.25 kirjoittanut Regel »

Krister

  • Käyttäjä
  • Viestejä: 243
  • "Search" is your friend
    • Profiili
Monien ohjelmien avaaminen Feistyssä on hidasta, jos tätä ei ole korjattu.

hosts tiedoston sisältö on alunperin tämmöinen (mun koneen nimi on masiina):

Koodia: [Valitse]
sudo gedit /etc/hosts

127.0.0.1       localhost
127.0.1.1       masiina

Korjattuna sen kuuluu olla tämmöinen (annoin kenkää tiedostossa oleville ipv6 hässäköille myös, koska olen poistanut ipv6:n pois käytöstä):

Koodia: [Valitse]
sudo gedit /etc/hosts

127.0.0.1       localhost masiina
127.0.1.1       masiina

Minulla ainakin nautiluksen ja geditin avautumiseen tuli huomattavasti lisää puhtia.

Lainaus
Lähde:
http://ubuntuforums.org/showthread.php?t=388765

Topelius

  • Käyttäjä
  • Viestejä: 358
    • Profiili
Mistähän näitä feistyn ohjelma lähteitä löytyy lisää?

Speque

  • Käyttäjä
  • Viestejä: 258
  • Ubuntu Hardy Heron
    • Profiili
Minulla päivitys aiheutti kernel panicin. Sain korjattua asian siten, että käynnistin koneen Feistyn live-cd:ltä, mounttasin root-osion kansioon /media/foo, vaihdoin sen chrootilla juurikansioksi (chroot /media/foo) ja asensin kernelin (jonka asennuksessa oli kai joku mennyt vikaan) uudelleen. Sitten toimi.

stfu

  • Käyttäjä
  • Viestejä: 197
    • Profiili
compiz ei käynnisty kun jouduin muokkaamaan hiiren nappeja xorg.conf:ssa. Itkee että muutettua xorg.conffia ei voi käyttää.. muuten kaikki hyvin. X ei lähtenyt ekalla päälle, piti jotain säädellä vähän.

stfu

  • Käyttäjä
  • Viestejä: 197
    • Profiili
Niin ja näytön resoluutio oli aluksi väärä eikä monitori tunnistunut suorilta. pikkuvikoja.

Risto H. Kurppa

  • Käyttäjä
  • Viestejä: 3024
  • Useita Kubuntuja ajossa.
    • Profiili
    • http://risto.kurppa.fi
KDE:n Akregator hukkasi kaikki feedit eli putsasi xml-tiedoston jossa feedit olivat. Auts. Onnekksi tilaamani 40-50 feediä löytyy vielä arkiston kansionnimistä, ehkä niistä parsettaa osoitteet auki..

https://launchpad.net/ubuntu/+source/kdepim/+bug/92452

r
UUSI UBUNTUN KÄYTTÄJÄ: SÄÄSTÄ AIKAASI LUKEMALLA  -> TÄMÄ <-

Daneli

  • Käyttäjä
  • Viestejä: 1037
  • Red Hat Chili Peppers
    • Profiili
    • www.daneli.org
Itse onnistuin ihan päätteessä komennolla: update-manager -d

mikkohuo

  • Käyttäjä
  • Viestejä: 562
  • The Ubuntu Counter Project - user number #3339
    • Profiili
Päivitys meni update-managerilla hienosti, mutta näytönohjaimen asetukset joutui korjaamaan käsin. Toinen mielenkiintoinen juttu oli virransäästön päällä olo automaattisesti. Ihmettelin, kun kone sammui itsekseen...

Speque

  • Käyttäjä
  • Viestejä: 258
  • Ubuntu Hardy Heron
    • Profiili
Toinen mielenkiintoinen juttu oli virransäästön päällä olo automaattisesti. Ihmettelin, kun kone sammui itsekseen...

Joo, huomasin saman omalla koneellani. Vähän oli ihmettelemistä.  :D

pjotr

  • Käyttäjä
  • Viestejä: 625
    • Profiili
Itse onnistuin ihan päätteessä komennolla: update-manager -d

Päivitys meni tällä tavalla hyvin.

Yksi pieni ongelma tosin: Virtuaalityöpöytiä oli aluksi vain yksi, ja kun lisäsin niiden lukumäärän neljään gdeskletit näkyvät vain ykköstyöpöydällä ja samaten muistitikun kuvake näkyy vain työpöydällä 1. Enpä keksi miten muuttaa/korjata.

Ja tyhjällä työpöydällä kun klikkaa hiiren oikealla se valikkokaan ei aukea kuin työpöydällä yksi.

Jaa, KDE:n ja XFCE:n puolella ovat joka työpöydällä ja hiiren oikea nappi avaa valikon... taidanpa siirtyä käyttämään XFCE:tä.

Editit: Lisäyksiä
« Viimeksi muokattu: 11.04.07 - klo:07.59 kirjoittanut pjotr »
www.tehotuotanto.net

The surest sign that intelligent life exists elsewhere in the Universe is that none of it has tried to contact us.

Tonde

  • Käyttäjä
  • Viestejä: 919
  • Feisty Fawn
    • Profiili
Update manager näyttää olevan taas buginen.

Komensin gksudo “update-manager -c -d”
Ensimmäisen kerran manager kaatui, kun se muutti ohjelmalähteitä. Koko ikkuna meni ihan harmaaksi, enkä löytänyt prosessia, jonka tappamalla olisin sen saanut suljettua.

Tänään jatkoin ja ilmeisesti ohjelmalähteet oli muuttunu, kun käynnistettäessä konetta tuli imoitus, että pitäisi ladata 561 päivitystä.

Aloin latailla päivityksiä. Kun tiedostot oli ladattu, tuli kuvassa näkyvä virhe.

Jatkampa tästä sitten komentorivillä...

[ylläpito on poistanut liitteen]
« Viimeksi muokattu: 13.04.07 - klo:18.07 kirjoittanut Tonde »
Heitä hyväsit hitaudelle. Asenna ubuntu!

juyli

  • Vieras
Update manager näyttää olevan taas buginen.
Komensin gksudo “update-manager -c -d”

Yllättävää. Itse onnistuin kyllä Regelin ohjeiden mukaan tuolla update-manager loitsulla. Muuten olisin asennellut apt-get:in -dist-upgrade:lla, joka ei täydellisesti toiminut (kerralla) Dapper -> Edgyn -päivityksessä.
Ylimääräiset repothan eivät toimi Feisty-päivityksessä (esim. medi*), mutta tuskinpa tuo sentään kaataa ohjelman.

Tonde

  • Käyttäjä
  • Viestejä: 919
  • Feisty Fawn
    • Profiili
Komentoriviltä meni läpi muutamalla virheilmoituksella:

Koodia: [Valitse]
Errors were encountered while processing:
 exim
 logwatch
E: Sub-process /usr/bin/dpkg returned an error code (1)
Heitä hyväsit hitaudelle. Asenna ubuntu!

juyli

  • Vieras
Komentoriviltä meni läpi muutamalla virheilmoituksella:
Koodia: [Valitse]
Errors were encountered while processing:
 exim
 logwatch
E: Sub-process /usr/bin/dpkg returned an error code (1)

$ exim
Ohjelma "exim" löytyy seuraavista paketeista:
 * exim
 * exim4-daemon-heavy
 * exim4-daemon-light
Kokeile: sudo apt-get install <valitsemasi paketti>
bash: exim: command not found

:) Onkohan minulla jäänyt exim ja logwatch asentamatta (logwatch asennus asentaa myös exim:in).
http://packages.ubuntu.com/feisty/admin/logwatch

Tonde

  • Käyttäjä
  • Viestejä: 919
  • Feisty Fawn
    • Profiili
Poistin tuon logwatcin ja eximin, mutta se ei ole suurikaan murhe.

Uudella kernelillä kone ei enää käynnisty. :) Irkissä sanottiin sen olevan yleinen ongelma... Odotellaan päivitystä.

EDIT:
Seuraavana päivänä tuli päivitys ja feisty alkoi toimia hienosti.
« Viimeksi muokattu: 16.04.07 - klo:10.27 kirjoittanut Tonde »
Heitä hyväsit hitaudelle. Asenna ubuntu!

pjotr

  • Käyttäjä
  • Viestejä: 625
    • Profiili
Mielenkiintoisia efektejä...

www.tehotuotanto.net

The surest sign that intelligent life exists elsewhere in the Universe is that none of it has tried to contact us.

janne

  • Käyttäjä
  • Viestejä: 5150
    • Profiili
Yllättävää. Itse onnistuin kyllä Regelin ohjeiden mukaan tuolla update-manager loitsulla. Muuten olisin asennellut apt-get:in -dist-upgrade:lla, joka ei täydellisesti toiminut (kerralla) Dapper -> Edgyn -päivityksessä.

minä päivitin työkoneeni eilen apt-get dist-upgradella ja homma meni läpi moitteetta.

Ylimääräiset repothan eivät toimi Feisty-päivityksessä (esim. medi*), mutta tuskinpa tuo sentään kaataa ohjelman.

ei sillä pitäisi olla mitään väliä. ko. ohjelmista on joka tapauksessa uusimmat versiot, joten niitä ei päivitetä (ellei esim. medibuntua vaihda käyttämään feistyn repoja) ja ne eivät ole systeemin toiminnan kannalta krittiisiä, joten niitten mahdollinen toimimattomuus ilmenisi vasta niitä eksplisiittisesti kutsuttaessa.
Janne