Kirjoittaja Aihe: Kirjoitusoikeudet NTFS-osioille - NTFS-3G (vakaa!)  (Luettu 18550 kertaa)

Melmacian

  • Käyttäjä
  • Viestejä: 868
  • Ubuntu Hardy
    • Profiili
Kirjoittelin uuden oppaan aiheesta, koska tuo vanhempi opas käyttää vanhempaa beta versiota ajurista.


http://www.ubuntu-fi.org/Wiki/ntfs-3g
« Viimeksi muokattu: 21.05.08 - klo:13.34 kirjoittanut Timo Jyrinki »

Kalle Kipinä

  • Käyttäjä
  • Viestejä: 78
    • Profiili
Vs: Kirjoitusoikeudet NTFS-osioille - NTFS-3G (vakaa!)
« Vastaus #1 : 07.04.07 - klo:14.37 »
Ohjeessa lukee, että fstabin rivi muutettaisiin vain muotoon
Koodia: [Valitse]
# /dev/sda1
UUID=9CA45D83A45D6136 /media/sda1     ntfs-3g    defaults,nls=utf8,umask=007,gid=46 0       1
Olenko ymmärtänyt jotain väärin? Mihin umask fstabissa - nimenomaan ntfs:n osalta - vaikuttaa? Jos luin ymmärsin lukemani umaskista oikein (http://en.wikipedia.org/wiki/Umask), se kylläkin vaikuttaa vain uutena luotujen tiedostojen oletusoikeuksiin. Mutta eikö olisi joka tapauksessa järkevää myöntää oletuksena myös kirjoitusoikeudet ainakin käyttäjälle, jos kerran ntfs-3g kirjoittamisen osiolle mahdollistaa?
« Viimeksi muokattu: 07.04.07 - klo:14.41 kirjoittanut kekale »

Melmacian

  • Käyttäjä
  • Viestejä: 868
  • Ubuntu Hardy
    • Profiili
Vs: Kirjoitusoikeudet NTFS-osioille - NTFS-3G (vakaa!)
« Vastaus #2 : 07.04.07 - klo:15.03 »
Enpä ole tuohon hirveän tarkkaan perehtynyt, sillä tuo umask-optio on tuohon tullut suoraan Ubuntun asennuksessa.

NTFS ei kuitenkaan tue Linux tyylisiä umaskeja eikä niitä siten voida tallentaa tiedostoihin jotka ovat tallennettu NTFS-osiolle. Mount:n man-sivu  sanoo seuraavaa:
Lainaus
Set the umask (the bitmask of the permissions that are not present). The default is the umask of the current process.  The value  is  given in octal.
"the bitmask of the permissions that are not present". Ymmärtäisin tämän niin, että se asettaa määrätyt oikeudet niille tiedostoille joilla ei ole ennestään minkäänlaisia oikeuksia, kuten NTFS-osiolle tallennetuille tiedostoilla.

Ja kyllä umask=007 on vähän huono sillä se estää käyttäjältä pääsyn kokonaan NTFS-osiolle. Opas korjattu.
« Viimeksi muokattu: 07.04.07 - klo:15.24 kirjoittanut Epeli »

Kalle Kipinä

  • Käyttäjä
  • Viestejä: 78
    • Profiili
Vs: Kirjoitusoikeudet NTFS-osioille - NTFS-3G (vakaa!)
« Vastaus #3 : 07.04.07 - klo:16.42 »
Mount:n man-sivu  sanoo seuraavaa:
Lainaus
Set the umask (the bitmask of the permissions that are not present). The default is the umask of the current process.  The value  is  given in octal.
"the bitmask of the permissions that are not present". Ymmärtäisin tämän niin, että se asettaa määrätyt oikeudet niille tiedostoille joilla ei ole ennestään minkäänlaisia oikeuksia, kuten NTFS-osiolle tallennetuille tiedostoilla.
Itse uskon, että man-sivun teksti viittaa myös sivulla http://www.acm.uiuc.edu/workshops/cool_unix/umask.html mainittuun ominaisuuteen, joka erottaa umaskin käyttötavan chmodista:
Lainaus
It's important to remember this is a MASK, not a bit setting like chmod.
Käsittäisin siis, että umask on numeromaski oikeuksille, jotka eivät ole käytössä toisin kuin chmodin oktaalinotaatiossa, jossa numerot tarkoittavat oikeuksia, jotka käyttäjät saavat. Ja tämä olisi siis asia, johon mountin man-sivu viittaisi tuolla yllä lainatulla lausahduksella.

Kalle Kipinä

  • Käyttäjä
  • Viestejä: 78
    • Profiili
Vs: Kirjoitusoikeudet NTFS-osioille - NTFS-3G (vakaa!)
« Vastaus #4 : 23.04.07 - klo:12.55 »
Tehtyäni tuolla Wikin ohjeella en nähnyt ntfs-osiolla ollenkaan tiedostoja tai hakemistoja, joiden nimissä oli ääkkösiä. Hankaloitti esimerkiksi Työpöytä-hakemiston kanssa toimimista kovasti, kun sieltä olin jotain kopioimassa. :)

Sitten asensin ntfs-config -ohjelman ja ajoin sen. Se pullautti fstabiin tuollaisen rivin Wikissä neuvotun sijaan:
UUID=92FCE1F5FCE1D38F /media/hda1 ntfs-3g defaults,locale=en_US.UTF-8 0 1

Tuossa siis nls on poistettu kokonaan. Riville on puolestaan lisätty locale-määritys, minkä oletan olevan syynä siihen, että nyt myös ääkkösiä nimissään sisältävät hakemistot ja tiedostot näkyvät.

jemaku

  • Käyttäjä
  • Viestejä: 328
    • Profiili
Vs: Kirjoitusoikeudet NTFS-osioille - NTFS-3G (vakaa!)
« Vastaus #5 : 24.04.07 - klo:22.52 »
Tehtyäni tuolla Wikin ohjeella en nähnyt ntfs-osiolla ollenkaan tiedostoja tai hakemistoja, joiden nimissä oli ääkkösiä. Hankaloitti esimerkiksi Työpöytä-hakemiston kanssa toimimista kovasti, kun sieltä olin jotain kopioimassa. :)

Sitten asensin ntfs-config -ohjelman ja ajoin sen. Se pullautti fstabiin tuollaisen rivin Wikissä neuvotun sijaan:
UUID=92FCE1F5FCE1D38F /media/hda1 ntfs-3g defaults,locale=en_US.UTF-8 0 1

Tuossa siis nls on poistettu kokonaan. Riville on puolestaan lisätty locale-määritys, minkä oletan olevan syynä siihen, että nyt myös ääkkösiä nimissään sisältävät hakemistot ja tiedostot näkyvät.
Mulla lukee
UUID=E44868134867E2B2 /media/c-win ntfs-3g nls=utf8 0 0
Ja ääkköset toimii. Tiedä sitten olisiko tuo defaults tms hyödyllinen.

Misplaced

  • Käyttäjä
  • Viestejä: 3
    • Profiili
Vs: Kirjoitusoikeudet NTFS-osioille - NTFS-3G (vakaa!)
« Vastaus #6 : 08.05.07 - klo:21.42 »
Minulla on kaksi ntfs-osiota joista vain toinen näkyy (hda1, entinen C) ja toinen (hda5, entinen D) näkyy hakemistona mutta tiedostoja ei näy.

Missä voisi olla vika?

Lisäinfoa postailen huomenna tarvittaessa.
Ubuntu 7.04 -käyttäjä.

juyli

  • Vieras
Vs: Kirjoitusoikeudet NTFS-osioille - NTFS-3G (vakaa!)
« Vastaus #7 : 09.05.07 - klo:09.41 »
ja toinen (hda5, entinen D) näkyy hakemistona mutta tiedostoja ei näy.
Missä voisi olla vika?

Onko tuo hda5 liitetty? Kaikki liitetyt osiot näet komennolla mount.
Liitospiste (mountpoint) on toki olemassa. Jos liitospisteeseen ei ole liitetty levyosiota, ei siellä mitään tiedostoja näy.

Mr. J.

  • Käyttäjä
  • Viestejä: 1
    • Profiili
Vs: Kirjoitusoikeudet NTFS-osioille - NTFS-3G (vakaa!)
« Vastaus #8 : 14.05.07 - klo:12.16 »
Asensin (mielestäni) ohjeiden mukaan tuon NTFS-3G:n. Kaikki toimii muuten mainiosti, mutta törmäsin yhteen mielenkiintoiseen asiaan. En kykene luomaan NTFS:iin uusia kansioita. Tiedostoja voi muokata ja uusia tiedostoja voi luoda. Voin toki luoda työpöydälle kansioita ja sitten siirtää ne NTFS:ille. Mutta jostain syystä suoraan kansioiden luominen ei onnistu. Paitsi konsolissa, rootilla tai ilman. Ubuntu herjaa että "Virhe uuden kansion luonnissa. Virhe "Yleinen virhe" uutta kansiota luodessa".

Olen (erittäin) uusi näissä touhuissa, joten todennäköisesti olen vain ryssinyt jotain yksinkertaista keisarillisesti... ;)


Pistetään nyt piruuttaan fstabin sisältöä:
proc /proc proc defaults 0 0
# Entry for /dev/hdb2 :
UUID=bc5a427e-f8f0-48c4-9965-aea31ebafaa7 / ext3 defaults,errors=remount-ro 0 1
# Entry for /dev/hda1 :
UUID=501808501808378C /media/hda1 ntfs-3g defaults,nls=utf8,umask=000,gid=46 0 1
# Entry for /dev/hda2 :
UUID=64BC2FD6BC2FA192 /media/hda2 ntfs-3g defaults,nls=utf8,umask=000,gid=46 0 1
# Entry for /dev/hdb1 :
UUID=72807F39807F02C1 /media/hdb1 ntfs-3g defaults,nls=utf8,umask=000,gid=46 0 1
# Entry for /dev/hdb3 :
UUID=ee961bba-0936-41cb-97c0-bd67ca827b46 none swap sw 0 0

cyanhaze69

  • Käyttäjä
  • Viestejä: 29
    • Profiili
Vs: Kirjoitusoikeudet NTFS-osioille - NTFS-3G (vakaa!)
« Vastaus #9 : 29.05.07 - klo:01.46 »
Kuinkas saan kirjoitusoikeudet usb-kovalevylleni joka on ntfs-muodossa mutta ei näy edes koko listassa  sudo nano /etc/fstab -komennolla

Seiken

  • Käyttäjä
  • Viestejä: 61
    • Profiili
Vs: Kirjoitusoikeudet NTFS-osioille - NTFS-3G (vakaa!)
« Vastaus #10 : 29.05.07 - klo:08.04 »
Kuinkas saan kirjoitusoikeudet usb-kovalevylleni joka on ntfs-muodossa mutta ei näy edes koko listassa  sudo nano /etc/fstab -komennolla

Itse ainakin sain ulkoiselle kovalevylle myös kirjoitusoikeudet kun asensin ensin tietysti tuon ntfs-3g paketin ja sitten heitin perään vielä
Koodia: [Valitse]
sudo apt-get install ntfs-configSillä sain valikkoon ntfs configuration toolin josta valitsin "enable external device write support tms..." Jotenkin näin... Sorry jos muistan hieman
likimain... Näin sain ainakin nopeasti vanhaan läppäriin liitettyä ntfs muotoisen usb kovon ja kirjoitettua sille....

cyanhaze69

  • Käyttäjä
  • Viestejä: 29
    • Profiili
Vs: Kirjoitusoikeudet NTFS-osioille - NTFS-3G (vakaa!)
« Vastaus #11 : 29.05.07 - klo:23.27 »
SUURKIITOS!!! säätöjen jälkeen viel buuttasin niin johan pelittää :) ;D

Deisto

  • Käyttäjä
  • Viestejä: 74
    • Profiili
Vs: Kirjoitusoikeudet NTFS-osioille - NTFS-3G (vakaa!)
« Vastaus #12 : 03.06.07 - klo:23.04 »
Mulla on usb:n kautta kovalevy ja siinä ntfs-osio.
Asensin ntfs-3g:n tuon ohjeen mukaan mutta se ei silti mounttaa sitä oikein, vaan jättää sen ro:ksi.
Sain sen kuitenkin kirjoitettavaan tilaan komennolla:
Koodia: [Valitse]
sudo ntfs-3g /dev/sda1 /home/omat/
Kysymys kuuluu: mitä oikein pitäisi laittaa fstabiin, ohjeen mukainen rivi ei toimi
Lainaus
/dev/sda1 /home/omat ntfs-3g    defaults,nls=utf8,gid=46 0       1


ntfs-config heitti tällaisen rivin kun painoin "enable external device write support", tällä se ei ainakaan toimi:
Koodia: [Valitse]
/dev/sda1 /home/omat ntfs umask=222,utf8 0 0
Ubuntu Feisty 32-bit
AMD64 3500+
nVidia GeForce 6600 256Mt

Melmacian

  • Käyttäjä
  • Viestejä: 868
  • Ubuntu Hardy
    • Profiili
Vs: Kirjoitusoikeudet NTFS-osioille - NTFS-3G (vakaa!)
« Vastaus #13 : 04.06.07 - klo:10.26 »
no kurkkaa tuosta wikin ohjeesta millainen sen pitää olla. Tuossa näyttämässäsi rivissä ei ole edes ntfs-3g:ta käytössä ja asetus rw puutuu joka antaa kirjoitusoikeudet.

Deisto

  • Käyttäjä
  • Viestejä: 74
    • Profiili
Vs: Kirjoitusoikeudet NTFS-osioille - NTFS-3G (vakaa!)
« Vastaus #14 : 04.06.07 - klo:13.41 »
Epeli ei tainnut lukea postiani kunnolla?  ;)
Lainaus
Kysymys kuuluu: mitä oikein pitäisi laittaa fstabiin, ohjeen mukainen rivi ei toimi:
/dev/sda1 /home/omat ntfs-3g    defaults,nls=utf8,gid=46 0       1
Tämä oli siis wikin mukainen lauseke
Ubuntu Feisty 32-bit
AMD64 3500+
nVidia GeForce 6600 256Mt

pttk

  • Käyttäjä
  • Viestejä: 1045
    • Profiili
Vs: Kirjoitusoikeudet NTFS-osioille - NTFS-3G (vakaa!)
« Vastaus #15 : 04.06.07 - klo:14.51 »

Feistyssä noille osioille pääsee suoraan ja ne näkyy tiedostoselaimessa ainakin minulla, kuinka niille kirjoittamiseen annetaan oikeudet?
Debian 6 "Squeeze", Ubuntu  10.04, Ubuntu 12.04

Deisto

  • Käyttäjä
  • Viestejä: 74
    • Profiili
Vs: Kirjoitusoikeudet NTFS-osioille - NTFS-3G (vakaa!)
« Vastaus #16 : 04.06.07 - klo:17.32 »
Niin kyllähän ne näkee, mutta kirjoittamiseen tarvitaan juurikin tässä threadissa aiheena oleva ntfs-3g, jonka how-to löytyy ekasta postauksesta.
Kesä taitaa kuumentaa ihmisten päät kun ei vaivauduta lukemaan ensimmäistä riviä pidemmälle ;)
Ubuntu Feisty 32-bit
AMD64 3500+
nVidia GeForce 6600 256Mt

Melmacian

  • Käyttäjä
  • Viestejä: 868
  • Ubuntu Hardy
    • Profiili
Vs: Kirjoitusoikeudet NTFS-osioille - NTFS-3G (vakaa!)
« Vastaus #17 : 04.06.07 - klo:18.03 »

Feistyssä noille osioille pääsee suoraan ja ne näkyy tiedostoselaimessa ainakin minulla, kuinka niille kirjoittamiseen annetaan oikeudet?
Feisty ei muistaakseni asenna ntfs-3g:tä oletuksena ollenkaan, joten ohjeen mukaan. Vai onko sinulla sen kanssa jokin ongelma?

Lainaus
Kesä taitaa kuumentaa ihmisten päät kun ei vaivauduta lukemaan ensimmäistä riviä pidemmälle
Heh, sen verrran voin puolustella, että luin tuon postauksen kännykällä ;) Mutta kyllä tuo defaults pitäisi riittää kirjoitusoikeuksiin. Voit kuitenkin koittaa lisätä siihen rw-parametrin. Koita myös pystytkö kirjoittamaan sinne rootin oikeuksin.
« Viimeksi muokattu: 04.06.07 - klo:18.05 kirjoittanut Epeli »

pttk

  • Käyttäjä
  • Viestejä: 1045
    • Profiili
Vs: Kirjoitusoikeudet NTFS-osioille - NTFS-3G (vakaa!)
« Vastaus #18 : 04.06.07 - klo:18.48 »

 Kyllä ihan tuon wikiin laittamasi ohjeen mukaan menee ja toimii.     ;)

 http://www.ubuntu-fi.org/Wiki/ntfs-3g
Debian 6 "Squeeze", Ubuntu  10.04, Ubuntu 12.04

Deisto

  • Käyttäjä
  • Viestejä: 74
    • Profiili
Vs: Kirjoitusoikeudet NTFS-osioille - NTFS-3G (vakaa!)
« Vastaus #19 : 04.06.07 - klo:23.24 »
Jees ei anna kirjoitusoikeuksia edes rootille.
Koitin laittaa sekä defaults, rw, että defaults,nls=utf8,gid=46,rw.
Ja ntfs-3g oli luonnollisesti tiedostomuotona.
Ubuntu Feisty 32-bit
AMD64 3500+
nVidia GeForce 6600 256Mt