Kirjoittaja Aihe: Grub hukassa + mountit  (Luettu 8400 kertaa)

petri0

  • Käyttäjä
  • Viestejä: 247
    • Profiili
Vs: Grub hukassa + mountit
« Vastaus #20 : 05.02.07 - klo:22.38 »
Nyt meni henkimaailman jutuiksi  ::) Grubin manuaalin mukaan (
http://www.gnu.org/software/grub/manual/html_node/Stage2-errors.html#Stage2-errors )
Lainaus
22 : No such partition
    This error is returned if a partition is requested in the device part of a device- or full file name which isn't on the selected disk.

Sulla ei varmaan ole kovalevyt lisääntyneet tai vaihtaneet paikkaa tänä aikana joten sudo fdisk -l ei tarvi mutta haluaisin nähdä miltä nano /boot/grub/menu.lst (terminaalissa vai päätekö se oli?) näyttää, kokonaisuudessaan.

Hm, silloinhan sinun pitää käynnistää kone DesktopCD:llä ja silloin kyllä voit itsekin jo hakea Nautiluksen avulla se menu.lst mutta kovalevy, tai se osio täytyy joka tapauksessa liittää. Toivottavsti käytössäsi on 6.06 koska siinä on vielä jäljellä ohjelma nimeltä Disks, tai jotain, System > Administration > Disks jolloin se osio on helppo liittää. Mutta kysy jos et löydä.

nihil

  • Käyttäjä
  • Viestejä: 10
    • Profiili
Vs: Grub hukassa + mountit
« Vastaus #21 : 06.02.07 - klo:21.32 »
nano /boot/grub/menu.lst ei sano mitään, ei löydy sitä fileä. Ei ole ainakaan tuolla, enkä findillä löytänyt, tai sitten en vain osannut etsiä oikein.

Se admin, disks sanoo jotta partition 6 (jostain syystä se on partition 6 siinä, luulin, että olisi 5) on inaccessible. Enable ei toimi. Tässä kokonaisuudessaan mitä sen partition infot sanovat:

Partition properties
device: /dev/hdb6
filesystem: extended 3
access path: none
status: inaccessible

Tuolla ei ole mount pointtia jostain syystä. Kun katsoin esim. partition 1:stä (windows), sillä oli mount point /tmp/disks-conf-hdb1 (eli access pathin kohdalla oli tuo polku). Se että access pathia ei ole on kai se syy miksi enable failaa.

petri0

  • Käyttäjä
  • Viestejä: 247
    • Profiili
Vs: Grub hukassa + mountit
« Vastaus #22 : 06.02.07 - klo:23.19 »
Lainaus
Se että access pathia ei ole on kai se syy miksi enable failaa.

Joo, aivan oikein. Kyseessä oli siis DesktopCD? Teet rohkeasti vain kansion vaikka siihen näkösälle (työpöydälle) johon sitten liität sen hdb6. Tai tee kansio mihin vaan sehän katoaa kun lopetat Desktop session. Silloin pääset hakemaan Nautiluksen (tiedostoselain?) avulla sitä Grubin starttilistaa osoitteesta /boot/grub/menu.lst

Grub alkaa laskea nollasta eli eka levyn eka osio on (hd0,0)
GUI alkaa laskea ykkösestä eli eka levyn eka osio on (hda1)

Eli toka levyn kuudes osio grubin mukaan on (hd1,5) kun se on GUIn mielestä hdb6

nihil

  • Käyttäjä
  • Viestejä: 10
    • Profiili
Vs: Grub hukassa + mountit
« Vastaus #23 : 13.02.07 - klo:22.33 »
Menu.lst sanoo tällasta:

title           Ubuntu, kernel 2.6.15-26-386
root            (hd1,5)
kernel          /boot/vmlinuz-2.6.15-26-386 root=/dev/hdb6 ro quiet splash
initrd          /boot/initrd.img-2.6.15-26-386
savedefault
boot

title           Ubuntu, kernel 2.6.15-26-386 (recovery mode)
root            (hd1,5)
kernel          /boot/vmlinuz-2.6.15-26-386 root=/dev/hdb6 ro single
initrd          /boot/initrd.img-2.6.15-26-386
boot

title           Ubuntu, memtest86+
root            (hd1,5)
kernel          /boot/memtest86+.bin
boot

### END DEBIAN AUTOMAGIC KERNELS LIST
# This is a divider, added to separate the menu items below from the Debian
# ones.

title           Other operating systems:
root

# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/hda1
title           Windows NT/2000/XP (loader)
root            (hd0,0)
savedefault
makeactive
chainloader     +1

# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/hdb1
title           Microsoft Windows XP Professional
root            (hd1,0)
savedefault
makeactive
map             (hd0) (hd1)
map             (hd1) (hd0)
chainloader     +1

Ainoa mikä noista toimii on toi "Windows NT/2000/XP (loader)".

petri0

  • Käyttäjä
  • Viestejä: 247
    • Profiili
Vs: Grub hukassa + mountit
« Vastaus #24 : 14.02.07 - klo:13.32 »
No, menipä vaikeaksi.  :(

Miltä näyttää sinun device.map?  ( gedit /boot/grub/device.map )



EDIT: Sekä kokeile tätä: http://users.bigpond.net.au/hermanzone/p15.htm#cli

Jaune

  • Käyttäjä
  • Viestejä: 481
    • Profiili
Vs: Grub hukassa + mountit
« Vastaus #25 : 12.03.07 - klo:19.53 »
Nyt on melko onneton olo...

Eli Ubuntu(Edgy) toiminut kun junanvessa jo pitkään... mutta tänä aamuna emäntä soitti ja tuumas jotta grub error 21.

Nyt tässä iltasella sitä zoomaillessa en oikeen tiedä mitä tehdä. Live CD ei jostain syystä toimi, ei pääse windowssiin, eikä pääse ubuntuun. Kannettavalta nyt sentäs pääsin tänne voivottelemaan.

Eli eli...'
Tässä kannettavassa ei ole polttavaa romputinta ja pöytäkoneessa(joka solmussa) ei ole korputinta. Millähän tuohon grubiin pääsisi nyt käsiksi?

Koneessa:
AMD xp3200
512 mb muistia
200gt win osio xp:llä
80 gt osio ubuntulle
dvd-rw
dvd


Jaune

  • Käyttäjä
  • Viestejä: 481
    • Profiili
Vs: Grub hukassa + mountit
« Vastaus #26 : 12.03.07 - klo:21.23 »
Eli eli, tilanne rupiaa ahistamaan aina vaan enempi... tuntuu että mikään live cd ei toimi tuossa koneessa  :(

Puppy hyytyy johonkin kernel panic hässäkkään... Ubuntu alternative install cd ei löydä paketteja... knoppix jämähtää "scanning hardiscs and creating fstab...

. Eli vaikuttaisi rauta vialtako? mistähän tuota yrittäisi lähtä purkamaan? hd kaapelit irti ja live cd:llä uutta yritystä?


petri0

  • Käyttäjä
  • Viestejä: 247
    • Profiili
Vs: Grub hukassa + mountit
« Vastaus #27 : 13.03.07 - klo:00.19 »
http://www.gnu.org/software/grub/manual/grub.html#Stage2-errors

Lainaus
21 : Selected disk does not exist
    This error is returned if the device part of a device- or full file name refers to a disk or BIOS device that is not present or not recognized by the BIOS in the system.

Sulla ilmeisesti on XP sillä isommalla levyllä? XP levy sisään koneeseen ja boottaat rescue vai mikähän se on ja komennat fixmbr niin XP oma startteri tulee toimintakykyiseksi jälleen. Tuota komentoa ja tapaa kannatta ensin tarkastaa jostakin, vaikkapa tältä foorumilta. En nimittäin ole ihan varma oliko se just noin.

Jaune

  • Käyttäjä
  • Viestejä: 481
    • Profiili
Vs: Grub hukassa + mountit
« Vastaus #28 : 13.03.07 - klo:08.00 »
Ai niin tuota ajattelin myös aluksi, mutta minullahan on tietenkin HP:n pakettikone jossa asennus media on omalla osiollaan ja kun grubi on särki en pääse edes niihin käsiksi. "käynnistys" ruudussa on vaihtoehto "F10 Rescue" mutta se hyytyy samaan Error 21:een.

Tänään jahka pääsen kotiin kaivan tuon vanhan koneen komerosta ja kokeilen siinä ensin ilman kovoa livecd:tä ja jos pelittää niin koitan sitten kovo kerrallaan päästä noihin levyihin käsiksi ja kattella onko ne ok.

Petri Järvisalo

  • Käyttäjä
  • Viestejä: 579
    • Profiili
    • Kotisivut
Vs: Grub hukassa + mountit
« Vastaus #29 : 13.03.07 - klo:14.44 »
Juu kiitos. Nyt alkoi grubi pelittämään. Tuli kuitenkin uusi ongelma. Windowsin saan grubista käyntiin, mutta ubuntua en. Kun otan sen ubuntu-valinnan grubista, se sanoo jotta:
booting 'Ubuntu, kernel 2.6.15-26-386'
root (hd1, 5)
error 22: No such partition

Eli jostain syystä se ei nyt löydä tuota ubuntua, vaikka se on kyllä ihan tasan tarkkaan tuolla hd1, 5-partitiolla.


joo, huomasin saman, luettuani lisää käy ilmi, että uusimmissa grubeissa lisätään tuohon numeroon jostain hyvin mystisestä syystä yksi lisää automaattisesti.
eli muuta menu.lst  --> root(hd1,4) sitten toimii.

ikävää tämä, mutta minkäs mahdat.
« Viimeksi muokattu: 13.03.07 - klo:14.46 kirjoittanut Petri Järvisalo »
Lisää [ratkaistu] ketjun ensimmäisen viestin otsikkoon, kun ongelma on ratkennut.

Jaune

  • Käyttäjä
  • Viestejä: 481
    • Profiili
Vs: Grub hukassa + mountit
« Vastaus #30 : 13.03.07 - klo:20.19 »
Noniin...

Liitin tuon 200gt levy wanhaan koneeseeni ja ajattelin josko live cd toimisi siinä ja pääsisin siihen grubiin käsiksi... no , wanhan koneen cd asema ei pidä rw levyjä juuri minään ja ei boottaa.

Sain sen kuitenkin boottaamaan jollain vanhalla knoppix 3.3:lla.

Mutta nyt kummastuttaa mistä löydän tuon mystisen grubin? Eli tuo 200gt levy on windows levy, mutta grubi on jossain sen syövereissä... kait :) ainakin se antaa saman herjan kun koitan käynnistää konetta.


Toni Alenius

  • Käyttäjä
  • Viestejä: 1478
  • fasistinen sosialistipiraatti
    • Profiili
Vs: Grub hukassa + mountit
« Vastaus #31 : 14.03.07 - klo:08.13 »
yksinkertaista: Windowsin asennuslevy sisään ja mene katsomaan osioita, Windows -levyllä on pakko olla GRUBia varten pieni Linux -osio, jota Windows ei tunnista, siinä kohdassa lukee: "(joku osiotunnus, esim. E) osio   tuntematon (osion koko)

Toni Alenius

  • Käyttäjä
  • Viestejä: 1478
  • fasistinen sosialistipiraatti
    • Profiili
Vs: Grub hukassa + mountit
« Vastaus #32 : 14.03.07 - klo:08.14 »
jos Windows -kovolla ei tuntemattomia osioita ole, ei siellä GRUBia ole.

Jaune

  • Käyttäjä
  • Viestejä: 481
    • Profiili
Vs: Grub hukassa + mountit
« Vastaus #33 : 14.03.07 - klo:08.54 »
Ongelmahan on siinä että ei ole tuota windows asennusmediaa... vaan se on tuolla kovalevyn yhdellä osiolla(kiitos HP:n loistavan politiikan olla jakamatta windows romppuja).

Grubi kyllä on tuolla osiolla koska antaa saman errorin kun tuuppaan tuon levyn tuohon vanhaan koneeseen... Tosin jostain syystä tuo prkleen härveli ei enää saa tuota knoppixiakaan käyntiin... rupiaa menemään todella vmäiseksi.

Jos saan tuon koneen joskus vielä jaloilleen... onko mahdollista asentaa muuta bootloaderia? Onko LiLo vielä olemassa ja onko se kenties turvallisempi vaihtoehto? meni usko tuohon grubiin...

Toni Alenius

  • Käyttäjä
  • Viestejä: 1478
  • fasistinen sosialistipiraatti
    • Profiili
Vs: Grub hukassa + mountit
« Vastaus #34 : 14.03.07 - klo:08.59 »
Ongelmahan on siinä että ei ole tuota windows asennusmediaa... vaan se on tuolla kovalevyn yhdellä osiolla(kiitos HP:n loistavan politiikan olla jakamatta windows romppuja).

Grubi kyllä on tuolla osiolla koska antaa saman errorin kun tuuppaan tuon levyn tuohon vanhaan koneeseen... Tosin jostain syystä tuo prkleen härveli ei enää saa tuota knoppixiakaan käyntiin... rupiaa menemään todella vmäiseksi.

Jos saan tuon koneen joskus vielä jaloilleen... onko mahdollista asentaa muuta bootloaderia? Onko LiLo vielä olemassa ja onko se kenties turvallisempi vaihtoehto? meni usko tuohon grubiin...
Toki, en ole sitä käyttänyt pitkään aikaan, mutta kyllä se vielä monista jakeluista löytyy, teet jollakin vanhalla jakelulla käynnistyslevykkeen, ja sitten BIOSista tms. korppu -boot päälle, kai se sillä lähtee käyntiin, muistelisin että Spectra Linuxissa (vuodelta 2001) olisi molemmat, sekä LiLo että Grub, ja käynnistyslevykkeen tekoa tarjotaan aina asennuksen yhteydessä. Itse sitä käyttäessäni käytin LiLoa, ja taitaapa olla vielä käynnistyslevykekin olemassa, pitää katsoa...

EDIT: siis toki se on olemassa, turvallisuudesta en osaa sanoa mitään.
« Viimeksi muokattu: 14.03.07 - klo:09.01 kirjoittanut Toni Alenius »

petri0

  • Käyttäjä
  • Viestejä: 247
    • Profiili
Vs: Grub hukassa + mountit
« Vastaus #35 : 14.03.07 - klo:09.15 »
Ongelmahan on siinä että ei ole tuota windows asennusmediaa... vaan se on tuolla kovalevyn yhdellä osiolla(kiitos HP:n loistavan politiikan olla jakamatta windows romppuja).

Grubi kyllä on tuolla osiolla koska antaa saman errorin kun tuuppaan tuon levyn tuohon vanhaan koneeseen... Tosin jostain syystä tuo prkleen härveli ei enää saa tuota knoppixiakaan käyntiin... rupiaa menemään todella vmäiseksi.

Jos saan tuon koneen joskus vielä jaloilleen... onko mahdollista asentaa muuta bootloaderia? Onko LiLo vielä olemassa ja onko se kenties turvallisempi vaihtoehto? meni usko tuohon grubiin...
Tähän voi luultavasti antaa ratkaisun Hermanin sivut jolloin voit mm. käynnistää koneesi grubia editoimalla ja sen jälkeen ehjätä sen... aika täydellinen saijtti Grubille.