Kirjoittaja Aihe: Grub hukassa + mountit  (Luettu 8488 kertaa)

nihil

  • Käyttäjä
  • Viestejä: 10
    • Profiili
Grub hukassa + mountit
« : 25.01.07 - klo:23.05 »
Olen tässä yrittänyt etsiä tähän ongelmaan pari päivää ratkaisua, mutta kun ei vaan löydy, eikä ole käsiä, niin ei onnistu. Eli siis dapperia instaan (kai), tuo 6.06.1-i386. Partitioin kovon ntfs-, ext3- ja swap-osioihin. Ajan installerin cd:lta ja instaan ubuntun normisti, mutta grubi kai sitten hukkuu johonkin väärään paikkaan. Kun boottaan kovolta, windows buuttii normaalisti, eikä käyttiksenvalinta ilmesty.

Kysymys kuuluu siis: miten ja mitkä mount pointit minun pitää asentaa rootin ja swapin lisäksi ja mille osioille, jotta se grubi ajellaan käynnistyksen yhteydessä? Partition 5 on ext3 9G osio, sinne asennan rootin. Partition 6:lle asennan swapin. Nämä ovat ok. Sitten ne loput. Esim, pitääkö minun asentaa /boot johonkin, esim. sille partitiolle jolla windows on? En löytänyt mistään tarkempia ohjeita, mitä mount pointteja pitää asettaa ja mille osiolle ne kuuluu mountata jos haluaa dualbootti-järjestelmän saada toimimaan.

Vapaan koodin kananmuna

  • Käyttäjä
  • Viestejä: 1536
    • Profiili
Vs: Grub hukassa + mountit
« Vastaus #1 : 26.01.07 - klo:00.39 »
Ei ole mounteista kiinni. Grub kirjoitetaan master boot recordille joka luetaan ensimmäisenä levyltä käynnistäessä. Katso vaikka wikipediasta lisäinfoa MBR:stä http://en.wikipedia.org/wiki/Master_boot_record
Kerro hiukan lisää systeemistäsi, onko minkälainen kone? SATA levyjä vai ihan ide? Kuinka monta ja onko windows tässä tapauksessa kenties eri levyllä kuin mihin yritit asentaa Ubuntua?
Voisikohan myös tuo osioiden määrä vaikuttaa, kerro tarkemmin miten olet osioinut levyn. (Live-cd:ltä komennon sudo fdisk -l tuloste on ehkä ymmärrettävin)
En Vastaa Vaikeisiin Kysymyksiin.

pttk

  • Käyttäjä
  • Viestejä: 1045
    • Profiili
Vs: Grub hukassa + mountit
« Vastaus #2 : 26.01.07 - klo:16.54 »

 Niin ja voit tuoltakin katsoa  asennettaessa Grub kysyy asennetaanko se ja mihin.

 (Ratkaistu) Ubuntu 6.10 ei käynnisty

 On vielä ainakin tällä samalla sivulla tuo.
Debian 6 "Squeeze", Ubuntu  10.04, Ubuntu 12.04

nihil

  • Käyttäjä
  • Viestejä: 10
    • Profiili
Vs: Grub hukassa + mountit
« Vastaus #3 : 28.01.07 - klo:13.51 »
sudo fdisk -l sanoo tällaista:
Disk /dev/hda: 82.3 GB, 82348277760 bytes
255 heads, 63 sectors/track, 10011 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hda1   *           1       10011    80413326    7  HPFS/NTFS

Disk /dev/hdb: 61.4 GB, 61475807232 bytes
255 heads, 63 sectors/track, 7474 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hdb1   *           1        6199    49793436    7  HPFS/NTFS
/dev/hdb2            6200        7474    10241437+   f  W95 Ext'd (LBA)
/dev/hdb5            6200        6327     1028128+  82  Linux swap / Solaris
/dev/hdb6            6328        7474     9213246   83  Linux

Windowssi on tuolla hb1:lla, eli samalla levyllä, mihin yritän installoida ubuntun. Ei tule grub:sta kysymystä installoinnin yhteydessä.

nihil

  • Käyttäjä
  • Viestejä: 10
    • Profiili
Vs: Grub hukassa + mountit
« Vastaus #4 : 31.01.07 - klo:13.58 »
Hjeelp!

Toni Alenius

  • Käyttäjä
  • Viestejä: 1478
  • fasistinen sosialistipiraatti
    • Profiili
Vs: Grub hukassa + mountit
« Vastaus #5 : 31.01.07 - klo:14.12 »
sellaista kysyisin, että mitä tarkoittaa käynnistyksen yhteydessä "Grup error 21", tiedän, ei käynnisty, mutta tarkoittaako se sitä, että Grubia ei löydy, vai onko se vahingoittunut, vai mitä?

Regel

  • Käyttäjä
  • Viestejä: 1090
  • Lucid
    • Profiili
Vs: Grub hukassa + mountit
« Vastaus #6 : 31.01.07 - klo:15.29 »
Lainaus
Error 21 means :
"
21 : Selected disk does not exist
    This error is returned if the device part of a device- or full file name
refers to a disk or BIOS device that is not present or not recognized by the
BIOS in the system.
"

Toni Alenius

  • Käyttäjä
  • Viestejä: 1478
  • fasistinen sosialistipiraatti
    • Profiili
Vs: Grub hukassa + mountit
« Vastaus #7 : 31.01.07 - klo:15.39 »
No justiinsa, taas meni IDE Master/Slave järjestely uusiksi, vaikka BIOS sanookin täsmälleen samaa kuin mitä pitäisikin: "Primary drive: IBM 8Gb", ja Slavena on 14,3Gt Maxtor (koneen mukaan 15,4), pinneissä olevat palikat oikein, ja kytketty IDE -kaapeliin oikein, tai ainakin luulisin pinnien olevan oikein, tuosta Maxtorista ota hullukaan selvää, kun on yksi nippeli, 7 pinniä ja niistä 2 pitäisi yhdistää sillä nippelillä, eikä kovon päällä olevassa tarrassa ole kunnon ohjeistusta, IBM:ssä on kaksi nippeliä ja kunnollinen ohjeistus.

nihil

  • Käyttäjä
  • Viestejä: 10
    • Profiili
Vs: Grub hukassa + mountit
« Vastaus #8 : 31.01.07 - klo:19.25 »
Voisin tietenkin laittaa käsin sen grubin sinne, vaikka näiden ohjeiden mukaan: https://help.ubuntu.com/community/RecoveringUbuntuAfterInstallingWindows

..mutta kohtuudella ahdistaa alkaa sitä MBR:ää käpistelemään, kun ei ole backuppeja eikä mitään. Toimiikos noi direksöönit kunnolla, onko riskiä, pitääkö alkaa backuppailemaan? Minun pitäisi ilmeisesti tehdä tuon "Using the Desktop/LiveCD while preserving Windows Bootloader"-osion mukaan, vai?

Ryppy

  • Käyttäjä
  • Viestejä: 837
    • Profiili
Vs: Grub hukassa + mountit
« Vastaus #9 : 31.01.07 - klo:20.38 »
nihil:
Sulla on buuttaustäppä kahdella winkku osiolla. Ota pois se toinen (hdb1).
Poistuu taka vasemmalle - - -

nihil

  • Käyttäjä
  • Viestejä: 10
    • Profiili
Vs: Grub hukassa + mountit
« Vastaus #10 : 31.01.07 - klo:21.28 »
Tuo hdb1 on se miltä sen pitäisi buutata. Instasin kaksi kertaa, kun ei alkanut toimimaan, mutta eipä se mitään muuttanut, siksi on kahdessa paikkaa, mutta ei sen käsittääkseni pitäisi mitään vaikuttaa, kun kuitenkin buutin tuolta hdb1:lta? Jos vaikuttaa, niin miten poistan sen toisen?

Ville Pöntinen

  • Käyttäjä
  • Viestejä: 2078
    • Profiili
Vs: Grub hukassa + mountit
« Vastaus #11 : 31.01.07 - klo:22.32 »

Muistaakseni asennus kysyy, että laitetaanko GRUB ensimmäisen kiintolevyn MBR:ään. Täten, kun sulla kerran on ollut boottitäppä ilmeisesti kahdessa paikassa, lienee se (GRUB) asentunut hda1:n MBR:ään, eikä hdb1:n.

Korjatkaa jos olen väärässä... Voit koettaa korjata GRUB:ia tai yrittää uudelleenasennusta (kun et vielä kai ole muuta päässyt tekemään) ja tsempata sen osioinnin kanssa.


Ryppy

  • Käyttäjä
  • Viestejä: 837
    • Profiili
Vs: Grub hukassa + mountit
« Vastaus #12 : 31.01.07 - klo:23.02 »
Juuri näin tarkoitin. Oletin että hda1 olisi se buutattava osio.
Poistuu taka vasemmalle - - -

pttk

  • Käyttäjä
  • Viestejä: 1045
    • Profiili
Vs: Grub hukassa + mountit
« Vastaus #13 : 01.02.07 - klo:01.08 »
 Juh GRUB pois hda,lta ja sinne winkusta    fixmbr, luulisin vähäisellä kokemuksellani  ( jos et muuten saa Grub;ia pois hae gookkelilla win98 boottikorppu ja poottaa se ensimmäisenä + fdisk /mbr sitten windowsista korjaava asennus  fixmbr. 

Tämä siis ( C:\ ) llä eli hda;lla toimaa XP;ssäkin. Mutta kuten todettua ei kuudessa viikossa täällä vielä neroksi olla linuxin kanssa tultu.      ::)
Debian 6 "Squeeze", Ubuntu  10.04, Ubuntu 12.04

petri0

  • Käyttäjä
  • Viestejä: 247
    • Profiili
Vs: Grub hukassa + mountit
« Vastaus #14 : 01.02.07 - klo:18.42 »
Tuo hdb1 on se miltä sen pitäisi buutata. Instasin kaksi kertaa, kun ei alkanut toimimaan, mutta eipä se mitään muuttanut, siksi on kahdessa paikkaa, mutta ei sen käsittääkseni pitäisi mitään vaikuttaa, kun kuitenkin buutin tuolta hdb1:lta? Jos vaikuttaa, niin miten poistan sen toisen?
Jos olet LiveCd:llä asentanut niin Grub meni hda:lle kysymättä, AlternateCD:llä se sentään kysyy. Jos kuitenkin olet saanut Grubin hdb:lle niin asenna se hda:lle vaikka Hermannin ohjeiden mukaan: http://users.bigpond.net.au/hermanzone/p15.htm#Re-install_Grub_with_Live_CD tai http://users.bigpond.net.au/hermanzone/p15.htm#reinstallgrub

nihil

  • Käyttäjä
  • Viestejä: 10
    • Profiili
Vs: Grub hukassa + mountit
« Vastaus #15 : 01.02.07 - klo:19.44 »
Yritinpä seurata noita ohjeita ja selvisi, että Live CD on ilmeisesti instannut sen grubin hd1,5:lle, eli linux partitiolle. Ehkä tämä tästä selviää. Windows on nyt siis slavella ja tarkoitus on buutata siltä, eli hdb1:llä. Samoin linux, partitiolla 5. Nyt, kun yritän instata sitä grubia tuon slavelevyn MBR:ään, eli onko tämä oikein:
sudo grub
root (hd1, 1)
setup (hd1)
?
Vai alkaako tuo nollasta, eli pitäisikö olla:
sudo grub
root (hd1, 0)
setup (hd1)

Kun kokeilin tuonne 0:aan, sanoi "filesystem type unknown" ja setup sanoi: "cannot mount selected partition", eli jos se tuonne nollaan pitää laittaa, jotain muuta häikkää tässä on. Kysyn nyt tarkasti, kun ei ole backuppeja, eikä viitsi hajottaa systeemejä.

petri0

  • Käyttäjä
  • Viestejä: 247
    • Profiili
Vs: Grub hukassa + mountit
« Vastaus #16 : 01.02.07 - klo:22.19 »
(hd1,0) on yhtäkuin (hdb1)

Kokeile sillä toisella, ei se enempi rikki mene, mitä nyt XP lakkaa vastaamasta. Sekin korjaantuu "kädenkäänteessä" tältä sivulta  http://www.users.bigpond.net.au/hermanzone/p18.htm

Nyt tosin en pysy mukana mutta olen aina luullut ettei Windows toimi muultakuin ensimmäiseltä kovalevyltä eli (hd0,0) tai (hda1) mutta jos Grub ei suostu asentumaan ekalle kovalevylle niin kokeile sitä toista ja varsinkin jos XP on sillä toisella kovalevyllä.

nihil

  • Käyttäjä
  • Viestejä: 10
    • Profiili
Vs: Grub hukassa + mountit
« Vastaus #17 : 01.02.07 - klo:22.43 »
Ei, kyllä minulla windows on slavella ja siltä buuttaan, eli hdb1. Mutta grub ei suostu instaantumaan tällä:
sudo grub
root (hd1, 0)
setup (hd1)

Vaan sanoo: "filesystem type unknown" kun kirjoitan root (hd1, 0) ja  "cannot mount selected partition" kun yritän setuppia.

petri0

  • Käyttäjä
  • Viestejä: 247
    • Profiili
Vs: Grub hukassa + mountit
« Vastaus #18 : 01.02.07 - klo:23.25 »
Siis sinä teet näin:

Koodia: [Valitse]
sudo grub
grub> find /boot/grub/stage1

eikö silloin grub vastaa
Lainaus
grub> find /boot/grub/stage1
   (hd1,5)
eli seuraavaksi sun pitäisi tehdä näin
Koodia: [Valitse]
grub> root (hd1,5) eikä (hd1,0). Se root (hd1,5) kertoo missä osiossa on ne tiedostot mitkä sinä haluat asentaa. Ja sitten lopulta
Koodia: [Valitse]
grub> setup (hd1)

Tästä nyt on aikaa enkä silloinkaan ymmärtänyt mutta minusta tuntuu että sinun tapauksessa se pitää sittenkin asentaa
Koodia: [Valitse]
grub> setup (hd0) mutta kokeile ensin ekaa vaihtoehtoa. Se että Grub valittaa "filesystem type unknown" sekä "cannot mount selected partition" johtunee siitä että se ei voi liittää osiota (hd1,0) koska siellä asuu XP ntfs:llä.
« Viimeksi muokattu: 01.02.07 - klo:23.30 kirjoittanut petri0 »

nihil

  • Käyttäjä
  • Viestejä: 10
    • Profiili
Vs: Grub hukassa + mountit
« Vastaus #19 : 05.02.07 - klo:19.25 »
Juu kiitos. Nyt alkoi grubi pelittämään. Tuli kuitenkin uusi ongelma. Windowsin saan grubista käyntiin, mutta ubuntua en. Kun otan sen ubuntu-valinnan grubista, se sanoo jotta:
booting 'Ubuntu, kernel 2.6.15-26-386'
root (hd1, 5)
error 22: No such partition

Eli jostain syystä se ei nyt löydä tuota ubuntua, vaikka se on kyllä ihan tasan tarkkaan tuolla hd1, 5-partitiolla.