Kirjoittaja Aihe: Broadcom 4400  (Luettu 1528 kertaa)

Masse

  • Käyttäjä
  • Viestejä: 38
    • Profiili
Broadcom 4400
« : 28.10.06 - klo:22.45 »
Dapperissa ja vanhalla kernelillä 2.6.15 broadcomin kortti toimii mainiosti, mutta 2.6.17 ja 2.6.18 kerneleillä tulee ongelmia. Tarpeeksi nopeasti ladatessa tai upitessa luultavasti bufferi täyttyy ja kortista tulee käyttökelvoton ennen uudelleenkäynnistystä. Edgyssä ei ole sorsia 2.6.15 kernelille joten vaihdoin hetkeksi dapperin repot ja latasin sorsat, purin ja otin b44.* uuteen kerneliin ja käänsin. Ongelma säilyi.

juyli

  • Vieras
Re: Broadcom 4400
« Vastaus #1 : 28.10.06 - klo:23.44 »
dapperin repot ja latasin sorsat, purin ja otin b44.* uuteen kerneliin ja käänsin. Ongelma säilyi.

??? b44-moduli asentuu jo oletuksena.

$ locate b44
/lib/modules/2.6.17-10-generic/kernel/drivers/net/b44.ko

$ cat /etc/issue
Ubuntu 6.10 \n \l

Masse

  • Käyttäjä
  • Viestejä: 38
    • Profiili
Re: Broadcom 4400
« Vastaus #2 : 28.10.06 - klo:23.50 »
Tiedän, ilman sitähän en saisi edes pingiä menemään läpi. Toimii normaalissa internet liikenteessä, mutta lanin nopeudella bufferi ylittyy

Masse

  • Käyttäjä
  • Viestejä: 38
    • Profiili
Re: Broadcom 4400
« Vastaus #3 : 04.11.06 - klo:21.06 »
Eli ilmeisesti ongelma ei ole b44 moduulissa. Kernelin 2.6.15 mukana tulee 0.97 versio b44 moduulista, mutta sen siirtäminen uuteen kerneliin ei auta. Samoin vanilla kernel 2.6.15 kääntäminen ei auta. Ilmeisesti jokin bufferi täyttyy 100mbps nopeuksissa. Ongelman ilmestymisen jälkeen koetin pingata toiselta lanikoneelta. Tcpdump ei kerro mitään muuta kuin satunnaisia merkkejä. Mutta ifconfig ilmoittaa että rx paketit lisääntyvät, mutta tx paketit eivät lisäänny joten ilmeisesti kortti edelleen vastaanottaa, mutta ei pysty lähettämään. Moduulin uudelleenlataaminen ei auta