Kirjoittaja Aihe: Ubuntu 6.10:een päivittäminen: ohjeet ja ongelmat tänne!  (Luettu 71995 kertaa)

Risto H. Kurppa

  • Käyttäjä
  • Viestejä: 3024
  • Useita Kubuntuja ajossa.
    • Profiili
    • http://risto.kurppa.fi
Ylläpidon huomautus: tämä viestiketju käsittelee Ubuntun 6.10-julkaisuun päivittämistä. Tämä päivitys ei ole tarpeen kenellekään tämänhetkiselle 6.06-version käyttäjälle. Seuraava LTS-julkaisu (pitkäaikainen tuki) julkaistaan 18 kk päästä, ja siihen asti voi aivan hyvin käyttää julkaisua 6.06. Nyt kun tämä huomautus on tehty, niin tervetuloa kaikki innostuneet kokeilemaan uusimpaan Ubuntuun siirtymistä :) -Timo

----

Uusin *buntun versio julkaistiin eilen ja päivittäminen lienee käynnissä.
Koitetaan koota vaikka tähän threadiin ohjeita ja ongelmia eli kysymyksiä edgyyn dapperista päivittämisessä.

PÄIVITYSOHJEITA

1) Varmuuskopioi xorg.conf (eli graafisen ympäristön asetustiedosto):
Koodia: [Valitse]
sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf_pre_edgy

2) Wiralliset päivitysohjeet lontooksi: https://help.ubuntu.com/community/EdgyUpgrades
 HUOM: Ubuntun graafinen päivitysohjelma on taipuvainen tällä kertaa ongelmiin eli komentoriviltä _saattaa_ mennä helpommin. Fifty Fifty.

3) Jos ongelmat iskevät, käynnistä Ubuntusi recovery modeen (käynnistyksessä valikosta tai jos valikkoa ei näy niin paina ESC kun sitä pyydetään ja valitse sieltä)
  a) varmista että käytössäsi on Edgyn pakettivarasto (eli että /etc/apt/sources.list - tiedostossa ei lue missään dapper):
http://fi.wikibooks.org/wiki/Ubuntu_tutuksi/Ohjelmien_asentaminen_ja_pakettivarastot#sources.list_-_tiedosto_Ubuntu_Edgylle_.286.10.29
  b) aja sudo aptitude update
  c) aja sudo apt-get -f install
  d) aja sudo dpkg --configure -a
  e) aja sudo apt-get dist-upgrade
 ja toista kohtia c) - e) kunnes e) menee läpi ilman virheilmoituksia tai asentamatta jääneitä paketteja.

Jos jokin yksittäinen paketti ei suostu tottelemaan, voit asentaa paketin uudelleen komennolla
 sudo apt-get reinstall paketinnimi

Jos jää vielä hiertämään, vilkaise tästä ketjusta olisiko muilla ollut samoja ongelmia ja kysy vinkkejä!

----

Itse kohtasin tämänkaltaista ongelmaa ajaessani sudo aptitude dist-upgradea uudella edgy - pakettivarastoilla (sources-list):
Koodia: [Valitse]
Tarvitsee noutaa 0B/358MB arkistoista. Levytilaa kuluu 218MB purkamisen jälkeen.
Haluatko jatkaa? [Kyllä=y/ei=n/?] y
Kirjoitan tilatietoja... Valmis
Puretaan malleja paketeista 100%
Esiräätälöidään paketteja...
(Reading database ... 103512 files and directories currently installed.)
Preparing to replace libexiv2-dev 0.7-9.1ubuntu1 (using .../libexiv2-dev_0.10-1.3ubuntu1_i386.deb) ...
Unpacking replacement libexiv2-dev ...
dpkg: error processing /var/cache/apt/archives/libexiv2-dev_0.10-1.3ubuntu1_i386.deb (--unpack):
 trying to overwrite `/usr/lib/libexiv2.la', which is also in package libexiv2c2a
Errors were encountered while processing:
 /var/cache/apt/archives/libexiv2-dev_0.10-1.3ubuntu1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Jonkin paketin asennus epäonnistui. Yritän toipua:
rhk@ribantu:

Eli libexiv2 aiheuttaa ongelmia.
Koodia: [Valitse]
sudo aptitude purge libexiv2 -f otti sen pois , uudelleen asentui dist-upgraden yhteydessä ja näyttää ihan hyvin taas etenevän.


Jostain syystä minulla on huonoja kokemuksia päivittämisen kanssa - aina olen omat asennukseni saanut rikki tavalla tai toisella.. Ainakin tilapäisesti. Tai ainakin päivittäminen on ollut turhan hankalaa vaikka käytännössä pitäisi olla helppoa ja näppärää. Kerran olen yhden breezyn päivittänyt täysin ilman ongelmia dapperiksi. Sekin oli kaverin kone.


r
« Viimeksi muokattu: 02.11.06 - klo:22.46 kirjoittanut rhk »
UUSI UBUNTUN KÄYTTÄJÄ: SÄÄSTÄ AIKAASI LUKEMALLA  -> TÄMÄ <-

Risto H. Kurppa

  • Käyttäjä
  • Viestejä: 3024
  • Useita Kubuntuja ajossa.
    • Profiili
    • http://risto.kurppa.fi
Re: EDGYYN PÄIVITTÄMINEN: ohjeet ja ongelmat tänne!
« Vastaus #1 : 27.10.06 - klo:01.52 »
Kubuntun päivityksen jälkeen Ati 9550:n 3D - ominaisuudet (direct rendering) tipahti kyydistä
eli päivityksen jälkeen:
Koodia: [Valitse]
rhk@ribantu:/$ glxinfo |grep direct
direct rendering: No
rhk@ribantu:/$ 

ja näillä ohjeilla http://hs.dy.fi/foo/edgy_ja_ati_fglrx.html ja uudelleenkäynnistämällä

sain direct renderingin taas pelaamaan eli

Koodia: [Valitse]
rhk@ribantu:/$ glxinfo |grep direct
direct rendering: Yes
rhk@ribantu:/$ 

jee.



r
UUSI UBUNTUN KÄYTTÄJÄ: SÄÄSTÄ AIKAASI LUKEMALLA  -> TÄMÄ <-

junnuh

  • Käyttäjä
  • Viestejä: 331
    • Profiili
    • Kotisivu
Re: EDGYYN PÄIVITTÄMINEN: ohjeet ja ongelmat tänne!
« Vastaus #2 : 27.10.06 - klo:06.39 »
Tervehdys!

Hyvin alkanut Dapperin päivitys on tyssänyt tähän:

Distribution Upgrade-ikkunassa lukee: "noudetaan ja asennetaan päivityksiä" ja asennus on vaiheessa "valmistellaan libc6 asetuksia"!

Upggrade-ikkunan päätteellä lukee seuravaa: "unpacking python-cairo (from .../python-cairo_1.2.0-1build1_amd64.deb"

ja asennus on jumissa!

Mitä voin tehdä! :D

lämpimin terveisin junnuh
valoa lämmöllä ja rakkaudella - ubuntu rulaa
www.junnunterapiat.com

shukle

  • Käyttäjä
  • Viestejä: 79
    • Profiili
Re: EDGYYN PÄIVITTÄMINEN: ohjeet ja ongelmat tänne!
« Vastaus #3 : 27.10.06 - klo:09.15 »
Minulla jumitti samaan kohtaan.
Pääsin eteenpäin tappamalla tuon jumittuneen session ja käynnistämällä synaptecin.
Jouduin poistamaan 2 rikkinäistä (open office kieliä) pakettia, jonak jälkeen synaptec
suostui jatkamaan päivitystä.

Ei se kyllä helposti mennyt senkään jälkeen, mutta nyt tuntuu toimivan.

moonstone

  • Vieras
Re: EDGYYN PÄIVITTÄMINEN: ohjeet ja ongelmat tänne!
« Vastaus #4 : 27.10.06 - klo:09.18 »
Muokkaa /etc/apt/sources.list tiedostoa niin, että dapper korvataan sanalla edgy kommentoi myös universe, multiverse ja backports pois

sitten käynnistä kone recovery consoleen

apt-get update
apt-get dist-upgrade

mikäli tulee jotain herjaa välissä niin
apt-get install -f
apt-get update
apt-get dist-upgrade

jos jotain uupuu niin asenna paketit
apt-get install ubuntu-desktop ubuntu-minimal

hiltuer

  • Käyttäjä
  • Viestejä: 60
    • Profiili
Re: EDGYYN PÄIVITTÄMINEN: ohjeet ja ongelmat tänne!
« Vastaus #5 : 27.10.06 - klo:09.27 »
Minun tarinani on tämä:
Eilen työpäivän päätteeksi laitoin päivityksen päälle näiden ohjeiden mukaisesti (https://help.ubuntu.com/community/EdgyUpgrades) päivitysten hallinalla. Hyvin lähti käyntiin. Tänään aamulla päällimäisenä ruudulla oli ilmoitus, että update-managerille löytyy virheraportti ja ilmoitus "installArchives() failed".
Päivitysilmoitin kertoo, että "Tapahtui virhe, käynnistä paketinhallinta tai suorita apt-get päätteessä nähdäksesi mikä on ongelmana. Virhe oli: Error: BrokenCount>0"
Apt-get ei kerro mitään. Paketinhallinta kertoi, että on 20 rikkinäistä pakettia. Käskin asentaa nämä rikkinäiset uudelleen. Jäljelle jäi 16 rikkinäistä, joista suurin osa liittyy OpenOfficeen.
Open office ei toimi. Muuta häikkää ei näytä olevan, paitsi että tämä näyttää edelleen 6.06 versiolta.
Apua kaivaten,
Erkki H.

shukle

  • Käyttäjä
  • Viestejä: 79
    • Profiili
Re: EDGYYN PÄIVITTÄMINEN: ohjeet ja ongelmat tänne!
« Vastaus #6 : 27.10.06 - klo:09.37 »
Päivityksesi on kesken. sen pitäisi jatkua kun menet joko synapticiin tai päivitysten hallintaan.
Jos ei niin tee nuo edellä mainitut komennot uudestaan.
(Sain samat virheet aluksi.)

Djmasa

  • Käyttäjä
  • Viestejä: 42
    • Profiili
Kannattaako päivittää?
« Vastaus #7 : 27.10.06 - klo:10.19 »
MItä viisaammat sanovat - kannattaako perustaunon lähteä heti päivittämään vai tuleeko se helpommaksi/ongelmattomammaksi jos hieman toppuuttelee ja odottelee? Lukemani perusteella monilla tai ainakin joillakin on ollut onglemia, ja jos ei ole aloittelijana ole suurta kompetenssia niistä selvitä niin..... päivitelläänkö? =)

-masa-

Thomas

  • Käyttäjä
  • Viestejä: 10
    • Profiili
Re: EDGYYN PÄIVITTÄMINEN: ohjeet ja ongelmat tänne!
« Vastaus #8 : 27.10.06 - klo:10.56 »
Monen mutkan kautta onnistuin päivittämään edgyyn, mutta ongelma tuli koneen käynnistyksessä: ubuntu herjasi xserverin asetuksista. Hetken aikaa meinasin alkaa panikoida, mutta sitten aloin miettimään, vaikka en graafista käyttöliittymää sakaan käyttööni, on tässä avoinna terminaali. Niinpä asensin Lynxin ja sillä sitten surffailemaan ja etsimään apua :)

Firefox 2.0:an tottuneelle kokemus oli aika karu, mutta apua löytyi: selvisi että jostain syystä xserver-xorg ei ole asennettuna joten sen asentaminen sudo apt-get install xserver-xorg -komennolla ja uudelleen konfiguroiminen sudo dpkg-reconfigure -phigh xserver-xorg -komennolla ratkaisi ongelman.

Veikkaan että jos seuraa päivitysohjeita eikä ramboile - kuten minä tein - niin välttää tuonkin ongelman...

Risto H. Kurppa

  • Käyttäjä
  • Viestejä: 3024
  • Useita Kubuntuja ajossa.
    • Profiili
    • http://risto.kurppa.fi
Re: Kannattaako päivittää?
« Vastaus #9 : 27.10.06 - klo:11.04 »
MItä viisaammat sanovat - kannattaako perustaunon lähteä heti päivittämään vai tuleeko se helpommaksi/ongelmattomammaksi jos hieman toppuuttelee ja odottelee? Lukemani perusteella monilla tai ainakin joillakin on ollut onglemia, ja jos ei ole aloittelijana ole suurta kompetenssia niistä selvitä niin..... päivitelläänkö? =)

Vaikea tuohon on sanoa.. Dapper toimii vakaana kuin juna (ei niin että edgyssäkän ongelmia olisi). Itselleni uusia näkyviä juttuja oli oikeastaan vain uusi firefox, versio 2. KDE:n olin päivittänyt jo dapper - aikoinani versioon 3.5.5. Uutta on myös mm. uusi kernel ja ilmeisesti jotain uutta käynnistyspuolella. Nopeammaksi tätä kutsuisin kuin dapperia.

Eli.. ihan miltä tuntuu, kumpikin ratkaisu toimii. Enpä muuten osaa sanoa tulisiko dapperinkin repoihin uusi firefox jossain vaiheessa.. Melkein voisi luulla että jos sitä työpöydälläkin tuetaan vuoteen 2009 asti niin firefox (ja kernel) päivittyy jossain vaiheessa siihenkin..



r

UUSI UBUNTUN KÄYTTÄJÄ: SÄÄSTÄ AIKAASI LUKEMALLA  -> TÄMÄ <-

shukle

  • Käyttäjä
  • Viestejä: 79
    • Profiili
Re: EDGYYN PÄIVITTÄMINEN: ohjeet ja ongelmat tänne!
« Vastaus #10 : 27.10.06 - klo:12.18 »
Ottaen huomioon kuinka vaivaton ja loistavasti toimiva 6.06 Dapper on, en menisi
päivittämään. Omat kokemukseni päivityksestä olivat huonot ja vaikka 6.10 Eft
nyt toimiikin, en näe juuri muutoksen arvoisia parannuksia.

Söötti

  • Käyttäjä
  • Viestejä: 12
    • Profiili
Re: EDGYYN PÄIVITTÄMINEN: ohjeet ja ongelmat tänne!
« Vastaus #11 : 27.10.06 - klo:12.34 »
Muokkaa /etc/apt/sources.list tiedostoa niin, että dapper korvataan sanalla edgy kommentoi myös universe, multiverse ja backports pois

sitten käynnistä kone recovery consoleen

apt-get update
apt-get dist-upgrade

mikäli tulee jotain herjaa välissä niin
apt-get install -f
apt-get update
apt-get dist-upgrade

jos jotain uupuu niin asenna paketit
apt-get install ubuntu-desktop ubuntu-minimal

Mulla päivitys 6.06:sta jämähti kesken kaiken (en muista enää mihin). Näillä Aleksin ohjeilla homma jatkui. Seuraavaksi Synaptic oli rikki, mutta sekin hoitui kohdan 'jos jotain uupuu...' opastuksen mukaisesti. Kiitos Aleksille!

KaiMaani

  • Käyttäjä
  • Viestejä: 95
    • Profiili
Re: EDGYYN PÄIVITTÄMINEN: ohjeet ja ongelmat tänne!
« Vastaus #12 : 27.10.06 - klo:15.45 »
Meni päivitys muuten suhtellisen kivuttomasti (kerran jumittui), mutta paketteja jäi saamatta:
Koodia: [Valitse]
:~$ sudo apt-get dist-upgrade
Luetaan pakettiluetteloita... Valmis
Muodostetaan riippuvuussuhteiden puu       
Luetaan tilatietoja... Valmis       
Käsitellään päivitystä ... Valmis
Nämä paketit on jätetty odottamaan:
  libggi2 mplayer openoffice.org python-adns python-clientcookie
  python-egenix-mxproxy python-egenix-mxstack python-egenix-mxtexttools
  python-egenix-mxtools python-gadfly python-htmlgen python-htmltmpl
  python-imaging python-imaging-sane python-jabber python-kjbuckets
  python-ldap python-mysqldb python-osd python-pam python-pexpect python-pgsql
  python-pylibacl python-pyopenssl python-pyxattr python-reportlab
  python-simpletal python-soappy python-sqlite python-syck python-xmpp
0 päivitetty, 0 uutta asennusta, 0 poistettavaa ja 31 päivittämätöntä.
Mitäköhän tälle vois tehdä? Sources.lst näyttää tältä:
Koodia: [Valitse]
# PAKETTIVARASTOLISTAUS UBUNTU 6.06 LTS (Dapper)

# Tämä listaus käyttää varastoina suomalaista Ubuntun peilipalvelinta (ftp.funet.fi)
 
# Listaus ottaa käyttöön seuraavat pakettivarastot:
# - main
# - restricted
# - universe
# - multiverse
# - backports
# - dapper-commercial
# - PLF (epävirallinen)
# - Voikko
# - Oo2-soikko


# UBUNTUN VIRALLISESTI TUKEMAT PAKETIT (paketit, GPG key: 437D05B5)

# main- ja restricted-pakettivarastot
deb ftp://ftp.funet.fi/pub/mirrors/archive.ubuntu.com/ edgy main restricted

# Päivitykset main- ja restricted-pakettivarastoihin
deb ftp://ftp.funet.fi/pub/mirrors/archive.ubuntu.com/ edgy-updates main restricted

# Turvapäivitykset main- ja restricted-pakettivarastoihin
deb ftp://ftp.funet.fi/pub/mirrors/archive.ubuntu.com/ edgy-security main restricted


# UBUNTUN VIRALLISESTI TUKEMAT PAKETIT (lähdekoodi, GPG key: 437D05B5)

# Main- ja restricted-pakettivarastot
deb-src ftp://ftp.funet.fi/pub/mirrors/archive.ubuntu.com/ edgy main restricted

# Päivitykset main- ja restricted-pakettivarastoihin
deb-src ftp://ftp.funet.fi/pub/mirrors/archive.ubuntu.com/ edgy-updates main restricted

# Turvapäivitykset main- ja restricted-pakettivarastoihin
deb-src ftp://ftp.funet.fi/pub/mirrors/archive.ubuntu.com/ edgy-security main restricted


# YHTEISÖN TUKEMAT PAKETIT (paketit, GPG key: 437D05B5)

# universe- ja multiverse-paketivarastot
deb ftp://ftp.funet.fi/pub/mirrors/archive.ubuntu.com/ edgy universe multiverse

# päivitykset universe- ja multiverse-paketivarastoihin
deb ftp://ftp.funet.fi/pub/mirrors/archive.ubuntu.com/ edgy-updates universe multiverse

# Turvapäivitykset universe- ja multiverse-paketivarastoihin
deb ftp://ftp.funet.fi/pub/mirrors/archive.ubuntu.com/ edgy-security universe multiverse


# YHTEISÖN TUKEMAT PAKETIT (lähdekoodi, GPG key: 437D05B5)

# universe- ja multiverse-paketivarastot
deb-src ftp://ftp.funet.fi/pub/mirrors/archive.ubuntu.com/ edgy universe multiverse

# päivitykset universe- ja multiverse-paketivarastoihin
deb-src ftp://ftp.funet.fi/pub/mirrors/archive.ubuntu.com/ edgy-updates universe multiverse

# Turvapäivitykset universe- ja multiverse-paketivarastoihin
deb-src ftp://ftp.funet.fi/pub/mirrors/archive.ubuntu.com/ edgy-security universe multiverse


# BACKPORTS
deb ftp://ftp.funet.fi/pub/mirrors/archive.ubuntu.com/ edgy-backports main universe multiverse restricted


# EDGY-COMMERCIAL REPOSITORY
 deb http://archive.canonical.com/ubuntu edgy-commercial main


# PLF-PAKETTIVARASTO

# paketit
 deb http://packages.freecontrib.org/plf/ edgy free non-free
# lähdekoodi
 deb-src http://packages.freecontrib.org/plf/ edgy free non-free


# VOIKKO-OIKOLUKU
 deb http://www.lemi.fi/voikko/ubuntu/ edgy/
 deb-src http://www.lemi.fi/voikko/ubuntu/ edgy/

# Oo2-soikko (openoffice.org-soikko) OpenOffice.org ohjelmistolle (Teemu Likonen)
 deb http://dtw.silverentertainment.fi/oo2-soikko/ edgy non-free
 deb-src http://dtw.silverentertainment.fi/oo2-soikko/ edgy non-free
 deb http://www.beerorkid.com/compiz edgy main
deb http://archive.ubuntu.com/ubuntu/ edgy main
 deb http://ubuntu.compiz.net/ edgy main
Tän sain ratkaistua noitten puuttuvien pakettien suhteen siten että asensin ne apt-get installilla, muutama paketti kerrallaan
« Viimeksi muokattu: 27.10.06 - klo:21.59 kirjoittanut KaiMaani »

Stupido

  • Käyttäjä
  • Viestejä: 176
  • Gutsy Gibbon
    • Profiili
Re: EDGYYN PÄIVITTÄMINEN: ohjeet ja ongelmat tänne!
« Vastaus #13 : 27.10.06 - klo:16.25 »
Elikkä mä päätin tossa eilen päivittää Dapperini Edgyksi asentamalla koko Ubuntu Edgy Eftin asennuslevyllä jonka olin ladannu netistä ja polttanu .iso- levykuvaks siihen tarkotetulla ohjelmalla. Sitte käynnistyksessä ku laitoin levyn sisään nii kaikki näytti ihan normaalilta. Valitsin suomen kielen ja painoin käynnistä ubuntu/asenna-nappulaa. Sitte rupes Ubuntu käynnistymään, mut se latausruutu näytt ihan oudolta siin oli Ubuntun logo harmaa-mustana ja latauspalkki oli harmaan värinen ja näytti muutenli ihan bugiselta eikä latauspalkin alla muistaakseni näkyny sitä listaa mtä juttuja on käynnistymässä eli aika erilainen kuin Dapperin käynnistys. Sitte ku Ubuntu oli käynnistyksensä tehny nii kaikki näytti taas ihan normaalilta, mutta ku se oli kokonaan käynnistyny nii huomasin, että hiiri ei liikkunu minnekkään eikä näppäimistökään toiminu. Mulla on langaton näppis ja hiiri ja konees on sellanen usb-vastaanotin niille. Tarkistin et liitännät oli kunnossa ja niinhan ne oliki. Kummallista, että näppis toimi kuitenki siinä ekassa valikossa mis valitaan Ubuntun käynnistys. Käynnistin koneen uudestaan ja ajoin cd-levyn virheentarkistuksen ja se sano että kaikki on kunnossa. Siinä sitten sanottiin että press any key to exit ja siinä ei sitten näppis toiminu taaskaan. Mulla on 64-bittinen versio Ubuntust jos yhtään autaa. Toimiikohan hiiri ja näppis jos päivitän sources.lististä?

(Pari tuntia myöhemmin)
Elikkä päätin ottaa riskin ja asentaa Ubuntun ohjelmalähteista. Asennus sujui ilman ongelmia mutta kun sitten boottasin koneen ja pääsin kirjautumisruutuun, niin hiiri eikä näppäimistö toiminut vieläkään. Nyt en kyllä tiedä mitä tehdä.
« Viimeksi muokattu: 27.10.06 - klo:22.23 kirjoittanut Stupido »

Ubuntun käyttäjä jo vuodesta 2006.

Juuso

  • Käyttäjä
  • Viestejä: 156
    • Profiili
Re: EDGYYN PÄIVITTÄMINEN: ohjeet ja ongelmat tänne!
« Vastaus #14 : 27.10.06 - klo:20.06 »
Minäkin asennin edgyn ihan cdltä nytten ja muuten toimii hyvin mutta kun koitin asentaa nvidian ajureita http://ubuntuguide.org/wiki/Ubuntu_dapper#How_to_install_Graphics_Driver_.28NVIDIA.29 tuon ohjeen mukaisesti, niin kun olen bootannut X niin menee X ihan sekaisin. Olen jo kahesti tehnyt noin, olisi kiva tietää miten saisin xorg.confin backupin käyttöön kun X on solmussa ja mitenkä ihmeessä noi ajurit asennetaan kun ei tuokaan toimi vaikka tein täysin oikein!?
« Viimeksi muokattu: 27.10.06 - klo:20.19 kirjoittanut Juuso »

paappa

  • Käyttäjä
  • Viestejä: 6
    • Profiili
Re: EDGYYN PÄIVITTÄMINEN: ohjeet ja ongelmat tänne!
« Vastaus #15 : 27.10.06 - klo:21.14 »
Itse myös kerkesin käyttää elämäni ensimmäistä linukkaa (Dapperia) muutaman viikon ilman suurempia moitteita. Edgyn asensin myös kokonaan puhtaalta pöydältä Edgy Eftin asennuslevyllä.

Yritin asentaa (lisää/poista sovelluksia) ohjelmalla erästä ohjelmaa. Ei asentanut lisuketta, nyt lukee joka kohdassa lisää/poista sovelluksissa.

Sovellusta (se ja se) ei voida asentaa tietokonetyypillesi (i386). Sovelluksella voi olla erityisiä laitteistovaatimuksia, tai sovelluksen valmistaja on päättänyt olla tukematta tietokonetyyppiäsi.

Taidan olla jo liian vanha tähän virittely touhuun. Siirtyykö pappa suoraan takaisin Dapperia käyttämään, vai kokeilenko vielä tuota 64Bit asennusta. Jos ohjelmat hyväksyisi ne paremmin?
(Koneen tehot kyllä riittää 64Bitin pyörittämiseen).

Kiitos jo etukäteen.

janne

  • Käyttäjä
  • Viestejä: 5150
    • Profiili
Re: EDGYYN PÄIVITTÄMINEN: ohjeet ja ongelmat tänne!
« Vastaus #16 : 27.10.06 - klo:21.43 »
Yritin asentaa (lisää/poista sovelluksia) ohjelmalla erästä ohjelmaa. Ei asentanut lisuketta, nyt lukee joka kohdassa lisää/poista sovelluksissa.

Sovellusta (se ja se) ei voida asentaa tietokonetyypillesi (i386). Sovelluksella voi olla erityisiä laitteistovaatimuksia, tai sovelluksen valmistaja on päättänyt olla tukematta tietokonetyyppiäsi.

kannattaa ehkä kertoa mikä sovellus ei suostunut asentumaan.

Taidan olla jo liian vanha tähän virittely touhuun. Siirtyykö pappa suoraan takaisin Dapperia käyttämään, vai kokeilenko vielä tuota 64Bit asennusta. Jos ohjelmat hyväksyisi ne paremmin?
(Koneen tehot kyllä riittää 64Bitin pyörittämiseen).

32-bittiselle on edelleen saatavilla enemmän sovlluksia kuin 64-bittiselle. softia joita on saatavana ainoastaan 64-bittiselle prossulle on aika vähän verrattuna päinvastaiseen tilanteeseen.
Janne

paappa

  • Käyttäjä
  • Viestejä: 6
    • Profiili
Re: EDGYYN PÄIVITTÄMINEN: ohjeet ja ongelmat tänne!
« Vastaus #17 : 27.10.06 - klo:22.01 »
Yritin asentaa (lisää/poista sovelluksia) ohjelmalla erästä ohjelmaa. Ei asentanut lisuketta, nyt lukee joka kohdassa lisää/poista sovelluksissa.

Sovellusta (se ja se) ei voida asentaa tietokonetyypillesi (i386). Sovelluksella voi olla erityisiä laitteistovaatimuksia, tai sovelluksen valmistaja on päättänyt olla tukematta tietokonetyyppiäsi.

kannattaa ehkä kertoa mikä sovellus ei suostunut asentumaan.

Taidan olla jo liian vanha tähän virittely touhuun. Siirtyykö pappa suoraan takaisin Dapperia käyttämään, vai kokeilenko vielä tuota 64Bit asennusta. Jos ohjelmat hyväksyisi ne paremmin?
(Koneen tehot kyllä riittää 64Bitin pyörittämiseen).

32-bittiselle on edelleen saatavilla enemmän sovlluksia kuin 64-bittiselle. softia joita on saatavana ainoastaan 64-bittiselle prossulle on aika vähän verrattuna päinvastaiseen tilanteeseen.

Adobe PDF Reader.

Aiheutti moisen virheen nyt ei pääse asentamaan mitään lisukkeita lisää/poista sovelluksissa. Samaa herjaa pukkaa päälle. Ei muuten mutta, ekaluokkalainen ja päiväkotilainen ei saa unta, kun taas sä rikoit sen kommenttia tulee ennen nukkumaan menoa. >:(

Ei tää muuten niin vakavaa ole.

jonssoni

  • Käyttäjä
  • Viestejä: 31
    • Profiili
Re: EDGYYN PÄIVITTÄMINEN: ohjeet ja ongelmat tänne!
« Vastaus #18 : 27.10.06 - klo:22.37 »
Meni päivitys muuten suhtellisen kivuttomasti (kerran jumittui), mutta paketteja jäi saamatta:
Koodia: [Valitse]
:~$ sudo apt-get dist-upgrade
Luetaan pakettiluetteloita... Valmis
Muodostetaan riippuvuussuhteiden puu       
Luetaan tilatietoja... Valmis       
Käsitellään päivitystä ... Valmis
Nämä paketit on jätetty odottamaan:
  libggi2 mplayer openoffice.org python-adns python-clientcookie
  python-egenix-mxproxy python-egenix-mxstack python-egenix-mxtexttools
  python-egenix-mxtools python-gadfly python-htmlgen python-htmltmpl
  python-imaging python-imaging-sane python-jabber python-kjbuckets
  python-ldap python-mysqldb python-osd python-pam python-pexpect python-pgsql
  python-pylibacl python-pyopenssl python-pyxattr python-reportlab
  python-simpletal python-soappy python-sqlite python-syck python-xmpp
 
0 päivitetty, 0 uutta asennusta, 0 poistettavaa ja 31 päivittämätöntä.
Itselläni  lähes sama vika, tosin pakettin asennus yksi kerrallaa ei onnistu, herjaa notta E: Pakettia xxx ei löytynyt.
Myös tällaisia paketteja on jäänyt itsellä asentumatta:

 hpijs
 x-windows-system-core

Edgyn päivityksen aikana herjasi myös virheitä localien kanssa, niitä olen aiemmin dapperissa muokannut.

Tästä seurauksena x latautuu kyllä, mutta kirjauduttaessa sisään työpöytä ja työkalu/valikkopalkit eivät lataudu, johtuneeko tuosta x-windows-system-core :n puuttumisesta? Kuinka saan sen asennettua? (herjaa pakettia ei löytynyt)
Yritin palauttaa varmuuskopiota x:stä, mutta apua ei ollut.
Mikä neuvoksi?  :'(

EDIT: Päivitykstä ongelmaan: apt-get install ubuntu-desktop   tuottaa seuraavan virheen:

/**
ensin pitkä litannia tekstiä ja sitten tärkein
**\
The following packages have unmet dependencies:
 ubuntu-desktop: Depends: xorg but is is not going to be installed
 E: Broken packages

« Viimeksi muokattu: 27.10.06 - klo:22.56 kirjoittanut jonssoni »

janne

  • Käyttäjä
  • Viestejä: 5150
    • Profiili
Re: EDGYYN PÄIVITTÄMINEN: ohjeet ja ongelmat tänne!
« Vastaus #19 : 27.10.06 - klo:23.05 »
Adobe PDF Reader.

onko jotain syytä miksi valmiiksi asennettu evince ei kelpaa? se ei kieltämättä osaa vielä täyttää koneella täytettäviä pdf-lomakkeita (tai osaa näyttää niitä 3d-juttuja joita seuraavassa versiossa tulee mukaan), mutta muuten se osaa aika monta juttua jota acrobat reader ei. itse pidän enemmän sen käyttöliittymästäkin.

Aiheutti moisen virheen nyt ei pääse asentamaan mitään lisukkeita lisää/poista sovelluksissa. Samaa herjaa pukkaa päälle.

en oikein vieläkään tiedä mikä se virhe on, mutta mitä mahtaa tulostua jos kirjoitat päätteeseen komennon:
Koodia: [Valitse]
$ sudo apt-get install acroread
Janne