Kirjoittaja Aihe: ioquake 3 probleema [ratkaistu]  (Luettu 3038 kertaa)

tomppa

  • Käyttäjä
  • Viestejä: 165
  • Debian4.0
    • Profiili
ioquake 3 probleema [ratkaistu]
« : 24.10.06 - klo:13.00 »
Niille jotka eivät tiedä: http://icculus.org/quake3/

Kun yritän käynnistää pelin konsolista: ioquake3
Koodia: [Valitse]
/usr/local/bin/ioquake3: 8: Syntax error: Bad substitution

Minulla ei ole mitään hajua mistä moinen voisi johtua.  ??? Muut pelit toimivat kyllä oikein, ajurit ok jne. Asennuksenkin pitäisi olla oikein tehty (sudo sh ioquake....run) ja kopioitu pak0.pk3 tuolta quaken cd-romilta baseq3-kansioon. Aiemmin näin asennettuna on kyllä toiminut dapperissa. Mutta tässä edgyssä ilmeni tämä ongelma.

EDIT:

Juu eli löyty ratkaisu tähänkin ja laitan tähän ohjeet jos jollain muullakin on samoja ongelmia:

Ekana:
Koodia: [Valitse]
ls -l /usr/local/bin/ioquake3
Sitten muokataan tuota filua:
Koodia: [Valitse]
sudo nano /usr/local/bin/ioquake3
Etsitään sieltä seuraava kohta:
Koodia: [Valitse]
if [ -L "$path" ]; then
   ll="$(LC_ALL=C ls -l "$path" 2> /dev/null)" &&
   echo "${ll/* -> }"

Korvataa se tällä:
Koodia: [Valitse]
f [ -L "$path" ]; then
   echo "/usr/local/games/ioquake3/ioquake3"

Seuraavaksi piti asentaa libopenal0-niminen paketti ainakin omalle koneelle. Ja näiden jälkeen rupesi rokkaamaan.  8)
« Viimeksi muokattu: 30.10.06 - klo:13.22 kirjoittanut tomppa »

Rusakko

  • Käyttäjä
  • Viestejä: 11
    • Profiili
Re: ioquake 3 probleema
« Vastaus #1 : 24.10.06 - klo:13.57 »
Niille jotka eivät tiedä: http://icculus.org/quake3/

Kun yritän käynnistää pelin konsolista: ioquake3
Koodia: [Valitse]
/usr/local/bin/ioquake3: 8: Syntax error: Bad substitution

Minulla ei ole mitään hajua mistä moinen voisi johtua.  ??? Muut pelit toimivat kyllä oikein, ajurit ok jne. Asennuksenkin pitäisi olla oikein tehty (sudo sh ioquake....run) ja kopioitu pak0.pk3 tuolta quaken cd-romilta baseq3-kansioon. Aiemmin näin asennettuna on kyllä toiminut dapperissa. Mutta tässä edgyssä ilmeni tämä ongelma.

Onko tuossa nettipeliä? Onko paljon pelaajia?

tomppa

  • Käyttäjä
  • Viestejä: 165
  • Debian4.0
    • Profiili
Re: ioquake 3 probleema
« Vastaus #2 : 24.10.06 - klo:14.41 »
Niille jotka eivät tiedä: http://icculus.org/quake3/

Kun yritän käynnistää pelin konsolista: ioquake3
Koodia: [Valitse]
/usr/local/bin/ioquake3: 8: Syntax error: Bad substitution

Minulla ei ole mitään hajua mistä moinen voisi johtua.  ??? Muut pelit toimivat kyllä oikein, ajurit ok jne. Asennuksenkin pitäisi olla oikein tehty (sudo sh ioquake....run) ja kopioitu pak0.pk3 tuolta quaken cd-romilta baseq3-kansioon. Aiemmin näin asennettuna on kyllä toiminut dapperissa. Mutta tässä edgyssä ilmeni tämä ongelma.

Onko tuossa nettipeliä? Onko paljon pelaajia?

On moninpeli. Ja kyllähän noita vannoutuneita quaken pieksäjiä taitaa vielä löytyä aika paljon, ;)