Kirjoittaja Aihe: [Ratkaistu] Ubuntu 22 ja Wayland - miten saada Gnome automaattisesti käynnis...  (Luettu 935 kertaa)

karima

  • Käyttäjä
  • Viestejä: 10
    • Profiili
Bootissa kone menee ei-graafiseen ympäristöön. Siinä voi käynnistää Gnomen:
sudo service gdm start
Miten tämän saa konffattua, niin että bootissa tulee heti Gnome Login screen esille?
« Viimeksi muokattu: 02.12.23 - klo:18.31 kirjoittanut karima »

Tomin

  • Palvelimen ylläpitäjä
  • Käyttäjä / moderaattori+
  • Viestejä: 11427
    • Profiili
    • Tomin kotisivut
Koodia: [Valitse]
sudo systemctl enable gdmSitä vähän ihmettelen, miten olet saanut koneen siihen tilaan ettei tuo tapahdu automaattisesti.
Automaattinen allekirjoitus:
Lisäisitkö [RATKAISTU] ketjun ensimmäisen viestin aiheeseen ongelman ratkettua, kiitos.

karima

  • Käyttäjä
  • Viestejä: 10
    • Profiili
λ> sudo systemctl enable gdm
The unit files have no installation config (WantedBy=, RequiredBy=, Also=,
Alias= settings in the [Install] section, and DefaultInstance= for template
units). This means they are not meant to be enabled using systemctl.
 
Kiitos vastauksesta, vaikka en sillä vielä saanut ongelmaa ratkaistua. Pitää varmaan asentaa toi gdm jotenkin uudestaan.

Pitkä tarina, miksi meni sekaisin. Torstaina päivitin paketit ja näyttö jäätyi kun kone oli kiinni ulkoisissa näytöissä. Luulin ensin, että nvidia näytönohjainpäivitys aiheutti ongelman, mutta en saanut sitä ratkaistua. Lopulta asensin koneen uudestaan. Ongelma oli edelleen sama: kun koneen laittoi kiinni ulkoisiin monitoreihin, niin näyttö jäätyi. Koneessa on nvidia-kortin lisäksi jokin integroitu Intelin kortti ja kokeilin, josko sillä ongelma ratkeaisi. Sitten kokeilin poistaa Xorg paketit ja asentaa uudestaan. Ei ratkennut. Sitten kokeilin vaihtaa Xorgista Waylandiin ja ulkoiset monitorit toimivat. Mutta jostain syystä nyt Waylandissa ei heti käynnisty gdm, vaan se pitää käynnistää manuaalisesti bootissa.

Waylandissa ulkoiset monitorit toimivat. Mutta ongelmana on vielä näppäin-konfiguraation saaminen samanlaiseksi Waylandissa kuin Xorgissa, tästä erillinen thread:
https://forum.ubuntu-fi.org/index.php?topic=58457.0


karima

  • Käyttäjä
  • Viestejä: 10
    • Profiili
Tällä gdm-jutulla ei oikeastaan niin väliä ole. Tärkeämpää on keksiä jokin ratkaisu tuohon Wayland näppäimistökonfiguraatioon. Kun sen saan tehtyä, niin asennan Ubuntun uudestaan puhtaalta pöydältä.

Tomin

  • Palvelimen ylläpitäjä
  • Käyttäjä / moderaattori+
  • Viestejä: 11427
    • Profiili
    • Tomin kotisivut
λ> sudo systemctl enable gdm
The unit files have no installation config (WantedBy=, RequiredBy=, Also=,
Alias= settings in the [Install] section, and DefaultInstance= for template
units). This means they are not meant to be enabled using systemctl.

Aa, joo, Ubuntussa tuo tuleekin varmaan pakettienhallinnasta.

Kiitos vastauksesta, vaikka en sillä vielä saanut ongelmaa ratkaistua. Pitää varmaan asentaa toi gdm jotenkin uudestaan.

Kokeilisin seuravaaksi gdm:n paketin uudelleen konfigurointia (komento on Ubuntun versiolle 22.04):
Koodia: [Valitse]
sudo dpkg-reconfigure gdm3Saatat joutua liikkumaan tabilla ja valitsemaan enterillä.

Sitten kokeilin vaihtaa Xorgista Waylandiin ja ulkoiset monitorit toimivat. Mutta jostain syystä nyt Waylandissa ei heti käynnisty gdm, vaan se pitää käynnistää manuaalisesti bootissa.

Wayland-istunnolla ei oikeastaan pitäisi olla tälle asialle mitään väliä. Jos vaihtaa istuntoa kirjautumisikkunasta (eli sitää gdm:stä), niin se ei muuta kirjautumisikkunan toimintaa. Olet toki voinut yrittää jotain muuta, mikä on sitten ottanut gdm:n pois suorituksesta käynnistyksessä.
Automaattinen allekirjoitus:
Lisäisitkö [RATKAISTU] ketjun ensimmäisen viestin aiheeseen ongelman ratkettua, kiitos.

karima

  • Käyttäjä
  • Viestejä: 10
    • Profiili
Kiitti vinkistä! Tämä toimi!

sudo systemctl start gdm3.service   
sudo dpkg-reconfigure gdm3

juyli

  • Käyttäjä / moderaattori
  • Viestejä: 1198
    • Profiili
Kiitti vinkistä! Tämä toimi!
sudo systemctl start gdm3.service   
sudo dpkg-reconfigure gdm3
Jos ja kun ongelmasi on löytänyt ratkaisun, voit alkuperäisen kysymyksesi viestin otsikkoon lisätä vaikkapa [Ratkaistu]