Kirjoittaja Aihe: [Ratkaistu]Asennus ei onnistu Asus E410KA läppärin eMMC levylle.  (Luettu 1618 kertaa)

tapioa

  • Käyttäjä
  • Viestejä: 2
    • Profiili
Alko Wintoosa kyllästyttämään ja eikun vaihto Ubuntuun. Vaan ei onnistu. Tökkää levyn osiointiin, "Tiedostojärjestelmän ext4 luonti laitteelle MMC/SD-kortti " # 1 (mmcblk0) osiolle n:ro5 ei onnistunut."

Tällaisen löysin: https://superuser.com/questions/1688659/128gb-emmc-drive-on-asus-laptop-unable-to-format-to-ext4

"Way 1: Unload the module and reload it with the option specified.

sudo modprobe -r sdhci_pci
sudo modprobe -r sdhci
sudo modprobe sdhci debug_quirks=0x20000
sudo modprobe sdhci_pci


This works when the system isn't going to access eMMC drive during boot. For example, you are in some kind of linux installer and about to begin installation on the eMMC drive."

"Way 2: Specify sdhci.debug_quirks=0x20000 option to the kernel command line.

This often can be done with bootloader menu. It might save the day when the eMMC drive is used during boot and you didn't have a chance to burn the option via /etc/modprobe.d to initramfs."


"Way 3: Use /etc/modprobe.d

Create a file like /etc/modprobe.d/sdhci-disable-cqe.conf which contains:

options sdhci debug_quirks=0x20000

This is usually "the right" way to permanently tweak module load behaviour. However, in order for it to work at early boot, one should make sure the config file gets to initrd image. Ways to do this may differ across distributions. For Ubuntu it's usually running sudo update-initramfs -u after creating/editing a file in /etc/modprobe.d.

PS: From what I see - debug_quirks thing seems to be the only available option for disabling CQE on common kernel builds. The issue seems to be rare and usually encountered on some specific non-x86 hardware. I was really desperate and about to order an SSD, the idea to dig sdhci source code for all available options in response to some (non-CQE related) debug_quirks mentions came up just the last moment =)"


Kohdan 1 koodilla asennus onnistui, mutta Ubuntu ei kuitenkaan toiminut. Ilmeisesti koodi toimii tasan niin kauan, kuin kone on käynnissä. Kohdan 2 tai 3 mukaiset toimenpiteet toimisivat pysyvästi, jos olen oikein ymmärtänyt? Tietotaito vaan ei ainakaan toistaiseksi taida riittää.

« Viimeksi muokattu: 12.08.23 - klo:11.49 kirjoittanut tapioa »

nm

  • Käyttäjä
  • Viestejä: 16111
    • Profiili
Vs: Asennus ei onnistu Asus E410KA läppärin eMMC levylle.
« Vastaus #1 : 11.08.23 - klo:19.21 »
Tervetuloa foorumille! Oletkin poiminut heti alkuun hieman haastavamman pähkinän purtavaksi tuon Asusin kanssa.

Ilmeisesti asennusohjelma osaa lisätä tarvittavan parametrin asennettuun järjestelmään, jos sen olisi määrittänyt asentimen GRUB-valikon kautta:
https://www.quantulum.co.uk/blog/xubuntu-on-a-chromebook/

Jos Ubuntu on kuitenkin nyt asennettu, mutta käynnistäminen ei onnistu, ongelma ratkeaa samalla toimenpiteellä. Ensin siis pitää avata GRUB-käynnistysvalikko (paina vasenta shift-näppäintä tai mahdollisesti esc-näppäintä ennen kuin Ubuntu yrittää käynnistyä). Kun GRUB-valikko avautuu, paina e:tä Ubuntun kohdalla, jotta pääset editoimaan kernelin komentoriviä. Siirry nuolinäppäimillä linux-alkuisen rivin loppuun ja kirjoita sinne tarvittava asetus sdhci.debug_quirks=0x20000 Käynnistä Ubuntu Ctrl+X:llä.

Kun saat järjestelmän käyntiin, asetus täytyy vielä lisätä pysyvästi tiedoston /etc/default/grub riville GRUB_CMDLINE_LINUX_DEFAULT
Katso ohje: https://askubuntu.com/a/19487

tapioa

  • Käyttäjä
  • Viestejä: 2
    • Profiili
Vs: Asennus ei onnistu Asus E410KA läppärin eMMC levylle.
« Vastaus #2 : 12.08.23 - klo:11.48 »
Suuri kiitos!
Nyt pelittää. Mutta olipahan työn takana, kaiken kaikkiaan.
Tiedoston tallennus ei onnistunut ja päätin sitten tehdä koko homman taas kerran alusta lähtien tuon ensimmäisen linkkisi mukaan.

nm

  • Käyttäjä
  • Viestejä: 16111
    • Profiili
Vs: Asennus ei onnistu Asus E410KA läppärin eMMC levylle.
« Vastaus #3 : 12.08.23 - klo:14.00 »
Suuri kiitos!
Nyt pelittää. Mutta olipahan työn takana, kaiken kaikkiaan.
Tiedoston tallennus ei onnistunut ja päätin sitten tehdä koko homman taas kerran alusta lähtien tuon ensimmäisen linkkisi mukaan.

Hyvä että sait toimimaan!

Tosiaan geditillä editointi root-oikeuksin voi olla nykyisissä Ubuntuissa hankalaa ainakin Wayland-ikkunoinnissa, jossa ei voi suoraan ajaa graafisia sovelluksia sudolla tai gksudolla. Periaatteessa pitäisi onnistua admin://-protokollan avulla, mutta joskus siinäkin voi tulla ongelmia eteen:

Koodia: [Valitse]
gedit admin:///etc/default/grub
Jos geditille ei saa riittäviä oikeuksia, nano toimii päätteessä:

Koodia: [Valitse]
sudo nano /etc/default/grub
Tallennus: Ctrl+O
Sulje editori: Ctrl+X